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CHAPTER

1

Getting Started
Jasc Paint Shop Pro 8 is the most complete, easy-to- use software for
professional digital imaging results. Combining a unique set of
automatic and precision photo editing and graphic design tools with
an integrated learning system, Paint Shop Pro helps you deliver
superior results with power and ease. It’s your complete solution for
print and Web.
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Chapter 1: Getting Started

What’s New in Version 8
Paint Shop Pro version 8 includes many new and improved features
to make photo enhancements and image editing easier and more
powerful.

Enhanced User Interface
A New Look Paint Shop Pro includes new icons, palettes, and menu
displays to make using the software more intuitive.
Enhanced Tool options The Tool Options palette is now fully
dockable, streamlined, and much more intuitive.
Enhanced Materials The Materials palette (formerly the Color
palette) includes easy-to-use controls for selecting colors, patterns,
gradients, and textures.
Enhanced Tools toolbar The tools on the Tools toolbar are grouped
into related categories organized on flyouts.
Enhanced Layer palette The Layer palette allows you to better
manage and view image data.

Integrated Learning Tools
Learning Center Window Get started quickly with the new Learning
Center window that guides you around Paint Shop Pro. Try out new
Quick Guides that lead you through a variety of common projects to
help you get up and running fast.
Product Tour Familiarize yourself with Paint Shop Pro by viewing
the all-new Product Tour. Nearly 50 topics show you the many
results you can achieve using Paint Shop Pro for all of your photo
and graphics projects.
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New Tools to Create Professional Results
Background Eraser Brush Use the new Background Eraser brush to
select a colored area of the image and replace it with transparency.
Warp Brush Create fun or dramatic effects by altering your photos.
Stretch, pull, push, tug, or swirl to create unlimited effects.
Straighten Tool Align crooked photos. Simply draw a horizontal or
vertical line specifying the direction in which to align the image.
Enhanced Deform Tool The new handles are easier to use. Use the
tool to scale, shear, distort, rotate, and apply perspective to images.
Enhanced Painting Engine Enjoy better photo retouching with
greater precision and smoother blending of brush strokes.
Enhanced Retouch Brushes All of the retouch brushes that were
formerly part of the Retouch tool are now separate brushes. For
example, use the Dodge brush to lighten images and bring out
details, use the Burn brush to darken areas of images, or use the
Saturation brush to increase or decrease the saturation.
Enhanced Crop Tool Choose from preset crop sizes, such as 4 x 6 or
8 x 10. This tool now also provides aspect ratio control to make it
even easier to achieve the perfect crop.
Enhanced Selections New Edge Seeker mode adds more
intelligence as the Freehand Selection tool automatically seeks an
edge between mouse click points along an object. You also have a
wide choice of ways to modify selections, such as removing holes
and specks and adding an inside feather.
Versatile Tablet Options Explore your freedom and creativity with
additional options for pen tablets—vary the color, density, opacity,
rotation, size, and thickness of brush strokes based on pressure, tilt,
altitude, and more.
Layer Groups Place layers in layer groups to organize the Layer
palette, apply settings (such as opacity) to all layers within a group,
and have mask and adjustment layers affect only layers within the
group (rather than all underlying layers).
Mask Layers Masks are now separate layers rather than attributes of
other layers. Mask layers mask all image data below them at the
same level.
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New Filters and Special Effects
Black and White Points Feature Set the overall tonal range of
photographs and bring out image detail without losing information.
Lens Distortion Correction Quickly correct images that have
pincushion, barrel, or fisheye distortions.
Balls and Bubbles Have fun creating realistic transparent bubbles
with full control over the reflection.
Halftone Create a trendy dot representation of a photograph.
Soft Focus Create your own “glamorous shot.”
Magnifying Lens Draw focus to an area of the image. This effect
simulates placing a lens on the image. Enjoy full control over
lighting, reflection, optical distortions, and magnification strength.
Lens Distortion Simulate many lens distortion effects, such as
fisheye, barrel, or pincushion.
Offset Precisely define where an image wraps when creating
seamless patterns.
Seamless Tiling Professionally prepare high-quality seamless
patterns and tiled images.

Share Images with Others
Enhanced Print Layout Use a variety of preset printing templates
designed to offer common page layouts and commercial papers, such
as 3 x 5’s, 4 x 6’s, and business cards. Create and save your own
custom templates to reuse or share with others.
More File Types Now Paint Shop Pro supports even more file types,
such as new JPEG 2000 and PDF, as well as Wireless Bitmap
(WBMP).
EXIF Photo Information View detailed EXIF photo information from
digital cameras, including date, time, resolution, f-stop, ISO speed,
and more. Information is preserved when you save the images in
Paint Shop Pro (.PspImage), JPEG, and TIFF file formats.
Windows Image Architecture (WIA) Support Easily import images
directly from many digital cameras and scanners using the WIA
interface (available only when using Windows ME or XP).
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Automated Productivity
Presets Create and save custom presets for all filters and effects.
Use the presets to recreate a specific look or to share with others.
Brush Presets Paint with creative brush effects such as crayon,
charcoal, pencil, and more, designed to provide realistic painting
effects. Choose from many artistic presets or create, save, and share
your own.
Scripts Use the new scripts feature to repeat any series of commands
or steps on any image. Choose from dozens of preset scripts or
record your own custom series of steps to save and replay or share
with others. Modify your scripts using a text editor.
Enhanced Batch Processing Save time and maximize your
processing power with many new enhancements to Batch
Processing, such as the ability to rename files and apply a script to a
series of images in a folder.
New File Extensions Many of Paint Shop Pro’s native formats have
new file extensions that make them easier to recognize. Images are
.PspImage files; gradients are .PspGradient files; masks are
.PspMask files, and so on. Paint Shop Pro version 8 also reads file
formats from previous versions of the software.

Dynamic Personalization
Customizing the User Interface Adapt your workspace to the way
you work. Drag and drop any feature, special effect, filter, and tool
anywhere on the interface - wherever you want. Place menu items
and tools you frequently use on a floating or docked toolbar that you
create. You can also create your own keyboard shortcuts, and
customize the menus.
Enhanced Workspaces Once you have everything set up just the way
you like it, save your workspace - or multiple workspaces. This is
perfect if you share a computer with others because each person can
have their own personalized workspace that loads instantly and
saves time otherwise spent moving things around.
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System Requirements
Before you install this program, make sure that your computer meets
or exceeds these requirements:


Windows® 98 / NT4 SP6a / 2000 / ME / XP



Pentium® or comparable processor



128 MB RAM



200 MB free disk space



16-bit display adapter at 800 x 600 resolution



Microsoft Internet Explorer 5.0 or later

Installing the Software
Before you install the program, close any programs or applications
that you have running on your computer.
To install the software:
1 Insert the Paint Shop Pro CD in your CD-ROM drive. The
installation program starts automatically.
Note: If the installation program does not start automatically,
double-click the My Computer icon, and then double-click on the
CD-ROM icon. When the window opens displaying the contents
of the CD-ROM, double-click Setup.exe.
2 Follow the prompts to install the program.
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Learning Paint Shop Pro
Learn Paint Shop Pro in a variety of ways: follow the Quick Guides,
view the Product Tour, or use the Help system.

Using the Quick Guides to Learn
Common Tasks
Quick Guides are short, fast tutorials that guide you through new
tasks and projects using your own image. Perform each step
yourself, or have the program show you where to find the tools
needed to complete the task.
To use Quick Guides:
1 Choose View > Palettes > Learning Center or press F10 to open the
Learning Center window.
2 Click the title of a Quick Guide to view the selected topic.

Viewing the Product Tour
Watch the movies in the Product Tour to see the new tools and
features in action. The product tour even links to the Help file and
the Quick Guides.
To view the Product Tour:
1 In the Windows desktop, click the Start button and choose
Programs. The Programs pop-out menu appears to the right.
2 Choose Jasc Software - Jasc Paint Shop Pro to open Paint Shop
Pro.
3 Choose Help > Product Tour.
When you are finished viewing the Product Tour, click Start Using
Paint Shop Pro to return to the main program window.
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Using the Jasc Software Learning
Center
The Jasc Software Learning Center shows you how to use Paint
Shop Pro’s features to create amazing photographic enhancements
and sophisticated graphics. Jasc and third-party tutorials walk you
through the steps for everything from restoring old photographs to
creating metallic text.
To access the Jasc Software Learning Center, browse to
www.jasc.com/learncenter.asp. Or, go to Jasc.com, click the
Support tab and select Learning Center.

Getting in Touch with Other Paint Shop
Pro Users
Millions of people use and love Paint Shop Pro. There are many
independent (non-Jasc) Paint Shop Pro communities where users
share tips and tricks, ask questions, and get answers about Paint
Shop Pro. There are Websites, newsgroups, and chatrooms devoted
to Paint Shop Pro. As a starting point, search online for “Paint Shop
Pro.”
One popular newsgroup is the Usenet newsgroup,
comp.graphics.apps.paint-shop-pro, which you can access using
your favorite news reader.

Getting Help
With Paint Shop Pro, you have many options for getting help with
the software: you can use the Help system, contact Jasc Technical
Support, check out our web-based resources, or refer to the
README.html file that was installed with Paint Shop Pro for the
latest information about the software.

Using the Help System
Paint Shop Pro’s Help system complements this user guide. To use
help, choose Help > Contents and Index or press F1.
Most dialogs also have a Help button; click it to display contextsensitive help.
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Accessing Free Technical Support
When you buy Paint Shop Pro, you have free access to Jasc’s staff of
technical support personnel. Contact us to get assistance in any of
the following ways:
US / Canada Contact Method

Address or Number

Call Technical Support

952-930-9171

Technical Support on the Web

www.jasc.com/custcare/support.asp

Fax Technical Support

952-930-9172

Call Customer Service
Go to the Jasc Website

International Contact
Method

800-622-2793
(8am - 5pm CST, Monday - Friday)
www.jasc.com

Address or Number

Find your local country
contact details on the Web

www.jasc.com/world

International e-mail

intl@jasc.com

Call International Customer
Service
(English Only)

+1- 952-930-9800

Fax International Customer
Service

+1- 952-930-9172

(8am - 5pm GMT-6:00, Monday - Friday)
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Using Web-Based Resources
On the Help menu of Paint Shop Pro, you can access a number of
Website pages dedicated to support issues. Choose Help > Jasc
Software Online and select one of the following Website links:
Jasc Software Website Visit www.jasc.com to preview or buy the
latest Jasc products, access the Learning Center or the Support
Center, and find answers to your questions.
Support Center Access the Jasc Customer Care Center to search for
answers in our Knowledge Base, submit questions to Technical
Support, or give us feedback.
Register Product Online Register your copy of Paint Shop Pro
online.
Check for Updates Check the Jasc.com Website for updates to Paint
Shop Pro.
E-mail Technical Support Send an e-mail message to Technical
Support.
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Getting to Know The Program
The Paint Shop Pro workspace includes menus, tools, and palettes
that you can use to create and edit images. Navigate this workspace
to accomplish your painting, drawing, and photo editing tasks.
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Starting and Exiting Paint Shop Pro
To start Paint Shop Pro:


If you chose to place the Paint Shop Pro icon on your desktop
during installation, you can start the program by double-clicking
this icon.



If you chose not to place the Paint Shop Pro icon on your
desktop, start the program by clicking the Start button and
choosing Programs > Jasc Software > Jasc Paint Shop Pro 8.

The first time you start Paint Shop Pro, the program displays the File
Format Associations dialog. This dialog lets you assign file formats
to the program so that your computer always uses Paint Shop Pro to
open files in those formats. You can change associations at any time
by choosing the File > Preferences > File Format Associations menu
commands. For more information, see “Setting File Format
Associations” on page 407.
To exit paint Shop Pro:


Click the close button in the upper right-hand corner of the
program window.



Click the Paint Shop Pro icon in the upper left-hand corner of the
title bar and choose Close.
Note: If you have any images that need to be saved, Paint Shop
Pro displays a messages asking if you want to save the images
before closing the program.

Exploring the User Interface
When you open Paint Shop Pro, it displays the main program
window. This window is your work area. It contains the commands
and tools used to create, edit, print, and export your images.
The Paint Shop Pro workspace includes the following components:
Menu bar The menu bar displays commands for performing tasks.
Menus are organized by topic. For example, the Effects menu
contains commands for applying effects to images.
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Save time by saving
workspaces
Did you know that you can save
entire workspaces, not just
images? The workspace includes
open images and their
magnifications and screen
positions, as well as positions and
preferences of palettes, toolbars,
dialogs, and windows.
For more information, see “Using
Custom Workspaces” on page 401.

Toolbars The toolbars display buttons for common commands. See
“Using Toolbars” on page 15.
Palettes The palettes display information and help you select tools,
modify options, manage layers, select colors, and perform other
editing tasks. See “Using Palettes” on page 16.
Status bar The Status bar displays text about the selected tool or
menu command as well as image information, including the
dimensions and color depth. See “Viewing Image Information” on
page 24.
Browser Displays thumbnail previews of image files. You can open,
delete, copy, and perform other file commands in the Browser. For
more information, see “Using the Paint Shop Pro Browser” on
page 43.
Print Layout window Displays a page on which you can arrange and
size multiple images, and then print the images. For more
information, see “Printing Multiple Images on a Page” on page 360.

Tools
toolbar

Title Standard Menu
bar toolbar
bar

Image

Script
toolbar

Tool Options
palette

Overview
palette

Materials
palette

Learning Center
palette
Status bar

Layer palette

Browser (minimized)
Script Output
palette
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Using Toolbars and Palettes
You can dock, float, move and resize both palettes and toolbars.
To dock a toolbar or palette:
Docked and floating
Materials palette



Drag its title bar to one edge of the workspace. The toolbar or
palette snaps into place.



Double-click its title bar.

To float a toolbar or palette:


Drag the handle to move the toolbar or palette away from the
edge of the workspace.
Note: The drag handle size and position will vary depending on
the size of the palette and whether the palette is vertical or
horizontal.



Double-click its title bar.

To move an undocked toolbar or palette:
Drag its title bar to a new position.
To resize a toolbar or palette:
Click and drag the sides or corners of a toolbar or palette to change
its size.
To display all toolbars and palettes:
Press Ctrl + Shift +T.
Note
 To hide a specific palette, click the close button on its title bar.


Press and hold Ctrl while dragging a palette to prevent it from
docking.
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Using Toolbars
The toolbars display buttons for the most common tasks. Position the
cursor over a button to display a ToolTip with its name. The Status
bar displays more information about the command.
Status bar
The Status bar displays text about
the selected tool or menu
command, as well as image
information including the
dimensions, color depth, and
cursor position. For more
information, see “Viewing Image
Information” on page 24.

Display or hide toolbars, or arrange them on the workspace. Dock a
toolbar to snap it into place at an edge of a workspace, or to float it
to move it anywhere on the screen.
Paint Shop Pro contains these toolbars:
Standard toolbar Displays the most common commands, such as
saving images, undoing a command, and cutting items. Paint Shop
Pro automatically displays this toolbar when you first run the
program.
Tools toolbar Crop, paint, draw, type, and perform other image
editing tasks. See “Using the Tools” on page 18.
Browser toolbar Displays commands for using the Paint Shop Pro
Browser.
Effects toolbar Displays commands for applying effects to your
images.
Photo toolbar Displays commands for enhancing photos.

Customizing toolbars
You can add and remove buttons
from toolbars and create your own
toolbars. For more information, see
“Customizing Toolbars and Menus”
on page 412.

Script toolbar Displays commands for creating and running scripts.
Web toolbar Displays commands for creating and saving images for
the Web.
To execute a toolbar command:
Click the command button. If the button is greyed out, it is not
available.
To display or hide a toolbar:

Flyout menu displaying toolbars

Do either of the following:


Choose View > Toolbars and choose the toolbar from the menu.



Right-click any toolbar or palette, choose Toolbars, and then
choose the toolbar from the context menu.
Note: To hide a specific toolbar or the palette, click the close
button on its title bar.
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Using Palettes
Use palettes to choose tools and tool options, select colors, and
manage layers. Display or hide palettes, or arrange them on the
workspace. Dock a palette to snap it into place at an edge of a
workspace, or to float it to move it anywhere on the screen.
Paint Shop Pro contains these palettes:
Materials palette Select colors and materials for painting, drawing,
filling, and retouching. See “Using the Materials Palette” on
page 82.
Tool Options palette Modify options for the currently selected tool.
See “Setting Tool Options” on page 18.
Layers palette View, organize, and edit image layers. See “About
Layers” on page 260.
Learning Center palette Displays tutorials for common tasks. See
“Using the Quick Guides to Learn Common Tasks” on page 7.
Histogram palette Displays a graph of the distribution of red, green,
blue, greyscale, hue, saturation, and lightness values in an image.
Analyze the distribution of detail in the shadows, midtones, and
highlights to decide how to make corrections. See “Using the
Histogram to Analyze Images” on page 201.
Overview palette Displays a thumbnail view of the active image, as
well as information about the image. See “Using the Overview
Palette” on page 19.
Script Output palette Displays actions you take and the results of
running scripts. See “About the Script Output Window” on
page 379.
Brush Variance palette Sets additional brush options. This palette is
particularly useful if you have a 4D mouse or a pressure-sensitive
tablet. For example, you can vary the opacity of a brush stroke by
applying pressure with the stylus. You can use some options with a
mouse.
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To display or hide a palette:
Flyout menu displaying pallets

Do one of the following:


Choose View > Palette and choose the palette name.



Type the palette’s shortcut key (listed to the right of the name).



Right-click any palette and choose the palette name from the
context menu.

To set palette roll up options:
On a palette:
Overview palette rolled-up



Click

to allow the palette to automatically roll-up.



Click

to lock the palette open.

For information about setting palette locking preferences, see
“Palettes Preferences” on page 396.
To set the docking preference of palettes:
Choose File > Preferences > General Program Preferences and click
the Palettes tab of the dialog. In the Allow docking of group box,
mark the check boxes of the palettes you want Paint Shop Pro to
dock automatically when you drag them to the edge of the
workspace.
Note
You can also open the Palettes tab of the Paint Shop Pro 8
Preferences dialog by right-clicking any toolbar or palette and
choose Docking Options or by choosing View > Docking Options.
To resize a palette:
Click and drag a corner or an edge, or use the Minimize and Maximize
buttons in the upper right corner.
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Using the Tools
Flyout menu displaying tools

Use the Paint Shop Pro tools to crop, paint, draw, add text, and
perform other image editing tasks. Select a tool by clicking its button
on the Tools toolbar. A tool button with a small arrow on the right
side includes several tools. Click the down-arrow to display a flyout
menu, and then choose a tool.
To view information about a tool, pause the cursor over it. A ToolTip
displays the tool name and shortcut key, and the Status bar displays
hints for using the tool.
To use a tool:

Why some tools are inactive
(greyed out)

1 Click its button on the Tools toolbar. For tools that share a flyout
with other tools, click the down-arrow next to the tool and select
the tool.

Some tools work only on raster or
vector layers. For example, the
Paint Brush and Clone Brush work
only on raster layers; the Object
Selection tool works only on vector
layers.

2 Specify options using the Tool Options palette. See “Setting Tool
Options” below.

For information on raster and
vector layers, see “About Layers”
on page 260.

For information on moving, hiding, and displaying the Tools toolbar,
see “Using Toolbars” on page 15.

3 Use the tool on the image.

Setting Tool Options
After you select a tool from the Tools toolbar, set its options in the
Tool Options palette. Options include such settings as brush size and
shape for painting tools and line width for drawing tools. By default,
the palette is underneath the standard toolbar. The palette displays
options grouped into bands, which you can minimize and drag
within the palette. To display a minimized band, click its handle or
right-facing arrow.
Here is an example of an un-docked Tool Options palette for the
Paint Brush tool:

Set the options before you use the tool. You cannot edit settings in
the Tool Options palette for brush strokes or objects you have
already created.
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Although the items in the Tool Options palette depend upon the
active tool, here are the common features:
Presets Scripts that save specific settings for a tool. For more
information, see “Using and Creating Presets” on page 386.
Down-Arrow button
tool.

Shows or hides additional options for the

For information on moving, hiding, and displaying the Tool Options
palette, see “Using Palettes” on page 16.

Using the Overview Palette
The Overview palette

Display the Overview palette to preview the entire active image or to
view image information. The Overview palette displays a rectangle
over the part of the image visible in the image window. To show
other areas of the image, click and drag this rectangle.
The Overview palette contains two tabs:
Preview Displays the image preview. The image updates after you
complete an action. Transparent areas of the image appear as white.
Info Displays image status information including height and width,
color depth, memory used, cursor position, rotation, and other
information.

Using Context Menus
A context menu on the
Layer palette

Context menus provide quick access to commands specific to the
active tool, selection, or palette.
Note
For a complete list of Context menus, choose View > Customize to
open the Customize dialog. Click the Menu tab, and select a context
menu from the Select context menu drop-down list.
To use a context menu:
1 Position the cursor over an image, an empty area of a palette, a
layer name on the Layers palette, a thumbnail in the Browser, or a
toolbar.
2 Right-click to display the context menu.
3 Choose a command from the menu.
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Viewing Images
An image window

The image window displays your image. You can move or size the
image window or open the same image in multiple image windows
(for example, to see the image at different magnifications).
The title bar at the top of the image window shows the file name and
the magnification percentage. An asterisk after the filename
indicates the image has been modified since you last saved it.
To see a thumbnail of the entire image, display the Overview palette.
See “Using the Overview Palette” on page 19.
To move an image window:
Click and drag the title bar to move an image to a new position in the
workspace.
To resize an image window:

Does the image have a
watermark?
If the image has an embedded
watermark, a copyright symbol is
displayed in front of its name. For
more information on watermarks,
see “Using Digital Watermarks” on
page 351.

Click an edge or a corner of the image window and drag it to a new
position.
If the image is larger than the window, use the scrollbars to view
another area of the image.
Note
When you resize an image window, you are changing the window
only, not the image itself. To resize the image (make it larger or
smaller), see “Resizing Images” on page 137.
To open multiple views of the same image:

Save time by saving
workspaces
Did you know that you can save
entire workspaces, not just
images? The workspace includes
open images, their magnifications
and screen positions, as well as
the positions of palettes, toolbars,
and windows.
For more information, see “Using
Custom Workspaces” on
page 401.

Choose Window > New Window or press Shift + W.
A new window opens with another view of the active image. When
you make changes in one window, the other is updated.
To arrange multiple windows:
Do either of the following:


Choose Window > Cascade to display windows stacked and
cascading from the upper left to the lower right of the workspace.



Choose Window > Tile Vertically or Window > Tile Horizontally to
display windows side by side vertically or horizontally. Windows
are resized to fit within the workspace.

Chapter 2: Getting to Know The Program

To close an image window:
Do either of the following:


To close an active window, choose File > Close or click the Close
button
on the title bar of the image.



To close all windows, choose Window > Close All.
If there are any unsaved changes in the images, you will be
prompted to save the files.

To see a list of all open windows:
Choose Window. All open windows display at the bottom of the
Window menu in the order they were last viewed.

Navigating the View Area
When an image is too large to fit within its window, scroll bars
appear on the bottom and right sides of the image.
To view another area of the image:
Do one of the following:


On the Tools toolbar, choose the Pan tool
drag in the image.



Click and drag the horizontal or vertical scroll bar.



Press the arrow keys to move the image by small increments.



Display the Overview palette (choose View > Palettes >
Overview), and then drag the preview rectangle to a new position.

To fit the window to the image:
Choose Window > Fit to Image or press Ctrl + W.

, and then click and
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Magnifying and Reducing the View
Zooming in and out

Magnify the view of an image (zoom in) to view and edit image
details or reduce the view (zoom out) to see the overall image. The
title bar of the image window displays the zoom percentage.
To zoom in:
Do one of the following:


Zoom with the mouse wheel, roll the optional wheel on your
mouse to zoom in or out quickly.



On the Tools toolbar choose the Zoom tool
(if necessary, click
the down-arrow next to the Pan tool), and then left-click the area
you want to magnify. The view magnifies to the next preset
percentage with each click, up to the maximum magnification of
5000%.



Choose the Zoom tool or the Pan tool, and then in the Tool
Options palette select a zoom percentage or click the Zoom In By
1 Step or Zoom in by 5 Steps buttons.



Choose View > Zoom In By 1 Step to magnify the view to the next
preset percentage.



Choose View > Zoom In by 5 Steps to magnify the view by five
preset percentages.

Automatic resizing
By default, when you zoom in or
out the image window is
automatically resized to fit the
image. To change this preference
setting, see “View Preferences” on
page 394.

To zoom out:
Do one of the following:


On the Tools toolbar, select the Zoom tool
(if necessary, click
the down-arrow next to the Pan tool) and then right-click the area
you want to reduce. The view reduces to the previous preset
percentage with each click, down to a minimum magnification of
1%.



Choose the Zoom tool or the Pan tool, and then in the Tool
Options palette select a zoom percentage or click the Zoom Out
By 1 Step or Zoom Out by 5 Steps buttons.



Choose View > Zoom Out By 1 Step to reduce the view to the next
preset percentage.



Choose View > Zoom Out by 5 Steps to reduce the view by five
preset percentages.
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To magnify a specific area:
1 Choose View > Magnifier, or press Ctrl + Alt + M to display the
magnifier.
2 Click and drag over the part of the image you want to magnify.
The selected area is displayed at the highest percentage that will
fit within the window.

Previewing and Editing Using the
Full Screen
Previewing on the full screen

Use the Full Screen Preview command to preview an image without
any of the menus, toolbars, or palettes visible.
Use the Full Screen Edit command to expand the entire workspace,
giving you the largest possible space for displaying and editing
images. The palettes and toolbars are visible but the menus, Paint
Shop Pro title bar, and Status bar are hidden.
To preview an image on the full screen:
1 Choose View > Full Screen Preview or press Ctrl + Shift +A. The
workspace disappears and the image displays at its current
magnification.
2 To return to the Paint Shop Pro workspace, press any key.
To edit using the full screen:

Editing using the full screen

1 Choose View > Full Screen Edit or press Shift + A. The menu bar
and status bar disappear.
To select from a menu when using the full screen, move the
cursor to the top of the screen and left-click. The menus appear
as you move the mouse along the top.
2 To return the window to its previous size, press Shift + A.
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Viewing Image Information
As you work with an image, you may want to view information
about it.
To view general image information:


Look at the Status bar (at the bottom of the Paint Shop Pro
workspace) to see the cursor position, image height and width in
pixels, and the color depth.



Display the Info tab of the Overview palette to view information
about the image. Choose View > Palettes > Overview, and then
click the Info tab. The information displayed depends on what
tool is selected.

To view image color information:
Choose Image > Count Image Colors to display the number of unique
colors in the image.
To view detailed image information:
1 Choose Image > Image Information, or press Shift + I.
2 Do one of the following:


Click the Image Information tab to view the file name and
format, image dimensions, resolution, and color depth,
modification status, number of layers and alpha channels, and
the amount of RAM and disk space used for the image as well
as its selections, masks, alpha channels, and undo storage.



Click the Creator Information tab to view or edit the image
title, artist name, copyright, description, date created, and date
modified.



Click the EXIF Information tab to view information for images
taken with digital cameras. In the Section group box, mark the
check boxes for the information you want to display: Input
Device, Artist, Date, Image, Shot Conditions, and GPS.
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Working with Dialogs
The Average dialog

Dialogs are windows that open when you choose certain Paint Shop
Pro commands. Use them to select and preview command options.
All dialogs remember where you last positioned them on the screen
and re-open in the same location.
Most dialogs have the following features in common:
Preview windows Zoom and navigate to see before and after views
of changes. See “Using Preview Windows” on page 26.
Presets Default settings and commonly used options that you have
saved as a script. See “Using and Creating Presets” on page 386.
Numeric edit controls The controls that you use to select a value. See
“Editing Numerical Values” on page 27.
Color boxes The box you click to select a color. See “Using Color
Boxes” on page 27.
Randomize parameters button A button you click to try out random
settings in the dialog. See “Randomizing Parameters” on page 28.
Resize Handle A handle in the lower right corner of the dialog used
to change the size of the dialog. See “Resizing a Dialog” on page 28.
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Using Preview Windows
The preview windows

Most dialogs that correct images, apply effects, or modify selections
have two preview windows that show the image before and after
changes are applied. Use the window controls to zoom the preview
in or out, pan it, or proof changes on the actual image.
You can show or hide the preview windows. When you hide
previews, use the main image window to proof changes.
To display or hide preview windows:
Click the Show/Hide Previews button

.

To zoom the image preview:
Size the dialog
In each Paint Shop Pro dialog with
preview windows, you can size the
dialog by clicking and dragging a
corner. Expand a dialog when you
want the preview windows to be
large enough to see detailed
changes. You can also doubleclick the dialog title bar to
maximize the dialog.

Exceptions to panning in
the left preview window
In a few dialogs, the left preview
window is used for making
selections (such as selecting a red
eye in the Red Eye Removal
dialog). In these dialogs, the
cursor does not change to a hand
over the left preview window. Use
the right preview window for
panning instead.

Click the Zoom In
or Zoom Out
buttons. The zoom
percentage displays next to the Zoom buttons.
To pan the image:
Do either of the following:


Move the cursor over either preview window (the cursor changes
to a hand), and then click and drag the image.



Click and hold the Navigate button
, and then center the
selection rectangle over the part of the image you want to
display.

To proof changes in the main image window:
Click the Proof button
. All settings in the dialog are applied to
the main image window. Each time you change settings, click the
Proof button to view the changes in the main image window.
To set automatic proofing:
Click the Autoproof button

.

Paint Shop Pro automatically applies all dialog settings to the main
image window each time you change a setting.
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Using Preset Settings
Presets in a dialog

Presets are saved settings, or scripts, that you can use to make quick
changes to images. Use the presets that come with Paint Shop Pro or
create your own. For more information on creating and using
presets, please refer to “Using and Creating Presets” on page 386.

Editing Numerical Values
Numeric edit controls
Spin controls
Edit
box

To edit numbers in Paint Shop Pro dialogs, you use the Jasc numeric
edit controls, which provide an easy way to edit numbers and change
settings.
To edit numbers:
Do one of the following:

Meter bar

Slider button



To enter a specific value, click the edit box, use the Delete or
Backspace key to delete the number as needed, and then type a
new value. You can also double-click the number to highlight it,
and then type a new value.
Note: If you type a value in the edit box that is out of range for
the control, the box turns red.



To increase or decrease the number by one, click the up or down
arrow of the spin controls.



To choose an approximate value, click once at a position on the
meter bar.



To choose from the range of possible settings, click and hold the
mouse button down on the meter bar or the slider button, drag to
select a desired setting, and release the mouse.

Using sliders to select values

Using Color Boxes
The color box in the New Image
dialog.

In some dialogs, a color box displays the currently selected color.
When you move the cursor over the color box, the cursor changes to
a dropper and displays the RGB values. Click the color box to select
another color:


Left-click the color box to select from the Color dialog.



Right-click the color box to select from recently used colors.

For more information, see “Choosing Colors” on page 86.
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Randomizing Parameters
Many correction and effect dialogs have a Randomize parameters
button. Click this button to update all dialog settings with random
values. To try out a variety of settings, click the button multiple
times.
To randomize settings within a dialog:
Click the Randomize parameters button

.

Resizing a Dialog
All dialogs contain a Resize Handle
in the lower right corner of
the dialog. Click and drag the handle to resize the dialog.

Using Shortcut and Function Keys
To work quickly and easily in Paint Shop Pro, learn the shortcut and
function keys for common tasks. Key combinations like Ctrl + Z
(Undo) and Ctrl + C (Copy) become second nature as you work, and
they save time over using the mouse.
Customizing Shortcut Keys
If you don’t like the assigned
function keys, you can customize
the function keys to suit your
needs. See “Assigning Shortcut
Keys” on page 416.
To view all assigned keys,
including custom shortcuts, choose
Help > Keyboard Map.

Here are the ways you can use shortcut and function keys in Paint
Shop Pro:


Use shortcut keys to execute menu commands, display palettes,
edit nodes on vector objects, and execute Browser commands.
All menu commands list their shortcut keys on the menu.
Shortcut keys for palettes are listed on the View > Palettes menu.



Use shortcut keys to select tools. Move the cursor over a tool to
display a ToolTip with its shortcut key in parentheses.



Use function keys to display a menu by pressing Alt plus the
underlined letter of the menu name (for example, press Alt + F for
the File menu). Then, press the underlined letter of a menu
command or scroll through menus using the arrow keys. Press
ESC to return to your image without executing a command.

To display all default shortcut keys, choose Help > Keyboard Map.
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Getting Images into Paint Shop Pro
You can get images into Paint Shop Pro in a variety of ways: import
images (from a digital camera, card reader, or scanner), capture
images from the computer screen, duplicate an existing image or
layer, or create a new raster or vector image.
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Opening Existing Images
You can open images in a variety of file formats. The list of formats
you can open in Paint Shop Pro appears in the Open dialog.
You can select which formats Paint Shop Pro displays as available to
open. See “Setting File Format Associations” on page 407.
You can open a file using the Open dialog or the Browser or by
choosing a recently used file from the File > Recent Files menu.
With the Open dialog, you can view a preview of each image file
that you select. With the Browser, you can view previews of all
image files within a folder. When you open a file via the Browser,
the Browser window stays open until you close it.
To open an image file using the Open dialog:
1 Do one of the following:

From open to browse
While opening a file from the Open
dialog, you may decide you want to
preview all files in a folder. Click
the Browse button to open the
Browser.



Choose File > Open.



Click the Open button



Press Ctrl + O.

.

2 In the Look in drop-down list, select the folder where the file is
stored.
3 Click the name of the file you want to open. To select multiple
files, press Ctrl and click each name.
4 To view information or a preview of the image, choose an option:
Details Click this button to open a pop-up that displays
information about the selected image. Click OK to close this popup.
Show preview Mark this check box to display the selected image
in the preview area. If you have selected multiple files, no
preview is displayed; use the Browse window instead.
5 Click Open.
To open an image file using the Browser:
1 Do one of the following:


Choose File > Browse.



Click the Browse button



Press Ctrl + B.

.
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The Browse window opens. Note that the main menu displays
commands specific to the Browse window. The Browse menu is
active until you open a new file or click an open image.
2 In the left panel of the Browse window, select the folder that
contains the file you want to open. The right panel displays
thumbnails of image files located in the selected folder.
3 Select files using one of these methods:
Explore the Browser
For more information on using the
Browser, see “Using the Paint
Shop Pro Browser” on page 43.



Click a thumbnail image.



To select more than one file, press Ctrl and click each file.



To select sequential files, click the first file, press Shift, and
click the last file.

Note: To deselect a file, press Ctrl and click its thumbnail.
4 Open the selected file(s) using one of these methods:


Double-click a single file’s thumbnail or Ctrl + double-click
one thumbnail when multiple files are selected.



Select a file or multiple files and then drag them onto a blank
part of the work space.



Press Enter.



Right-click and select Open from the context menu.



Choose Image File > Open.

After the file or files open, you can close the Browse window by
clicking its Close button or leave the Browse window open in the
work space.
To open a recently used file:
Choose File > Recent Files and then choose the file name.
By default, the Recent Files menu lists four recently used files. You
can include up to 10 files. For more information, see “Miscellaneous
Preferences” on page 400.
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Creating Images
About Raster and Vector Graphics
Computer graphics are of two types: raster (also called bitmap) or
vector. With Paint Shop Pro, you create both raster and vector
images. You can also create an image with both raster and vector
layers. It’s important to understand the differences between the two
data types.

Raster Images
Raster images are composed of individual elements, called pixels,
arranged in a grid. Each pixel has a specific location and color. If
you magnify raster data, you can see the individual pixels as squares
of colors.
An object in a raster image is defined by its pixels. For example, the
front door in an image of a house is made up of a mosaic of pixels at
certain locations in the image. In bitmap images you edit pixels
rather than objects or shapes.
Raster images can display subtle changes in tones and colors, so they
are most often used for images like photographs and digital artwork.
Raster images contain a fixed number of pixels, so when you
magnify the image you are magnifying the display size of the pixels.
As a result, raster images can display jagged rather than smooth
edges if magnified on screen or printed at a large magnification.

Vector Graphics
Vector graphics or images use geometric characteristics—lines,
curves, and their locations—to define objects. For example, a door
in a graphic of a house is made up of a rectangle with a certain width
and height at a specific location and filled with a certain color. In
vector images you edit objects or shapes rather than pixels.
Vector graphics do not lose clarity or detail when scaled to any size
or printed at any resolution. They work well for technical
illustrations or corporate logos.
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Choosing Raster or Vector
In Paint Shop Pro, you create and edit raster and vector data on
separate layers. With some tools you create raster data (like brush
strokes with the Paint tool) and with other tools (like the Text and
Preset Shapes tools) you can choose whether you want to create
raster or vector data.
In general, use vector objects when you’ll need to edit the object as
an element separate from other parts of the image. For example, if
you add a star to an image, you may want to change its size, color or
location. This is easier if the star is a vector object. You can create
raster data on separate layers so you can easily edit or move them.
To apply tools or commands to vector objects that work only on
raster data (such as the painting tools or the effects commands), you
can create a raster selection of a vector object. Then, paste the
selection to a new raster layer.

About Image Size, Resolution, and Color
Depth
Before you create a new image, think about how you will use it. For
example, will you display the image on a Web site, send it as an email attachment, or print it? How you use the image helps you
determine the image’s size, resolution, and color depth. All three
elements also contribute to the file size of the image.
Image Size The physical dimensions of the image. In Paint Shop Pro
you define image height and width in pixels, inches, or centimeters.


For printed images for which you know the size you need, use
inches or centimeters. By starting with the final image
dimensions, you can produce an image that will fit the page.



For printed images that you will import into another software
package (such as a word processor) and resize as needed, use
whichever unit is easiest for you.



For images to be displayed on screen, use pixels.

You can resize an image after you have created it, but doing so may
result in loss of image data. For more information, see “Resizing
Images” on page 137.
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Image Resolution The number of pixels per inch (ppi) or pixels per
centimeter in images. It is important to select an appropriate
resolution. Too low a resolution causes pixelation, or large pixels
that produce coarse output. Too high a resolution adds to an image’s
memory requirements without producing a proportional increase in
its quality.
Typical image resolutions are as follows:


For images displayed on Web pages, use 72 ppi.



For images printed to a high-quality printer, set the image
resolution to one-half to one-quarter of the actual printer
resolution. For example, for a laser printer with a resolution of
600 dots per inch (dpi), use an image resolution of 150 to 300
ppi.

Color Depth The number of colors that a pixel can display. Each
pixel’s color information is stored in a certain number of computer
bits—from 1 bit to 24 bits. In a 1-bit image, each pixel can display
only one of two colors (black or white). In a 24-bit image, each pixel
can display one of 16 million colors. Images with a color depth of 16
million colors look best because they contain the most colors, but
they also require the most memory to store and edit. Not all
computer monitors can display 16 million colors, so some file
formats limit the number of supported colors. For example, GIF
images, a popular format for the Web, contain up to 256 colors (8-bit
depth).
Many of Paint Shop Pro’s effect and correction commands work on
16 million color images only. Therefore, its best to create most
images using 16 million colors. When you have finished working on
the image, you can decrease its color depth and save it in another
format.
For more information, see “Understanding Color Depth” on
page 108.
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Creating an Image
You can create a new image by creating a blank image or by using
another image as a starting point.
For information on using other images, see “Creating New Images
from Existing Images” on page 36.
When you create a new blank image, you select the image size and
resolution, along with the color depth and background color and
material. It’s important to choose a size and resolution that fits with
your desired output type and output quality. For more information,
see “About Image Size, Resolution, and Color Depth” on page 33.
To create a new image:
1 Do one of the following to open the New Image dialog:


Choose File > New.



Press Ctrl + N.



Click the New Image button

on the toolbar.

2 Choose the image dimensions:


To select a preset size for the new image, in the Presets dropdown list choose a standard size for print materials (such as
4” x 6” or letter) or computer screens (such as 640 x 480
pixels).
The Presets list defaults to the Last Used option, which
specifies the settings that were used the last time you created a
new image.



To create an image using specific dimensions, in the Image
Dimensions group box, set the following options:

Units The units of the dimensions (pixels, inches, or
centimeters).
Width The width of the new image.
Height The height of the new image.
Resolution The resolution of the new image. Specify the
resolution units (pixels/inch or pixels/cm) in the drop-down
list.
3 In the Image Characteristics group box, select from these
options:
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Raster Background or Vector Background. The type of the
bottom layer: raster or vector. Choose a raster background for
most photographic applications. Choose a vector layer if you are
creating vector graphics.
Color depth The color depth, or number of bits per pixel, of the
image. For more information on color depth, see “About Image
Size, Resolution, and Color Depth” on page 33.
Background The background color or material.


For raster images, click the color box to select from the
Material dialog (for 16 million color images) or the image
palette (for images of all other color depths). To choose a
transparent background (for greyscale or 16 million color
images only), mark the Transparent check box.
For more information on choosing colors or materials, see
“Using the Materials Palette” on page 82.



For vector images, you only need to choose the color depth.
Vector images start with a transparent vector layer.
Note: The Memory Required field displays the amount of
memory required for the image. Your computer should have at
least two to three times this amount of RAM. To reduce the
memory requirement, reduce the resolution or the dimensions
of the image.

4 Click OK. The new image opens in the work space.

Creating New Images from Existing
Images
You can use a copy of an existing image or a layer to create a new
image. You can also create an image from any graphic data copied to
the Windows clipboard from Paint Shop Pro.
To duplicate an entire image:
1 Open the image you want to duplicate.
2 Choose Window > Duplicate or press Shift + D. A new window
containing the image opens in the work space.
To create a new image from a layer of another image:
1 On the Layer palette, click the layer you want to copy.
2 Choose Edit > Copy.
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Note: If you use the Cut or Copy commands, the current selection
or layer is placed on the clipboard.
3 Choose Edit > Paste > As New Image. A new image window
opens in the work space. The layer you copied is now the
background of the new image.
To create a new image from a layered image:
1 On the Layer palette, click a layer.
2 Choose Edit > Copy Merged.
Note: All layers are merged into one layer and placed on the
clipboard.
3 Choose Edit > Paste > As New Image. A new image window
opens in the work space. The new image contains all layers
merged into one raster layer.
To create a new image from clipboard data:
1 Cut or copy a selection or layer of an image, or an item from
another program.
2 Choose Edit > Paste > As New Image. The clipboard data is
pasted as a new image. If this command is greyed out, then the
data you have copied to the clipboard cannot be pasted as a Paint
Shop Pro image.
Note: A dialog may appear requesting additional information
such as width and height of the new image window. You can
change your preferences so that Paint Shop Pro does not prompt
for size and options when you paste data. See “Setting File
Format Preferences” on page 410.
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Importing Images from Digital Cameras and
Scanners
Running scanning software
In addition to running the scanning
software from Paint Shop Pro, you
can also run the software from the
Windows Start menu. After you
perform the scan, you then need to
run Paint Shop Pro.

With Paint Shop Pro you can access and manage your images while
they are in your digital camera. You can also load the images directly
into Paint Shop Pro.
Before you can view and download images from a digital camera,
card reader, or scanner you must install the special software (called
drivers) that enables your computer to connect to the camera, card
reader, or scanner. You must install this software before connecting
the camera, card reader, or scanner to the computer. Refer to the
documentation supplied with your camera, card reader, or scanner
for more information about this software.
Determine which type of connection your camera, card reader, or
scanner uses:


WIA The default for WIA compatible computers running the
Windows XP and ME operating systems. Your camera, card
reader, or scanner must support WIA.



Mounted Drive The default for non-WIA computers, and the most
common type of connection. Some cameras and scanners, and
most card readers are viewed as an additional disk drive when
they are connected to the USB port of your computer.



TWAIN Most cameras and scanners are TWAIN-compliant. Use
this setting if your camera, scanner, or card reader is TWAINcompliant.
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Downloading Images Using
Windows XP, ME and a USB Cable
Paint Shop Pro supports the WIA connection protocol. If your
computer has the Windows XP or ME operating system, your camera
or scanner uses the WIA connection system, and you connect your
camera or scanner to the computer using a USB cable, then Paint
Shop Pro and Windows XP or ME will automatically detect when
you have connected your camera to your computer.
To download from a WIA camera or scanner with Windows XP or
ME:
1 Connect the camera, card reader, or scanner to the computer using
the USB cable.
2 Choose File > Import > From Scanner or Camera to download the
images to your computer.

Downloading Images From a Mounted
Drive
Viewing EXIF Data
EXIF stands for Exchangeable
Image File Format. If your camera
supports this standard, it will record
the time & date the image was
taken, exposure information (ISO,
shutter, aperture) and other camera
details in the header of each image
file. To view EXIF data, choose
Image > Image Information to
open the Current Image
Information dialog, and then click
the EXIF Information tab.

Some cameras, card readers, and scanners display as a separate drive
(assigned a drive letter) on your computer. For example, your
camera may display as My Computer\Removable Disk (G:).
To download from a camera, card reader, or scanner that appears
as a mounted drive:
1 Choose File > Open to open the Open dialog. Or choose File >
Browse and use the browser to locate the images on the mounted
drive.
2 Navigate to the drive for your camera, card reader, or scanner.
3 Locate the images that you want to download in a folder or subfolder of that drive.
4 Select the images that you want to download and click Open to
open the images in Paint Shop Pro.
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Importing Images Using the TWAIN
Interface
To import images using the TWAIN interface:
1 Choose File > Import > TWAIN > Select Source. The Select Source
dialog lists the TWAIN-compliant devices connected to your
computer.
What does your image
need?
Here are some edits your digital
photograph may need:




Crop the image. Cropping
reduces the amount of memory
the image uses and eliminates
extra areas of color, which may
allow you to make better color
corrections. See “Cropping
Images” on page 134.
Correct colors or retouch parts of
the image. See “Basic Steps in
Improving Photographs” on
page 52.

Note: You only need to select the source the first time you
connect to the camera, card reader, or scanner.
2 Click the name of the device, then click Select.
3 Choose File > Import > TWAIN > Acquire to run the device’s
software.
4 Do one of the following:


For scanners, perform the scan using the device’s software.
(Refer to the scanner manufacturer’s documentation for
details.)



For digital cameras, an Import dialog displays. Select the
images that you want to download, and then click Download.

When the device and software finish processing the image, the
image is sent to Paint Shop Pro and placed in an image window.
The software remains open so you can continue to acquire
images or close the software.
5 Click the Paint Shop Pro icon in the Windows task bar to display
Paint Shop Pro and your image.
6 Choose File > Save As to save the image.
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Capturing Images from the Computer Screen
You can take a picture, called a screen capture, of all or part of the
computer screen. You can then edit and save the screen capture in
Paint Shop Pro. Before you capture screens you should configure the
screen capture options.

Setting Screen Capture Options
Add the capture icons to a
toolbar
If you frequently capture screens,
you may want to create a new
toolbar containing the icons for the
screen capture command, see
“Creating a New Toolbar” on
page 415.

Use the Capture Setup dialog to select how you want to capture, how
you activate the screen capture, and to set other options.
To set screen capture options:
1 Choose File > Import > Screen Capture > Setup to open the
Capture Setup dialog.
2 In the Capture group box, select the type of capture:
Area Captures an area of the screen that you select by clicking
once at one corner of the area and clicking again at the opposite
corner.
Full screen Captures the entire computer screen.
Client area Captures the contents of the active program.
Window Captures the active window. If a dialog is open, this
option captures the dialog. If no dialog is open, this option
captures the active application.
Object Captures an object within a program, such as a menu bar,
toolbar, icon, or a document window. When you initiate the
capture, you move the cursor over an object and it is highlighted
with a rectangle.
3 In the Activate capture using group box, select the method for
activating the screen capture:
Right mouse click A right mouse click activates a capture.
Hot key A key (such as F11) or key combination (such as Shift +
F1) activates a capture. Select the option, then click the dropdown list to select a key or key combination.
Delay timer The screen capture is taken a certain number of
seconds after you start the screen capture.
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Note: These options select the method for activating the capture
after you have started the screen capture feature. To start the
screen capture, you click the Capture Now button on this dialog,
or at the Paint Shop Pro work space press Shift + C or choose
File > Import > Screen Capture > Start.
4 In the Options group box, select from the following options:
Include cursor Mark this check box to include the cursor in
screen captures. This check box is not available for area captures.
Multiple captures Mark this check box when you want to take
multiple captures one after the other. Start the screen capture, and
then press the hot key to activate it multiple times. Clear this
check box to have Paint Shop Pro display after you take one
screen capture.
5 Do one of the following:


To start the screen capture feature immediately, click Capture
Now. Screen capture settings are saved and Paint Shop Pro
minimizes to the task bar. Use the hot key to activate the
screen capture. See “Capturing Images from the Computer
Screen” on page 41.



To save the settings, click OK.

Capturing a Screen
How do I capture a
Paint Shop Pro screen?
Open two copies of Paint Shop Pro.
In one copy, set up the screen
capture options and start the
capture feature (press Shift + C),
which minimizes the software.
Display the other Paint Shop Pro
and press the hot key to activate
the capture.

Once you have configured the screen capture settings, you can begin
capturing screens.
When you are finished, you can edit the screen captures as needed
and save the image in Paint Shop Pro. For information about saving
images, see “Saving Image Files” on page 47.
To capture a screen:
1 Open or display Paint Shop Pro.
2 To start the screen capture feature, do one of the following:


Choose File > Import > Screen Capture > Start.



Press Shift + C.

Paint Shop Pro minimizes to the Windows task bar.
3 Open or display the image or window that you want to capture.
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4 To activate the screen capture, right-click or press the hot key
(such as F10) you chose during setup.
If you chose Full Screen, Client Area, or Window during setup,
the screen, area, or window is captured.
5 For Area and Object captures, select the area or object to capture:


For Area captures, click at the top corner of the area you want
to capture, then move the cursor to the bottom corner and
click again. As you move the cursor a rectangle displays the
selection area.



For Object captures, move the cursor until the area you want
is highlighted (with a black rectangle around it), then click to
activate the capture.

6 If you selected to take multiple captures during setup, you can
now take another capture. Right-click or press the hot key for
each screen capture. When you are finished, click the Paint Shop
Pro button in the Windows task bar.

Using the Paint Shop Pro Browser
With the Paint Shop Pro Browser, you can view, open, and manage
your files.
When you open the Browse window, you have a variety of options
for selecting files to open and for renaming, moving, copying, and
deleting the image files. You can use the Browse window just as you
would Windows Explorer—with the additional help of being able to
see the image files you are managing.
To open the Browser:
Choose File > Browse or press Ctrl + B.
To select all files in a folder:
On the Browser menu, choose Edit > Select All or press Ctrl + A.
To deselect all files in a folder:
On the Browser menu, choose Edit > Select None or press Ctrl + D.
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To select files by file characteristics:
1 On the Browser menu, choose File > Select.
In the Select dialog, you can select files that have specific file or
image attributes, such as name, file extension, size, width, bits
per pixel, and date.
2 Select the file and image attributes, then click OK.
To change the order of thumbnails:
Click the file’s thumbnail and drag it to a new position within the
same folder.
To sort thumbnails by file characteristics:
1 Choose File > Sort to open the Thumbnail Sort dialog.
2 On the Primary Sort tab, select the primary sort criteria for
thumbnails.
3 To add additional sort criteria, click the Secondary Sort tab, and
select additional criteria.
4 Click OK.
Note
Sorting thumbnails is a one-time operation. The thumbnails will not
remain sorted if you add new images or change the properties of the
existing files. New images are always added to the end of the list.
To invert which files are selected:
Choose Edit > Invert Selection. All selected thumbnails are
deselected and all unselected thumbnails are selected.
To rename files:
1 Press Ctrl + R or right-click the thumbnail and select Rename from
the context menu.
2 Type the new filename. The Browser does not automatically add
an extension.
3 Click OK.
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To copy files:
1 Press Ctrl + Y or right-click the thumbnail and select Copy To from
the context menu.
2 Select the folder to copy the file to.
3 Click OK.
To paste files to other applications that support OLE functions:
Copying one image into
another image
You can copy the layers of one
image into another image. See
“Cutting, Copying, and Pasting” on
page 124.

Press Alt and click the file’s thumbnail, drag it to the application’s
button in the Window task bar until the application opens, then move
the cursor to the application and release the mouse button.
You can paste images into any applications that support meta files,
DIBs, and BMPs, such as Microsoft Word. If the image has more
than one layer, all layers are automatically merged.
To move files:
Do one of the following:


Click the file’s thumbnail and drag it to a different folder in the
left pane of the Browse window. You can also select several
thumbnails and drag them to a new folder.



Select the file or files, then press Ctrl + M or right-click the
thumbnail and choose Move To from the context menu. At the
Browse for Folder dialog, select the desired folder and click OK.

To delete files:
1 Select the file or files you want to delete.
2 Press Ctrl + Delete or right-click the file’s thumbnail and select
Delete from the context menu.
To find files:
1 Choose File > Find Name to open the Find dialog.
2 Enter the search criterial and click Find Next or Find All to
display the search results in the Browser window.
To rotate files:
1 Select the files that you want to rotate.
2 Choose ImageFile > JPEG Lossless Rotation, and then choose an
option to rotate the selected files.
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Updating Thumbnails
When you open a folder in the Browser, Paint Shop Pro creates
thumbnails for all supported graphic images and stores them in a file
called PspBrwse.jbf. Every folder you have opened in the Browser
has a copy of this thumbnail file. Paint Shop Pro uses this file to
display thumbnails more quickly each time you open a folder.
The default preference setting is to have the thumbnails file update
automatically every time you open the folder. To change this
preference, see “Browser Preferences” on page 397.
Occasionally you may want to update the thumbnails with the
Update Thumbnails command. For example, if you have used
Windows Explorer to delete or add a file in a folder, you can choose
File > Update Thumbnails, or press F5 to update the thumbnails file.
(You can also open the folder again in the Browser for Paint Shop
Pro to update it automatically.)
After a thumbnail file is created, new files are appended to the end of
the thumbnails list. To sort the list alphabetically or by other
characteristics, choose File > Sort.
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Saving Image Files
Paint Shop Pro has a native .PspImage format that supports layers,
alpha channels, and other features you use to create images. You will
find it convenient to save an image in this format while you are
working on it and then convert it to a different format after you have
finished.

Using Autosave
You can use the Autosave feature to save your files automatically at
specified intervals. This can prevent you from losing your work if
your computer shuts down unexpectedly. For more information,
please refer to “Setting Autosave Preferences” on page 409.

Compressing a .PspImage File
Always save a .PspImage
version of your file
To be able to use all Paint Shop
Pro features, we recommend you
save and edit your files in
.PspImage format with a color
depth of 16 million colors. You can
then use the Save As or Export
command to save a copy of the file
in the desired output format. Your
original image stays intact in case
you need to make changes to it
later.

An image file in the .PspImage format can be saved without
compression, or it can be compressed to save space. Both of the
compression methods that Paint Shop Pro uses are lossless, and
reduce the file size without losing any image information. Saving a
file without compressing it is the quicker method, but it requires
more hard disk space.
Paint Shop Pro uses two compression methods:


Run length encoding (RLE), which is fast and compresses most
multi-layered images to about 75% of their original sizes. It
works well with images that contain large areas of the same
color.



LZ77 compression, which is slower than RLE, but can compress
an image to a smaller size than RLE. It works well with photorealistic images.

Choose a compression option by clicking the Options button in the
various save dialogs.
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Saving an Image
You can easily save an image with the same file name and location.
Note that this will overwrite the original image with the modified
image. To save the image using a different name or file format,
choose File > Save As.
To save an image:
To automatically save the image with the same file name and
location (overwriting the original image with the modified image):


Choose File > Save.



Press Ctrl + S.



Click the Save button

on the toolbar.

Saving a New Image File
The first time you save an image, Paint Shop Pro automatically
opens the Save As dialog, where you select a location, name, and
format for the image. After this, Paint Shop Pro saves changes to the
original image without opening the dialog.
To save a new image:
1 Choose File > Save, press Ctrl + S, or click the Save button
the toolbar to open the Save As dialog.

on

2 Use the Save In drop-down list to navigate to the folder in which
you want to save the image file. If you frequently save files to the
same folder, click the Favorites folder
and select a folder
from the list.
3 In the File Name field, type a name for the file.
4 To save the file in a new format, select the format from the Save
As Type list.
5 If the file format has save options, click the Options button to
open the Save Options dialog. Select new settings, if appropriate.
If you are unsure of the settings, use the default values. Click OK
to return to the Save As dialog.
6 Click Save to close the dialog and save the file.
You can have Paint Shop Pro display the last used file type when
opening this dialog. Select this option in the Dialogs and Palettes
Preferences tab of the General Program Preferences dialog.
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Saving an Image File in its Original
Format
When you save an image and then edit it, the image title bar displays
a Modified tag (an asterisk) after the file’s name to indicate the file
has been modified. This tag disappears each time you save the file; it
reappears when you again edit the image.

Saving an Image in a New File Format
If you want to save a file in another format, use the Save As
command.
To save a file:
1 Choose File > Save As or press F12 to open the Save As dialog.
2 Navigate to and open the folder in which you want to save the
image file.
3 To rename the image file, type a new name in the File name field.
4 In the Save as type drop-down list, select a new format.
5 If the file format has save options, click the Options button to
open the Save Options dialog. Select new settings, if appropriate.
If you are unsure of the settings, use the default values. Click OK
to return to the Save As dialog.
6 Click Save to save the image file and close the dialog.
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Saving a Copy of an Image
When you save an image using the Save Copy As command, you are
copying the original file, not saving it. Use this command to save a
version of a file without affecting the original. The dialog contains
all the same features as the Save As dialog.
Note
When using the Save Copy As command:


The modifier tag is not affected. It does not disappear from the
title bar.



The file name does not change. The copy is titled “Image Name.”



Paint Shop Pro saves the copy to the same directory and in the
same format that was last used with the Save Copy As command
(not the Save As command).

To save a copy of an image:
1 Choose the File > Save Copy As or press Ctrl + F12 to open the
Save Copy As dialog.
2 Use the Save In drop-down list to navigate to a new folder if you
want to save the copy in a different folder. If necessary, use the
Up One Level button to help navigate, or the Create New Folder
button to create a new folder.
3 In the File Name box, type a name for the file.
4 To save the file in a different format, select the format from the
Save As Type drop-down list.
5 If the file format has save options, click the Options button to
open the Save Options dialog. Select new settings, if appropriate.
If you are unsure of the settings, use the default values. Click OK
to return to the Save As dialog.
6 Click Save to save a copy of the file.
Note
 For information about saving several images in a new file format
see, “Processing Multiple Files” on page 388.


For information about optimizing images for the Web, see
“Saving Images for the Web” on page 341.
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Improving Photographs
Once you have photos in Paint Shop Pro, the next step is to correct
any problems with the images. Sometimes the problems are obvious,
such as when the subject is too dark. Sometimes, you know that the
picture could look better, but you don’t know what to fix. This
chapter will help you determine what needs improvement in a photo
and show you how to improve it.
Note
All commands mentioned in this chapter work on 16 million color
and greyscale images only. To increase the color depth of an image,
see “Increasing the Color Depth of an Image” on page 109.
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Basic Steps in Improving Photographs
Paint Shop Pro contains many features you can use to enhance your
photos. Whenever you work on photos, you should follow the same
basic steps in a specific order to get the best results. This is
necessary because some later actions remove image data that is
needed to successfully complete earlier steps.
To improve photographs:
1 Calibrate your monitor to ensure that screen and print images
match as closely as possible and that colors are consistent from
image to image. For more information, see “Calibrating Your
Monitor” on page 418.
Analyzing images using the
histogram
For image editing professionals,
the histogram and its
accompanying adjustment features
are powerful tools for
understanding and correcting
images—especially those with
contrast or brightness problems.
For casual users, getting familiar
with the histogram may not be
necessary because Paint Shop Pro
offers many simpler ways to adjust
images. For information about
using the histogram to analyze
your photos, see “Using the
Histogram to Analyze Images” on
page 201.

2 Improve colors, contrast, and saturation. Use Paint Shop Pro’s
automatic adjustment commands or use the manual adjustments
to make initial corrections to your images. See “How to
Approach Color, Contrast, and Saturation Adjustments” on
page 53.
3 Correct defects caused by the image source, including unwanted
patterns on scanned images and undesirable lines on video
frames. See “Removing Source Defects” on page 62.
4 Correct image defects, such as black or white specks, and image
distortions caused by camera lenses. See “Removing Image
Defects and Noise” on page 65 and “Correcting Image
Distortions” on page 69.
5 Retouch photos, including removing scratches and red-eye
effects on people and animals. During this step you can also
remove unwanted highlights and objects from your photos. See
“Retouching Photographs” on page 72.
6 Clarify and sharpen images. See “Improving Image Clarity” on
page 79.

Chapter 4: Improving Photographs

How to Approach Color, Contrast, and Saturation
Adjustments
The color, contrast, and saturation have the most influence on our
perception of a photograph’s quality. If the colors are washed out or
the contrast is low, the photo doesn’t look right.
Curious about color?
For more information about the
qualities of color, see
“Understanding Color and Color
Models” on page 103.

Adjusting greyscale images
Because greyscale and black-andwhite photos have no color, you
can adjust only the contrast. See
“Improving Contrast” on page 60.

Paint Shop Pro’s adjustments modify the basic components of color:
hue, saturation, and lightness. Hue is the color (such as red or
yellow). Saturation is the vividness of the color. Lightness is the
intensity of light in the color.
Make adjustments in this order:


For most photos, first adjust the color and then adjust the
contrast. (Contrast adjustment can result in a loss of image
information that is needed for color adjustments.)



For images that are extremely dark or light, first adjust the
contrast to make the colors more visible, then adjust the color. If
necessary, adjust the contrast again.



Always adjust the saturation last.

Each color, contrast, and saturation adjustment can be made
automatically or manually. For automatic adjustments, you choose a
few settings and Paint Shop Pro does the rest. For manual
adjustments, you analyze the photo and decide what adjustments it
needs.
Note
When correcting color photographs, start with the automatic
adjustments, and see if you like the result. If the photo still isn’t
right, use the manual adjustments.

Fixing Photos in One Step
Use the One Step Photo Fix command to automatically adjust the
color balance, contrast,
clarity, saturation, smooth edges, and sharpen an image.
To fix a photo in one step:
On the Photo toolbar, choose One Step Quick Fix to automatically
fix a photo.
Note: Note: To view the Photo toolbar, choose View > Toolbars
> Photo.
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Improving Colors
To improve your photographs, start by adjusting the colors.
Different types of lighting, photographic equipment, and photo
processing can cause incorrect coloring in images. In addition,
scanned images or digital camera images can have unnatural color
casts.
Note
The Automatic Color Balance and Fade Correction commands work
on 16 million color images only. To increase the color depth of an
image, see “Increasing the Color Depth of an Image” on page 109.

Automatically Balancing Colors
To create natural-looking colors and remove any color cast in your
image, use the Automatic Color Balance command. This command
works best for correcting images with several colors rather than
images with variations of one color. You can apply the command to
a selection or an entire image.
To balance colors automatically:
1 Choose Adjust > Color Balance > Automatic Color Balance.
2 In the preview window, center an important part of the image
(such as a face). Pan the image by clicking and dragging in the
preview window; zoom in or out as necessary.
3 Set the Strength of correction for the image, from 1 (the least) to
100 (the most). Start with 30 and then adjust the strength until the
image looks the most natural.
4 If there is a strong color cast to the image (a particular color
added to all colors in the image), mark the Remove color cast
check box to remove it.
5 In the Illuminant temperature group box, adjust the image’s
illuminant temperature from warmer tones (oranges) to cooler
tones (blues). Type a value or drag the slider. The default setting
is 6500K, which gives the effect of a photo taken in typical
daylight. Photos taken indoors tend to look more orange, while
photos taken in bright sunlight tend to look more blue. Adjust the
value to achieve the desired effect or until the colors look
natural. If colors do not improve, you may not need to make this
adjustment.
6 Click OK.
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Using Source and Target Colors to
Correct Colors Manually
When it is particularly important to get a certain color right, use the
Manual Color Correction command. Select a color in the image that
needs to be corrected (the source color), and then select the color
you want it to be (the target color). For the target color, choose from
preset color options, a specific color, or a color from another image.
Paint Shop Pro then adjusts all colors in the selection or image based
on the shift from the source color to the target color.
Use this command when the image has skin tones that need to be
corrected or when you want to get a specific color exactly right. This
adjustment also works well for images with grossly incorrect colors.
You can apply the command to a selection or an entire image.
To use the Manual Color Correction dialog:
1 Choose Adjust > Color Balance > Manual Color Correction.
2 In the right preview window, center the area with the source
color. Pan the image by clicking and dragging in the preview
window; zoom in or out as necessary.
Note: You must use the right preview window for panning the
image because you select the source color in the left preview
window.
3 Define the Source color in the left preview window using one of
these methods:


Click once to select a single pixel. Zoom in to make sure you
select the correct color.



Click and drag to select a rectangular area.



To select an irregularly shaped area, mark the Freehand check
box, then click and drag over the image.

To change your selection, click the Clear button or make another
selection.
Choose an area that is mostly one color. You do not have to be
overly precise with the selection area because pixels in the
selection are averaged to determine the source color.
When you select the source color, the Source color box displays
the selected color.
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4 Choose the Target color using one of these methods:
The Source and Target color
boxes

Select target colors manually by
entering Hue, Saturation, and
Lightness values



To choose from a preset color category, select the Preset
colors option, choose a color category from the list, and then
choose a color from within the category. See “Choosing Color
Categories” on page 56.



To choose from the Color dialog, left-click the Target color
box. See “Choosing Colors” on page 86.



To choose from recently used colors, right-click the Target
color box.



To choose from any open image, move the cursor over the
image until it changes into a dropper and then click the color.



To choose a color based on its hue, saturation, and lightness
(HSL) values, select the Manual option, and then enter the
values.

When you select the color, the Target color box displays the
target color.
5 If you are using the Preset colors option or have selected a
source color from the Target color box, choose from the
following options:
Preserving lightness and
saturation
If you mark Preserve Lightness and
Preserve Saturation, and the
source and target colors are similar
hues, you may not notice much
change in the adjusted image. Try
clearing one or both options.
To match the target color exactly,
clear Preserve Lightness and
Preserve Saturation.

Preserve Lightness Mark this check box to preserve the lightness
of the source color in the corrected image. Clear this check box
to match the lightness of the corrected image to the target color’s
lightness.
Preserve Saturation Mark this check box to preserve the
saturation of the source color in the corrected image. Clear this
check box to match the saturation of the corrected image to the
target color’s saturation.
6 Click OK.

Choosing Color Categories
The preset color categories of the Manual Color Correction dialog
consist of a variety of frequently occurring colors. Most of these
categories are called memory colors because people remember them
particularly well and notice when they don’t look natural. Typical
examples are skin tones and sky colors. Memory color categories in
the Color Category list are Beverage, Foliage, Fruits, Grasses,
Grays, Hair Colors, Metals, Skintones, Sky, Various Foods,
Vegetables, Water, and Woods.

Chapter 4: Improving Photographs

There are other categories that you may find helpful when defining
the target colors for your photographs:
Pure Colors The main colors on the color wheel (example, red,
orange, yellow).
Standard A set of colors designed to let you make very subtle
changes in hue. When you select a source color, the Nearest preset
color field above the list displays a number for the color that is the
closest match in the Standard category.
To correct an image using Standard Colors:
1 Choose Adjust > Color Balance > Manual Color Correction.
2 Click in the left preview window to select a source color.
3 Select the Preset colors option.
4 In the list underneath, choose Standard.
The Nearest preset color area above the list box displays the
Standard color that is the closest match to the source color. Click
the Color box to the right of the list and scroll to view the color.
5 Modify the target color using one of the following options:


To shift all hues in the image slightly, choose a color from the
Preset colors list that is similar to the current color.



To shift all hues in the image drastically, choose a color from
the Preset colors list that is quite different from the current
color.



Preserve Lightness Mark this check box to preserve the
lightness of the source color in the corrected image. Clear this
check box to match the lightness of the corrected image to the
target color’s lightness.



Preserve Saturation Mark this check box to preserve the
saturation of the source color in the corrected image. Clear
this check box to match the saturation of the corrected image
to the target color’s saturation.
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Using Grey World to Adjust Colors
Like the Automatic Color Balance command, the Grey World Color
Balance command corrects image colors, but it uses a different
mathematical algorithm.
If you average all the colors in a complex, outdoor photograph, the
average color turns out to be grey. Grey World color correction uses
this fact to determine what a photograph needs to have better looking
colors.
As with any of Paint Shop Pro’s color correction commands, the best
approach is to try the Grey World command and see if you like its
results. You can apply this command to a selection or an entire
image.
To correct colors using the Grey World dialog:
When not to use Grey World
color correction
This color correction may not work
well for:




Very simple scenes with few
colors
Images with a limited range of
hues (such as mostly blues)
Simple computer-generated
graphics

1 Choose Adjust > Color Balance > Grey World Color Balance.
The right preview window shows the image colors automatically
corrected with the Grey World algorithm.
2 In the preview window, center an important part of the image
(such as a face). Pan the image by clicking and dragging in the
preview window; zoom in or out as necessary.
3 In the Illuminant Temperature group box, type a value or drag the
slider to change the image’s illuminant temperature from warmer
tones (oranges) to cooler tones (blues). The default setting is
6500K, which gives the effect of a photo taken in typical
daylight. Photos taken indoors tend to look more orange, while
photos taken in bright sunlight tend to look more blue. Adjust the
value to achieve the desired effect or until the colors look the
most natural.
4 Click OK.
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Correcting Faded Images
Color depth
The Fade Correction command
works on 16 million color images
only. To increase the color depth of
an image, see “Increasing the Color
Depth of an Image” on page 109.

With time and exposure to the elements, especially light, the dyes in
a photograph fade. Colors become less vivid, the image acquires an
undesirable color cast, and contrast is lost. Use the Fade Correction
command to restore color and contrast to faded photographic
images. You can apply the command to a selection or an entire
image.
The Fade Correction command is a simple, one-step adjustment that
corrects both color and contrast. If the resulting image doesn’t look
as good as you would like, the image may need different
adjustments. Instead, try applying the three automatic adjustments
from the submenus of the Adjust menu in this order: Automatic
Color Balance, Automatic Contrast Enhancement, Automatic
Saturation Enhancement.
To use fade correction:

Have a faded black-andwhite photo?
Black-and-white photos have no
colors to correct. Instead, use the
Automatic Contrast Enhancement
command to restore the
photograph. See “Automatically
Enhancing Contrast” on page 60.

1 Choose Adjust > Color Balance > Fade Correction.
2 In the preview window, center an important part of the image
(such as a face). Pan the image by clicking and dragging in the
preview window; zoom in or out as necessary.
3 For Amount of correction, start with 45 and adjust the value until
the image looks the most natural.
Note: Use the minimum value that produces a good correction. If
you apply too much correction, highlight and shadow areas may
lose detail and objects may blend together.
4 Click OK.
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Improving Contrast
Contrast is the variation of dark and light intensities within an
image. To look its best, an image must have the proper balance
between highlights, midtones, and shadows.
Brightness is a term often associated with contrast. Brightness is the
overall lightness of an image. If the image has a high brightness, all
colors are bright. If the image has a low brightness, all colors are
dark. Several of Paint Shop Pro’s contrast adjustments also affect the
brightness of images.
Note
The Automatic Contrast Enhancement command works on 16
million color and greyscale images only. To increase the color depth
of an image, see “Increasing the Color Depth of an Image” on
page 109.

Automatically Enhancing Contrast
To adjust an image’s overall lightness and intensity and to balance
its highlights, midtones, and shadows, use the Automatic Contrast
Enhancement command. You can apply the command to a selection
or an entire image.
Note: If you apply this command to a selection on an image, the
contrast adjustment may not be as effective because all the image
information is not available.
To automatically adjust contrast:
1 Choose Adjust > Brightness and Contrast > Automatic Contrast
Enhancement.
2 In the preview window; center an important part of the image.
Pan the image by clicking and dragging in the preview window;
zoom in or out as necessary.
3 Adjust the Bias (the brightness) of the correction: Lighter,
Neutral, or Darker.
4 Adjust the Strength of correction: Normal or Mild.
5 Adjust the Appearance of the correction:
Flat (a slight difference between light and dark areas)
Natural (an average difference between light and dark areas)
Bold (a striking difference between light and dark areas).
6 Click OK.
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Improving Saturation
After you have corrected the color balance and contrast of your
image, adjust the saturation. Saturation is the vividness of colors that
results from the amount of grey in each color. Saturated colors, such
as fire-engine red, appear bright and brilliant. Desaturated colors,
such as pastels, appear subdued or washed-out.

Automatically Enhancing Saturation
To adjust the overall color saturation of your image automatically,
use the Automatic Saturation Enhancement command. You can
apply the command to a selection or an entire layer.
Note
 This command works on 16 million color and greyscale images
only. To increase the color depth of an image, see “Increasing the
Color Depth of an Image” on page 109.


If you apply this command to a selection (rather than the entire
image), the saturation adjustment may not be as effective because
all image information is not available.



This command has no effect on greyscale images because they
have no color, it can be used on sepia or duotone images.

To automatically enhance saturation:
1 Choose Adjust > Hue and Saturation > Automatic Saturation
Enhancement.
2 In the preview window, center an important part of the image
(such as a face). Pan the image by clicking and dragging in the
preview window; zoom in or out as necessary.
3 Adjust the Bias (the vividness) of the corrected colors:
Less colorful, Normal, or More colorful.
4 Adjust the Strength of correction: Weak, Normal, or Strong.
5 Mark the Skintones present check box if significant amounts of
skintones are present in the selection or image. Marking this
check box gives people more natural coloring. Clear the check
box if the image has few or no skintones.
6 Click OK.
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Removing Source Defects
Images can contain defects that come from the process of scanning
or capturing them
Note
These commands work on 16 million color and greyscale images
only. To increase the color depth of an image, see “Increasing the
Color Depth of an Image” on page 109.

Fixing Line Problems in Video Images
Video images can contain visible scan lines. In these images, lines
can be missing or out of alignment with other lines. The resulting
image looks excessively blurry.
Use the Deinterlace command to eliminate missing or misaligned
lines from your image and to reconstruct missing information. If the
image contains noise, it may become more visible after removing
scan lines. For information on removing noise, see “Removing
Image Defects and Noise” on page 65.
Note: Apply the Deinterlace command before you resize the
image. Resizing adds or removes pixels from the image, which
makes it more difficult to determine scan lines.
If your image has already been resized, you must return it to as close
to the original size as possible so that each scan line is one pixel
high. Zoom in until you can see individual pixels to determine how
many pixels make up one scan line, and then resize the image so that
each scan line is one pixel. For example, if the enlarged image has
scan lines that are two pixels high, you would resize it by 50 percent.
Keep in mind that the image loses clarity when you resize it.
To deinterlace an image:
1 Make sure the image has no selections. If necessary, choose
Selections > Select None. The Deinterlace command is not
available if the image contains a selection.
2 Choose Adjust > Add/Remove Noise > Deinterlace.
3 In the preview window, center the area of the image where the
scan lines are most apparent.
4 For Scanlines to retain, select either Odd or Even to determine
whether the odd-numbered or even-numbered scan lines are kept.
5 Click OK.
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Removing Artifacts from JPEG Images
When you save a file to the JPEG format from any software package
(such as scanning software), the file information is compressed to
create a smaller file. The compression produces artifacts—unwanted
image problems—that can appear as halos or color leakage beyond
the edges of objects, checkerboard problems on smooth
backgrounds, or blocky-looking areas in an image.
Use Paint Shop Pro’s JPEG Artifact Removal command to restore a
JPEG image to its original appearance.
Note
Because JPEG compression discards image information, there are
limits to how well the image can be restored.
To remove JPEG artifacts:
What if my file is not in
JPEG format?
You can apply the JPEG Artifact
Removal command to a file in any
format. For example, if you have
saved a JPEG file as a Paint Shop
Pro (.PspImage) file, you can still
apply the command.

1 Make sure the image has no selections. If necessary, choose
Selections > Select None. The JPEG Artifact Removal command
is not available if the image contains a selection.
2 Choose Adjust > Add/Remove Noise > JPEG Artifact Removal.
3 In the preview window, center the area of the image where the
artifacts are most apparent.
4 In the Strength group box, set the strength of correction to Low,
Normal, High, or Maximum. For best results, try each option and
examine all areas of the image to see which strength setting
works best.
5 Set the Crispness to determine the amount of detail that is
restored, from 0 (the least) to 100 (the most). Start with 50 and
adjust the value until the image looks the most natural. This
option determines how much fine-detail information the artifact
removal attempts to create. The recreated information can only
be a guess since the original information is lost. Excessive
crispness may produce fine dots in the image.
6 Click OK.
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Removing Undesirable Patterns in
Scanned Images
Scanning printed images can produce undesirable patterns called
Moiré patterns. Other patterns may come from scanning photographs
printed on textured paper. Paint Shop Pro’s Moiré Pattern Removal
command removes these patterns from your images. You can apply
the command to a selection or an entire layer.
To remove moiré patterns:
1 Choose Adjust > Add/Remove Noise > Moiré Pattern Removal.
2 Magnify the image in the preview window until you can see the
fine patterns clearly.
3 For Fine details, select a value to remove fine patterns. Change
the value one number at a time until the pattern just disappears.
Higher values may blur the image, so use the lowest value that
removes the pattern.
4 Reduce the image magnification until you can see bands or color
blotches clearly in the preview window. Bands or blotches may
be visible when the image is at 100%, but may be easier to see at
smaller percentages.
5 For Remove bands, change the value one number at a time until
any color bands or blotches are less visible (they may not
disappear completely). Use the lowest value possible to avoid
desaturation of small objects.
6 Click OK.
Note
After you have removed the Moiré pattern, you may be able to use
the Sharpen commands to restore detail and remove blurriness
without reintroducing the pattern. This approach works best when
you choose a Fine Details setting in the Moiré Pattern Removal
dialog that is slightly higher than needed to remove the pattern. For
more information on the Sharpen commands, see “Clarifying
Images” on page 79.
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Removing Image Defects and Noise
Sometimes images have defects that are called noise—black, white,
or colored specks ranging in size from very tiny to relatively large or
all-over noise that gives surfaces a grainy look. You can use Paint
Shop Pro’s Noise commands to remove noise from images. Before
you decide which command to use, determine the type of noise that
your image contains.
Note
All Noise commands work on 16 million color and greyscale images
only. To increase the color depth of an image, see “Increasing the
Color Depth of an Image” on page 109.

Removing Single-Pixel Specks
Use the Despeckle command to remove single-pixel specks that are
mostly white or black. This command analyzes the brightness of
each pixel and compares it to the surrounding pixels to determine if
it should be removed.
To remove single-pixel specks in an image:
1 Select the area that contains the specks. See “Using the Selection
Tools” on page 154.
2 Choose Adjust > Add/Remove Noise > Despeckle. The selection
is despeckled.

Removing Multiple-Pixel Black or
White Specks
Use the Salt and Pepper Filter command to remove multiple-pixel
black or white specks, such as those caused by dust on film or video.
This command compares an area of pixels to the surrounding pixels
and adjusts an area that is a speck to match those surrounding pixels.
To remove multiple-pixel specks:
1 Select the area that contains the specks. See “Using the Selection
Tools” on page 154.
2 Choose Adjust > Add/Remove Noise > Salt And Pepper Filter.
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3 Define the adjustment using the following options:
Speck size The minimum size, in pixels, of the largest speck that
can be completely removed. The value is always an odd number.
Sensitivity to specks How different an area must be from its
surrounding pixels to be considered a speck.
4 Mark the Include all lower speck sizes check box to have Paint
Shop Pro remove all lower speck sizes. Results are usually better
if you mark this check box.
5 Mark or clear the Aggressive action check box to set whether the
strength of correction is normal (if the check box is cleared) or
aggressive (if the check box is marked).
6 Click OK.

Removing Noise While Preserving
Edge Details
Should I make a
selection first?
You can apply the Edge Preserving
Smooth command to a selection or
an image. It is faster and more
effective when applied to a
selection.

Use the Edge Preserving Smooth command to remove noise in an
image without losing edge details. This command finds details such
as object edges and preserves them, while smoothing the areas
between the edges. For example, you can preserve the edges of facial
features while removing a blotchy complexion.
You can also use the Edge Preserving Smooth command to minimize
film grain.
To remove noise while preserving edge details:
1 Select the area that contains the noise. See “Using the Selection
Tools” on page 154.
2 Choose Adjust > Add/Remove Noise > Edge Preserving Smooth.
3 For Amount of smoothing, change the value until you are
satisfied with the adjustment. Choose the smallest amount of
smoothing that removes the specks while retaining image detail.
4 Click OK.
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Removing Small Areas of Noise
Use the Median Filter command to remove small random specks or
areas of noise that are distinctly different from the surrounding area.
You can also use the command to remove single-pixel colored
specks.
The Median Filter command adjusts the intensity of each pixel in the
image to the median intensity of surrounding pixels. The median
intensity is the middle value (not the average) in the range of values.
To preserve object edges, the Median Filter command adjusts a pixel
that is very different from surrounding pixels more than a pixel that
is similar to surrounding pixels. You can choose the number of
surrounding pixels to use in the calculation. If you choose a large
number, more noise is removed and so more detail is lost.
To remove small areas of noise:
1 Select the area that contains the noise. See “Using the Selection
Tools” on page 154.
2 Choose Adjust > Add/Remove Noise > Median Filter.
3 For Filter Aperture, choose the number of surrounding pixels to
include in determining the median intensity of each pixel. The
filter is always an odd number of pixels. To preserve image
details, choose the smallest filter that removes the noise.
For single-pixel colored specks, set the filter to 3.
4 Click OK.
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Removing Noise While Keeping Texture
Details
Should I make a
selection first?
You can apply the Texture
Preserving Smooth command to a
selection or an image. The
command is faster and more
effective when applied to a
selection.

Use the Texture Preserving Smooth command to remove noise or
specks in an image while preserving texture details. This command
analyze’s an image’s pixels to determine if they display textured or
smooth areas. Textured areas are preserved (few noise adjustments
are made) and smooth areas are adjusted to remove noise. For
example, textures in clothing may be preserved while noise from
another area (such as a person’s face) is removed.
To remove noise while keeping texture details:
1 Select the area that contains the noise. See “Using the Selection
Tools” on page 154.
2 Choose Adjust > Add/ Remove Noise > Texture Preserving
Smooth.
3 For Amount of correction, set a value to choose the strength of
the correction. At lower values, a small amount of noise is
removed but textured areas are preserved. At higher values, more
noise is removed but textured areas may not be fully preserved.
4 Click OK.

Softening the Image
The three Softness commands are Soft Focus, Soften, Soften More.
Soften applies a uniform blur to your image. Soften More applies the
Soften command with more intensity. The Soft Focus command
makes the image look as though it was taken with a camera using a
soft focus filter.
To use the Soften and Soften More commands, choose Adjust >
Softness and either the Soften or Soften More command.
To use the Soft Focus command:
1 Choose Adjust > Softness > Soft Focus to open the dialog.
2 In the preview window, center the important part of the image.
Pan the image by clicking and dragging in the preview window;
zoom in or out as necessary.
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3 For Softness, set a percentage value to choose the strength of the
correction. At lower values, the image is softened only a small
amount. At higher values, the image appears to have a blurred
effect.
4 For Edge importance, set a percentage value to choose the
strength of the correction. At lower values, the edges of the
image are softened. At higher values, the detail of the edges are
retained.
5 Mark the Include scattered light check box if you want bright
areas in the background of the image to be softened.
6 For Amount, set a percentage value to choose the strength of the
halo effect. At lower values, the halo is added to only very bright
areas in the image. At higher values, a halo effect is created
around bright areas.
7 For Halo size, set a percentage value to choose the size of the
halo. At lower values, the halo is small. At higher values, the
halo effect is large.
8 For Halo visibility, set a percentage value to choose the strength
of the halo visibility. At lower values, the halo effect is subtle. At
higher values, the halo effect is more obvious.
9 Click OK.

Correcting Image Distortions
Camera lenses can create distortions in photographs. You see these
distortions most often in wide-angle photographs, in close-up
photographs taken with cameras with fixed focal ranges, and in
cameras with inexpensive lenses (such as disposable cameras).
Note
 The Barrel and Fisheye Distortion Correction commands work
on 16 million color and greyscale images only. To increase the
color depth of an image, see page 109.


You must correct lens distortions before cropping the image. For
distortion corrections to work properly, the axis of the camera
lens must coincide with the center of the image.

69

70

Chapter 4: Improving Photographs

Correcting Barrel Distortions
If your image has a barrel distortion, it looks pushed out at the
center. Lines that should be straight are curved.
To correct a barrel distortion:
1 Choose Adjust > Lens Correction > Barrel Distortion Correction.
2 Set the Strength of the correction. Adjust this value until the
distortion disappears. Look for lines in the image that are curved
and adjust the Strength Value until they become straight. The
image is resized as you adjust this value.
3 Preserve central scale Whether the scale of the center of the
picture remains the same or is adjusted. If you mark this check
box, pixels are either added to, or removed from the image. Clear
this check box if you do not want to change the size of the image
or layer.
Note: If the Preserve central scale check box is marked, the
size changes to the original image display in the Result size
group box.
4 Click OK.

Correcting Fisheye Distortions
If your image has a fisheye distortion, it looks as though it has been
pasted onto a sphere or blown up like a balloon. Lines that should be
straight are curved and the edges of the image look compressed.
To correct a fisheye distortion:
1 Choose Adjust > Lens Correction > Fisheye Distortion
Correction.
2 Adjust the image using the following options:
Field of View The strength of the correction. Adjust this value
until the distortion disappears.
Preserve central scale Whether the scale of the center of the
picture remains the same or is adjusted. If you mark this check
box, pixels are either added to, or removed from the image. Clear
this check box if you do not want to change the size of the image
or layer.
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Note: If the Preserve central scale check box is marked, the
size changes to the original image display in the Result size
group box.

Correcting Pincushion Distortions
If your image has a pincushion distortion, it looks pushed in at the
center. Lines that should be straight are curved.
To correct a pincushion distortion:
1 Choose Adjust > Lens Correction > Pincushion Distortion
Correction.
2 Adjust the image using the following options:
Strength of the correction. Adjust this value until the distortion
disappears. Look for lines in the image that are curved and adjust
the Strength value until they become straight. The image is
resized as you adjust this value.
Preserve central scale Whether the scale of the center of the
picture remains the same or is adjusted. If you mark this check
box, pixels are either added to, or removed from the image. Clear
this check box if you do not want to change the size of the image
or layer.
Note: If the Preserve central scale check box is marked, the
size changes to the original image display in the Result size
group box.
3 Click OK.
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Retouching Photographs
Paint Shop Pro offers many options for retouching your photos. You
can remove red eyes from people, or the green eyes of animals using
the Red-Eye Removal command. If there are scratches, cracks, and
other unwanted defects on a relatively smooth background, use the
Scratch Remover tool. If there are many small scratches or creases,
use the Automatic Small Scratch Remover command. If there are
elements you want to remove, use the Clone Brush tool. Use the
retouch tools to lighten, darken, emboss, change colors, and apply
other retouches to parts of the image.
Note
The Red-Eye and Small Scratch Removal commands work on 16
million color images only. To increase the color depth of an image,
see “Increasing the Color Depth of an Image” on page 109

Removing Red Eyes
When you take a flash picture of people, sometimes their eyes look
red—the result of the flash’s light reflecting off the retina of the eye.
Use the Red-Eye Removal command to return eyes to natural colors.
You can also use this command to enhance or change eye colors.
To use the Red-Eye Removal command:
1 Make sure the image has no selections. If necessary, choose
Selections > Select None. The Red-Eye Removal command is not
available if the image contains a selection.
2 Choose Adjust > Red-Eye Removal.
3 In the right preview window, center the red eyes of the subject.
Pan the image by clicking and dragging in the preview window;
zoom in or out as necessary.
Note: You must use the right preview window for panning the
image because you select the subject’s eyes in the left preview
window.
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4 From the Method drop-down list, select a correction method:
So you always wanted
blue eyes...
To use the Red-Eye Removal
command to enhance or change
eye colors, follow the same steps
for correcting red eyes with these
special instructions:





Select the new eye color.
Select the entire eye (pupil and
iris).
Adjust the Iris Size setting until
the pupil and iris look natural.
Use the Feather and Blur
settings to make the new eyes
look more natural.

Auto Human Eye Automatically selects the correction area using
a circular selection and chooses settings appropriate to a human
eye. If you are correcting human eyes (even partially obscured
ones), try this method first.
Auto Animal Eye Automatically selects the correction area using
a circular or elliptical selection area and chooses settings
appropriate to an animal eye. You can also rotate the selection
with this method. If you are correcting animal eyes, try this
method first.
Freehand Pupil Outline Manually select the correction area on
human or animal eyes using a Freehand Selection tool. Use this
method for difficult situations, such as a partially obscured pupil.
Point-to-Point Pupil Outline Manually select the correction area
on human or animal eyes using a Point-to-Point Selection tool.
Use this method for difficult situations, such as a partially
obscured pupil.
5 In the left preview window, select the first eye to correct:

About manual eye
correction methods



For both the Pupil Outline methods,
select the pupil (the small dark
circle at the eye’s center), not the
entire eye. These methods correct
red pupils on humans and animals,
but do not correct human irises
(you’ll notice the Hue option for
setting the iris hue is not available).

For the Auto Human Eye or Auto Animal Eye method, click
anywhere inside the red area of the eye to select the eye
automatically. You can also click and drag from the center of
the eye to the outside edge of the red area.



For the Freehand Pupil Outline method, click and drag the
cursor around the edge of the red area of the pupil. Release the
mouse button when you reach the beginning point of the
selection.



For the Point-to-Point Pupil Outline method, left-click at
points a few pixels apart around the edge of the red area of the
pupil. (Right-click to reverse a click.) When you reach the
beginning point, double-click.

Typically, red-eye effect is confined
to the pupil, so with these manual
methods you can correct the red
pupil.

Note: To remove a selection, click Delete.
After you select the eye, a circle appears around the selected area
and a control box for making adjustments encloses the circle. The
right preview window displays the corrected eye.
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6 Make sure the selection is positioned and sized properly over the
red area of the eye:


To move the selection, drag it to a new location.



For the Auto Animal Eye method, drag the center rotation
handle to rotate the selection. You can also reshape the eye
from a circle to an ellipse by dragging its side handles.

7 Fine-tune the eye correction by adjusting the pupil size and
lightness, glint, iris size, and feathering and blurring of the iris.
Refer to the fine-tuning steps later in this section.
Need to change a setting?
To make further corrections on any
eye you have selected, click the
circle surrounding the eye. You can
change any of the settings except
Method. To change the correction
method, remove the selection (click
Delete), select the method, and
then select the eye again.

8 To correct other red eyes, repeat the previous steps. The settings
from the first eye are retained, so the subsequent corrections
should be much quicker.
9 Click OK.
To fine-tune the eye correction on the Red-Eye Removal dialog:
1 For a human eye, look at the corrected eye to see if you need to
adjust the iris area around the pupil. (An animal eye usually does
not show an iris.) Sometimes the red eye area covers the iris. If
needed, adjust the iris with the following options:
Iris Size The size of the iris. Increasing the iris size decreases the
pupil size.
Hue The color of the iris (such as blue, brown, or green). This
option is not available for the Freehand Pupil Outline and Pointto-Point Pupil Outline methods because these methods select the
pupil, rather than the pupil and iris.
Color The color variation of the iris (such as light blue or deep
blue).
2 For Pupil lightness, adjust the value so that the corrected eye
appears the appropriate shade and matches your perception of the
natural color.
3 Examine the glint in the eye. A glint makes the eye look natural
and lively; without it the eye looks “dead.” Adjust the glint using
the following options:
Glint size The size of the glint.
Glint lightness The lightness of the glint. Lower values darken
the glint; higher values lighten it.
Center glint Mark the check box to move the glint to the center of
the pupil. Clear it to leave the glint at its original position.
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Correcting obscured human
eyes
If a human eye is partially
obscured, select the Auto Human
Eye method, and then use the
Refine setting to adjust the
correction area.

4 Use Refine when the eye is partially obscured in the original
image. For example, if the eyelid covers part of the original eye,
it should cover it in the corrected eye. Use the Refine Slider to
reduce the correction. Slowly drag the slider to the left to reduce
the correction and minimize its overlap with the surrounding
skin.
5 To blend the corrected eye with the rest of the image, set the
following options:
Feather Adjusts the edges of the corrected eye. Smaller values
make the edges more defined; larger values blend the edges to
the surrounding image areas.
Blur Blends the eye with surrounding pixels when the photo has a
grainy appearance. Increase the setting one unit at a time until the
eye blends naturally with the rest of the image.

Removing Scratches with the Scratch
Remover Tool
Smooth vs. textured
background
The Scratch Remover tool uses the
background image details to create
new information to replace the
scratch. If the background is
relatively smooth, the result is
usually satisfying.
To remove scratches from a
textured background, the Clone tool
may be more effective. See
“Cloning Parts of Images” on
page 219.

The Scratch Remover tool is one way to remove scratches, cracks,
and other defects from your images. Use the tool to enclose the area
with the scratch and erase it. The tool works best for scratches on
relatively smooth backgrounds.
Note
This tool can be used only on backgrounds; it is not available when
you are working on layers.
If there are many small scratches in the image, use the Automatic
Small Scratch Remover command. See “Removing Scratches with
the Automatic Small Scratch Removal Command” on page 77.
To use the Scratch Remover tool:
1 If necessary, click the background layer on the Layer palette.
2 To limit the correction to a specific area, make a selection. (See
“Using the Selection Tools” on page 154.) This step works well
when you need to be careful not to remove important details near
the scratch.
3 Select the Scratch Remover tool

.
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4 On the Tool Options palette, set the following options:
Width The width, in pixels, of the tool. Choose a width that is
about 3 or 4 pixels wider than the scratch. If the width is
considerably larger than the scratch, you will lose image detail.
Selection boxes The shape of the Scratch Remover tool. Select
the flat-end option
to correct scratches that are perpendicular
to object edges in the image or are in an open area (the
background is similar and has no objects in it). Select the
pointed-end option
to correct scratches at an angle to object
edges in the image (with this option, you can place the tool closer
to the edges).
Achieving the best results
If the scratch background is highly
textured or contains many image
variations (say, a flower, a face,
and a wall), the result may not be
as satisfying.

5 Center the cursor just outside one end of the scratch, then click
and drag the bounding box over the scratch:


If the tool width is 10 or fewer pixels, the box is single-sided.
Position the box so that the edges surround, but do not touch,
the scratch.



If the tool width is more than 10 pixels, the box is doublesided. Position the box so that the inner edges surround, but
do not touch, the scratch.

Try these tips to get the best
results:







Before using the tool, select the
area that contains the scratch.
Use a tool width about 3 or 4
pixels wider than the scratch
itself.
For scratches over several
different backgrounds, try
removing the scratch a section at
a time.
Consider using the Clone Tool
instead.

6 With the mouse button still pressed, you can adjust the size and
position of the rectangle:


Press the Arrow keys to move the starting point of the
bounding box by 1 pixel.



Press PageUp or PageDown to increase or decrease the width
of the box by 1 pixel.

7 When the rectangle properly encloses the scratch, release the
mouse button. The scratch is removed.
If you are not satisfied with the result, click Undo
to undo the
scratch removal, then try selecting the scratch again (perhaps
varying the width of the tool).
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Removing Scratches with the Automatic
Small Scratch Removal Command
Color depth
The Automatic Small Scratch
Removal command works on 16
million color or greyscale images
only. To increase the color depth of
an image, see page 109.

The Automatic Small Scratch Remover command finds and
eliminates small, line-shaped defects that are either lighter or darker
than the surrounding area.
To use the Automatic Small Scratch Removal command:
1 To limit the correction to a specific area, make a selection. (See
“Using the Selection Tools” on page 154.) The command works
best on a selection rather than the entire image.
2 Choose Adjust > Add/Remove Noise > Automatic Small Scratch
Removal.
3 Mark the check box of the type of scratches to remove (you must
choose at least one option):
Remove dark scratches Mark this check box to remove scratches
that are darker than their background.
Remove light scratches Mark this check box to remove scratches
that are lighter than their background.
4 Specify how scratches are removed with the options in these two
group boxes:
Local contrast limits The difference in contrast between a scratch
and its background. Use a value that sets the limits to where they
achieve the best results. Start with the Lower limit at 0 and the
Upper limit at 50. If scratches remain, the Automatic Small
Scratch Removal command is unable to remove them. If
scratches disappear, then adjust the limits to minimize loss of
image detail. Adjust the Lower limit up to the setting just below
where scratches reappear. Adjust the Upper limit down to the
setting just above where the scratches reappear.
Strength The strength of the scratch removal: Mild, Normal, or
Aggressive. Select the lowest setting that removes scratches.
Look at all areas of the image to make sure important details are
not lost.
5 Click OK.

77

78

Chapter 4: Improving Photographs

Blurring Images
Use Blur to soften a selection or an image. Blur images for photo
retouching or to remove noise in the image. The Blur commands
smooth transitions and decrease contrast by averaging the pixels
near edges and areas of significant color transitions.
To increase the effect of any of the Blur effects, apply them multiple
times to the same image.
Note
 These commands work on greyscale and 16 million color (24-bit)
images only. To increase the color depth of an image, see
page 109.


For descriptions and visual examples all the blur commands,
refer to the Help system.

Select from the following blur commands:
Applying the Motion Blur effect

Average Removes noise that occurs throughout an image by
adjusting the intensity of each pixel to the average intensity of its
surrounding pixels. Also removes color dithering that results from
increasing the color depth of an image from paletted to 24 bit.
Blur and Blur More Remove noise by applying smooth transitions
and decreasing the contrast in your image. The Blur More effect
applies the Blur effect with more intensity. Use either effect to
reduce graininess in your image.
Gaussian Blurs an image by an adjustable amount. Blends a specific
number of pixels incrementally, following a bell-shaped curve. The
blurring is dense in the center and feathers at the edges.
Motion Blur Blurs in a particular direction (from 0 to 359 degrees)
and at a particular strength (from 1 to 100). Use this effect to
simulate taking a picture of a moving object using a fixed exposure
time.
To apply a Blur effect:
1 On the Layer palette, click the layer containing the area you want to
blur.
2 To limit the blur to a specific area, make a selection in the image.
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3 Choose Adjust > Blur, then choose a effect.


For the Blur and Blur More effects, the effect is applied to the
image or selection.



For the Average, Gaussian, and Motion effects, a dialog
opens. Choose from the options, then click OK. The effect is
applied to the image or selection.

Improving Image Clarity
Accentuating Edges and
Contrast Areas
Use Edge effects to accentuate
edges and contrast areas in your
image. For more information on
Edge effects, see “Applying Edge
Effects” on page 318.

Improving image clarity is the final step in image correction. Use the
Clarify and Sharpen commands to clarify and sharpen your images.
Note
The Clarify and Sharpen Edge commands work on 16 million color
or greyscale images only. To increase the color depth of an image,
see “Increasing the Color Depth of an Image” on page 109.

Clarifying Images
Use the Clarify command to give your image a crisp, focused look so
objects stand out. This command adds a sense of depth and clarity to
the image. It can also make hazy, foggy, or slightly out of focus
images look clearer.
To clarify images:
1 Make sure the image has no selections. If necessary, choose
Selections > Select None. The Clarify command is not available if
the image contains a selection.
2 Choose Adjust > Brightness/Contrast > Clarify.
3 In the preview window, center an important part of the image
(such as a face). Pan the image by clicking and dragging in the
preview window; zoom in or out as necessary.
4 For Strength of effect, use the smallest value that gives a
satisfying result.
5 Click OK.
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Sharpening Images
Paint Shop Pro contains several commands that sharpen your image
by increasing the contrast of adjacent pixels:
Sharpen and Sharpen More Focus the image and improve its clarity
by increasing the contrast between adjacent pixels where there are
significant color contrasts, usually at the edges of objects. The
Sharpen More command sharpens with a stronger effect than the
Sharpen command. Both commands are automatically applied to the
image.
Unsharp Mask Sharpens the mid- to high-contrast edges in the image
without enhancing noise. This command locates adjacent pixels that
have a difference in lightness values that you specify and increases
their contrast by an amount you specify. This command is typically
used in professional color corrections.
To use the Sharpen or Sharpen More command:
Choose Adjust > Sharpness > Sharpen or Adjust > Sharpness >
Sharpen More.
To use the Unsharp Mask dialog:
1 Choose Adjust > Sharpness > Unsharp Mask.
2 In the preview window, center an important part of the image
(such as a face). Pan the image by clicking and dragging in the
preview window; zoom in or out as necessary.
3 Sharpen the image with the following options:
Radius The number of pixels to adjust around each edge. A value
between 0.5 and 2 works best, depending on the image. A lower
value sharpens only the edge pixels, while a higher value
sharpens a wider band of pixels. The effect is much less
noticeable in print than on-screen because a small radius (for
example, 1 pixel) represents a smaller area in a high-resolution
printed image. Therefore, use lower values for on-screen images
and higher values for high resolution printed images.
Strength The amount of contrast to increase in the image’s
pixels. Start with a low value and increase it gradually.
Clipping The difference in lightness values that adjacent pixels
must have before they are sharpened.
4 Click OK.
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Working with Colors and Materials
Whether you are applying color to an image or adjusting
photographic colors, it’s important to understand how Paint Shop
Pro works with color. This chapter describes how to choose colors
and materials that you can use to paint, draw, or fill. It also discusses
the basics of color—how it is displayed on screen and printed—as
well as image color depth.
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Using the Materials Palette
Color basics
For information on color—how it is
perceived, displayed, and printed—
see “Understanding Color and
Color Models” on page 103.

About the relationship
between the Material and
Color boxes
Since you can select colors by
clicking the Material boxes, you
may wonder why the Materials
palette includes Color boxes too.
With the Foreground or
Background Color box, you can
select a new color even when the
Material box displays a gradient or
a pattern. The Color boxes provide
a quick way to change colors
without changing the other parts of
the material.

With Paint Shop Pro you can paint, draw, and fill with a variety of
colors, styles, and materials. A style is the color, gradient, or pattern.
A material is the style plus the optional texture. You select materials
on the Materials palette.
In general you use foreground materials for brushstrokes and
background materials for fills. When you paint with a brush, rightclicking the brush paints with the background material, and for fill
tools, left-clicking fills with the foreground material. For text and
preset shapes, the foreground color is the stroke (or outline) of the
text or shape and the background color is the fill of the text or shape.
In general, it’s best to select the tool you want to use, select the
material on the Materials palette, and then apply the tool. The
Materials palette is shown below.
Colors tab

Swatches
tab

Available
Colors panel

Foreground
Material box

Background
Material box

Foreground
Color box
Background
Color box

Style
buttons

Color
button

Transparency
button

Texture button

Here are the main components of the Materials palette:
Colors tab Displays the Available Colors panel, where you can click
to select a color. At the bottom of the tab you can click to select
white, black, or three shades of grey.
Swatches tab Displays swatches, which are materials you can save
to use again. For more information, see “Working with Swatches” on
page 96.
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Foreground and Background Color boxes Display the current
foreground or background color.
You can reverse the foreground
and background color or
material
Swap Colors
Swap Materials

Foreground and Background Material boxes Display the current
foreground or background material (the style—color, gradient, or
pattern—plus the texture).
Style button
Specifies which style is currently selected:
color
, gradient
, or pattern
. To change between the most
recently selected color, gradient, or pattern: click the Style button
and select a new style. To define a new color, gradient, or pattern,
click a Material box.
Texture button
Turns the current texture on or off. To choose a
new texture, click the Foreground Material or Background Material
boxes.
Transparency button
Specifies whether the foreground or
background material is transparent (in other words, it has no style or
texture). You use a transparent material primarily with vector
objects and text—a transparent foreground has no outline (the
objects or letters are filled only) and a transparent background has
no fill (the objects or letters are outlined only). This button is
unavailable for tools that require a foreground or background color.
All Tools If the check box is marked, the selected foreground and
background materials apply to all tools. If the check box is cleared,
the selected materials apply only to the active tool (such as the
Paintbrush tool or the Preset Shapes tool).
Note
The All Tools check box does not apply to the Edit Text command.

83

84

Chapter 5: Working with Colors and Materials

Basics of Using the Materials palette
The Materials palette offers a variety of ways to choose colors,
styles, and materials.
To display or hide the Materials palette:
Choose View > Materials palette or press F6. To close the palette you
can click the Close button
.
To choose a foreground or background solid color:
1 On the Materials palette, do one of the following:


To choose a foreground color, click the
Foreground Color box.



To choose a background color, click the
Background Color box.

The Color dialog opens.
Note: You can also click the Foreground Material box or the
Background Material box to display the Material dialog, and
then click the Color tab.
2 Choose a color from the Jasc Color Picker or the image palette.
(See “Choosing Colors” on page 86.)
The Material dialog

To choose a foreground or background material (color, gradient,
pattern, or texture):

1 On the Materials palette, do one of the following:


To choose a foreground material, click the
Foreground Material box.



To choose a background material, click the
Background Material box.

The Material dialog opens. In this dialog, you can choose from
all of Paint Shop Pro’s colors, gradients, patterns, and textures.
2 To choose the style, click the Color, Gradient, or Pattern tab and
select the appropriate settings. For more information, see
“Choosing Colors” on page 86, “Choosing Gradients” on
page 91, or “Choosing Patterns” on page 93.
3 To choose a texture, mark the Texture check box and select a
texture. For more information, see “Choosing Textures” on
page 94.
4 Click OK.
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To choose from recently used materials:
Recent Materials dialog

On the Materials palette, right-click a Color or Material box to
display the Recent Materials dialog, and then choose a material.
On the Recent Materials dialog you can click the Other button to
display the Material dialog and choose or create a material from all
of Paint Shop Pro’s colors, gradients, patterns, and textures.

To choose a color from the Available Colors panel:
The Available Colors panel of
the Materials palette

1 On the Materials palette, click the Colors tab

.

2 Move the cursor over the Available Colors panel. A ToolTip
displays the color value.
Choose a color

Or choose black,
a shade of grey,
or white

3 Do one of the following:


To choose the foreground color, left-click in the Available
Colors panel.



To choose the background color, right-click in the Available
Colors panel.

The Foreground or Background Color box displays the selected
color. If the Style button is set to Gradient
or Pattern
,
change it to Color
so that the material is updated with the
color.
To apply the current materials to all tools:
You can reverse the foreground
and background color or
material

On the Materials palette, mark the All tools check box.
If you clear this check box, the current materials are applied to the
active tool only.

Swap Colors

To reverse the foreground and background colors:
Swap Materials

Click the Swap Colors icon

.

To reverse the foreground and background materials:
Click the Swap Materials icon

.
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Choosing Colors
When you edit images in Paint Shop Pro, you often need to choose a
color—before you paint, when making manual color corrections, or
when choosing a background for a new image. You choose colors as
follows:


For images with 16 million colors, choose from the Jasc Color
Picker. See “Choosing Colors from the Jasc Color Picker” on
page 86.



With images with 2 to 256 colors, choose from the image palette.
See “Choosing Colors from the Image Palette” on page 89.



For all images, you can choose a color from an open image or
from any displayed color. See “Choosing Colors from an Image
or the Desktop” on page 90.



Choose a color from the Available Colors panel of the Materials
palette—left-click to choose the foreground color or right-click
to choose the background color.

Choosing Colors from the Jasc Color Picker
The Jasc Color Picker
Color wheel

The Jasc Color Picker displays when you click a Color or Material
box on the Materials palette. You also choose from this color picker
when you click a Color box in some Paint Shop Pro dialogs.
The Jasc Color Picker offers a variety of ways to select colors:

Saturation/
Lightness
box



Select from the Color wheel and Saturation/Lightness box, which
offer a visual way to select a color based on its hue, saturation,
and lightness.

Basic Colors
panel



Select from the Basic Colors panel, which displays commonly
used colors.



Select RGB or HSL values to choose a color based on its red,
green, and blue values or its hue, saturation, and lightness values.



Enter an HTML color code.



Select a color from the active image.

Note
If the active image has a color depth less than 24-bit (16 million
colors), you must select colors from a palette rather than the Jasc
Color Picker. See “Choosing Colors from the Image Palette” on
page 89.
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To display the Jasc Color Picker:
On the Materials palette, do one of the following:


To choose the foreground color, click the Foreground Material
box or Foreground Color box.



To choose the background color, click the Background Material
box or Background Color box.

If you clicked a Material box, the Material dialog opens (here you
can choose colors, gradients, patterns, and textures); click the Color
tab to display the Jasc Color Picker.
If you clicked a Color box, the Color dialog opens and displays the
Jasc Color Picker; here you can choose colors only.
To choose a color using the Color wheel:
The selection rings show which
color is selected

1 On the Color wheel, click the approximate color or drag the
selection ring around the color wheel to select the color.

Color wheel

The Color wheel represents the hue—notice that the Hue edit box
updates with a value between 0 and 255 as you go around the
wheel.

Saturation/
Lightness
box

2 On the Saturation/Lightness box, click to choose a color variation
or drag the selection ring. Move from left to right to increase the
saturation. Move from top to bottom to increase the lightness.
To choose a color from the Basic Colors panel:
The Basic Colors panel displays
commonly used colors

1 Move the cursor over the Basic Colors panel. A ToolTip displays
the color value.
2 Click the color you want. Notice that the RGB and HSL values
update with the current color values and the selection rings on
the Color wheel and the Saturation/Lightness box move to the
selected color.
To choose a color using its RGB or HSL value:
For each value you want to change, do one of the following:

Use the numeric edit controls to
choose a color using its
RGB or HSL value



Click the slider button



Drag the meter bar



Click the edit box and type a new value.



To change the value by one, click the up or down arrows .

and drag the slider to a new position.
to a new position.
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Note: Clear the Link Colors check box to have the sliders visually
represent only their selected value (such as just the hue).
To choose a color from the active image:
1 Make sure the Jasc Color Picker is displayed. See “To display the
Jasc Color Picker:” on page 87.
2 Move the cursor over the active image. The cursor turns into a
dropper and a ToolTip displays the color values.
3 Click the part of the image that has the color you want. The Jasc
Color Picker updates with that color.
Note: You can also choose a color from an image using the
Dropper tool or a special feature of Color or Material boxes. See
“Choosing Colors from an Image or the Desktop” on page 90.

Specifying HTML Code for Colors
With the Jasc Color Picker, you can view the HTML (Hypertext
Markup Language) code for each color you select. You can also
specify a color by entering the HTML code.
Note
By default, Paint Shop Pro displays decimal (base 10) numbers in
the Jasc Color Picker. You can also display hexadecimal (base 16)
numbers—the format of HTML color codes. For more information,
see “Display and Caching Preferences” on page 395.
To specify or view HTML code for colors:
The HTML code for the color
true red (RGB 255, 0, 0) in the
Jasc Color Picker
Hexadecimal symbol

Red
Blue
Green

1 Display the Jasc Color Picker. See “To display the Jasc Color
Picker:” on page 87.
2 Do one of the following:


To specify a color using its HTML code, type the code in the
HTML edit box.



To view the HTML code of a particular color, choose a color
by other methods (such as entering RGB values or selecting
from the color wheel), and then view the number in HTML
edit box.
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Choosing Colors from the Image Palette
Selecting colors from the
image palette

Images that have a color depth less than 24-bit (16 million colors)
are called paletted images—the available colors are a subset of all
the colors your computer can display. The palette varies from 2 to
256 colors, depending upon the color depth of your image. With
these images, you must choose foreground and background colors
from the palette rather than from the Jasc Color Picker.
Note
If you select the Rainbow Picker as your preference setting, the
Available Colors panel of the Materials palette shows all colors for
both paletted and non-paletted (16 million color) images. For
paletted images, when you select a color on the Available Colors
panel Paint Shop Pro chooses the nearest color in the palette. For
more information on the Rainbow Picker, see “Display and Caching
Preferences” on page 395.
To choose colors from the palette:
1 On the Materials palette, do one of the following:


To choose the foreground color, click the Foreground Color or
Foreground Material box.



To choose the background color, click the Background Color
or Background Material box.

Clicking a Color box opens the Color dialog and displays the
palette. Clicking a Material box opens the Material dialog; click
the Color tab to display the palette.
2 In the Sort order drop-down list, select the way the colors are
sorted: Palette (in order by the way the palette stores the colors),
Hue (in order by color) or Luminance (in order by lightness).
3 Click the desired color. The color’s index number within the
palette, color value (RGB or HSL), and HTML code are
displayed.
4 Click OK.
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Choosing Colors from an Image or the Desktop
When should I choose a
color from the desktop?
You can choose a foreground or
background color from the desktop
when you particularly like an icon
color, or when you want to match
the Windows desktop colors.

Use the Dropper tool to choose a foreground or background color
from any open image. Or use a special feature of Color and Material
boxes to select from any color within Paint Shop Pro (such as a color
on a toolbar). If you have Windows 2000 or later, you can choose a
color from other applications (such as a color displayed in a word
processor).
Note
You can also use the Jasc Color Picker to choose a color from any
open image. See “To choose a color from the active image:” on
page 88.
To use the Dropper tool to choose a color:
1 On the Tools toolbar, choose the Dropper tool
hidden under the Color Replacer tool.

. The tool may be

2 Position the cursor over the color in the image.
3 Left-click to make the color the foreground color or right-click to
make it the background color.
To choose a color from the active image:
1 Position the cursor over the active image.
Note: This applies to the Brush, Eraser, and Picture Tube tools.
2 Hold down the Ctrl key and left-click to choose the color as the
foreground color or right-click to choose the color as the
background color.
To choose a color from an image or the desktop:
1 Make sure the color you want to choose is displayed on the screen.
Material and Color boxes on the
Materials palette (left) and a
Color box on a Paint Shop Pro
dialog (right).

2 Position the cursor over a Color or Material box (on the Materials
palette or in a dialog).
Note: On the Materials palette, you must assign the foreground
and background color separately. Position the cursor over one or
the other, follow the steps, and then start over for the other color.
3 Hold down the Ctrl key and continue to hold it down until you’ve
completed the following steps.
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4 Move the cursor over the area of the desktop that has the color
you want to choose. The cursor is a dropper
over any area
that you can choose from. For Windows 2000 or later systems,
the cursor remains a dropper when you move off Paint Shop Pro
onto another application.
5 Left-click to select the color. The Color box or Material box
updates with the color.
6 To change the color selection, continue to hold the Ctrl key and
click on different parts of the desktop.
7 Release the Ctrl key.

Choosing Gradients
Color depth
Gradients are available for
greyscale and 16 million color
images only. To increase the color
depth of an image, see page 109.

Gradients are gradual blends between two or more colors. You can
paint, draw, or fill with gradients to create interesting effects or
helpful color transitions. Use gradients to create Web buttons with
shadows and highlights, to make objects look shiny or glowing, or to
add dimension to objects. Use gradients to fade Web page graphics
into other content or use a black-to-white gradient as a mask.
You choose gradients on the Gradient tab of the Material dialog.

Example applications of
gradients

To choose a foreground or background gradient:
1 On the Materials palette, do one of the following


To choose a foreground gradient, click the
Foreground Material box.



To choose a background gradient, click the
Background Material box.

The Material dialog opens.
2 Click the Gradient tab.
3 Click the Gradient Type drop-down list and select a gradient.
Note: The first three gradients (#1 Foreground-Background, #2
Fading Foreground, #3 Fading Background) use the current
foreground and background colors. The other types use custom
colors. You can edit the colors of all gradient types (see “Editing
Gradients” on page 98).
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4 Select the options for the gradient:
The Gradient tab of the
Material dialog

Style The style for the gradient: Linear
Sunburst , and Radial .

, Rectangular

,

Angle (Linear, rectangular, and radial gradients only) The angle
or direction of the gradient, from 0 to 359 degrees.
Gradient
Type

Repeats The number of times (from 0 to 100) to repeat the
gradient pattern.
Invert Mark to invert the colors of the gradient.
Center Point (Rectangular, sunburst, and radial gradients only)
The horizontal and vertical coordinates of the point from which
the gradient disperses or radiates. The distance is measured as a
percentage of the fill area’s width. Change the center point to
create fills in circles or other shapes where the center of the
gradient is not at the center of the object.

Get gradient ideas from
preset shapes!
Several of Paint Shop Pro’s preset
shapes use gradients to create
highlights and shadows. You can
use these shapes as resources for
your gradient applications. For
more information on preset
shapes, see “Drawing Preset
Shapes” on page 231.

Focal Point (Rectangular and sunburst gradients only) The
horizontal and vertical coordinates of the point where the
foreground color of the gradient begins. The distance is measured
as a percentage of the fill area’s width. Change the focal point to
create fills in circles or other shapes where the effective light
source is not at the center of the object. This option is available
only when the Link Center and Focal Points check box is cleared.
The examples below show the effect of varying the center point
and the focal point.

30, 30
50, 50

Location of
coordinates

Center: 50, 50
Focal: 50, 50

Center: 50, 50
Focal: 30, 30

Center: 30, 30
Focal: 50, 50

Center: 30, 30
Focal: 30, 30

Link center and focal points (Rectangular and sunburst
gradients) Mark this check box to have the center and focal
points be the same values. Clear the check box to edit the focal
point separately from the center point.
Note: You can also move the center point by dragging the control
needle or cross-hairs in the Gradient Type drop-down list. If you
clear the Link Center and Focal Points check box, you can move
the focal point by dragging the cross-hairs on the gradient.
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5 To edit the colors, transition points, and opacity of the gradient,
click the Edit button. For more information, see “Editing
Gradients” on page 98.
6 To save this gradient as a swatch that you can access later, click
the Add to swatches button, type a name, and press Enter.
7 Click OK.

Choosing Patterns
You can paint, draw, or fill patterns to create interesting effects.
Paint Shop Pro includes many patterns (such as bricks and zebra
stripes). You can create your own as well. You can also use an entire
image or part of an image as a pattern.

Example applications of
patterns

Patterns are a great way to add creative flair to your images. You can
apply patterned brushstrokes, create objects with patterned fills or
edges, and create patterned text. You can use patterns to create
stationary to use when sending e-mail or to create tiled images for
Web pages. Patterns are especially helpful for projects that require
an interesting background—such as a CD covers, calendars, or
greeting cards.
You choose patterns on the Patterns tab of the Material dialog.
Color depth
Patterns are available for greyscale
and 16 million color images only.
To increase the color depth of an
image, see page 109.

The Pattern tab of the
Material dialog

To choose a foreground or background pattern:
1 On the Materials palette, do one of the following:


To choose a foreground pattern, click the
Foreground Material box.



To choose a background pattern, click the
Background Material box.

The Material dialog opens.
2 Click the Pattern tab.
Pattern
Type

3 Click the Pattern Type drop-down list and select a type of
pattern.
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4 Select the options for the pattern:
Angle The angle (or direction) of the pattern, from 0 to 359
degrees. You can also click and drag the control needle on the
pattern to change the angle.
Scale The scale—from 10 to 250 percent of the image’s actual
size. At smaller values, the image is repeated more frequently
throughout the pattern. At larger values, the image may be
cropped and may lose detail and become blurry.
5 To save this pattern as a swatch that you can access later, click
the Add to Swatches button, type a name, and press Enter.
6 Click OK.
To use an image as a pattern:
1 Open the image you want to use.
2 To select a part of the image as the pattern, make a selection in
the image.
3 Follow the same steps as above for choosing a pattern and choose
the image from the Pattern Type drop-down list. If the image has
a selection, the selection rather than the entire image is available
as a pattern.
To create a new pattern:
1 Create an image (in Paint Shop Pro or another application).
2 Save the image as a file in the Patterns folder of the Paint Shop
Pro program folder.
Note: To change the default location of pattern files, on the
Material dialog click the Edit Paths button. See, “Editing File
Locations” on page 404.

Choosing Textures
Pattern versus texture
For a comparison of patterns and
textures, see “Understanding the
Difference Between Patterns and
Textures” on page 96.

You can paint, draw, or fill with a texture to create interesting
effects. Textures give your images the effect of having a textured
canvas or paper. Paint Shop Pro includes many textures, such as
clouds, cracked cement, and old paper. You can create your own as
well. You use textures with the current style (solid color, gradient, or
pattern) for foreground and background strokes or fills. You can
apply strokes or fills multiple times to gradually darken and fill in
the texture.
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Example of painting with
a texture

To select the current texture for the foreground or
background material:
On the Materials palette, click the Texture button
on the
Foreground Material box or the Background Material box. The most
recently chosen texture becomes active.
To choose a new texture:
1 On the Materials palette, do one of the following:


To choose a foreground texture, click the
Foreground Material box.



To choose a background texture, click the
Background Material box.

The Material dialog opens.
2 Mark the Texture check box.
The Texture panel of the
Material dialog

Texture
Type

3 Click the Texture Type drop-down list and select a type of
texture.
4 Select the options for the texture:
Angle The angle (or direction) of the pattern, from 0 to 359
degrees. You can also click and drag the control needle to change
the angle.
Scale The scale—from 10 to 250 percent of the image’s actual
size. At smaller values, the image is repeated more frequently
throughout the texture. At larger values, the image may be
cropped and may lose detail and become blurry.
As you modify the options, the Current color box displays the
resulting material (the style plus the texture).
5 To change the style of the material, click the Color, Gradient, or
Pattern tab and specify the options.
6 Click OK.
To create a new texture:

Where are texture files
stored?
The Texture Type drop-down list
lists all the available files in the
Textures folder of the Paint Shop
Pro program folder. You can also
include .TEX files from previous
versions of Paint Shop Pro in this
folder.

1 Create an image (in Paint Shop Pro or another application).
2 Save the image as a file in the Textures folder of the Paint Shop
Pro program folder.
Note: To change the default location of pattern files, on the
Material dialog click the Edit Paths button. See, “Editing File
Locations” on page 404.
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Understanding the Difference Between
Patterns and Textures
Painting with:
a pattern, a texture,
a pattern and a texture

On the Materials palette you can select both a pattern and a texture
as part of a material. What’s the difference between the two?
A pattern is an opaque, repeated image with specific colors and
details. A pattern is a style just like solid color or gradient. Thus,
patterns do not use the current foreground or background colors.
Let’s say you select the pattern called Bricks and then apply
brushstrokes with the Paintbrush tool. Each brush stroke paints the
brick pattern.
A texture gives the effect of having textured canvas or paper.
Textures use the current style (such as a solid color). Let’s say the
foreground color is yellow and you select the texture called
Crumpled Paper. When you apply a brush stroke, each brush stroke
paints yellow with the texture of crumpled paper.
Unlike patterns, textures can be applied at the same time as styles—
solid color, gradient, or pattern. That means you can have both a
pattern and a texture selected at the same time.

Working with Swatches
Swatches are materials that you can save to use again. For example,
if you create a material that is a certain shade of green with a fog
texture, you can save it as a swatch. Swatches are displayed on the
Swatches tab of the Materials palette.
To create a new swatch:
An alternative way to create
a swatch
While you are selecting a material
on the Material dialog, click the
Add to Swatches button to create
a new swatch of the currently
selected material.

1 On the Materials palette, click the Swatches tab

.

2 Click the Create New Swatch button
. You can also click the
More Options button
and choose New Swatch.
3 Type a name for the swatch. This name appears as a ToolTip
when you hold the cursor over the swatch on the Materials
palette.
4 Press Enter to open the Material dialog.
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The Swatches tab of the
Materials palette
Swatches
tab

5 Select the style (color, gradient, or pattern) and the texture for the
material.
6 Click OK.
To select a swatch:
1 On the Materials palette, click the Swatches tab

Swatches

View
button

Delete
button

New Swatch More Options
button
button

.

2 Do one of the following:


To select a swatch as the foreground material, left-click the
swatch you want to use.



To select a swatch as the background material, right-click the
swatch you want to use.

To edit a swatch:
1 On the Materials palette, click the Swatches tab

.

2 Double-click the swatch you want to edit. You can also click the
swatch, click the More Options button , and then choose Edit
Swatch. The Material dialog opens.
3 Edit the style (color, gradient, or pattern) or the texture for the
material.
4 Click OK.
To delete a swatch:
1 On the Materials palette, click the Swatches tab

.

2 Click the swatch you want to delete.
3 Click the Delete Swatch button
or click the More Options
button
and choose Delete Swatch.
To rename a swatch:
1 On the Materials palette, click the Swatches tab

.

2 Click the swatch you want to rename.
3 Click the More Options button

and choose Rename Swatch.

To change how swatches are displayed:
1 On the Materials palette, click the Swatches tab

.
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2 Do one of the following:


To select which swatch types are displayed, click the View
button and choose All , Colors , Gradients , or
Patterns . You can also click the More Options button ,
choose View, and then choose the swatch type to display.



To change how swatches are sorted, click the More Options
button , choose Sort, and then choose By Style or By Name.
By default, the swatches are sorted by style.



To change between small and large thumbnails of the
swatches, click the More Options button
and choose Small
Thumbnails or Large Thumbnails. By default, small
thumbnails are displayed.

Editing Gradients
Editing the default gradients
If you edit and save one of the
gradients that comes with Paint
Shop Pro, you are permanently
changing the gradient type. For
example, if you select the Green
Neon gradient type, change its
colors to orange and yellow, and
save it. The next time you select
the Green Neon gradient type, it is
no longer green.

You can change the colors, transition points, and transparency of
gradients in the Gradient Editor dialog. You can edit Paint Shop
Pro’s default gradients or create your own gradients. You can also
rename, delete, import, and export gradients.
The Gradient Editor dialog is shown below.

To maintain Paint Shop Pro’s
default gradients, save changes to
a new gradient file. See “Saving
Edited Gradients” on page 101.

Gradient bar

Transparency bar
Result shows
gradient settings plus
transparency settings

To specify the colors and transition points of the gradient, use
settings in the Gradient group box. To change the transition points,
edit the location of markers and midpoints on the gradient bar:


Markers



Midpoints
indicate the positions where two colors are equally
blended. Each pair of markers has a midpoint that can be located
anywhere between the markers.

indicate points of solid color.
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How can I restore Paint
Shop Pro’s default
gradients?
Do a custom installation to
reinstall the gradients from the
Paint Shop Pro program disk.
For more information, see
“Installing the Software” on
page 6.

To specify the transparency of the gradient, including opacity values
and transition points, use the settings in the Transparency group box.
Markers and midpoints indicate the places where the transparency
changes. You change and add markers on the transparency bar,
which represents the transparency of the gradient across its width.
The following table shows example gradients that result from
different numbers of markers.

These Gradient Marker Locations

Produce
this Linear
Gradient

Produce this
Rectangular
Gradient

Midpoint

Markers

Markers

To display the Gradient Editor dialog:
1 On the Materials palette, click the Foreground Material box or the
Background Material box.
The Material dialog opens.
2 Click the Gradient tab.
3 Choose the gradient you want to edit, then click the Edit button.
To change the location of markers and midpoints:
Do one of the following:


Click and drag the marker or midpoint to a new location.



Click the marker or midpoint to select it, then enter a value in the
Location field.
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To add a new marker:
Click a position under the gradient bar or the transparency bar.
For the gradient bar, the marker’s initial color is determined by the
currently highlighted Fore, Back, or Custom button. Click another
color button to change the color.
For the transparency bar, the marker’s initial opacity is 100%.
Change this value in the Opacity edit box.
To delete a marker:
Click the marker and drag it away from the gradient bar or the
transparency bar.
To change the color for a marker:
If a gradient uses
foreground or background
colors
If a gradient contains the
foreground or background color,
when you next apply the gradient it
uses the current foreground and
background colors of the image
(rather than the colors that you
used to define the gradient).
To create a gradient that always
contains the same colors, color all
markers with custom colors.

1 Click the marker below the gradient bar to select it. The triangle at
the top of the marker turns black.
2 Choose a color by doing one of the following:


To use the foreground color, click the Fore button



To use the background color, click the Back button



To use the currently defined custom color, click the Custom
button
.



To choose a new custom color, left-click the Custom color
box to select from the Color Picker or right-click to select
from recently used colors.



To select a color from within the gradient itself, click the
gradient bar.

.
.

To change marker transparency:
1 Click the marker below the transparency bar to select it. The
triangle at the top of the marker turns black.
2 Change the value in the Opacity edit box. Values range from 0%
(completely transparent) to 100% (opaque—the underlying
pixels are covered completely).
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Saving Edited Gradients
After you edit a gradient on the Gradient Editor dialog, you can save
the gradient in two ways:


Click the Save button to overwrite the previously saved gradient
with the current gradient. If you make changes to a Paint Shop
Pro default gradient, it’s best to use the Save As option rather
than overwrite the default gradient.



Click the Save As button to save the current gradient to a new
gradient name, which creates a copy of the current gradient. This
is a helpful way to save a gradient that you want to use frequently
and is also a good way to maintain Paint Shop Pro’s default
gradients—you can make your changes to the copy rather than
the original gradient.
When you click the Save As button, the Save Gradient As dialog
opens and displays a suggested gradient name (usually the
current gradient plus a number). Type a name for the new
gradient or leave the suggested name, then click OK.

Creating New Gradient Types
You can create a new gradient type that is selectable from the dropdown list of the Gradient tab of the Material dialog. If you use the
foreground and background colors to define the gradient, the
image’s current foreground and background colors are used when
you apply the gradient. To create a gradient type that always uses the
same colors, use custom colors for all markers.
To create a new gradient type:
1 Display the Gradient Editor dialog. See “To display the Gradient
Editor dialog:” on page 99.
2 Click the New button.
3 Type a name for the new gradient.
4 Click the Save button.
The gradient is initially defined with two markers at 0 and 100% that
use the custom color. You can now edit the gradient. For more
information, see “Editing Gradients” on page 98.
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Exporting Gradients
After creating a new gradient, you may want to export it to use in
another program. Although Paint Shop Pro’s default gradients are
stored in .PspGradient format, you export gradients as .GRD format,
which is commonly used in other applications.
To export a gradient:
How do I get my .GRD
format gradient to be
listed?
To have a .GRD format gradient be
listed as a gradient type, you must
import it. See “Importing Gradients”
on page 102.

1 Display the Gradient Editor dialog. See “To display the Gradient
Editor dialog:” on page 99.
2 If you have not already selected the gradient to export, choose it
from the Types box and edit its settings as desired.
3 Click the Export button.
4 Select the folder in which to save the gradient. Paint Shop Pro’s
default gradients are stored in the Gradients folder within the
Paint Shop Pro program folder.
5 In the File name edit box, type a name for the new gradient.
6 Click the Export button.

Importing Gradients
Importing Jasc gradient
files
To import a gradient saved in Jasc
Gradient format (.PspGradient),
place the file in the Gradients
folder. All .PspGradient files in that
folder are automatically listed as
available gradient types.

You can import gradients in the .GRD file format, which is a format
used in other applications.
To import a .GRD gradient:
1 Display the Gradient Editor dialog. See “To display the Gradient
Editor dialog:” on page 99.
2 Click the Import button.
3 Select the folder containing the gradient you want to import. All
.GRD files are listed.
4 Select the gradient’s file name.
5 Click OK.
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Renaming and Deleting Gradients
You can rename or delete gradient types.
To rename a gradient:
1 Display the gradient you want to rename in the Gradient Editor
dialog. See “To display the Gradient Editor dialog:” on page 99.
2 Click the Rename button.
3 Type the new name.
4 Click OK.
To delete a gradient:
How can I restore Paint
Shop Pro’s default
gradients?
Do a custom installation to reinstall
the gradients from the Paint Shop
Pro program disk. For more
information, see “Installing the
Software” on page 6.

1 Display the gradient you want to delete in the Gradient Editor
dialog. See “To display the Gradient Editor dialog:” on page 99.
2 Click the Delete button.
Note: If you accidentally delete a gradient you want to keep,
click the Cancel button to undo the deletion (and any changes
you made to gradients).
3 Click Save to close the Gradient Editor dialog and delete the
gradient.

Understanding Color and Color Models
We usually think of color as a quality inherent in an object—a red
car or a green frog. But color is really what we see as a result of
three factors interacting: light, the object, and the observer. As rays
of light hit the object, the object absorbs some light and reflects
some light. We see the reflected light and perceive it as color.
Different colors reflect light of different wavelengths. Human eyes
are able to perceive thousands of colors in the visible spectrum of
light.
When you apply ink to paper, the colors we see result from the light
that the ink reflects. Computer monitors use emitted light rather than
reflected light—the colors we see result from light emitted from the
screen.
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To describe how color is produced or perceived, we use color
models. Computer monitors display colors by producing varying
amounts of red, green, and blue light—the RGB color model. Human
eyes perceive color by its hue, saturation, and lightness levels—the
HSL color model. With Paint Shop Pro you can select colors using
either the RGB or HSL color model. You can also output images
using the CMYK (Cyan, Magenta, Yellow, Black) model, which is
used for high-end printing applications.

RGB Model
Selecting the color model
RGB is the default color model. To
change your color model
preference, see “Display and
Caching Preferences” on
page 395.
Paint Shop Pro uses your preferred
color model (RGB or HSL)
whenever color values are
displayed, such as with the
Dropper tool. When you select
colors from the Jasc Color Picker,
you are able to enter RGB or HSL
values regardless of your
preference setting.
The color model used to display
color values on-screen has no
effect on how colors are printed.
Choose a color model preference
that is easier for you to use.

All colors on your computer screen are created by mixing red, green,
and blue light in varying proportions and intensities. Adding all the
colors together creates white.
Each primary color (red, green, and blue) is assigned a value from 0
(none of the color present) to 255 (the color at full strength). For
example, pure red is produced by combining a red value of 255, a
green value of 0, and a blue value of 0. Yellow is a combination of a
red value of 255, a green value of 255, and a blue value of 0. Setting
all three values to 255 produces white; setting all three values to 0
produces black. When all three colors are set to the same value (such
as 120, 120, 120), the result is grey.

HSL Model
The HSL model is based on how the human eye perceives color
using the characteristics of hue, saturation, and lightness. Each
characteristic is assigned a value from 0 to 255. The three
characteristics are described as follows:
Hue The color reflected from an object, such as red, yellow, or
orange. Each hue value is assigned based on its position on the color
wheel. On the Jasc Color Picker’s color wheel, colors are assigned
counter-clockwise from the top. Red is at the top (value 0) and as
you move around the wheel the colors go through orange, yellow,
green, blue, purple, and back to red.
Saturation The purity or vividness of the color. Saturation represents
the amount of grey in the color, from 0 (entirely grey) to 255 (fully
saturated color).
Lightness The perceived amount or intensity of light in the color.
Lightness ranges from 0 (no light, or black) to 255 (total lightness,
or white). At 50 percent lightness, or a value of 128, a color is
considered pure. For example, pure red has a hue of 255, a saturation
of 255 (100 percent) and a lightness of 128 (50 percent). For pure
blue, the hue is 170, saturation is 255 and lightness is 128.
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CMYK Model
The CMYK model is based on the fact that ink on paper both absorbs
and reflects light. As white light strikes the ink, part of the color
spectrum is absorbed and part is reflected back to your eyes
(resulting in the color you see).
In this model, the primary colors cyan (C), magenta (M), and yellow
(Y) combine in varying proportions to produce a variety of colors.
When the three colors are combined, they produce black. Because
impurities in the ink make it difficult to produce a true black, a
fourth color, black (K), is added.
Combining inks in this way is called four-color process printing. It is
used by printing services and high-end color printers.
Although you cannot create images in Paint Shop Pro using the
CMYK model, you can produce color separations that can be printed
on CMYK printers. There are two ways to do this: You can split the
images into CMYK channels or you can print color separation pages.
CMYK channels are simply four separate greyscale images that
represent the percentage and location of cyan, magenta, yellow, and
black in the image. For more information, see “Working with Color
Channels” on page 107.
When you print CMYK separations, Paint Shop Pro prints a separate
greyscale page for each primary color. You can then use these pages
as “color plates” to give to a printing service. For more information,
see “Printing with CMYK Color Separations” on page 371.
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How Monitor and Print Colors Differ
Computer monitor colors and printed colors may often be quite
different—which is a challenge when you are trying to match a
certain color. Colors can also appear different from monitor to
monitor.
Image colors on a monitor are influenced by a variety of factors: the
color range, called the color gamut, of the input device (such as the
scanner or camera), the manufacturer and age of the monitor, and the
monitor’s brightness and contrast settings.
When you print an image, you introduce other factors that influence
color: the quality and absorption properties of the paper, the color
gamut of the printer, and the conversion of RGB values from the
monitor to the CMYK values of the printer’s ink.

Additive
colors

Subtractive
colors

This conversion is a challenge because of the different approaches to
color between monitors and printers. Because monitors use light to
display color, they use additive colors—when you add them
together, they produce white. Conversely, when you remove all
monitor colors you produce black. Because printers use ink to
display color, they use subtractive colors—when you remove colors,
you produce white, and when you add all printer colors you produce
black. As a result, monitors and printers have different color gamuts.
Although they share many of the same colors, there are some colors
a monitor can display that a printer can’t print and some colors a
printer can print that a monitor can’t display.
Given all the factors that go into producing colors, how do you go
about making colors accurate and consistent? Try these options:


Calibrate your monitor every few months. See “Calibrating Your
Monitor” on page 418.



Get to know the typical differences between your monitor’s
colors and your printer’s colors so that you can adjust your
images as needed. Print out several photographs or other images
and compare them to the screen. Are there typical results? For
example, your printer may always print colors darker than your
monitor displays them. Knowing this, you can modify the
lightness of your images accordingly.



Consider using Windows Color Management, which helps to
improve color consistency across devices. See “Adjusting
Monitor Display Options” on page 418.
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Working with Color Channels
Does it matter what color
model is selected?
No. You can split images into RGB,
HSL, or CMYK color channels
regardless of the type of color
model (RGB or HSL) you chose as
a display preference.

Color channels are planes of
color. This RGB image has
three channels: red, green, and
blue.

Image files store their color information in channels, or planes, of
colors. You can separate (or split) an image into RGB, HSL, or
CMYK color channels. An RGB image has three channels: red,
green, and blue. An HSL image has three channels: hue, saturation,
and lightness. Although you cannot create or edit an image using the
CMYK model, you can still split the image to four channels: cyan,
magenta, yellow, and black.
The Split Channel command creates a new greyscale image for each
color channel; the original image is not affected. For example, an
HSL image is split into separate greyscale images named “Hue,”
“Saturation,” and “Lightness.” Each greyscale image represents the
percentage and location of a color (such as red) or a characteristic
(such as lightness) within the image.
You can edit the greyscale images and use them to create interesting
effects or masks. You can combine them again using the Combine
Channel command. If you split an image into CMYK channels, you
can then send the four greyscale images to a printing service. (You
can also print CMYK separations directly; see “Printing with CMYK
Color Separations” on page 371.)
To split color channels:
1 Open the image.
2 Choose Colors > Split Channel and choose RGB, HSL, or CMYK.
A new greyscale image opens for each color channel.
To combine color channels:

Creative ideas for
color channels

1 Open each color channel file.

Here are a few of the things you
can do with color channels:

2 Choose Colors > Combine Channel and choose Combine from
RGB, Combine from HSL, or Combine from CMYK.





Create a color shift by splitting an
image into HSL channels,
modifying the Hue channel, then
combining the channels.
Use a channel greyscale to
create a selection.

3 For each Channel source drop-down list, select the name of the
file that contains that channel. For example, in the Combine RGB
dialog, you might select the file Red1 as the red channel source.
Note: If you are combining channels that you split with the Split
Channels command, mark the Sync check box to have Paint
Shop Pro automatically fill in the Channel Source boxes with
matching file names.
4 Click OK. Paint Shop Pro displays a new image file that
combines the color channels you selected.
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Understanding Color Depth
Color depth, also called bit depth, refers to the number of colors
each pixel (and therefore its image) can display. As the color depth
increases, the number of colors an image can display increases. Each
pixel’s color information is stored in a certain number of computer
bits—from 1 bit to 24 bits. In a 1-bit image, each pixel can display
only one of two colors (black or white). In a 24-bit image, each pixel
can display one of 16 million colors (224 or 2 colors for each bit).
Images with a color depth of 16 million colors look best because
they contain the most colors, but they also require the most memory
to store and edit.
In Paint Shop Pro, you can create 2 color (1-bit), 16 color (4-bit),
greyscale (8-bit), 256 color (8-bit), and 16 million color (24-bit)
images. Many of Paint Shop Pro’s effect and correction commands
work on 16 million color images only. Therefore, it is best to create
most images using 16 million colors. After you finish working on an
image, you can decrease its color depth and save it in another format.
Computer monitors also have a color depth that is determined by the
monitor’s capabilities as well as the selected color setting. If you
display an image with a higher color depth than the monitor can
display, the image will have some color distortion. Some file formats
limit the number of supported colors so that images display correctly
on a variety of monitor types. For example, GIF images, a popular
format for the Web, contain up to 256 colors (8-bit depth).
The number of colors actually used in an image is usually less than
the color depth. For example, in a 16 million color image, the image
is capable of displaying that many colors but may only use 50,000
colors. You can use the Image > Count Colors Used command to
count the number of colors in a layer of the image.
To view the color depth of an image:
Do one of the following:


Look at the Status bar, which displays the active image’s pixel
dimensions (the first two numbers) and color depth (the third
number).



Press F9 to display the Overview palette, click the Info tab, and
then view the Color Depth field.



Choose Image > Image Information, then look at the Pixel Depth/
Color field.

The color depth is the third
number in the Status bar (here
16 million colors).
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To view the color depth of a monitor:
Viewing and adjusting
monitor settings
You can view the possible settings
for your monitor by following these
steps: click the Windows Start
button, choose Settings > Control
Panel, double-click the Display
icon, and then click the Settings
tab.
For information on adjusting your
monitor settings, see your
Windows documentation.

1 Choose Help > About Paint Shop Pro.
2 Click the System Info button.
3 Scroll down to the Video Driver Information section and look at
the Number of Colors field.
To view the number of colors in a layer:
1 On the Layer palette, click the layer name that you want to check.
2 Choose Image > Count Image Colors.

Increasing the Color Depth of an Image
Quick color depth changes
If you are increasing or decreasing
several images to the same color
depth, you can add the color
depth’s button to the toolbar. For
more information, see
“Customizing Toolbars and Menus”
on page 412.

If an image has a color depth less than 24-bit, you may want to
increase the color depth while editing the image. Many of Paint Shop
Pro’s effect and correction commands work only on images with 16
million colors. Depending on the color depth of your image, you can
also increase an image to 16 colors (4-bit) or 256 colors (8-bit).
Because all colors are available in a 16 million colors (24-bit) image,
increasing the color depth to 16 million colors (24-bit) automatically
loads the Rainbow Color Picker. If your image has its own palette
and you need to keep those exact colors, you may want to save the
palette before increasing the color depth. After editing the image,
reload its original palette. For more information, see “Working with
Image Palettes” on page 117.
To increase the color depth of an image:
Choose Colors > Increase Color Depth and choose the desired color
depth: 16 Colors (4-Bit), 256 Colors (8-Bit), or 16 Million Colors (24bit). Color depths not available for the active image are greyed out.
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Decreasing the Color Depth of an Image
Limitations of decreasing
color depth
Keep in mind these limitations
when decreasing color depth:




Most Paint Shop Pro effect and
correction commands work on
16 million color and greyscale
images only.
When you decrease the color
depth, Paint Shop Pro first
flattens the image, merging the
data on all layers. However, you
can add vector layers to images
of any color depth.

If you are creating an image for on-screen viewing, you may want to
decrease the number of colors to make sure most monitors can
display the image properly. Also, when you have finished editing an
image, you may want to decrease color depth to save memory space.
Note
If you are creating images for the Web, we recommend that you
work with 16 million colors (24-bit) images so that all Paint Shop
Pro commands are available. When you are ready to save the images,
use the GIF optimizer or JPEG optimizer, which automatically
decreases the color depth in the saved image but doesn’t change the
color depth or layers of your original .PspImage file.
Depending upon the current color depth of your image, you can
decrease its color depth to the following:
2 colors (1-bit) Converts to a black and white image and drastically
reduces file size. See “Decreasing Color Depth to 2 Colors (1-bit)”
on page 111.
16 colors (4-bit) Converts to a color image with very limited colors.
Use this option if your image uses a small number of colors and you
want a smaller file size. See “Decreasing Color Depth to 16 Colors
(4-Bit)” on page 112.
256 colors (8-bit) Converts to a color image that works well for onscreen viewing when your image will be viewed on a variety of
monitor types. This is a helpful color depth for images viewed on the
Web. See “Decreasing Color Depth to 256 Colors (8-Bit)” on
page 113.
32K or 64K colors (24-bit) Converts to 32,000 or 64,000 colors
within a 24-bit image. For images viewed on older monitors, this
color depth results in better refresh rates. See “Decreasing Color
Depth to 32K or 64K Colors (24-Bit)” on page 114.
X colors Converts to a color image with a number of colors that you
specify (from 2 to 256). This color depth can produce smaller file
sizes and faster download times for file formats such as GIF. See
“Decreasing Color Depth to a Selected Number of Colors” on
page 114.
Note
When you change the color depth, you permanently change the
colors of the image’s pixels. Before decreasing the color depth, do as
much editing as possible in your original image and save a backup
copy of the image that includes all layers.
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Decreasing Color Depth to 2 Colors (1-bit)
Another way to create a
black-and-white image
You can use the Threshold
command to select the lightness
value threshold (from 1 to 255) at
which color pixels are changed to
black or white. With this command,
the color depth does not change.
For more information, see
“Creating Black-and-White Images”
on page 198.

To create a black-and-white image, you can decrease an image’s
color depth to 2 colors. If your image is already black and white
(perhaps it is a line drawing or a photograph to which you applied
the Threshold command), decreasing the color depth to 2 colors can
drastically reduce the file size.
When you decrease color depth to 2 colors, choosing from the
variety of options is not an exact science. Try out several different
combinations and see which produces your desired result.
To decrease the color depth to 2 colors:
1 Choose Image > Decrease Color Depth > 2 Colors (1-bit).

Ordered Dither reduction
method and Error Diffusion
reduction method

Original color image and
Nearest Color reduction method

2 In the Palette component group box, choose the color channel to
use for the final image: Grey (the lightness values), Red, Green,
or Blue. Choosing Grey produces the best results in most cases.
However, if the image consists mostly of a single color, selecting
that color channel may produce the best results.
3 In the Reduction method group box, choose a color reduction
method. See “About Color Reduction Methods” on page 115.
Note: With the Error Diffusion method, you must also select the
Floyd-Steinberg, Burkes, or Stucki option, which are algorithms
for the dithering pattern. Try them out to see what result you like
best.
4 In the Palette weight group box, select an option:
Weighted A weighted palette produces less dithering and
produces sharper edges.
Non-weighted A non-weighted palette produces more dithering
and softer edges.
Note: Dithering places pixels of different colors or grey levels
next to each other to simulate missing colors or greys.
5 Click OK.
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Decreasing Color Depth to 16 Colors (4-Bit)
To reduce the file size of images with few colors, decrease the color
depth of an image to 16 colors (4-bit). This color depth is especially
useful for simple graphics on Web pages that you want to load
quickly.
To decrease the color depth to 16 colors:
Edit the palette
When you decrease color depth to
16 colors, the resulting image has
an image palette that contains 16
specific colors. You can change
any of those colors (and create
interesting effects) by editing the
image palette. See “Working with
Image Palettes” on page 117.

1 To emphasize the importance of certain colors in the conversion,
select an area of your image (optional).
2 Choose Image > Decrease Color Depth > 16 Colors (4-bit).
3 In the Palette group box, choose a palette option. See “About
Palette Options” on page 116.
4 In the Reduction Method group box, choose a color reduction
method. See “About Color Reduction Methods” on page 115.
Note: The Ordered Dither option is available only for the
Windows color palette.
5 In the Options group box, mark or clear these check boxes:
Boost marked colors by If you selected an area of your image,
you can mark this check box to make the colors in the selection
more important by a factor of the value you enter. The selected
colors will stand out from the rest of the image.
Reduce color bleeding If you chose the Optimized Median Cut or
the Optimized Octree palette and the Error Diffusion reduction
method, you can mark this check box to make the left-to-right
bleed effect of colors less noticeable.
6 Click OK.
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Decreasing Color Depth to 256 Colors (8-Bit)
To limit your image to colors most monitors can display and to
reduce file size, decrease the color depth of the image to 256 colors
(8-bit). You can choose a Web-safe palette that assures your image
displays properly on a variety of computer monitors.
To decrease the color depth to 256 colors:
Greyscale versus 256-color
images
Greyscale images can have 256
shades of grey; 256-color images
can have 256 colors. Both types of
images are 8-bit depth. However,
the Color Depth commands apply
to color images only.
If you want to create a greyscale
image from a color image, see
“Creating Greyscale Images” on
page 199.

1 To emphasize the importance of certain colors in the conversion,
select an area of your image (optional).
2 Choose Image > Decrease Color Depth > 256 Colors (8-bit).
3 In the Palette group box, choose a palette option. See “About
Palette Options” on page 116.
4 In the Reduction method group box, choose a color reduction
method. See “About Color Reduction Methods” on page 115.
Note: The Ordered Dither option is available only for the
Standard/Web-safe color palette.
5 In the Options group box, mark or clear these check boxes:
Boost marked colors by If you selected an area of your image
and you are using the Optimized Median Cut method, mark this
check box to make the colors in the selection more important by
a factor from 1 to 10. The selected colors will stand out from the
rest of the image.
Include Windows’ colors If you chose the Optimized Median Cut
or the Optimized Octree palette, you can mark this check box if
you want the 16 standard Windows colors included in the
converted image’s palette.
Reduce color bleeding If you chose the Optimized Median Cut or
the Optimized Octree palette and the Error Diffusion reduction
method, you can mark this check box to make the left-to-right
bleed effect of colors less noticeable.
6 Click OK.
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Decreasing Color Depth to 32K or 64K Colors
(24-Bit)
To reduce the number of colors used in a 24-bit image, decrease the
color depth of an image to 32K (32,000) or 64K (64,000) colors.
Displaying images with 32K or 64K colors on older monitors results
in better refresh rates than displaying 24-bit images with 16 million
colors.
To decrease the color depth to 32K or 64K colors:
1 Choose Image > Decrease Color Depth and then choose 32K
Colors or 64K Colors.
2 In the Reduction method group box, select the method. See
“About Color Reduction Methods” on page 115.
3 Click OK.

Decreasing Color Depth to a Selected
Number of Colors
To select the number of colors in an image, use the X Colors
command to decrease the color depth of an image and reduce the file
size. If you specify 16 or fewer colors, the image is saved as a 4-bit
image. If you specify 17 to 256 colors, the image is saved as an 8-bit
image. For some file formats, particularly GIF, file compression is
sensitive to the number of colors in the image. For example, using
100 colors instead of 256 colors produces a smaller file size (and
produces faster download times), even though both files are 8-bit
images.
To decrease the color depth to a selected number of colors:
1 To emphasize the importance of certain colors in the conversion,
select an area of your image (optional).
2 Choose Image > Decrease Color Depth > X Colors (4/8-bit).
3 In the Number of colors edit box, enter the number of colors
(from 2 to 256) for the converted image’s palette.
4 In the Palette group box, select the palette options. See “About
Palette Options” on page 116.
5 In the Reduction method group box, choose a color reduction
method. See “About Color Reduction Methods” on page 115.
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6 In the Options group box, mark or clear these check boxes:
Boost marked colors by If you selected an area of your image
and you are using the Optimized Median Cut or Optimized
Octree methods, mark this check box to make the colors in the
selection more important by a factor from 1 to 10. The selected
colors will stand out from the rest of the image.
Include Windows’ colors Mark this check box if you want the 16
standard Windows colors included in the converted image’s
palette.
Reduce color bleeding If you chose the Error Diffusion reduction
method, you can mark this check box to make the left-to-right
bleed effect of colors less noticeable.
7 Click OK.

About Color Reduction Methods
Give it a try
When you decrease an image’s
color depth, don’t be intimidated
by the mathematical algorithms
that make up the color reduction
methods and the palette options.
Your best bet is to start with the
default settings, see if you like the
result, and then try out several
other combinations of settings.
Finding the right options is not an
exact science—it takes some
experimentation.

When you decrease an image’s color depth, you must select a color
reduction method. Depending upon the color depth you select, two
or three of these methods are available:
Nearest Color Replaces the original color of a pixel with the color in
the newly generated palette that is closest to the original RGB value.
This method eliminates dithering and produces a high-contrast
image. Simple graphics may look better with this method.
Error Diffusion Replaces the original color of a pixel with the most
similar color in the palette, but spreads the discrepancy between the
original and new color to the surrounding pixels. As it replaces a
color (working from the top left to the bottom right of the image), it
adds the “error,” or discrepancy to the next pixel, before selecting
the most similar color. This method produces a natural looking
image and often works best for photographs or complex graphics.
Ordered Dither Adjusts adjacent pixels so that two colors give the
illusion of a third color and intermingles pixels to produce patterns
based on a known palette. Use this method to give the image the
appearance of containing more colors than it actually does. Images
may appear to be composed of cross-hatches and dots and may have
distinct patterns of light and dark areas.
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About Palette Options
When you decrease an image’s color depth, you must select a palette
option. Depending upon the color depth you select, two or three of
these methods are available:
Optimized Median Cut Measures and ranks each color by how
frequently it occurs in the image, then uses the most frequently
occurring colors to determine the new palette. Even if your image
contains fewer colors than the palette that is generated, this method
may not represent each color exactly. The method, therefore, is not
as accurate as the Optimized Octree method, but it is better at
weighting color importance.
Optimized Octree Creates an eight-level “tree” with eight branching
nodes totaling 256 individual “leaves” or colors to determine the
new palette. This method attempts to reproduce each color in the
original image, so if your image contains fewer colors than the
palette that is generated, every color in the image is represented.
This method is faster and more accurate than Optimized Median Cut,
but it is not as good at weighting color importance.
Windows Changes each pixel’s color to the nearest color in the
Windows palette.
Standard/Web-Safe Palette Changes each pixel’s color to the nearest
color in the standard Web-safe palette. Use this method to create
images for the Web that can be viewed without color distortion on
most monitors.
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Working with Image Palettes
Should I load a Web-safe
palette for Web images?
Not necessarily. When you load an
image palette into 16 million color
images, you decrease the color
depth to 256 colors, which flattens
all layers and makes many effect
and correction commands
unavailable.
Except when you want to control
the specific colors in a palette,
keep your image at a color depth
of 16 million colors in .PspImage
format. When you finish editing the
image, export it to GIF or PNG
format using a Web-safe palette.
Your original .PspImage file
remains intact for later editing. See
“Saving Images for the Web” on
page 341.

An image palette is a collection of colors that an image uses—
similar to a painter’s palette of paints. An image palette is a subset of
all the colors your monitor can display.
Images with color depths of 16 to 256 colors have an image palette
that contains those colors that are used in the image. You can edit
this palette to fine-tune colors or create interesting color effects.
Images with a color depth of 16 million colors do not have an image
palette because they can contain all the colors your computer can
display. For these images, you can load an image palette to decrease
the image’s color depth to 256 colors or 8-bit. Loading a palette
produces the same result as using the Decrease Color Depth
command, except that you are controlling which colors are used in
the converted image. For more information on color depth, see
“Understanding Color Depth” on page 108.
Paint Shop Pro also includes a Safety palette for creating Web
images that can be viewed without color distortion on most
monitors. Using this palette produces the same result as using the
Decrease Color Depth > 256 Colors (8-bit) command and selecting
the Standard/Web-safe palette option. For more information, see
“Using the Web-Safe Color Palette” on page 119.
You can also create and save your own palettes. Preset palettes are
located in the Palettes folder of the Paint Shop Pro program folder.
You can store your custom palettes there as well.
To edit an image palette of 16 to 256 color images:

Editing the palette of a
greyscale image
If you select the Edit Palette
command for a greyscale image,
you are prompted to change the
image to 8-bit indexed color. Doing
so allows you to add color to your
greyscale image, similar to the
Colorize command.

1 Choose Image > Palette > Edit Palette.
Note: This command is not available for 16 million color images.
2 To change the sort order (or arrangement) of colors, select an
option from the Sort Order drop-down list: Palette Order (in
order by the way the palette stores the colors), By Luminance (in
order by lightness) or By Hue (in order by color).
3 To replace a color, double-click it. The Color dialog opens and
displays the Jasc Color Picker. (For more information, see
“Choosing Colors from the Jasc Color Picker” on page 86.) Make
your selection and click OK. Notice that the image updates with
the new color. To return the palette to its original colors, on the
Edit Palette dialog click the Revert button.
4 Click OK.
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To save an image palette:
Why should I save a
palette?
When you save a palette, you can
load it into other images—a good
way to achieve consistent colors
across several images. Saving a
palette is also useful if you are
making many color changes and
want to save a backup copy of the
palette.
If you are using a palette with the
current image only, you don’t need
to save it as a separate file
because the palette colors are
saved with the image itself.

1 Choose Image > Palette > Save Palette.
2 Select the folder where you want to save the palette. It’s most
convenient to save it in the Palettes folder of the Paint Shop Pro
program folder, where the preset image palettes are saved.
3 In the File name field, type a name for the palette. Paint Shop Pro
automatically adds the .PspPalette extension when you save the
file.
4 In the Save palette as group box, select a palette format:
PSP palette (the default) or Microsoft palette (for use with other
applications).
5 Click Save.
To load an image palette:

Color depth changes
When you load a palette, the color
depth of the image decreases, if
necessary, to match the number of
colors in the palette. For example,
if you load a 256 color palette into
a 16 million (24-bit) color image,
the image decreases to a 256 color
(8-bit) image.

1 Choose Image > Palette > Load Palette.
2 Select the folder which contains the palette you want to load.
Preset image palettes are stored in the Palettes folder of the Paint
Shop Pro program folder.
3 Select the palette.
4 In the Apply palette using group box, select an option:
Nearest color matching Changes each image color to the color in
the palette that is the closest match.
Error diffusion dithering Attempts to maintain the image’s
appearance by dithering colors that are not in the palette.
Dithering places pixels of different colors next to each other to
simulate missing colors.

What if I change my mind?
If you loaded a palette and now
you want to change it back to the
original palette or color depth, click
the Undo button or press Ctrl + Z.

Maintain indexes Assigns each color in the palette a sequential
index number and does the same for each color in the image, then
changes each color in the image to the like-numbered color in the
palette.
5 Click Open. The palette is loaded and the image’s colors are
updated.
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Using the Web-Safe Color Palette
Paint Shop Pro includes a Safety palette with 256 colors that are
Web-safe—your images can be viewed without color distortion on
most computer monitors. There are three ways to use this palette on
an image:


Load the Safety palette into your image. For 16 million color
(24-bit) images, this flattens the layers, reduces the image’s color
depth to 256 colors (8-bit), and makes many of Paint Shop Pro’s
effect and correction commands unavailable.



Decrease the image’s color depth to 256 colors and select the
Standard/Web-Safe Palette option. Decreasing the color depth
also flattens layers and makes some Paint Shop Pro commands
unavailable. For more information, see “Decreasing Color Depth
to 256 Colors (8-Bit)” on page 113.



Edit the image in 16 million colors (saving it in .PspImage
format), then use the GIF or PNG optimizer to export a copy of
the image. These optimizers use the Web-safe palette by default
and decrease the color depth in the saved image. We recommend
this alternative because it does not change the color depth or
flatten the layers of your original .PspImage file and keeps all
Paint Shop Pro effect and commands available. For more
information, see “Saving Images for the Web” on page 341.

To load the Web-safe color palette:
1 Choose Image > Palette > Load Palette.
2 Select the Palettes folder of the Paint Shop Pro program folder.
3 Select the palette Safety.pal.
4 In the Apply palette using group box, select an option:
Nearest color matching Changes each image color to the color in
the palette that is the closest match.
Error diffusion dithering Attempts to maintain the image’s
appearance by dithering colors that are not in the palette.
Dithering places pixels of different colors next to each other to
simulate missing colors.
Maintain indexes Assigns each color in the palette a sequential
index number and does the same for each color in the image, then
changes each color in the image to the like-numbered color in the
palette. This option is not available for 16 million color images.
5 Click Open.
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Making a Palette Color Transparent
Two logos displayed on a Web
page: without a transparent
color (top) and with a
transparent color (bottom)

Paletted images (those with 256 or fewer colors, such as GIF or PNG
files) do not support transparent backgrounds, but you often need a
way to make part of your image transparent when displayed on a
Web page. For example, you may have a round logo and you want
the background of the Web page to display around the logo.
Most Web browsers can choose not to display one color, effectively
making it transparent. In Paint Shop Pro you have two ways to make
one color transparent:


Use the Set Palette Transparency command to make one color in
an image palette transparent. The color can be the background
color or any color from the image. To set a transparent color, the
image must have one layer only and must use an image palette,
which means the image must have a color depth less than 16
million colors (24-bit).



Edit the image in 16 million colors (saving it in .PspImage
format), then use the GIF or PNG optimizer to export a copy of
the image. With these optimizers you can set the transparency of
the image. We recommend this alternative because it does not
change the color depth or flatten the layers of your original
.PspImage file and keeps all Paint Shop Pro effect and commands
available. For more information, see “Saving Images for the
Web” on page 341.

If you decide to make one color transparent in your image, use the
Set Palette Transparency command to select the color, and then use
the View Palette Transparency command to display the transparent
color in your image. You can also use the Set Palette Transparency
command to change or undo the transparency of a color.
To make one image color transparent:
1 Choose Image > Palette > Set Palette Transparency.
2 If you are prompted to reduce the color depth and number of
layers, click Yes to continue and then choose the options for
decreasing color depth. For more information, see “Decreasing
Color Depth to 256 Colors (8-Bit)” on page 113.
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3 On the Set Palette Transparency dialog, select an option:


To undo the transparency of a color, select No Transparency.



To make the background color transparent, select Set the
transparency value to the current background color.



To assign a specific color to be transparent, click the color on
the image itself, enter a value in the edit box of the Set the
transparency value to a palette entry option, or click the color
box to select from the current color picker.

4 To view the transparency on the image, click the Proof button.
5 Click OK. The color is now transparent; however, it may still be
displayed until you hide it.
To view or hide the transparency of a color:
Choose Image > Palette > View Palette Transparency.
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Editing Images
Edit your images in many ways: copy from one image to another,
crop or resize an image, flip, mirror, or rotate an image, or change an
image’s scale or perspective.
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Cutting, Copying, and Pasting
What is the clipboard?
The Windows clipboard is an area
of computer memory used for
temporary storage. Cut or copied
image data is stored in it.

You can cut or copy a selection or an entire layer to the Windows
clipboard and then paste the contents of the clipboard into the same
image or another image. The basic commands are:
Cut Removes a selection or a layer to the clipboard and replaces it
with the selected background color or transparency.
Copy Copies a selection or a layer to the clipboard.
Copy Merged Copies a flattened (merged) version of all the layers in
a selection to the clipboard.
Paste Pastes a cut or copied selection or layer as a new image, a
selection, a new layer, or into the current layer.
To cut a selection or a layer:

Cutting vs. deleting
The Cut command places your
data in the Windows clipboard so
that you can paste it. The Clear
command throws away the data.

1 Select the area or layer you want to cut. For information about
making selections, see Chapter 7, Making Selections in Images.
2 Choose Edit > Cut or press Ctrl + X.
To copy a selection or a layer:
1 Select the area or layer you want to copy.
2 Do either of the following:


To copy the selection or active layer, choose Edit > Copy or
press Ctrl + C.



To copy all layers of the selected area, choose
Edit > Copy Merged or press Ctrl + Shift + C.

To paste a cut or copied selection as a new image:
Choose Edit > Paste > Paste As New Image or press Ctrl + V.
To paste a cut or copied selection as a new layer:
1 Select the image into which you want to paste the selection.
2 Choose Edit > Paste > Paste As New Layer or press Ctrl + L.
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To paste a cut or copied selection into a layer:
When the pasted selection
looks out of proportion
When you paste data into another
image, the data keeps its original
pixel dimensions. If one image is
much larger or smaller than the
other, the selection may look out of
proportion.
After you paste the selection, use
the Deform tool to scale the
selection. See the sidebar “Quick
steps for proportional scaling” on
page 144.
Resize the two images to make
them similar size before copying
and pasting. See “Resizing
Images” on page 137.

Another way to remove a
color from a selection
Modify your selection by choosing
Selections > Modify > Select
Color Range. For detailed
instructions, see “Adding or
Removing a Color from a
Selection” on page 170.

1 On the Layer palette of the target image, click the layer into which
you want to paste the selection.
2 Choose Edit > Paste and choose one of these commands:
Paste As New Selection (Ctrl + E) Pastes the contents of the
clipboard as a floating selection above the current layer. If the
image already contains a floating selection, it is defloated first.
Paste As Transparent Selection (Ctrl + Shift + E) Use this
command to remove a specific color from the selection you are
pasting. The command makes transparent any pixels in the
clipboard data that exactly match the current background color
(in the Materials palette). Then the command pastes the contents
of the clipboard as a floating selection above the current layer.
Note: Select the background color before you paste.
Paste Into Selection (Ctrl + Shift + L) Pastes the contents of the
clipboard into the current selection. The clipboard contents are
resized to fit the current selection.

Copying One Image into Another Using
the Browser
You can copy all the layers of an image in the Browser into an open
image by dragging the image thumbnail from the Browser onto the
open image.
To use the Browser to copy one image into another:
1 Open the image into which you want to copy the layers. This target
image must be a 16 million color or greyscale image.
2 On the Layer palette, click the layer which you want to place the
new image above.
3 Open the Browser (choose File > Browse or press Ctrl + B).
4 Navigate to the folder containing the image you want to copy.
5 Click the browser thumbnail and drag it into the target image.
When you release the mouse button, the layers are added to the
image. They are linked automatically.
Note: If a new layer duplicates the name of a layer in the target
image, a number is appended to the name.
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Copying Paint Shop Pro Images into
Other Applications
Copy a Paint Shop Pro image into other applications (such as word
processors or desktop publishing packages) in these ways:

Don’t have the other
document visible?
Drag the image to the application’s
icon on the Windows task bar, wait
for the application to open, move
the cursor over the document, and
then release the mouse button.



Choose File > Save As to save the image to another file format
(such as TIF or BMP), and then open the other application and
import or place the file.



In Paint Shop Pro, copy the image (choose Edit > Copy to copy
the current selection or layer or Edit > Copy Merged to copy all
layers), and then open the other application and paste the image.



Open the Paint Shop Pro Browser, select the image, and then
press Alt while clicking and dragging the image to an open
document in the other application. A multi-layered image is
merged (or flattened) before it is copied into the other document.

The copy and browser options are available only for programs that
support graphic clipboard data.

Emptying the Clipboard
Placing large amounts of data in the clipboard can slow your
computer’s performance. Emptying the clipboard erases the
clipboard data.
Note
This command cannot be undone.
To empty the clipboard:
Choose Edit > Empty Clipboard.
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Deleting Images
In Paint Shop Pro you can delete image files from the main
workspace or using the Browser.
To delete the current image in the workspace:
Choose File > Delete or press Ctrl + Delete.
To delete an image using the Browser:
1 Display the Browser, choose File > Browse or press Ctrl + B.
2 Navigate to the folder containing the file you want to delete.
3 Select the image to be deleted.
4 Choose File > Delete or press Ctrl + Delete.

Using Undo/Redo
You can undo most actions as you edit an image. Use the Undo
command to remove brush strokes, color adjustments, effects, etc.
Use the Redo command to reapply a command that you have
undone. Use the Command History dialog to view which actions you
have performed and to revert to a previous state of the image. You
can also revert to the last saved version of an image.
To undo the last action:
What you can’t undo
In Paint Shop Pro you can undo
most actions—with these
exceptions:







Renaming files
Saving files
Opening and closing files
Changes that are program-wide
and not specific to the current
image (such as changes to color
settings and preferences)
Actions that do not change
image pixels (such as zooming
and scrolling)

Click the Undo button

, choose Edit > Undo, or press Ctrl + Z.

If the action can’t be undone, the Undo button and menu command
are inactive.
To redo the last action:
Click the Redo button
Ctrl + Alt + Z.

, choose Edit > Redo, or press

To revert to the last saved version of an image:
Choose File > Revert.
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To free memory used by the Undo/Redo commands:
Use this command only when the stored information is so large it
noticeably slows down Paint Shop Pro’s performance. This action
permanently clears from memory all information stored in the
Command History. It cannot be undone.
1 Choose Edit > Command History.
2 Click the Clear button in the Command History dialog.

Using the Command History to
Undo Actions
The Command History dialog

Revert to a previous state of an image using the Command History
dialog. This dialog displays all the actions you have performed since
you opened the image. The number of actions you can undo depends
on the settings in the Undo tab in the General Program Preferences
dialog. See “Undo/Redo Preferences” on page 394.
The Command History dialog lists the action number, amount of
time since you performed the action, and the command performed.
Note
To undo or redo one command from the list you must undo/redo all
commands above it. When you select a command to undo or redo,
the program automatically selects all commands above it.
To undo or redo actions with the Command History:
1 Choose Edit > Command History.
2 Select the actions you want to undo or redo.
Note: You cannot select undo and redo commands at the same
time.
3 Click Undo or Redo.
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Repeating Commands
To repeat multiple actions:
Record a script and run it on each
image. For more information on
using scripts, please see “Scripting
Basics” on page 378.

Another way to repeat
actions:
Holding down Shift while selecting
any toolbar button or menu item
bypasses the dialog and runs the
command with the last used
setting.

Choose Edit > Repeat to apply the same command to multiple
images or to apply a command multiple times to the same image.
This command allows you to apply the same effect or correction
without opening a dialog each time.
The last command that can be repeated always displays in the Edit
menu. If the previous command cannot be repeated, the Repeat
command is inactive.
To repeat a command:
Choose Edit > Repeat or press Ctrl + Y.

Using Rulers, Grids, and Guides
Use the rulers, grids, and guides to align and arrange artwork and
image elements.
Note
You must save your image in .PspImage format to save your grid
and guide settings.

Using Rulers
Displaying rulers on an image

You can hide or display rulers. By default, rulers are hidden. When
the cursor is on the image, a thin line appears on each ruler to show
the cursor’s position. You can display rulers in pixels, inches, or
centimeters and change the color of the ruler.
To display or hide rulers:
Choose View > Rulers or press Ctrl + Alt + R.
To change ruler units and colors:
1 Choose File > Preferences > General Program Preferences.
2 Click the Units tab.
3 In the Display units drop-down list, select Pixels, Inches, or
Centimeters.
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4 Choose the ruler color by selecting either Black on white or
Toolbar colors.
5 Click OK.

Using Grids
Displaying grids on an image

Grids are horizontal and vertical lines that help you position items.
You can display or hide grids and set preferences for grid spacing
and appearance. When you display grids, they appear in all open
image windows.
To display or hide the grid:
Choose View > Grid or press Ctrl + Alt + G.
To modify the grid:
1 Do either of the following:


Right-click the image’s title bar and from the context menu
choose Change Grid, Guide, and Snap Properties.



Choose View > Change Grid, Guide, and Snap Properties.

2 Click the Grids tab.
The Default settings group box shows settings for all future grids
you display. The Current image settings group box shows
settings for the grid in the current image.
3 For either the default or current settings, select from these
options:
Horizontal grids Sets the distance between horizontal grid lines
(starting from the top of the image).
Vertical grids Sets the distance between vertical grid lines
(starting from the left side of the image).
Units The unit of measure for positioning grid lines.
Color Click the color box to select a different color for grid lines.
Snap influence Controls how many pixels away an item must be
to snap to a guide or grid. The Snap to Grid option must be
selected in the View menu.
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Using Guides
Displaying guides on an image

Guides are horizontal or vertical lines that you drag onto your image
to use for positioning items or aligning brush stokes. While grids
place a series of horizontal and vertical lines at certain intervals, you
place guides at the locations you want.
To place guides, you must display the rulers by choosing
View > Rulers.
To display or hide guides:
Choose View > Guides.
To place a horizontal or vertical guide:
1 Do one of the following:


To place a horizontal guide, click the top ruler and drag a
guide to the desired position.



To place a vertical guide, click the left ruler and drag a guide
to the desired position.

As you drag, the Status Bar displays the guide’s position in
pixels.
To move a guide:
Do either of the following:


Click the guide handle on the ruler and drag it to a new position.



Double-click or right-click the guide handle to display the Guide
Properties dialog, type in a new Guide position value, and click
OK.

To change the color and position of a guide:
1 Double-click or right-click the guide handle to display the Guide
Properties dialog.
2 Select from these options:
Color choice tip:
Right-click the color box to pick
from the Recent Colors dialog

Guide color Click the color box to choose a new color for the
guides.
Guide position Type values in this field to control the guide’s
position (in pixels).
3 Click OK.

131

132

Chapter 6: Editing Images

To modify settings for guides:
1 To open the Grid, Guide, and Snap Properties dialog, do any of the
following:


Choose View > Change Grid, Guide, and Snap Properties.



Right-click the image title bar to display a context menu, and
choose Change Grid, Guide, and Snap Properties.



Double-click the ruler.

2 Click the Guides tab.
The Default settings group box shows settings for all the guides
you place in the future. The Current image settings group box
shows settings for the guides in the current image.
3 For either the default or current image settings, select from these
options:
Color Click in the color box to choose a new guide color.
Snap influence Controls how many pixels away an item must be
to snap to a guide or grid. The Snap to Grid option must be
selected in the View menu.
4 Click OK.
To delete one guide:
Do either of the following:


Drag the guide handle in the ruler off the image window.



Double-click the guide handle to display the Guide Properties
dialog and click Delete.

To delete all guides in an image or all open images:
1 Choose View > Change Grid, Guide, and Snap Properties.
2 Click the Guides tab.
3 Mark the Delete guides check box, and then select From current
image only or From ALL open images.
4 Click OK.
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Snapping to Grids and Guides
Items won’t snap?
Grids or guides must be displayed
for items to snap to them.

You can use the Snap features to align your brush strokes and
objects precisely to the nearest grid line or guide. The snap influence
controls how many pixels away an item must be to snap to guide or
grid.
Note
An item’s center point will snap to a guide or grid point if the center
point is the closest part of the item to a grid point or guide.
To snap to the nearest grid line:
Choose View > Snap to Grid (Ctrl + Shift + G).
To snap to the nearest guide:
Choose View > Snap to Guides (Shift + Alt + G).
Note: If a grid point and a guide are equal distances from an item,
the item will snap to the guide.
To change the snap influence:
1 Choose View > Change Grid, Guide, and Snap Properties.
2 Click the Grid or Guides tab and change the Snap influence
value.
The Default settings group box shows settings for all future
guides or grids. The Current image settings group box controls
settings for guides in the current image.
3 Click OK.
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Cropping Images
Cropping an image

Crop Area

Crop images to create stronger compositions and change the image
focus. Cropping can reduce the memory needed to edit the image.
Also, by eliminating extraneous areas of color, cropping can
improve color corrections.
Use the Crop tool to select the crop area—a rectangle with edge and
corner handles that defines what part of the image to keep. You can
also crop based a selection or based on the opaque areas of an image.
Note
Cropping permanently removes the parts of the image outside the
crop area.
To define the crop area:
1 On the Tools toolbar, click the Crop tool

.

2 Select the area by doing any of the following:


Click and drag the crop area rectangle over the image.



On the Tool Options palette, enter values for the Height and
Width of the crop area. Change measurement systems with the
Units drop-down list.



On the Tool Options palette, enter positions for the Top,
Bottom, Left, and Right sides of the crop area.

3 To adjust the crop area, do any of the following:
After Cropping



Click and drag an edge or corner handle.



Click and drag within the crop area to move the whole
rectangle.



Adjust the Height and Width values.



Adjust the Top, Bottom, Left, and Right sides of the crop area.



To remove the crop area and start over, right-click anywhere
in the image.
Note: To constrain the crop area to its current proportions,
mark the Maintain aspect ratio check box on the Tool Options
palette.
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To crop an image for printing:
1 On the Tools toolbar, click the Crop tool

.

2 Define the crop area. See, “To define the crop area:” on
page 134.
3 On the Tool Options palette, mark the Specify Print Size check
box.
4 In the Units drop-down list, select inches or centimeters. You
cannot use pixels for this method of cropping.
5 Enter the desired Height and Width for the final image. The
program will fit the final crop area into this size (reducing or
increasing the image resolution as needed).
6 To adjust the crop area, do any of the following:


Click and drag an edge or corner handle.



Click and drag within the crop area to move the whole
rectangle.



On the Tool Options palette, enter positions for the Top,
Bottom, Left, and Right sides of the crop area.

7 To crop the image, double-click the image or click Apply

.

To crop an image for on-screen display:
1 On the Tools toolbar, click the Crop tool

.

2 On the Tool Options palette, clear the Specify Print Size check
box.
3 Define and adjust the crop area. See, “To define the crop area:”
on page 134.
4 To crop the image, double-click the image or click Apply

.
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Cropping with a Selection
In Paint Shop Pro, you can make a selection and then crop the image
using that selection.
Note: If you crop to a selection that is feathered, the current
background color fills in the feathered region of the selection.
To crop using a selection:
1 Make a selection in the image.
Note: The selection can be any shape. Paint Shop Pro places a
crop area rectangle around irregularly shaped selections.
2 Do either of the following:


Choose Image > Crop to Selection.



Click the Crop tool, and then click Current selection
in the
Snap crop rectangle to group box on the Tool Options palette.
Adjust the crop area and click Apply
.

Cropping Based on Opaque Areas
Cropping to opaque area

Use this feature to eliminate transparent areas at image edges. The
Crop tool can automatically set the crop area to cover just the opaque
(non-transparent) area of a single layer or an entire image.
Note
Opaque areas that are not rectangular, may have transparent areas
remaining after cropping.
To crop to the opaque area of a layer or image:
1 Click the Crop tool

.

2 On the Tool Options palette, select an option from the
Snap crop rectangle to group box:
Layer Opaque
Merged Opaque

Selects opaque areas of the current layer.
Selects opaque area of all layers.

Note: If any layer or the background has a solid color (nontransparent) background, the entire layer or image is selected as
the crop area.
After Cropping

3 Adjust the crop area as needed. See, “To define the crop area:” on
page 134.
4 To crop the image, double-click the image or click Apply

.
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Resizing Images
Other ways to change
an image’s size
In addition to resizing an image,
you can also change the image
size by changing the canvas size,
cropping the image, or printing at a
different size.








Resizing the image removes
pixels to make it smaller or adds
pixels to make it larger.
Increasing the canvas size adds
pixels at the edge of the image.
Decreasing the canvas size
hides pixels at the edges of the
image (full layer information is
kept).
Cropping an image deletes the
pixels outside the selected crop
area.
Printing through Print Layout
resizes the image for printing but
the image file remains
unchanged. This is the best
option if you want to print the
image at various sizes.

After scanning or importing an image, you can adjust its size using
Image > Resize.
Pixels have no set, physical size. Each pixel just represents one area
of a single color. Resizing can reduce or increase the number of
pixels in the image (resampling the image). This reduces or
increases the file size. For instructions, see “To increase or decrease
the pixels in an image:” on page 137.
Resolution is the number of pixels printed per inch. More pixels per
inch (ppi), will create smaller printed pixels and a smaller printed
image. Fewer ppi, will create larger printed pixels and a larger
printed image. Resizing can also change the image’s resolution,
leaving the number of pixels in an image (and the file size)
unchanged. For instructions see, “To change the resolution (print
size) of an image:” on page 138.
For best results:


Don’t increase an image’s size more than 25 percent. Increasing
the size of an image causes a loss of detail and sharpness.



Only resize an image once. If your first resize is not correct, undo
it and try again.



Correct and retouch images before resizing.

To increase or decrease the pixels in an image:
1 Choose Image > Resize (Shift + S) to open the Resize dialog.
2 To resize the current layer only, clear the Resize all Layers check
box.
3 Mark the Resample using check box and select a resampling
type:
Note: Bilinear, bicubic, and weighted average resampling are
available only for greyscale and 16 million color images.
Smart Size Use this type in most cases. Based on the new pixel
dimensions you set, Paint Shop Pro chooses the best algorithm
listed below.
Weighted Average Uses a weighted-average color value of
neighboring pixels to determine how newly created pixels will
appear. Use this type when reducing photo-realistic, irregular, or
complex images.
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Bilinear Uses the two nearest pixels around each existing pixel to
determine how newly created pixels will appear.
Bicubic Minimizes the jaggedness that often results from
expanding an image by estimating how the newly created pixels
will appear. Use this type when enlarging photo-realistic,
irregular, or complex images.
Pixel Resize Duplicates or removes pixels as necessary to
achieve the selected width and height of the image. Use this type
with hard-edged images and simple graphics.
4 To constrain the new image dimensions to the image’s current
proportions, mark the Lock Aspect Ratio check box.
The aspect (width-to-height) ratio defaults to the ratio of the
active image. Changing the aspect ratio distorts the image by
stretching or contracting it in one dimension more than the other.
5 To keep the image’s current print size, mark the Maintain original
print size check box. The image resolution will change, keeping
the print size constant. For information on selecting image
resolution, see “About Image Size, Resolution, and Color Depth”
on page 33.
6 In the Pixel Dimensions group box, enter the new Width and
Height values. From the drop-down list, choose whether to enter
values in pixels or as a percent of the original size.
7 Click OK.
To change the resolution (print size) of an image:
1 Choose Image > Resize (Shift + S) to open the Resize dialog.
2 Clear the Resample using check box.
3 In the Print Size group box, enter the new Width and Height
values or the new Resolution value. Choose measurement
systems from the drop-down lists. For information on selecting
image resolution, see “About Image Size, Resolution, and Color
Depth” on page 33.
4 Click OK.
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Changing Canvas Size
Original image and canvas
added at the top

The image canvas is the work area of the image and defines the
image’s dimensions—for example, 200 by 300 pixels. Sometimes
you need more canvas to add elements to an image; other times you
want to make the canvas size smaller. Use the Canvas Size command
to add or remove pixels at the edges of the image.
Note
Reducing the canvas size is not always the same as cropping an
image. For images with layers, reducing the canvas size does not
delete the pixels outside the new canvas area, it just shows less of the
layer. Background layer information will always be deleted, even
when there are other layers in the image.
To change the image’s canvas size:
1 Choose Image > Canvas Size to open the Canvas Size dialog.

Other resize options
You can also change the image
size by resizing, cropping, or
printing at a different size. For a
comparison of these options, see
the sidebar “Other ways to change
an image’s size” on page 137.

Color choice tip:
Right-click the color box to pick
from the Recent Colors dialog

2 Choose settings from the New Dimensions group box:
Width, Height Enter values for the new canvas size.
Units Use this drop-down list to change the measurement system.
Lock aspect ratio Mark this check box to constrain the new
canvas size to the current image proportions. The numeric edit
control (below the check box) indicates the image’s current
width-to-height ratio. Change this value to create a different
aspect ratio.
Background Click in the color box and pick a color for any added
canvas. Or, mark the Transparent check box to have any added
canvas be transparent.
Note: You must choose a color for any canvas added to the
background layer.
3 Set the placement of the image in the new canvas. In the
Placement group box, click a placement button. The fields to the
right of the placement buttons will show the amount of canvas
added or subtracted from each edge.
Note: You can also enter values in the fields to control image
placement.
4 Click OK.
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Rotating Images
Rotating an image turns it around its pivot point. Rotating can
straighten an image that was scanned at a slight angle. Use the
Rotate command, the Deform tool, or the Straighten tool, as shown
in the table.
Command
How to Use
or Tool

Applies to...

Free Rotate Choose the rotation angle from a
command
dialog and then apply the rotation.
See “To Free Rotate:” on page 140.

A selection, the
current layer, or all
layers of the image.

Rotate 90
degree
commands

Rotate image 90 degrees clockwise or
counter clockwise. See “To rotate all
layers 90 degrees:” on page 141.

All layers of the
image.

Deform
tool

Drag the rotation handle to see the
effect of the rotation immediately.
See “To rotate with the Deform tool:”
on page 141.

The current layer
only.

Specify a line along an image feature
that is supposed to be straight. Paint
Shop Pro aligns the image with this
rotation line.

The current layer or
all layers in the
image.

Straighten
tool

Raster layers only.

Raster layers only.

Use this tool when the image has a
strong vertical or horizontal feature
(such as a building or a horizon). See
“To rotate with the Straighten tool:” on
page 142.

To Free Rotate:
1 To rotate a selection or layer (rather than the whole image), do
either of the following:


To rotate a selection, make a selection in the image.



To rotate a layer, on the Layer palette click the layer name.

2 Choose Image > Rotate > Free Rotate (Ctrl + R) to open the Rotate
dialog.
3 In the Direction group box, select the rotation direction: Right or
Left.
4 In the Degrees group box, select the number of degrees to rotate.
To enter a value between 0.01 and 359.99, select the Free option.
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5 To apply the rotation to all layers rather than just the current
layer or selection, mark the All layers check box.
6 Click OK.
Note: When you rotate a selection, the selection becomes a
floating selection and the original image is unchanged.
To rotate all layers 90 degrees:
1 Choose Image > Rotate and pick Rotate 90 Clockwise or Rotate 90
Counter clockwise.
To rotate with the Deform tool:
1 Select a layer on the Layer palette.
Deform Tool rotation
Rotation Pivot Point

2 On the Tools toolbar, choose the Deform tool

.

3 To change the center of rotation, drag the rotation pivot point
(the circle at the image’s center).
4 Click and drag the rotation handle (the square connected by a line
to the rotation pivot point) to a new position. Keep adjusting the
rotation as needed.
Note: Paint Shop Pro hides the image data that is rotated off the
canvas. You can view the data by increasing the size of the
image canvas. See “Changing Canvas Size” on page 139.

Rotation Handle

Placing Rotation Pivot
Points
In Paint Shop Pro 8, pivot points
will snap to grids and guides.
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To rotate with the Straighten tool:
Straightening an image

1 To straighten a layer (rather than the whole image), click the layer
name on the Layer palette.
2 On the Tools toolbar, click the Straighten tool
.A
straightening bar with end handles appears on the image.
3 Click and drag each handle of the straightening bar to align it
with the part of the image that you want to be straight.
4 On the Tool Options palette, choose from these options:
Auto Paint Shop Pro automatically straightens the image based
on the position of the straightening bar.

Position Straighten Bar

Make vertical Rotates the image to make the straightening bar
vertical.
Make horizontal Rotates the image to make the straightening bar
horizontal.
Angle To choose a specific angle for the straightening bar, enter a
value with the numeric edit control.
Crop image To crop the edges of the image to make it rectangular
after straightening, mark the check box. Clear this check box to
fill edge areas with the background color.

After straighten and crop

Rotate all layers To straighten all layers in the image, mark this
check box.
5 To apply the command, double-click the image or click Apply
.
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Scaling and Transforming Images
The Deform tool gives you the power to transform images
interactively. Use the tool to scale, shear, distort, apply perspective,
or rotate a layer as follows:

Deforming an image



Scaling resizes the selection or layer horizontally, vertically, or
proportionally.



Shearing skews a selection or layer vertically or horizontally.



Distorting stretches or contracts a selection or layer in any
direction.



Applying perspective corrects the perspective or applies a false
perspective on a selection or layer. For specific directions, see
“Correcting Image Perspective” on page 145.



Rotating moves a selection or a layer around a pivot point. For
specific directions, see “Rotating Images” on page 140.

Bounding box

Distort

Skew

The Deform tool works on raster layers only. To deform vector
objects or text in similar ways, see “Resizing and Reshaping Vector
Objects” on page 243 or “Scaling and Transforming Text” on
page 309.
To deform an image:
1 Choose a layer by clicking its name on the Layer palette.

Asymmetric
Perspective

Symmetric
Perspective

Color depth and layers

2 On the Tools toolbar, select the Deform tool

.

A bounding box with handles appears on the selection or the
layer.
3 To deform the image by clicking and dragging in the image, do
one or more of the following:

The Deform tool works on greyscale
and 16 million color images only. To
increase the color depth of an
image, see page 109.



To resize, click and drag one of the corner or edge handles.



To resize while keeping the current proportions, right-click
and drag a corner handle.

To use the Deform tool, the image
data must be on a regular raster
layer. If necessary, promote the
background by choosing
Layers > Promote Background
Layer.



To move the entire image within the canvas, click and drag
anywhere within the bounding box.



To change the center of rotation, drag the rotation pivot point.



To rotate, drag the rotation handle.



To change perspective symmetrically, press Ctrl and drag a
corner handle horizontally or vertically.
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To change perspective asymmetrically, press Shift and drag a
corner handle.



To shear, press Shift while dragging a side handle.



To distort, press Ctrl and Shift while dragging a handle.

Deform Tool Tip
To make the deform handles on a
layer easier to see, drag the corner
of the image window to make it
larger than the image.

How do I resize and reshape
vector objects and text?
Use the Object Selection Tool. For
instructions, see “Using the
Selection Tools” on page 154.

Quick steps for
proportional scaling
To resize a floating selection or
layer and keep the same
proportions, select the Deform tool
and right-click and drag a corner
handle of the bounding box.

4 Adjust the deformation or view the deformation settings on the
Tool Options palette. For more information on these settings, see
“More Deform Options” below.
5 To cancel previous deformations, choose Edit > Undo (Ctrl Z).
Note
By default, you must press the Shift and Ctrl keys to deform an
image. To apply a deform operation without having to hold down
keys, choose a different Mode from the Tool Options Palette:
Scale The default setting; you must hold down a key or keys.
Shear (Shift) Allows you to shear without holding down Shift.
Perspective (Ctrl) Allows you to change perspective without
holding down Ctrl.
Free (Shift + Ctrl) Allows you to distort without holding down
Ctrl + Shift.

More Deform Options
You can precisely control many of the deform settings. The
following options appear on the Deform tool’s Tool Options palette:
Pivot X, Pivot Y Sets the X and Y coordinates of the rotation pivot
point.
Position X, Position Y Sets the X and Y coordinates of the top left
corner handle.
Scale X(%), Scale Y(%) Sets the percentage change for the horizontal
(X) and vertical (Y) resize.
Shear The offset of a side. Enter positive values to shear to the right
and negative values to shear to the left. At 0.5, a side shears 50% of
its length.
Angle The rotation around the pivot point. The image rotates clockwise from 0 to 360 degrees.
Reset Rectangle
Resets the deformation rectangle to its original
shape but keeps any current deformations.
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Perspective X, Perspective Y The best way to create and adjust
perspective is by dragging the control handles. When you create a
perspective effect with the control handles, you are manipulating
many variables. Changing the values in the Perspective fields may
affect the scale, shear, and position values.

Correcting Image Perspective
When you take pictures of tall objects, the resulting photographs
may have perspective distortion—the objects seem to be leaning or
angled. This distortion happens when the camera is at an angle to the
subjects.
Fix perspective distortion with two tools:
Tool

How to Use

Applies to...

Deform
tool

Drag the corner handles of a
bounding box around an entire layer
to interactively change the
perspective.

The current layer
only.
Raster layers only.

See “To use the Deform tool to
correct perspective:” below.
Perspective Drag a bounding box around a
The current layer
Correction feature within the image (such as a
only.
tool
building) that is supposed to be
Raster layers only.
rectangular but is angled. Paint Shop
Pro adjusts the perspective to make
the selected feature rectangular.
See “To use the Perspective
Correction tool to correct
perspective:” on page 146.

To use the Deform tool to correct perspective:
1 Select the layer to correct in the Layer palette.
2 Use grid lines to help you correct lines in your photograph that
should be vertical or horizontal. To turn on the grid, choose
View > Grid.
3 On the Tools toolbar, select the Deform tool

.

4 Press Ctrl and click and drag a corner handle. The image updates
when you release the mouse button. Continue adjusting the
perspective until the image looks correct.

145

146

Chapter 6: Editing Images

Note: If the correction causes some image data to fall outside the
image canvas, you can restore that data by increasing the size of
the canvas. See “Changing Canvas Size” on page 139.
To use the Perspective Correction tool to correct perspective:
Correcting perspective

1 On the Tools toolbar, select the Perspective Correction tool
A bounding box with corner handles appears on the image.

.

2 On the Tool Options palette, select from these options:

Bounding box



Grid lines To display grid lines in the box, enter the number of
lines to display.



Crop image Mark this check box to crop the image back to its
original size after the perspective is applied. Areas of the
image that fall outside the original image size are deleted.

3 Drag each handle to the corner of a feature that is supposed to be
rectangular. For example, the feature may be a building with
sides that are angled but should be straight.
4 On the Tool Options palette, fine-tune the position of the
bounding box by specifying the X and Y positions of the four
corner handles.
5 Double-click the image or click Apply.
After Correction

Note: To reset the perspective correction box to the original
rectangle, click Reset
on the Tool Options palette.

Warping Images
Warping with the Mesh Warp
tool

Use the Mesh Warp tool to deform images, layers, and selections.
Clicking the tool places a grid, or mesh, on the image. The grid
intersections have mesh points, or nodes, that you drag to create
deformations.
Note
The Mesh Warp tool is limited to deforming the interior of a
selection. Use the Warp brush when you want to blend the selection
into the rest of the image.
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To use the Mesh Warp tool:
1 On the Tools toolbar, select the Mesh Warp tool
Other ways to warp images
Use the Warp Brush. See “Warping
Images” on page 215.
Use the Warp Effect. See
“Applying Geometric Effects” on
page 319.

.

2 Drag the nodes to deform the image:


Click and drag a node to move it.



Press Shift while dragging a node to move the entire row or
column.



Press Ctrl while dragging a node to deform the row or column
into a smooth curve.

3 Choose settings from the Tool Options palette:
Activate and move nodes
using the keyboard
Press Ctrl + PgUp or Ctrl + PgDn
to activate the next or previous
node in a row.
Press Shift + Ctrl + PgUp or
Shift + Ctrl + PgDn to activate the
next or previous node in a column.
Press the Ctrl + Arrow keys to
move the node 1 pixel.
Press the Shift + Ctrl + Arrow keys
to move the node 5 pixels.

Draft quality Choose the quality of the preview that displays
while you edit the mesh nodes.
Note: Increasing the quality can slow the warping process in
large images.
Final apply Clear the Best Quality check box to create a finished
mesh warp at the lower quality of the mesh preview.
Mesh horizontal and Mesh vertical The values indicate the
number of mesh lines within the frame. The border lines are not
counted.
Note: You can change the grid size as you work. Entering new
Mesh values reconfigures the grid and returns it to the original
position. The image retains any deformations you have made.
Symmetric Mark this check box to create a grid that evenly
covers the image. If you image is not square, there will be
different values for Mesh horizontal and Mesh vertical. Clear this
check box to adjust the Mesh horizontal and Mesh vertical
independently.
Show grid Clear the check box to hide the mesh warp grid.
4 You can save the position of the mesh nodes (the deformation
map) to apply the deformation to other images. For instructions
see “Saving and Loading Deformation Maps” on page 148.
5 Use Edit > Undo to undo changes to the mesh as you edit.
6 To apply the mesh warp, double-click the image or click Apply
. To cancel the mesh warp, click Cancel
.

147

148

Chapter 6: Editing Images

Saving and Loading Deformation Maps
You can save the deformations you have created to warp other
images. Paint Shop Pro creates a Deformation Map file that contains
the positions of the nodes and the number of mesh lines. Save the
mesh during the warping process or after you have applied the
deformation.
To save a deformation map:
1 On the Mesh Warp Tool Options palette, in the Deformation map
group box, click Save
to open the Save Deformation Map
dialog.
2 In the New deformation map group box, type a name for the map
file.
3 In the Checkerboard size drop-down list, choose a checkerboard
size that helps you preview the deformation effect. This
information is not saved with the map file.
4 Click Save to add the file to the default Deformation Maps
folder. Click the Edit Paths button to choose a different folder for
saving the deformation maps.
To load a deformation map:
What is an Edge Mode
setting?
The Edge Mode setting determines
what happens if there is a gap
between the border of the image
and the edge of the image.

1 On the Mesh Warp Tool Options palette, select an option under
Edge mode:


Background or transparency fill The areas between the edge
of the image and the edge of the warp are filled with:
the current background color if the areas are on a background,
transparency if the areas are on a layer.



Fixed The edge pixels are replicated to fill in the areas
between the edge of the image and the edge of the warp.



Wraparound The areas between the edge of the image and the
edge of the warp are filled with material from the opposite
side of the image.

2 Click Open Deformation Map
Map dialog.

to open the Load Deformation

3 In the Deformation map group box, choose a map from the dropdown list. Click the Edit Paths button to load a map from a
different folder.
4 In the Operation group box, select how you want the map to be
added:
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Replace current map Replaces the existing mesh nodes with
the new map. Any adjustments you have made but not applied
are lost.



Add to current map Adds the settings from the new
deformation map to the mesh nodes. Any adjustments you
have made are retained.

5 In the Mapping group box, select how Paint Shop Pro should
adjust the size of the map to fit to the layer or image:


Fit to canvas The map size adjusts to fit the image canvas.



Fit to layer The map size adjusts to fit the current layer.



Current size centered on The map retains its original size and
is positioned in the center of the Canvas or Layer.

6 In the Preview group box, choose a Checkerboard size from the
drop-down list to obtain the best preview of the deformation.
7 Click Load.

149

150

Chapter 6: Editing Images

Adding Borders to Images
Adding Borders
Adding a colored border

Use the Add Borders command to add a colored frame around an
image. The border increases the dimensions of the image by the
width of the border.
For multi-layer images, Paint Shop Pro prompts you to flatten the
image first. To add colored borders without flattening an image, use
the Canvas Size command instead; see “Changing Canvas Size” on
page 139.
To add borders:
1 Choose Image > Add Borders to open the Add Borders dialog.
2 Mark the Symmetric check box to create an equal width border
on all sides. Clear the check box to enter each border width
independently.

Color choice tip:
Right-click the color box to pick
from the Recent Colors dialog

3 In the Size in pixels group box, select the dimensions of the
border.
Note: To change the dimensions from pixels, select the units in
the drop-down list in the Original Dimensions group box.
4 Click the Color box to choose the color for the border.
5 Click OK.
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Flipping and Mirroring Images
Flipping an image

Use the Flip command to reverse an image along its horizontal
axis—the on top becomes the bottom and vice versa. Use the Mirror
command to reverse the image along its vertical axis—the left side
becomes the right and vice versa.
Note
To flip or mirror all layers in an image, make them all part of the
same layer group.
To flip a selection, layer, or image:

Mirroring an image

Choose Image > Flip or press Ctrl + I. Flipping a selection converts it
into a floating selection, leaving the original layer unchanged.
To mirror a selection, layer, or image:
Choose Image > Mirror or press Ctrl + M. Mirroring a selection
converts it into a floating selection, leaving the original layer
unchanged.

Combining Two Images
Paint Shop Pro can combine two images into a third image. The new
image is the product of the color data from the two source images.
The color data from the two images is combined on a pixel-by-pixel
basis according to the function you select.
To combine two images:
1 Open the two images you want to combine.
2 Choose Image > Arithmetic to open the Image Arithmetic dialog.
3 Choose an image for Image #1 from the drop-down list. The size
of Image #1 determines the size of the new image.
4 Choose an image for Image #2 from the drop-down list.
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5 From the Function group box, select a method for combining the
images:
Add Image 1 Value + Image 2 Value
Subtract Image 1 Value - Image 2 Value
Multiply Image 1 Value x Image 2 Value
Difference Absolute Value of (Image 1 Value - Image 2 Value)
Lightest Maximum of (Image 1 Value, Image 2 Value)
Darkest Minimum of (Image 1 Value, Image 2 Value)
Average (Image 1 value + Image 2 Value)/2
OR Binary Or
AND Binary And
XOR Binary And/Or
6 From the Channel group box, select the color channel from each
image to use for combination. Mark the All channels check box
to use all the color channels in both images. This will produce a
24-bit image.
7 In the Modifiers group box, choose modifier options. The
modifiers are applied to the color values produced by the
Function and the Channel selections.
Divisor This number is used to divide the color values. It can
reduce the effects of the other selections.
Bias This number shifts each color value by a fixed amount. The
number is added to the color value produced by the Function,
Channel, and Divisor selections.
Clip color values This check box determines how Paint Shop Pro
handles final color values greater than 255 and less than 0.
Clip Color
Values

Value less than 0

Value more than 255

Marked

Value = 0

Value = 255

Cleared

Value = Value + 256

Value = Value - 256

8 Click OK.
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Making Selections in Images
Selecting the parts of images to edit is an important step in
modifying images. After you create a selection, you can edit it while
leaving the rest of the image unchanged. You can use tools (such as
painting or drawing) or apply commands (such as flipping, copying,
or cropping) to the selection.
The border of a selection is identified by black and white dashes
called a marquee. This chapter shows you how to make many types
of selections.
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Using the Selection Tools
Transforming a selection
Here are a few of the ways you can
edit selections:








Cut, copy, or paste selections.
Crop to a selection.
Move selections within the
image.
Flip, mirror, or rotate selections.
Correct colors within selections.
Apply effects to selections.
Paint or draw in selections.

Use multiple selections
tools
You can make an initial selection
with one selection tool, and then
switch to another selection tool to
add to or subtract from the
selection. For more information,
see “Modifying Selections” on
page 167, or “Subtracting from a
Selection” on page 169.

The way in which you select part of the image depends upon the type
of layer: raster or vector. (For more information on data types, see
“About Raster and Vector Graphics” on page 32.)
Paint Shop Pro contains selection tools that create raster (or pixel)
selections as well as vector selection tools that select vector objects.

Raster Selection Tools
Selection tool
Makes a selection of a specific shape, such as a
rectangle, circle, or star. See “Making Selections with the
Selection Tool” on page 155.
Freehand Selection tool
Makes a selection of an irregular shape
or around the edges of an object, such as the petals of a flower or a
child’s hand. See “Making Selections with the Freehand Selection
Tool” on page 157.
Magic Wand tool
Makes a selection based on a color, brightness,
or opacity. See “Making Selections with the Magic Wand Tool” on
page 159.
These selection tools are grouped together in a flyout on the Tools
toolbar. One tool is displayed at a time. Click the down arrow to the
right of the tool to see the other selection tools.
Although these selection tools create raster selections, you can use
them on vector layers; they create raster selections from the vector
objects. For example, if you copy the selection and paste it as a new
image, the object is copied as individual pixels (rather than a vector
object) onto a raster layer.

Vector Selection Tools
To select vector objects and vector text (without turning them into
raster selections), use these tools:
Object Selection tool
Selects vector objects or vector text. See
“Selecting Vector Objects” on page 161.
Text tool
Creates a selection in the shape of text. See “Selecting
Text” on page 162.
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Making Selections with the
Selection Tool
Use the Selection tool to select a portion of a raster layer, or to create
a raster selection of objects on a vector layer. You can make a
selection of a specific shape: rectangle, square, rounded rectangle,
rounded square, ellipse, circle, triangle, pentagon, hexagon, octagon,
star, or arrow.
To use the Selection tool:
1 On the Tools toolbar, choose the Selection tool
Selection tool flyout.

from the

2 On the Tool Options palette, choose from these options:
Selection Type Choose the shape of the selection area (such as
rectangle or circle).
Mode Specifies whether you want to Replace, Add, or Remove
from an existing selection.
Feather before or after
If you select a Feather value in the
Tool Options palette, that value
affects the next selection that you
make with the Selection tool. You
can also change the feathering of
an existing selection; choose
Selections > Modify > Feather or
Selections > Modify > Inside/
Outside Feather.

Feather Specifies a width in pixels (0 to 200) that the selection is
faded along the edges. When you move or paste the selection,
feathering helps blend the selection into the surrounding area and
makes it appear more natural. The higher the Feather value, the
softer the edges. Set the width to 0 to create a selection with no
feathering and distinct edges.
Anti-alias Mark this check box to use anti-aliasing, which
produces a smooth-edged selection by partially filling in pixels
along the edge, making them semi-transparent. Clear the check
box to keep the original edges.
Note: After you create a selection, you cannot change the
Selection Type or the Anti-alias setting. Changing these options
applies to the next selection you make. You can change the
feathering; see “Changing the Feathering of a Selection” on
page 169.
3 To make the selection, do one of the following:


Click and drag in the image. As you drag, a border indicates
the selection. When you release the mouse, the selection
border becomes a marquee. If you select a Feather value, that
portion of the selection is added to the marquee.
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To make a selection of a specific size, on the Tool Options
palette, click Custom Selection
and then enter the
selection position in pixels for the left, top, right, and bottom
positions. The positions are measured from the top left corner.



On the Tool Options palette, choose Layer opaque
to select
opaque areas (the non-transparent area that has data) of the
current layer.



Choose Merged opaque
to select the opaque area of
all layers within the image. This option is unavailable if the
image has only one layer.

4 To create a rectangular selection from an odd shaped selection:
Align that selection
You can use grids and guides in
the image window to help you align
your selections. For more
information, see “Using Rulers,
Grids, and Guides” on page 129.



In the Create selection from area of Tool Options, choose
Current selection . A new rectangular selection surrounds
the current selection.

5 To modify the selection borders, do any of the following:


To add to the selection, from the Mode drop-down list, choose
Add, or hold down the Shift key and click and drag another
selection area (it does not need to be part of the original
selection).



To subtract from the selection, from the Mode drop-down list,
choose Remove, or hold down the Ctrl key and click and drag
within the original selection.



To move the selection marque, choose the Mover tool
right-click and drag within the selection.

and

Note: You can also switch to another selection tool before adding
to or subtracting from the selection.
You can now edit the contents of the selection (move it, copy it,
paint it, correct colors, apply effects, and so on). The selection
remains active until you make another selection or right-click to
deselect it while one of the selection tools is active, or choose
Selections > Select None.
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Making Selections with the
Freehand Selection Tool
With the Freehand Selection tool, you can select objects with
irregular borders. Use this tool to select everything from the outline
of a tree to a child’s hand to the jagged edge of a leaf.
To use the Freehand Selection tool:
Select the layer first!
Before you make a selection,
display the Layer palette and click
the name of the layer that contains
the data you want to select.

Using the Edge Seeker
selection type

1 If the image has more than one layer, click the layer on which you
want to make a selection from the Layer palette.
2 On the Tools toolbar, choose the Freehand Selection tool
from the Selection tool flyout.
3 On the Tool Options palette, choose the Selection Type to
determine how Paint Shop Pro makes the selection:
Edge Seeker Click on the edges of irregularly shaped areas, and
Paint Shop Pro finds the edges between two areas with subtle
color or light changes between them.
Freehand Click and drag to select the area—like making a
freehand drawing. Use this type for irregular shapes when you
want to make a selection quickly.
Point to Point Click from point to point and Paint Shop Pro
draws a straight border between the points. Use this when you
want a selection with straight edges.
Smart Edge Click along the edges of irregularly shaped areas and
Paint Shop Pro finds the edges. Use this selection to create a
border between two areas of highly contrasting color or light.

Using the Freehand selection
type

4 On the Tool Options palette, choose from these additional
options:
Feather A width in pixels (0 to 200) that the selection is faded
along the edges. Feathering controls the sharpness of a
selection’s edges. For a detailed description, see page 155.
Range Specifies the distance (0 to 15) from the point you click
that Paint Shop Pro searches for an edge. This option is available
only for the Edge Seeker selection type.
Smoothing The amount of smoothing (from 0 to 40) for the
selection border. This smooths sharp edges or jagged lines.
Anti-alias Mark this check box to use anti-aliasing, which
produces a smooth-edged selection by partially filling in pixels
along the edge, making them semi-transparent. Clear the check
box to keep the original edges.
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Sample Merged If the check box is marked, the tool searches for
an edge in all layers of the area you select. If the check box is
cleared, the tool searches for edges only in the current layer. If
using the Edge Seeker and Smart Edge selection types, this
option can only be used on single layered images.
5 Make the selection:
Using the Point to Point
selection type



For the Edge Seeker and Smart Edge selection types, click in
the image where you want to start the selection, then click
points around the area you want to select. After you click each
point, a line indicates the selection border. To delete a
previous point, press Delete. To complete the selection,
double-click or right-click.



For the Freehand selection type, click and drag an outline of
the area you want to select. When the line encloses the
selection, release the mouse button. (If you release too soon,
start again or add to the selection as described in “Modifying
Selections” on page 167.)



For the Point to Point selection type, click where you want the
selection border to start and then continue clicking until you
return near the starting point. To complete the selection,
double-click or right-click. To delete a previous point, press
Delete.

For all selection types, the line becomes a marquee indicating the
selection border.
6 To modify the selection area, do either of the following:


To add to the selection, from the Mode drop-down list choose
Add, or hold down the Shift key and click and drag another
selection area.



To subtract from the selection, from the Mode drop-down list
choose Remove, or hold down the Ctrl key and click and drag
within the original selection.

Note: You can also switch to another selection tool before adding
to or subtracting from the selection.
You can now edit the contents of the selection (move it, copy it,
paint in it, correct colors, apply effects, etc.). The selection remains
active until you make another selection or right-click to deselect it,
or choose Selections > Select None.
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Making Selections with the
Magic Wand Tool
Select what you don’t want
Sometimes the easiest way to
select a complicated part of an
image is to select the part of the
image that you don’t want and then
invert the selection. For example, if
you have a picture of a tree
silhouetted against a blue sky, use
the Magic Wand tool to select the
sky and then invert the selection to
select the tree.
For more information, see
“Selecting Everything Outside the
Selection” on page 167.

Use the Magic Wand tool to select content rather than defining edges
in the image. It works well for selecting a complex part of an image
that has distinctly different pixels from other parts—for example, a
pink rose surrounded by green leaves. The tool uses four types of
values for making selections—color (RGB value), hue, brightness,
or opacity.
With the Magic Wand, you select the type of match you want (such
as hue), choose a tolerance that determines how closely pixels must
match, and then click once in the image to select the pixel that the
other pixels are compared to.
To use the Magic Wand tool:
1 If the image has more than one layer, on the Layer palette click the
layer name which contains the part of the image you want to select.
2 On the Tools toolbar, choose the Magic Wand tool
Selection tool flyout.

from the

3 On the Tool Options palette, choose the Match mode to
determine how Paint Shop Pro creates the selection:
None Chooses all pixels.
RGB Value Chooses pixels that match the red, green, and blue
value of the color that you select in the image.
Color Chooses pixels of the same color that you select in the
image.
Hue Chooses pixels based on the position in the color wheel of
the hues you select within the image.
Brightness Chooses pixels based on the brightness of the color
you select within the image.
All Opaque Chooses only areas containing pixels. No transparent
areas are selected.
Opacity Chooses pixels based on their opacity.
4 On the Tool Options palette, choose from these additional
options:
Tolerance Controls how closely the selected pixels must match
the initial pixel you click. At low settings, the values must be
close. At higher settings, the Magic Wand tool selects a wider
range of pixels.
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Feather A width in pixels (0 to 200) that the selection is faded
along the edges. Feathering controls the sharpness of a
selection’s edges. For a detailed description, see page 155.
Sample Merged Mark this check box to have the Magic Wand
tool search for matching pixels in the merged image. Clear this
check box to limit the selection to the active layer.
Anti-alias Mark this check box and then choose whether you
want to anti-alias inside or outside of the selection marquee.
5 Click the part of the image that has pixels you want to match. The
selection marquee surrounds all matching pixels.
If the Magic Wand tool selected more pixels or fewer pixels than
you wanted, adjust the Tolerance value and make a new
selection.
6 To modify the selection, from the Mode drop-down list, choose:


Replace to replace an existing selection with a new selection.



Add to add to the selection, click another area of the image.



Remove to subtract from the selection, click within the
original selection to remove the selection.

Note: Use the Expand or Select Similar commands to add to the
selection. See “Modifying Selections” on page 167.
You can now edit the contents of the selection (move it, copy it,
paint in it, correct colors, apply effects, etc.). The selection remains
active until you make another selection or right-click to deselect it.
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Selecting Vector Objects
To edit a vector object such as a Preset Shape or vector text, you
must first select the object with the Object Selection tool. You can
select one or several objects, on the same layer or on different layers.
You can also select vector objects from the Layer palette.
To select vector objects with the Object Selection tool:
Versatile Object Selector
In addition to selecting vector
objects, use the Object Selection
tool to:
Move, resize, reshape, and
rotate vector objects and vector
text.
 Align and distribute vector
objects.
 Group and ungroup vector
objects.
 Apply Edit menu commands
such as copying and pasting.
For more information, see
Chapter 10, Drawing and Editing
Objects.


1 On the Tools toolbar, choose the Object Selection tool

.

2 Do one of the following:


Click the object you want to select. To select multiple objects,
press Shift and click on each additional object.



Drag the cursor to create a rectangle around the object(s). The
rectangle must enclose all objects completely to select them.

A bounding box with handles surrounds the objects you selected.
For information on using these handles to edit the objects, see
“Resizing and Reshaping Vector Objects” on page 243.
To select vector objects from the Layer palette:
1 On the Layer palette, click the plus sign (+) to next to a layer to
expand the layer and display the objects within the layer.
2 Click the name of the object. To select multiple objects, press
Shift and click each object name. A bounding box in the image
surrounds the objects you selected.
To select all objects on all visible layers:

To de-selecting all
To undo the Select All command,
choose Selections > Select None.

1 On the Layer palette, make visible the each object you want to
select. If there are objects you don’t want selected, make their
layers invisible. (For more information, see “Showing and Hiding
Layers, Groups, and Vector Objects” on page 270.)
2 Right-click the name of a vector object and choose Select All
from the context menu.
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Selecting Text
You can make two types of selections with text:


Use the Object Selection tool to select vector text so that you can
edit it.



Use the Text tool to create a raster text selection (a selection
marquee shaped like text) that you can use to create interesting
effects. For example, create a text selection on a solid colored
layer and then delete the selection so the letters become
transparent and are outlined in the solid color.

To select vector text:
1 On the Layer palette, click the layer name that contains the text.
2 On the Tools toolbar, choose the Object Selection tool

.

3 Click the text. A bounding box with editing handles surrounds
the text.
You can now move or resize the text. Double-click to edit the
vector properties (such as the color or texture). To edit the words
themselves, click the Text tool and then double-click the text.
To create a text selection with the Text tool:
About the Text tool
Making a text-shaped selection is
just one thing that the Text tool can
do. The tool’s main function is to
add text to your image. For more
information, see Chapter 13,
Working with Text.

1 Select the Text tool

.

2 On the Tool Options palette, in the Create as group box choose
Selection (which creates a selection shaped like the text rather
than text as a painted object).
3 Click where you want to start the text selection to open the Text
Entry dialog.
4 Select the text options and type the text.
5 Click Apply.
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Deselecting a Selection
You can deselect any selection in the image, which removes the
marquee and integrates the selection back into the image. If you
deselect a floating selection, Paint Shop Pro defloats it and places it
in the underlying layer if the layer is raster. If the underlying layer is
vector, Paint Shop Pro creates a new raster layer and defloats the
selection to it.
To deselect a selection:
Choose Selections > Select None, right-click in the image, or press
CTRL + D.

Selecting All Non-Masked Areas
Creating a mask from
a selection
You can also use a selection to
create a mask. For more
information, see “Creating Masks
from Selections” on page 292.

Create a selection that selects all non-masked areas and omits all
masked areas. The selection is clipped to the canvas size.
To select all non-masked areas:
1 Create a mask as described in “Creating Masks” on page 289.
2 On the Layer palette, select the mask layer.
3 Choose Selections > From Mask. The selection marque surrounds
the non-masked areas.
Note
If you saved a mask to an alpha channel, you can load it as a
selection by choosing Selections > Load from Alpha Channel.

Selecting All Pixels
Selecting a layer
As long as there are no selections
on the image, when you click a
layer’s name on the Layer palette
Paint Shop Pro automatically
selects all contents of the active
layer (though without a selection
marquee). If the layer has data that
is moved off the image canvas, that
data is also selected.

Use the Select All command to select all pixels on a single layer or
in the entire image if the image has only one layer. The Select All
command selects all pixels on the image canvas, but does not include
pixels that have been moved off the canvas.
To select all pixels in a layer or an image:
1 If the image has more than one layer, on the Layer palette click the
name of the layer you want to select.
2 Choose Selections > Select All or press Ctrl + A. A marquee
appears around the layer on the canvas.
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Creating Raster Selections from Vector
Objects
You can select a vector object, convert it to a raster selection, and
then copy and paste this selection into another layer or another
image. Do this when you want to apply raster-only tools and
commands to vector objects.
To create a raster selection from a vector object:
1 Use the Object Selection tool to select one or more vector objects.
2 Choose Selections > From Vector Object.
The selection marquee surrounds each vector object. You can
now copy and paste the selection as needed. The original vector
objects remain unchanged.

Using Edit Selection
Use the Edit Selection command to create a selection from a brush
stroke, or to apply an effect to only the selection marquee.
To create a selection:
1 Choose Selection > Edit Selection, or click the Edit Selection
button
on the Layer palette. A selection layer is added to the
Layer palette.
2 Select a painting tool from the Tools toolbar. For more
information, see Chapter 9, Painting.
3 Set the options for the painting tool in the Tool Options palette
and the Variance palette.
4 Paint on the image with black, white or shades of grey.
The lightness of the paint controls the opacity of the selection.
A ruby overlay displays the brush strokes.
5 Choose Selection > Edit Selection, or click the Edit Selection
button
on the Layer palette. The selection marquee displays
the selected area.
To apply tools and effects to the selection marquee:
1 Make a selection on the image. See “Using the Selection Tools” on
page 154.

Chapter 7: Making Selections in Images

2 Choose Selection > Edit Selection, or click the Edit Selection
button
on the Layer palette. A ruby overlay displays in the
selected area.
3 Apply a tool or effect to the selection area.
4 For more information, see Chapter 9, Painting, or Chapter 14,
Applying Effects.
Note: The Preview tab of the Overview palette displays the edits
made to the selection marquee.
5 When finished editing the selection, choose Selection > Edit
Selection to display the selection marquee.
To turn off the selection marquee choose Selections > Select None.

Working with Standard and Floating Selections
Vector turned raster—pay
attention to the defloat!
When you use one of the raster
selection tools (Selection,
Freehand, or Magic Wand) to
select vector objects or text, the
tool creates a raster selection of
the object or text. If you move the
selection, it becomes a floating
selection. When you try to perform
a new action, Paint Shop Pro
automatically promotes the floating
selection to a new layer.

A raster selection can be either standard (non-floating) or floating. A
standard selection is part of a layer or image. When you edit a
standard selection, you modify the image itself. Standard selections
are what you create when you use the Selection, Freehand, and
Magic Wand tools.
A floating selection temporarily rests above the image or layer. The
Layer palette displays a Floating Selection icon
to indicate that
the layer contains a floating selection.
Floating applies to raster selections only. Selections are
automatically floated when you do one of the following:


Move a selection with one of the selection tools (Selection,
Freehand, or Magic Wand tool).



Paste a selection by choosing Edit > Paste > As New Selection.



Select the Floating option when creating text.

Floating selections are automatically defloated to the nearest raster
layer, or promoted to a raster layer, when you deselect the selection,
create a new selection, or add to or subtract from the selection. As a
result, much of the time you do not have to be aware of whether a
selection is floating or standard—Paint Shop Pro takes care of it for
you.
However, you can also float a selection using the Float command,
which creates a copy of the selection that you can move or modify
without changing the original image. When you finish editing the
floating selection, use the Defloat command to defloat it.
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To float a selection:
1 Make a raster selection in the image using the Selection, Freehand,
or Magic Wand tools.
2 Choose Selections > Float or press Ctrl + F.
To defloat a selection:
Choose Selections > Defloat or press Ctrl +Shift + F.

Adjusting Selection Borders
After you make a selection in your image, you may want to modify
or edit the selection borders.

Moving the Selection Marquee
Remember the Mover tool
To move the selection marquee,
you must first select the Mover
tool.
If you right-click in the image with a
selection tool, you deselect the
selection. If you click and drag the
selection with a selection tool, you
float the selection and move it.
(If you did one of these by mistake,
press Ctrl + Z to undo.)

To change or fine-tune the area the selection encloses, you can use
the Mover tool to move the marquee.
To move the selection marquee:
1 On the Tools toolbar, click the Mover tool

.

2 Right-click inside or on the marquee and drag the marquee to a
new position.

Hiding and Viewing the Selection
Marquee
The selection marquee is normally visible. Sometimes when working
with a selection it is helpful to hide the marquee temporarily without
disabling the selection. For example, you may want to see the results
of pasting a selection or feathering a selection’s edges.
To hide or view the marquee:
Choose Selections > Hide Marquee or press Ctrl + Shift + M.
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Selecting Everything Outside the
Selection
Inverting a selection

Sometimes the easiest way to select a complicated part of an image
is to select the part of the image that you don’t want and then invert
the selection. For example, if you have a picture of a person against
a solid color background, you can select the background and then
invert the selection to select the person.
To invert a selection:
1 Make a selection in the image.
2 Choose Selections > Invert. The marquee changes to enclose the
opposite area of the image.

Modifying Selections
After you make a selection in your image, you may want to modify
or edit the selection.

Adding to a Selection
Adding to a selection

You can add to the selection area using the selection tools, either the
same selection tool you used to make the original selection or a
different selection tool. For example, you have a picture of a person
carrying a large sign. You can select the sign with the rectangular
Selection tool, then add the person to the selection using the
Freehand Selection tool.
You can also use the Expand command to increase a selection by a
specific number of pixels or the Select Similar commands to add to
selections based on pixel color values.
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To add to a selection using the selection tools:
1 On the Tools toolbar, choose the selection tool (Selection,
Freehand, or Magic Wand tool) that you want to use to add to the
selection.
2 On the Tool Options palette, select the tool options.
3 Hold down the Shift key as you click the parts of the image you
want to add to the selection. The areas do not need to be adjacent.
To expand the selection by a specific number of pixels:
1 Choose Selections > Modify > Expand.
2 Select the number of pixels (1 to 100) by which you want to
expand the selection.
3 Click OK. The marquee expands while keeping its original shape.
To add pixels to a selection based on color values:
1 Choose Selections > Modify > Select Similar.
Note: In the dialog you can click the Transparency button
change between showing only the selection or showing the
selection and the rest of the image.

to

2 Select from these options:
Tolerance Specifies how closely pixels must match the colors of
the initial selection. At low settings, the values must be close. At
higher settings, more pixels match.
Sample Merged If the check box is marked, Paint Shop Pro
selects matching pixels in the merged image. If the check box is
cleared, Paint Shop Pro selects pixels in the active layer only.
Anti-alias Mark this check box to use anti-aliasing, which
produces a smooth-edged selection by partially filling in pixels
along the edge, making them semi-transparent. Mark whether
you want the areas Inside or Outside the selection marquee to be
anti-aliased. Clear the Anti-alias check box to keep the original
edges.
Contiguous Selects all adjacent pixels of a similar color.
Discontiguous Selects all pixels of a similar color anywhere
within the image.
3 Click OK. The selection changes to include matching pixels.
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Subtracting from a Selection
Subtracting from a selection

You can subtract from the selection area using the selection tools,
either the same selection tool you used to make the original selection
or a different selection tool. You can also use the Contract command
to contract a selection by a specific number of pixels.
To subtract from a selection using the selection tools:
Hold down the Ctrl key as you click the parts of the image you want
to remove from the selection.
To contract the selection by a specific number of pixels:
1 Choose Selections > Modify > Contract.
2 Select the number of pixels by which you want to contract the
selection.
3 Click OK. The marquee contracts while keeping its original
shape.

Changing the Feathering of a Selection
Feathering specifies a width in pixels (0 to 200) that the selection is
faded along the edges. When you move or paste the selection,
feathering helps blend the selection into the surrounding area and
makes it appear more natural. The higher the Feather value, the
softer the edges. Set the width to 0 to create a selection with no
feathering and distinct edges.
How to set the feathering
before you create a
selection
To feather a new selection, choose
a selection tool (Selection,
Freehand, or Magic Wand) and on
the Tool Options palette adjust the
Feather value. When you make the
new selection, that feathering is
used.

Use the Tool Options palette to set the feathering before creating a
selection. After you create the selection, you can modify the
feathering amount and the feathering position (inside or outside the
selection border) using commands from the Selection menu.
To change the feathering amount:
1 Choose Selections > Modify > Feather.
2 Select the number of pixels for the feathering width, both inside
and outside of the selection.
3 Click OK.
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To adjust the position and amount of feathering:
1 Choose Selections > Modify > Inside/Outside Feather.
Note: In the dialog you can click the Toggle Selection button
to change between showing only the selection or showing the
selection and the rest of the image.
2 Select the feather position: Inside, Outside, or Both (the feather
amount is added to each side).
3 In the Feather amount edit box, enter the width in pixels of the
feathering.
4 Click OK.
To unfeather a selection:
1 Choose Selections > Modify > Unfeather.
2 Select the threshold value. The higher the value, the less
feathering.
3 Click OK.

Adding or Removing a Color from a
Selection
An alternative
To remove a color from a
selection, you can also use the
Paste As Transparent Selection
command to remove a color when
you paste a selection. However,
with this command you cannot
remove shades of a color, only the
exact color you specify. For more
information, see “Cutting,
Copying, and Pasting” on
page 124.

To add or remove a color from a selection, use the Select Color
Range command. You can choose to add or remove a color from the
selection border. The color that you choose is either added or
removed, and the selection border changes. If you copy and paste the
selection, the pasted area has the color added or removed.
To add or remove a color from a selection area:
1 Make a selection in the image.
2 Choose Selections > Modify > Select Color Range.
3 Select either the Add color range or Subtract color range option.
4 Move the cursor over the image and click a color. The Reference
color box, displays the selected color.You can also click this box
to open the Color dialog and choose a color. For more
information, see “Choosing Colors” on page 86.
5 In the Tolerance edit box, specify a color tolerance (0 to 200). If
the value is 0, no colors are added or removed from the selection
area. If you specify a higher value, shades of the color or related
colors are added or removed.
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6 In the Softness edit box, specify the amount of softness for the
referenced color.
7 Click OK. The selection borders change to add or exclude the
color you specified.

Cleaning Up the Edges of a Selection
Color depth
These commands work on 16
million color and greyscale images
only. To increase the color depth
of an image, see page 109.

When you move or copy a selection, some of the pixels surrounding
the border are included, especially when the selection is anti-aliased
or feathered. Matting cleans up the border by removing these pixels.
There are three Matting commands: Remove Black Matte, Remove
White Matte, and Defringe. Use the Remove Black Matte or Remove
White Matte command when the selection is from an image with a
black or white background. These commands remove the black or
white pixels at the selection edges.
Use the Defringe command when the selection is from an image with
a colored background. Defringing bleeds non-feathered pixels in the
selection edges outward and over the “jaggies” in the feathered part
of the selection.
To use a Matting command:
1 If the selection is not floating, choose Selections > Float.

Using matting on a layer
You can also use matting to clean
up the edges of a layer created
from a selection. The Layers menu
has the same Matting commands
as the Selections menu.
For more information, see
“Cleaning up the Edges of Layers
Created from Selections” on
page 282.

2 Do one of the following:


To remove the black matte, choose Layers > Matting >
Remove Black Matte.



To remove the white matte, choose Layers > Matting >
Remove White Matte.



To move a colored matte, choose Layers > Matting > Defringe.
The Defringe dialog opens. Enter the number of pixels to
defringe and click OK.
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Removing Specks and Holes from a
Selection
To remove holes and specks from a selection:
1 Choose Selections > Modify > Remove Specks and Holes to open
the Remove Specks and Holes dialog.
2 Do one of the following:

How specks and holes are
removed
The Remove Specks and Holes
dialog removes specks and holes
from the area that you define in
square pixels. For example: If you
have an area of specs and/or holes
in an image that is 20 pixels wide
by 20 pixels high, then in the
number of pixels field, enter 5 and
a scale factor of 100. Because 20 x
20 = 400, and 5 X 100 = 500 then
all specs and/or holes in a pixel
area less than 500 will be
removed.



Choose the Remove Specks option to remove only specks
from the selection.



Choose the Remove Holes option to remove only holes from
the selection.



Choose the Remove Specks and Holes option to remove both
specks and holes from the edges of the selection.
Note: In the dialog you can click the Toggle Selection button
to change between showing only the selection or showing
the selection and the rest of the image.

3 For the Square area smaller than, enter the number of pixels and
the scale factor. Start at low values, and increase them as
necessary until the specks and/or holes are removed.
4 Click OK. The holes and specks in the selection are removed.

Smoothing the Boundary of a Selection
Use the Smooth command to smooth the edges of a selection.
To smooth the boundary of a selection:
1 Choose Selections > Modify > Smooth to open the Smooth
Selection dialog.
2 For Smoothing amount enter a number for the level of smoothing
for the corners of the selection.
Note: In the dialog you can click the Toggle Selection button
to change between showing only the selection or showing the
selection and the rest of the image.
3 For Corner scale enter the number of pixels at the corners of the
selection to smooth.
4 Anti-alias mark this check box to smooth the edges of the
selection.
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5 Preserve Corners mark this check box if you want the corners
preserved. Clear this check box if you want the corners to be
smoothed.
6 Click OK. The corners of the selection are smoothed.

Recovering the Anti-alias
Use the Recover Anti-alias command when you want to restore the
original anti-aliasing of an object that was pasted into an image. This
command is useful if you made the selection without anti-aliasing,
and now want the edges of the selection to be smooth.
To recover the anti-alias:
1 Choose Selections > Modify > Recover Anti-alias to open the
Recover Anti-alias dialog. The selection with the anti-alias added
in the right preview window.
2 To apply the anti-alias to all layers of the selection, mark the
Sample merged check box.
3 To apply the anti-alias and copy the result to a new layer, mark
the Result on new layer check box.
4 Choose an Anti-alias option:


Inside to anti-alias the inside of the selection marquee.



Outside to anti-alias outside of the selection marquee.

5 Click OK to anti-alias the selection edges.

Shape-Based Anti-aliasing
Use the Shape-Based Anti-alias command to anti-alias a selection
based on its shape.
To anti-alias based on shape:
1 Choose Selections > Modify > Shape-Based Anti-alias to open the
Shape-based Anti-alias dialog.
2 Choose an Anti-alias option:


Inside to anti-alias the inside of the selection marquee.



Outside to anti-alias outside of the selection marquee.

3 Click OK to anti-alias the selection edges.
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Modifying the Select Selection Borders
Use the Select Selection Borders command to add a border around
the selection. This command is useful when you want to add a border
around the selection, and then fill that border using the Flood Fill
tool.
To change the shape-based anti-alias:
1 Choose Selections > Modify > Select Selection Borders to open
the Select Selection Borders dialog.
2 Choose whether you want to add a selection border Inside,
Outside, or on Both sides of the selection border.
3 Mark the Anti-alias check box if you want to smooth the edges of
the selection border.
4 Enter the width of the border in pixels.
5 Click OK to add a selection border.

Moving Selections within an Image
You can move a selection and leave the space empty or you can
move a copy of the selection and leave the original data.
To move a selection:
Do one of the following:


To move a selection by cutting it from a layer and leaving a
transparent area or area of background color, use the selection
tool (Selection, Freehand, or Magic Wand tool) to drag the
selection.



To move a copy of the selection while leaving the original
unchanged, float the selection before moving it or press Alt while
using the selection tool to drag the selection.



To move the selection one pixel at a time, press Shift while
pressing the up, down, left, or right arrow key.



To move the selection 10 pixels at a time, press Shift while
pressing the Page Up, Page Down, Home, or End keys.

When you move the selection with any of these methods, it becomes
a floating selection. For more information, see “Working with
Standard and Floating Selections” on page 165.
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Converting a Selection into a Layer
Color depth
The Promote to Layer command
works on 16 million color and
greyscale images only. To increase
the color depth of an image, see
page 109.

To convert a selection into a layer, use the Promote to Layer
command on the Selections menu. The original selection contents
are unchanged; a copy of the selection becomes a new layer. By
converting the selection into a layer, you can modify it without
changing the original image data.
To promote a selection to a layer:

Placing a selection in
another image
To place a selection as a layer
within another image, copy the
selection, open the other image,
and choose Edit > Paste > As New
Layer.

1 Make a selection in the image.
2 Choose Selections > Promote to Layer.
The new layer is placed above the original selection’s layer and
is named Promoted Selection.

Creating Custom Patterns from Selections
How to use the pattern
To use the pattern that you create,
save it in the Patterns folder of the
Paint Shop Pro program folder and
select it as your foreground or
background material. (See
“Choosing Patterns” on page 93.)
You can then use the pattern to
paint, create text, or fill an entire
image.

You can turn a selection into a custom, seamless pattern which you
can use for applications like painting, adding text, or creating Web
page backgrounds.
To create a custom pattern:
1 Make a selection in the image.
2 Choose Effects > Image Effects > Seamless Tiling to open the
Seamless Tiling dialog.
3 Choose the tiling method, direction, settings, and corner style,
and then click OK.
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Saving and Loading Selections
It’s helpful to save complicated selections that you may use again or
to save selections to use in other images to create effects. Save a
selection in one of two ways:


Save the selection as a file with a .PspSelection extension on a
hard disk or removable disk; see “Saving Selections to Disk” on
page 176. To load this selection file into Paint Shop Pro, see
“Loading Selections from Disk” on page 177.



Save the selection as an alpha channel within the image. The
selection is stored as part of the image, not as a separate file. See
“Saving Selections to Alpha Channels” on page 177. To load the
selection into the same or a different image, see “Loading
Selections from Alpha Channels” on page 178.

Saving Selections to Disk
When you save a selection to a hard disk or a removable disk, Paint
Shop Pro saves the selection as a separate file with a .PspSelection
extension. You can then load this selection into the current image or
another image.
To save a selection file:
1 Make a selection in the image.
2 Choose Selections > Load/Save Selection > Save Selection to
Disk to open the Save Selection to Disk dialog.
The Selection files group box shows selections files in the
default directory for selections. To change the default directory,
or to add another directory, click the Edit Paths button.
3 In the File name edit box, type a name for the selection.
4 Click Save.
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Loading Selections from Disk
Load a selection (with a .PspSelection extension) or image file that
you have saved to a hard disk or removable disk. When you load an
image, Paint Shop Pro creates a selection based on luminance, nonblack pixels, or opacity.
To load a file or selection from disk:
1 Choose Selections > Load/Save Selections > Load Selection from
Disk to open the Load Selection from Disk dialog.
The Selection Files group box shows selections files in the
default directory for selections. To change the default directory,
click the Edit Paths button.
2 Choose the selection or image file you want to load.
Another way to create
greyscale images
You can open .PspMask and
.PspSelection files in Paint Shop
Pro, edit them and save them with
another file extension (.PspImage,
.jpeg, .gif, etc.).

3 In the Operation group box, select an option to determine
whether to replace the selection or add to or subtract from it.
4 In the Create selection from group box, choose what
Paint Shop Pro creates the selection from.
5 Click Load. The selection displays on the current layer.

Saving Selections to Alpha Channels
Save a selection to an alpha channel within the current image or
within another image. An alpha channel is a data storage area in an
image that holds selections and masks. Alpha channels are like
secret compartments within a suitcase—use them to store things you
may need later. Selections and masks stored in alpha channels have
no effect on the look of an image. To use the stored selections or
masks, load them into the same image or another image.
When you save the image to a file format other than .PspImage
format, the alpha channels are not saved. Always keep a master copy
of your image in .PspImage format.
To save a selection to an alpha channel:
1 Make a selection in the image.
2 Choose Selections > Load/Save Selections > Save Selection to
Alpha Channel to open the Save Selection to Alpha Channel
dialog.
The Add to document drop-down list displays the image name
and below it are the alpha channels in the image (if any).
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3 To save a selection to another image’s alpha channel, select the
image name in the Add to document drop-down list. The image
must be open in Paint Shop Pro.
4 To edit the default name for the new alpha channel, type a new
name in the Name edit box.
5 To move the selection to the upper left corner of the image
canvas, mark the Move to upper left of canvas check box. This
option is helpful when the selection is larger than the current
image and may not otherwise show up on the image.
6 Click Save. The selection is saved to the alpha channel.

Loading Selections from
Alpha Channels
When you save a selection as an alpha channel within a .PspImage
image, you can load that selection from the alpha channel into the
same image or into any other image.
To load a selection from an alpha channel:
1 Choose Selections > Load/Save Selection > Load Selection from
Alpha Channel to open the Load Selection from Alpha dialog.
Note: In the Preview group box, click the Transparency button to
show the area around the selection as either transparent or
black
.
2 In the Load from Document drop-down list, select the image that
contains the alpha channel you want to load. To load from
another image’s alpha channel, the image must be open in Paint
Shop Pro.
3 In the drop-down list below the document name, choose the alpha
channel that contains the selection you want to load.
4 In the Operation group box, choose whether the selection you
load replaces, adds to, or subtracts from the active selection in
the image (if there is one).
5 A message in the Operations group box indicates how the
original alpha channel rectangle (which is the saved selection)
intersects the canvas of the current image: completely intersects,
does not completely intersect (part of the selection is off the
canvas), or does not intersect at all. If it partially intersects or
does not intersect, mark the Move to Upper Left of Canvas check
box to move the selection onto the image canvas.
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6 In the Options group box, choose from these options:


Mark the Move to upper left of canvas check box to place the
loaded selection in the upper left. If the check box is cleared,
the selection remains in the same position it was on the
original image.



Mark the Clip to canvas check box to clip the selection at the
places where it goes beyond the image canvas.



Mark the Invert image check box to select everything outside
the original selection.

7 Click the Load button. The selection displays on the current
layer.

Deleting Selections from
Alpha Channels
If you saved selections to alpha channels that you no longer need,
you can delete them. You can delete alpha channels from the current
image only.
To delete an alpha channel:
1 Choose Image > Delete Alpha Channel to open the Delete Alpha
Channel dialog.
2 Select the alpha channel that you want to delete, or mark the
Delete all alpha channels check box.
3 Click Delete.
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Making Color and Tonal Corrections
Paint Shop Pro provides advanced and flexible commands that aid in
color corrections and create dramatic effects.
Start your corrections with Paint Shop Pro’s automatic commands
and then use the advanced correction commands if your images still
need adjusting. For an introduction to color and tonal corrections,
see “How to Approach Color, Contrast, and Saturation Adjustments”
on page 53. For an overview of steps that help you improve your
photographs, see “Basic Steps in Improving Photographs” on
page 52.
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Key Points to Know Before Making Corrections
All the Paint Shop Pro correction command dialogs have common
ways of adjusting color and lightness. Keep the following key things
in mind:


Lightness levels are specified in a scale from zero (no light,
black) to 255 (100% light, white).



Image files store their color information in channels, or planes,
of color. A color channel specifies the amount of a certain color
in each pixel of the image. Many correction dialogs let you to
edit the red, green and blue channels. The histogram also
displays the hue, saturation, lightness, and greyscale channels.
Colors are specified on a scale from zero (no color) to 255 (100%
of the color).



Hue settings are displayed on a color wheel or they use values
that represent positions on the color wheel. For a visual
representation, look at the Jasc Color Picker. Although actual hue
values range from 0 to 255, some correction dialogs use degrees
to represent hues on the color wheel (from 0 to 359 degrees
counter-clockwise starting at the top).



When you first open a correction dialog, reset the settings by
choosing Default in the Presets drop-down list. Otherwise, the
dialog uses the settings from the previous correction.



If there’s an adjustment layer available for a correction
command, use it. That way the original pixels are left unchanged.
If you change your mind or want to revise the correction, it’s
much easier when you use an adjustment layer. See, “Using
Adjustment Layers” on page 283



Depending upon the color depth of your image, some correction
commands may not be available. It’s always best to work with
images of 16 million (24-bit) colors. If needed, you can reduce
the color depth when you finish editing the image. For more
information, see “How Corrections Relate to Color Depth” on
page 183.
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How Corrections Relate to Color Depth
The following table shows you which correction commands and
adjustment layers are available for images of different color depths
and which color depths can apply commands to selections.

Color
Depth

Commands that Apply to
Entire Layer or Image

Commands available
for Selections

Available
Adjustment
Layers

2 color (1-bit)

Greyscale, Negative Image

None

None

16 color (4-bit)

Greyscale, Posterize, Solarize, and
Sepia, plus all commands in the
Adjust menu

None

None

256 color (8-bit)

Same as 16 color (4-bit), plus the
Equalize and Stretch Histogram
commands

None

None

Greyscale (8-bit)

All commands that correct
brightness or contrast

The same commands
that work on the layer or
image

Brightness/Contrast,
Curves, Invert,
Levels, Posterize,
Threshold

16 million, 32K,
or 64K color
(24-bit)

All correction commands

All correction commands

All adjustment
layers
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Adjusting the Color Balance
In technical terms, color balance refers to the balance of red, green,
and blue in your images. In common usage, balancing colors means
creating natural looking images without a color cast (an overall
imbalance of colors in an image). Use Paint Shop Pro to correct
color balance and also to change the balance to create dramatic
effects.

Changing the Overall Color Balance
Color depth
To apply this command to a
selection, the image must be a
16 million (24-bit) color image
(otherwise the command is applied
to the entire image).
To increase the color depth of an
image, see page 109.

Use the Red/Green/Blue command to adjust the amount of red,
green, and blue in your image and to make color corrections by
changing the overall color cast. To reduce the amount of a color in
the image, you can either increase its opposite color on the color
wheel or reduce the amount of adjacent colors on the color wheel.
For example, to color correct an image containing too much yellow,
either increase the amount of blue or decrease the amount of red and
green.
To use the Red/Green/Blue command:
1 To limit the correction to a specific area, make a selection in the
image. See “Using the Selection Tools” on page 154.
2 Choose Adjust > Color Balance > Red/Green/Blue.

The automatic alternative
For a quick and easy way to
balance colors, use the Automatic
Color Balance command. See
“Automatically Balancing Colors”
on page 54.

3 In the Red, Green, and Blue edit boxes, select the percentage to
change each value. A value of 0% indicates the original value. To
add more of a color, use a positive number. To remove some of a
color, use a negative number. Keep in mind the following:


Reducing the amount of blue adds a yellow cast to the image.



Reducing the amount of green adds a magenta cast to the
image.



Reducing the amount of red adds a cyan cast to the image.

4 Click OK.
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Changing the Color Balance of
Shadows, Midtones, and Highlights
Color depth
To apply this command to a
selection, the image must be a
16 million (24-bit) color image
(otherwise the command is applied
to the entire image).
In addition, adjustment layers are
available for 16 million (24-bit)
color images only.
To increase the color depth of an
image, see page 109.

Use the Color Balance command to change the balance of colors in
an image. This command provides general color correction and
allows you to adjust the color balance in shadows, midtones, and
highlights.
To use the Color Balance command:
1 To limit the correction to a specific area, make a selection in the
image. See “Using the Selection Tools” on page 154.
2 Do one of the following:


To modify the image pixels directly, choose Adjust >
Color Balance > Color Balance.



To create an adjustment layer, choose Layers >
New Adjustment Layer > Color Balance. For information on
adjustment layers, see “Using Adjustment Layers” on
page 283.

3 To reset the settings, in the Presets drop-down list, select
Default.
4 In the Tone balance group box, select which lightness level
(tonal range) of colors to adjust: Shadows (dark colors),
Midtones (colors in the middle range), and Highlights (bright
colors). Adjust each one individually.
5 To have the corrected image match the lightness of the original
image, mark the Preserve luminosity check box.
6 In the Color balance group box, drag a slider toward a color to
increase that color in the image or drag a slider away from a
color to decrease the color. Increasing the proportion of one color
decreases the proportion of its opposite on the color wheel.
The values in the Color levels edit boxes show the color changes
for the red, green, and blue channels. Values range from -100 to
100. Zero indicates the original color balance.
7 Click OK.
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Adjusting the Hue, Saturation, and
Lightness in Unison
Color depth
To apply this command to a
selection, the image must be a
16 million (24-bit) color image
(otherwise the command is applied
to the entire image).
In addition, adjustment layers are
available for 16 million (24-bit)
color images only.
To increase the color depth of an
image, see page 109.

Use the Hue/Saturation/Lightness command to shift all colors in an
image and change their strength and lightness. Here’s how the
command works:


Changing the hue shifts all pixels in an image around the color
wheel to a different point. For example, if you change the red
pixels to green, the green pixels turn to blue and the yellow
pixels turn to cyan.



Changing the saturation adjusts the amount of grey in a color.
The level of grey increases as the saturation decreases.



Changing the lightness adjusts the color’s brightness.

To use the Hue/Saturation/Lightness command:
Creating a duotone
You can use the Hue/Saturation/
Lightness command or the Colorize
command to create a duotone
image (a greyscale image with one
color added).
For more information on duotones,
see “Colorizing Images” on
page 197.

1 To limit the correction to a specific area, make a selection in the
image. See “Using the Selection Tools” on page 154.
2 Do one of the following:


To modify the image pixels directly, choose Adjust >Hue
and Saturation > Hue/Saturation/Lightness.



To create an adjustment layer, choose Layers > New
Adjustment Layer > Hue/Saturation/Lightness. For
information on adjustment layers, see “Using Adjustment
Layers” on page 283.

3 In the Edit drop-down list, choose the color range to adjust. To
edit all colors simultaneously, choose Master. To edit a specific
color range, choose Reds, Yellows, Greens, Cyans, Blues, or
Magentas.
The color rings represent the colors in the image. The outer ring
represents the original values and the inner ring represents the
adjusted values. If you choose a specific color range to edit, a
control ring is added between the inner and outer rings where you
can change the color range that you adjust.
4 To turn the image into a duotone (two-color) image, mark the
Colorize check box. The image turns into a greyscale image (if
you have previews or proofing on). You can now select a hue and
adjust the saturation and lightness values to colorize the image.
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5 If you are editing a specific color range (rather than the Master
mode), you can change the color range that you adjust using the
control ring:


To set the range width, drag the two outer points on the
control ring, which mark the beginning and end of the
adjustment area.



To change where the adjustment builds to full effect, drag the
two inner bars. In the area between the two inner bars, the
adjustment is in full effect.



To move the adjustment area, drag the white circle.

6 To change the hue, drag the Hue slider until the colors appear as
you want them. You can also type a value in the Hue edit box.
The hue value is not on the typical hue scale of 0 to 255. Instead,
the value is the number of degrees of rotation around the 360
degree color wheel from the pixel’s original color. A positive
values indicates a clock-wise rotation and a negative value
indicates a counter-clockwise rotation. For example, when the
Hue value is at 180, blue becomes yellow and green becomes
magenta.
7 Drag the Saturation slider up to increase the saturation or drag it
down to decrease the saturation. Values can range from -100 to
100; at zero the saturation is unchanged.
8 Drag the Lightness slider up to increase the lightness or drag it
down to decrease the lightness. Values can range from -100 to
100; at zero the lightness is unchanged.
9 Click OK.
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Correcting Colors by Setting Black and
White Points
Color depth
To apply this command to a
selection, the image must be a
16 million (24-bit) color image
(otherwise the command is applied
to the entire image).
To increase the color depth of an
image, see page 109.

If an image has a color cast, an effective way to correct it is to select
those points that you know are supposed to be black or white and
shift all colors based on resetting these points to true black and true
white. You can do this with the Black and White Points command.
You can also define the grey point too. After you select the points,
all colors are shifted.
To use the Black and White Points command:
1 To limit the correction to a specific area, make a selection in the
image. See “Using the Selection Tools” on page 154.
2 Choose Adjust > Color Balance > Black and White Points.
3 In the right preview window, center the area with the source
points (the points that should be black, white, or grey). Pan the
image by clicking and dragging in the preview window; zoom in
or out as necessary.
Note: You must use the right preview window for panning the
image because you select the source colors in the left preview
window.
4 To use a greyscale palette to select all destination colors, mark
the Balance to grey check box. If this check box is cleared, you
can select any color for the destination points.
5 For each point that you want to correct, do the following:


Select the source point: click the color’s dropper button ,
then click a color in the left preview window that is supposed
to be the color you are correcting (black, grey, or white).



If you want, change the default color: for the Desired color
boxes, click the appropriate Color box (black, grey, or white)
and select a color from a black-and-white color palette.
Note: To select a destination color from the image window or
the desktop, position the cursor over any destination color
box, press and hold the Ctrl key, move the cursor over the
image or the desktop, and click a color.

6 To preserve the lightness of the source color, mark the Preserve
lightness check box. If this check box is cleared, the lightness of
the corrected image matches the target color’s lightness instead.
7 Click OK.
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Adjusting the Color Channels
Color depth
To apply this command to a
selection, the image must be a
16 million (24-bit) color image
(otherwise the command is applied
to the entire image).
In addition, adjustment layers are
available for 16 million (24-bit)
color images only.
To increase the color depth of an
image, see page 109.

Use the Channel Mixer command to increase or decrease the red,
blue, or green color channel by a percentage of itself and the other
two channels. Use this command when you want to adjust color
channels individually.
To use the Channel Mixer command:
1 To limit the correction to a specific area, make a selection in the
image. See “Using the Selection Tools” on page 154.
2 Do one of the following:


To modify the image pixels directly, choose Adjust >
Brightness and Contrast > Channel Mixer.



To create an adjustment layer, choose Layers >
New Adjustment Layer > Channel Mixer. For information on
adjustment layers, see “Using Adjustment Layers” on
page 283.

3 Do one of the following:


To maintain a color image, in the Output channel drop-down
list, select a color channel to edit: Red, Green, or Blue.



To change the image to a monochrome (which looks like a
greyscale but has a color depth of 16 million colors), mark the
Monochrome check box. The Channel drop-down list displays
Grey. When you adjust the color channels in the next step, you
change the amount of each channel that is used to create the
monochrome image.

4 In the Source channels group box, use the Red, Green, and Blue
edit boxes or sliders to change the current percentage of that
color in the channel you are editing. For example, if you are
editing the Red channel and set the Red value to 50%, you reduce
the amount of red in the image to 50% of its original amount.
5 To brighten the color channel, drag the Constant slider to the
right. To darken the color channel, drag the slider to the left. The
default of zero is the original setting.
6 Click OK.

189

190

Chapter 8: Making Color and Tonal Corrections

Adjusting Brightness and Contrast
Automatic adjustment
Choose Adjust > Brightness and
Contrast > Automatic Contrast
Enhancement to adjust the
contrast with several easy-to-use
options.

There are numerous methods for correcting the brightness and
contrast of an image.


Analyze the image with the histogram and then use the histogram
commands to adjust the image.



Use the Brightness/Contrast command to adjust the brightness or
contrast individually.



Use the Curves command to change the brightness values of
individual pixels.



Use the Gamma Correction command to change the image’s
gamma, which adjusts the brightness and contrast in unison.



Adjust the brightness of highlights, midtones, and shadows to
improve contrast and bring out detail in light or dark areas.



Use the Levels command to adjust the lightness of the image.

Using the Histogram to Fix Contrast
Problems
Creative ideas for
equalizing
In some cases the effect of
equalizing the histogram of an
image may be too strong. You may
get better results when you blend
the original image with the
equalized version. Copy and paste
the original as a new layer, then
equalize the copied layer and use
the layer opacity options to blend
the two layers together.
For more information on the
opacity options, see “Changing
Opacity of Layers” on page 274.

In Paint Shop Pro there are three main ways to use the histogram to
fix contrast problems:


Use the Histogram Adjustment command to edit the luminosity
(or lightness) channel. See “Correcting Images by Adjusting the
Histogram” on page 204.



Use the Equalize command to average image brightness by
distributing the lightness values of pixels more evenly across the
lightness spectrum from black to white. This command makes
the darkest pixel as close to black as possible and the lightest
pixel as close to white as possible, and then distributes the
remaining pixels evenly between these two values.



Use the Stretch command to increase contrast. If an image’s
histogram does not cover the entire lightness spectrum, the image
does not contain very dark or very light areas and so it lacks
contrast. The Stretch command stretches the graph closer to both
ends so that it covers more of the spectrum. (You can also do this
manually with the Histogram Adjustment command.)
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To use the Equalize command:
Make your own adjustment
layer!
Although there are no adjustment
layers for the Equalize and Stretch
commands, you can still apply the
commands without changing the
original image pixels. Make a copy
of the layer to which you are
applying the commands and paste
it as a new layer. Apply the
commands to the copied layer,
and on the Layer palette turn off
the visibility of the original layer.
You can use this trick with all
Paint Shop Pro correction
commands that don’t have an
adjustment layer.

Color depth
To apply this command to a
selection, the image must be a
16 million (24-bit) color image
(otherwise the command is applied
to the entire image).
In addition, adjustment layers are
available for 16 million (24-bit)
color or greyscale images only.
To increase the color depth of an
image, see page 109.

Using automatic corrections
To adjust the contrast with several
easy-to-use options (such as
choosing an appearance that is
flat, natural, or bold), use the
Automatic Contrast Enhancement
command. See “Automatically
Enhancing Contrast” on page 60.

1 To limit the adjustment to a specific area, make a selection in the
image. See “Using the Selection Tools” on page 154.
2 Choose Adjust > Brightness and Contrast > Equalize. The image
updates in the image window.
To use the Stretch command:
1 To limit the adjustment to a specific area, make a selection in the
image.
2 Choose Adjust > Brightness and Contrast > Stretch. The image
updates in the image window.

Manually Adjusting Brightness and
Contrast
You can manually adjust the brightness and contrast of an image
using the Brightness/Contrast command. This is one of the simplest
of the lightness correction commands.
To adjust contrast and brightness manually:
1 To limit the adjustment to a specific area, make a selection in the
image. See “Using the Selection Tools” on page 154.
2 Do one of the following:


To modify the image pixels directly, choose Adjust >
Brightness and Contrast > Brightness/Contrast.



To create an adjustment layer, choose Layers >
New Adjustment Layer > Brightness/Contrast. For
information on adjustment layers, see “Using Adjustment
Layers” on page 283.

3 In the Brightness edit box, select a negative number to darken
the image or select a positive number to lighten image. A value
of zero indicates no change.
4 In the Contrast edit box, select a positive number to increase the
contrast or select a negative number to decrease the contrast. A
value of zero indicates no change.
5 Click OK.
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Adjusting Individual Brightness Values
Color depth
To apply this command to a
selection, the image must be a
16 million (24-bit) color image
(otherwise the command is applied
to the entire image).
In addition, adjustment layers are
available for 16 million (24-bit)
color or greyscale images only.
To increase the color depth of an
image, see page 109.

Use the Curves command to adjust the individual brightness values
of your image. You can change any brightness value on the 0–255
scale. For example, you can change all pixels that have a brightness
value of 128 to a value of 150. The Curves command gives you
enormous flexibility in changing the brightness of your image.
To use the Curves command:
1 To limit the adjustment to a specific area, make a selection in the
image. See “Using the Selection Tools” on page 154.
2 Do one of the following:


To modify the image pixels directly, choose Adjust >
Brightness and Contrast > Curves.



To create an adjustment layer, choose Layers >
New Adjustment Layer > Curves. For information on
adjustment layers, see “Using Adjustment Layers” on
page 283.

3 To reset the settings, in the Presets drop-down list choose
Default.
4 In the Channel drop-down list, select a color channel to edit.
Choose RGB to edit the red, green, and blue channels together.
Choose Red, Green, or Blue to edit the individual color channels.
5 Use the points on the graph to adjust the relationship between the
input levels (the brightness of the original pixels) and output
levels (the brightness of corrected pixels). At the lower left of the
chart, both values are zero (black). At the upper right, both
values are 255 (white).


To add a point to the graph, move the cursor over the dotted
red line until the cursor changes to an arrowhead and displays
“+ADD,” then click the line.



To move the line, drag a point or enter values in the Input or
Output edit box.



To remove a point, drag it off the graph.

6 Click OK.
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Adjusting the Brightness and Contrast
in Unison
Color depth
To apply this command to a
selection, the image must be a
16 million (24-bit) color image
(otherwise the command is applied
to the entire image).
To increase the color depth of an
image, see page 109.

Use the Gamma Correction command to adjust the brightness and
contrast of an image in unison. The gamma of an image is a standard
measure of its contrast and brightness.
The gamma curve has three components: the red, green, and blue of
the image. In addition to adjusting the brightness and contrast of the
image, with the Gamma Correction command you can adjust the
color balance of an image by unlinking the three components and
changing them separately. For example, if the image has a red cast to
it, you can reduce its red value.
To use the Gamma Correction command:
1 To limit the adjustment to a specific area, make a selection in the
image. See “Using the Selection Tools” on page 154.
2 Choose Adjust > Brightness and Contrast > Gamma Correction.
In the Gamma Correction dialog, the graph shows the gamma
curves for the three colors. If the three colors have the same
gamma value, there is one white line representing the three
colors. If the gammas are different values, there is a line for each
color.
The left side of the graph represents the shadows of the image;
the right side represents the highlights.
3 Do one of the following:


To adjust the brightness and contrast in unison, mark the Link
check box.



To change the color balance of the image rather than the
brightness and contrast, clear the Link check box.

4 For the Red, Green, and Blue values, drag the sliders or type new
numbers in the edit boxes. A value of 1 indicates the original
gamma. If colors are linked, increasing the value lightens the
image and decreasing the value darkens the image. If colors are
not linked, increasing or decreasing a individual color value
increases or decreases the amount of that color in the image.
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5 Click OK.
Note: The Gamma Correction command can result in an image
looking somewhat flat; you may want to increase the contrast
after correcting the gamma. See “Improving Contrast” on
page 60.

Adjusting the Brightness of Highlights,
Midtones, and Shadows
Color depth
To apply this command to a
selection, the image must be a
16 million (24-bit) color image
(otherwise the command is applied
to the entire image).
To increase the color depth of an
image, see page 109.

Use the Highlight/Midtone/Shadow command to separately adjust
the light, middle, and dark values (the tonal values) of a photograph.
To use the Highlight/Midtone/Shadow command:
1 To limit the adjustment to a specific area, make a selection in the
image. See “Using the Selection Tools” on page 154.
2 Choose Adjust > Brightness and Contrast > Highlight/Midtone/
Shadow.
3 To adjust values in relation to each other, select:
Linear adjustment method Each value ranges from 0 to 100 and
defaults are 0 for Shadow, 50 for Midtone, and 100 for Highlight.
Dynamic adjustment method Each value ranges from -100 to 100
and zero represents no change for that value.
4 Adjust these tonal values:
Shadow Removes lightness from the image. Increasing the value
darkens lighter pixels.
Midtone Changes the middle portion of the light scale. Increase
the value to darken middle values or decrease the value to lighten
middle values.
Highlight Adds lightness to the image. Decreasing the value
lightens darker pixels.
5 Click OK.
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Adjusting the Lightness Levels
Color depth
To apply this command to a
selection, the image must be a
16 million (24-bit) color image
(otherwise the command is applied
to the entire image).
In addition, adjustment layers are
available for 16 million (24-bit)
color or greyscale images only.
To increase the color depth of an
image, see page 109.

Use the Levels command to make adjustments to the brightness,
contrast, and gamma in the image. Adjusting the gamma changes the
brightness values of middle grey tones.
To use the Levels command:
1 To limit the correction to a specific area, make a selection in the
image. See “Using the Selection Tools” on page 154.
2 Do one of the following:


To modify the image pixels directly, choose Adjust >
Brightness and Contrast > Levels.



To create a Levels adjustment layer, choose Layers >
New Adjustment Layer > Levels. For information on
adjustment layers, see “Using Adjustment Layers” on
page 283.

3 In the Channel drop-down list, select a color channel to edit.
Choose RGB to edit the red, green, and blue channels together.
Choose Red, Green, or Blue to edit the individual color channels.
4 To increase the contrast of the image, drag the Input levels
sliders, which show the image’s brightness values. To darken the
darkest values, drag the black diamond to the right; all values
below this value become zero (black). To lighten the lightest
values, drag the clear diamond to the left; all values above this
value become 255 (white). To change the value of medium grey,
drag the grey Gamma diamond left or right; the range for of the
gamma value is 0 to 7.99, with 1 being in the middle.
5 To decrease the contrast, drag the Output levels sliders. To
lighten the darkest pixels, drag the black diamond to the right. To
darken the lightest pixels, drag the clear diamond to the left.
6 Click OK.
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Replacing Colors
Changing Individual Colors
Color depth
To apply this command to a
selection, the image must be a
16 million (24-bit) color image
(otherwise the command is applied
to the entire image).
To increase the color depth of an
image, see page 109.

Use the Hue Map command to replace one or more colors
throughout a photograph or other complex image. For example, you
can shift all greens to blues.
You can also use the Hue Map command to change the saturation or
the lightness of the image. When you adjust these values, all colors
(original and shifted colors) are adjusted.
To use the Hue Map command:
1 To limit the correction to a specific area, make a selection in the
image. See “Using the Selection Tools” on page 154.
2 Choose Adjust > Hue and Saturation > Hue Map.
The Hue Map dialog opens. In the Hue shift group box, the top
row of color boxes shows 10 original colors and the bottom row
of color boxes represents the shifted colors. Each color is
represented in degrees around the 360-degree color wheel.
3 To reset the colors to their default settings (which is no shift in
colors), in the Presets drop-down list choose Default.
4 For each color that you want to shift, drag its slider to a new
color.
5 To change the saturation of all colors, adjust the Saturation shift
value (from -100 to 100). A value of zero represents no change.
6 To change the lightness of all colors, adjust the Lightness shift
value (from -100 to 100). A value of zero represents no change.
7 Click OK.
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Colorizing Images
Color depth
To apply this command to a
selection, the image must be a
16 million (24-bit) color image
(otherwise the command is applied
to the entire image).
To increase the color depth of an
image, see page 109.

Use the Colorize command to replace all colors in a selection or an
image with a single color and saturation while leaving the lightness
values unchanged. You can use this command to create sepia tones
(the brown seen in old photographs) and other single-color effects.
Note
The Colorize command creates an image that looks like a duotone
(two-color) image. To create a duotone with more subtle color
changes, apply the Greyscale command, increase the color depth to
16 million (24-bit) colors, then apply the Colorize command.
To colorize an image:
1 To limit the correction to a specific area, make a selection in the
image. See “Using the Selection Tools” on page 154.
2 Choose Adjust > Hue and Saturation > Colorize.
3 To colorize the image, modify the following settings:
Hue The hue that all current colors are changed to. Click the
slider button and drag the slider to select the color visually.
Saturation The saturation of the selected hue. Click the slider
button and drag the slider to select the saturation visually.
4 Click OK.
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Reducing or Removing Colors
In Paint Shop Pro you can reduce or remove colors in several ways.
You can create black-and-white, greyscale, duotone (two-color),
colorized, and sepia images. You can also create a negative image or
create a positive image from a photographic negative.

Creating Black-and-White Images
Color depth
To apply this command to a
selection, the image must be a
16 million (24-bit) color image
(otherwise the command is applied
to the entire image).
In addition, adjustment layers are
available for 16 million (24-bit)
color or greyscale images only.
To increase the color depth of an
image, see page 109.

To create a black-and-white image, use the Threshold command.
Select the threshold lightness value—below which all pixels are
changed to black and above which all pixels are changed to white.
This command does not change the color depth of the image.
Note
The Threshold command creates an image with pixels of two colors:
black or white. To create a “black-and-white” photograph, which is
really made up of many shades of grey, see “Creating Greyscale
Images” on page 199.
To use the Threshold command:
1 To limit the correction to a specific area, make a selection in the
image. See “Using the Selection Tools” on page 154.
2 Do one of the following:

Another way to create a
black-and-white image
You can also decrease an image’s
color depth to 2 colors, which gives
you options for how colors are
reduced that may result in more
natural-looking images than the
Threshold command. For more
information, see “Decreasing Color
Depth to 2 Colors (1-bit)” on
page 111.



To modify the image pixels directly, choose Adjust >
Brightness and Contrast > Threshold.



To create an adjustment layer, choose Layers >
New Adjustment Layer > Threshold. For information on
adjustment layers, see “Using Adjustment Layers” on
page 283.

3 Click the Zoom out button until you can see the entire image in
the preview windows.
4 In the Threshold edit box, select a pixel lightness value that
determines which pixels change to white (those above the
threshold) and which pixels change to black (those below the
threshold). The value ranges from 1 to 255. Adjust the threshold
until the image in the preview window is satisfactory.
5 Click OK.
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Creating Greyscale Images
A greyscale look-alike
There’s another way to create an
image that looks like a greyscale
but maintains its same color depth:
Use the Channel Mixer command
and mark the Monochrome check
box. With this command you can
modify how much of the image’s
red, green, and blue channels are
used to create the monochrome
image. For more information, see
“Adjusting the Color Channels” on
page 189.

A greyscale image looks like a traditional black-and-white
photograph. Use the Greyscale command to convert a colored image
into a greyscale image with a palette that contains white, black, and
254 shades of grey. Each color in the image is replaced with a grey
that matches its lightness value.
The Greyscale command changes the color depth of the image to 8bit.
To create a greyscale image:
Choose Image > Grey Scale.

Creating Sepia Tone Images
Sepia tones are the browns of old black-and-white photographs and
newsprint. You can give your photographs and graphics this
19th Century look by turning them into sepia-tone images. In Paint
Shop Pro you have two ways to do this:


Apply the Sepia Tone effect to the image. You select the number
of years to age the image. See “Applying Artistic Effects” on
page 318.



Use the Colorize command and choose a brown hue. For more
information, see “Colorizing Images” on page 197.

Reducing the Number of Lightness
Levels
Color depth
To apply this command to a
selection, the image must be a
16 million (24-bit) color image
(otherwise the command is applied
to the entire image).
In addition, adjustment layers are
available for 16 million (24-bit)
color or greyscale images only.
To increase the color depth of an
image, see page 109.

Use the Posterize command to reduce the number of lightness levels
in the image and create interesting effects. With this command,
Paint Shop Pro divides the range of lightness levels (from 2 to 255)
into a number of equal increments that you specify. As you lower the
number, you increase the effect.
To use the Posterize command:
1 To limit the correction to a specific area, make a selection in the
image. See “Using the Selection Tools” on page 154.
2 Do one of the following:


To modify the image pixels directly, choose Effects > Artistic
Effects > Posterize.
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To create a Posterize adjustment layer, choose Layers >
New Adjustment Layer > Posterize. For information on
adjustment layers, see “Using Adjustment Layers” on
page 283.

3 In the Level edit box, select the number of lightness levels (2 to
255) for the adjusted image. To create a dramatic effect, the
number of levels typically must be below 10.
4 Click OK.

Creating Negative Images
Color depth
To apply this command to a
selection, the image must be a
16 million (24-bit) color image
(otherwise the command is applied
to the entire image).
In addition, adjustment layers are
available for 16 million (24-bit)
color or greyscale images only.
To increase the color depth of an
image, see page 109.

In Paint Shop Pro there are three ways to create a negative image
(which looks like a photographic negative):


Use the Negative Image command to replace each pixel color
with its opposite on the color wheel. You can also use the
Negative Image command to create a positive image from a
scanned photographic negative.



Use an Invert adjustment layer to create an adjustment layer that
has the same effect as the Negative Image command but doesn’t
change the original image pixels.



Use the Solarize command to produce a negative image in which
you control the threshold level. This level is the lightness value
above which all colors are inverted. Use this command to create
interesting effects.

You can create a negative of a selection or an entire image.
To use the Negative Image command:
Choose Adjust > Negative Image.
To use an Invert adjustment layer:
1 Choose Layers > New Adjustment Layer > Invert.
2 Choose the layer properties. There are no additional settings for
this adjustment layer. For information on adjustment layers, see
“Using Adjustment Layers” on page 283.
3 Click OK.
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To use the Solarize command:
1 Choose Effects > Artistic Effects > Solarize.
2 In the Threshold edit box, select a lightness threshold (1 to 254)
above which all colors are inverted. At a threshold of 1, all image
pixels are inverted and the effect is the same as applying the
Negative Image command.
3 Click OK.

Using the Histogram to Analyze Images
Do I need the histogram?
For image editing professionals,
the histogram is a powerful tool for
understanding and correcting
images.
For casual users, getting familiar
with the histogram may not be
necessary. Paint Shop Pro offers
many simpler ways to adjust
images. For information on how to
begin correcting your photos, see
“How to Approach Color, Contrast,
and Saturation Adjustments” on
page 53.

The histogram displays a graph of the distribution of red, green,
blue, greyscale, hue, saturation, and lightness values in an image.
You can analyze the distribution of detail in the shadows (shown in
the left part of the histogram), in the midtones (shown in the
middle), and the highlights (shown in the right part) and decide how
to make corrections.
After you analyze the histogram, you can correct the image with
Paint Shop Pro’s color and contrast correction commands or you can
use commands that adjust your image based on its histogram
features: Equalize, Histogram Adjustment, and Stretch.
To display the histogram for an image:
1 To limit the histogram data to a specific area, make a selection in
the image. See “Using the Selection Tools” on page 154.
2 Choose View > Palettes > Histogram or press F7.

The graph represents how many pixels are at each value of the
selected channels. The vertical axis represents the number of
pixels and ranges from zero pixels to the highest number of
pixels in the graph. The horizontal axis represents the value from
zero to 255 of a selected channel: Red, Green, Blue, Greyscale,
Hue, Saturation, and Lightness.
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For detailed information on the graph, see “Understanding
Histogram Values” on page 203 and “Guidelines for Analyzing
the Histogram” on page 203.
3 Mark or clear the check boxes below the graph to display or hide
the values for the channels.
4 Choose the image data that is graphed:
Sample merged If this check box is marked, the histogram graphs
all layers in the image. If this check box is cleared, the histogram
graphs only the current layer.
Selection only If this check box is marked, the histogram graphs
only the active selection. If the check box is cleared, the
histogram graphs the entire layer or image.
5 Do one of the following:


To view information about a specific value, place the cursor at
that point on the histogram.



To select a range of values, click and drag in the graph. When
you release the mouse, the range is deselected.

These fields show information about the selected point or range:
Value(s) The value or range of values (from 0 to 255) of the point
over which the cursor is positioned in the graph.
% in Range The percent of image pixels that are the value(s) of
the selected point or range. The number in parentheses is the
number of pixels that are the selected value(s).
% Above The percent of image pixels that are above the value(s)
of the selected point or range.
% Below The percent of image pixels that are below the value(s)
of the selected point or range.
6 To view the mean and median values for a channel, in the Display
channel drop-down list choose a channel: Red, Green, Blue, Hue,
Saturation, Lightness, or Greyscale. The Mean field displays the
average value for the selected channel. The Median field displays
the middle value in the range of values for the selected channel.
Note: The Display Channel has no effect on what is graphed in
the histogram and also does not affect the four statistics
immediately below it.
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Understanding Histogram Values
The value of a selected channel is graphed from 0 to 255 along the
horizontal axis of the histogram. The meaning of the value depends
on the selected channel:


Red, Green, and Blue values represent the amount of red, green,
or blue in each color channel. A channel value of zero indicates
the color is not present and a value of 255 indicates the color is at
full strength. For example, if the graph has a spike at the value
128 for the Red channel, then there are a large number of pixels
with a red value of 128 (or middle red).



Hue, Saturation, and Lightness values are a different
representation of color than the Red, Green, and Blue channels.
Hue is the actual color and the value is the number assigned on
the color wheel; for example, red is zero, yellow is 43, green is
85, cyan is 128, blue is 170, and magenta is 212. (As a reference,
look at the color wheel on the Jasc Color Picker.) Saturation is
the level of grey added to the hue; zero is very grey and
unsaturated and 255 is no grey and fully saturated. Lightness is
the brightness of the hue; zero is no light (black), 128 is middle
grey, and 255 is fully light (white). The lightness histogram has
information similar to the greyscale histogram.



Greyscale values are levels of grey; zero is black, 128 is middle
grey, and 255 is white. These represent the brightness or
luminosity of an image. The distribution of grey values
determines the contrast of an image.

Guidelines for Analyzing the Histogram
Here are guidelines that can help you analyze the histogram and
make decisions about how to correct your images:


If a line spikes, there are many pixels at that value.



If a line is close to the horizontal axis, there are few pixels at that
level.



If the graph is spread out, the image has a balanced composition
and probably has enough detail to be corrected.



If the lines are compressed into a narrow area, the image
probably doesn’t contain enough detail to be corrected; try a new
scan.
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The usefulness of the histogram depends upon the image content
as well as its channel values. For example, an image of pale,
desaturated skin tones may display a big saturation peak on the
left side (in the lower values) of the histogram. An image of a
bright red fire engine may display a peak on the right side (in the
higher values) of the histogram. If the images were improperly
saturated, the saturation histograms might be reversed.



If the greyscale graph is mostly at the left side, the image is too
dark.



If the greyscale graph is mostly at the right side, the image is too
light.



If the greyscale lines are not spread out enough, you may need to
increase the contrast.

Correcting Images by Adjusting the
Histogram
Color depth
The Histogram Adjustment
command applies to greyscale and
16 million (24-bit) color images
only.
To increase the color depth of an
image, see page 109.

Use the Histogram Adjustment command to adjust the contrast and
color balance of your image.
The graph in the Histogram Adjustment dialog displays how many
pixels are at each value of the selected channel. The vertical axis
represents the number of pixels and ranges from zero pixels to the
highest number of pixels in the graph. The horizontal axis represents
the value from zero to 255 of the selected channel.
When you change the histogram, the graph displays the adjusted
histogram as red and the original histogram as grey. To turn off the
red overlay, clear the Overlay result histogram check box.

What the ToolTip reveals
When you place the cursor over the
histogram, a ToolTip displays the
following information:






Input is the value on the
horizontal axis
Count is the number of pixels
that have that value
Integral is the percentage of
pixels in the image with that
value
Output is the adjusted value.

For detailed information on the graph, see “Understanding
Histogram Values” on page 203 and “Guidelines for Analyzing the
Histogram” on page 203.
In the Histogram Adjustment dialog, you can edit the luminance
(lightness) and the red, green, and blue color channels. The
Histogram Window (opened by choosing View > Palettes >
Histogram) also graphs the hue, saturation, and greyscale values, but
these cannot be edited by adjusting the histogram.

Chapter 8: Making Color and Tonal Corrections

Note
The Histogram Adjustment dialog graphs one color channel at a
time, unlike the Histogram Window which can display all color
channels at once. You may want to first display the Histogram
Window (choose View > Palettes > Histogram), then use
autoproofing on the Histogram Adjustment dialog so you can see
changes graphed in the Histogram Window.
To use the Histogram Adjustment command:
Quick histogram
adjustments
To correct contrast using
histogram functions, you can use
the Equalize or Stretch commands.
See “Using the Histogram to Fix
Contrast Problems” on page 190.

1 To limit the adjustment to a specific area, make a selection in the
image. See “Using the Selection Tools” on page 154.
2 Choose Adjust > Brightness and Contrast > Histogram
Adjustment to open the Histogram Adjustment dialog.
3 For the Edit option, choose a channel:
Luminance Lightness values of the image. If you are correcting
contrast, start with this channel.
Color Pick a color channel from the drop-down list: Red, Green,
or Blue.

Zoom in or out
Click
to magnify the histogram
or click
to reduce the view of
the histogram. Click 1:1 to display
the histogram at its original size.

4 In the Presets drop-down list, choose Default. The default values
represent no adjustment to the image.
5 On the left side of the histogram, look for a gap between the left
edge and the point where the graph starts to rise. If there is a gap,
it shows that the darkest pixels in the image are not completely
black. Click and drag the Low slider (the black triangle) to the
point where the graph rises. The top Low edit box displays the
low position (from 0 to 255). The bottom edit box displays the
percentage of pixels that are between zero and the low value;
their contrast will be lost. As a general rule, keep the percentage
below 0.1%.
6 On the right side of the histogram, look for a gap between the
right edge of the window and the point where the graph decreases
to zero pixels. If there is a gap, click and drag the High slider (the
white triangle) to that point on the graph. This changes the
lightest pixels in the image to white. As a general rule, keep the
High percentage change (the bottom edit box) to below 0.1%.
7 If the overall image is too dark or too light, adjust the gamma.
(Gamma is a standard measure of change in an image’s contrast.)
If the image is too dark, drag the Gamma slider (the grey
triangle) to the right to increase the gamma (the number changes
in the Gamma edit box). If the image is too light, drag the
Gamma slider to the left to decrease the gamma.
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8 If the graph has peaks on the left and right sides and contains low
points in the center, the midtones need to be compressed.
Shadows and highlights need to be expanded to reveal the
information they contain. This often occurs in flash photography
when a subject is too close to the camera; the subject appears
brightly illuminated but the background of the photograph is very
dark. To compress the midtones, click and drag the Midtones
slider up.
9 If the graph peaks in the center and has a low number of pixels at
the left and right sides, expand the midtones by dragging the
Midtones slider down.
10 If you are improving your image, skip this step. If you are
creating artistic effects, use the Output Max and Min sliders on
the left side of the histogram to make further adjustments. The
Max slider is the white circle within a grey square; the Min slider
is the black circle within a grey square. To darken the image’s
whites, click and drag the Max slider down. To lighten the
image’s blacks, click and drag the Min slider up.
Note: Even though you are dragging sliders along the vertical
axis, the Max and Min values actually affect the horizontal axis.
They indicate the maximum and minimum value (from 0 to 255)
in the image. All pixels outside those values are converted so that
they fall within the maximum and minimum.
11 To adjust another channel, choose it in the Edit drop-down list
and follow these steps again.
12 Click OK.
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Painting
Painting changes the pixels in your images. Dragging a painting tool
across an image changes the pixels under the brush stroke. These
tools give you endless options to get creative with your images.
Apply soft or hard-edged brush strokes of any color or material,
paint with another image as a source, retouch images to correct
colors or contrast, replace colors, or paint with picture tubes. You
can also erase pixels to transparency.
All painting tools work on raster layers only. The painting tools are
fully effective on greyscale or 16 million color images, but can be
applied with limited results to images of other color depths.
You can also make a selection in an image and then use the painting
tool to change only the pixels within the selection. For more
information on selections, see “Using the Selection Tools” on
page 154.
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Painting with the Paint Brush or Airbrush
Transparent painting
If you want a transparent paint
brush, use the Eraser or
Background Eraser tool. These
tools erase pixels to transparency
on raster layers. For more
information, see “Erasing” on
page 216.

The Paint Brush and the Airbrush tools work in similar ways. Both
create strokes of color in a selection or an image and have a variety
of options for changing the brush stroke.
The Paint Brush tool creates strokes of color that simulates an
artist’s paint brush. Brush strokes can have hard or soft edges. The
Airbrush simulates an airbrush or spray can, and is time-dependent,
meaning, the longer you hold the brush over an area, the more the
brush produces the effect.
To use the Paint Brush or Air Brush:

Painting with the Paint Brush
and the Airbrush

1 On the Tools toolbar, choose the tool: Paint Brush
. (One tool may be hidden under the other.)

or Airbrush

2 Choose the foreground and background colors and materials. See
“Basics of Using the Materials palette” on page 84.
3 On the Tool Options palette, choose a shape: round
, or square
. For information on creating your own brush tips, see
“Creating Brush Tips” on page 209.
Note: To create rectangular, elliptical, or angled brush tips, start
with the round or square shape and modify it using the Thickness
and Rotation options.
Default brush options
To reset brush options to their
default values, on the Tool Options
palette click the Presets dropdown window and click the
Reset to Defaults button.

4 Specify the brush options such as size, opacity, hardness,
thickness, and rotation. See “Setting Brush and Paint Options” on
page 211.
5 For the Airbrush, in the Rate edit box select the rate at which the
brush applies paint (from 0 to 50). Use a value of 0 if want to
apply a consistent amount of paint. Use higher values if you want
more paint applied when you drag the mouse slowly or pause the
mouse.
6 For the Paint Brush, set the following options:
Continuous Stroke Specifies whether paint builds up as you
apply multiple strokes of less than 100% opacity over the same
area. If this check box is marked, paint maintains a continuous
color and repainting an area has no effect.
If this check box is cleared (the default), each brush stroke over
the same area applies more paint; the color darkens until it
reaches 100% opacity. Click the New Stroke button to cancel the
effect for all previous brush strokes. Only new brush strokes will
darken if you paint over them.
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Wet Look Paint Mimics wet paint, with soft color inside and a
darker ring near the edge. Decrease the Hardness setting from its
maximum of 100% to see the effect.
7 Drag in the image to paint as follows:
Undoing paint strokes
When you are applying paint
strokes, the Undo command can be
your best friend. To remove the
most recent stroke, click the Undo
button or press Ctrl + Z. To undo
multiple brush strokes, press
Ctrl + Z multiple times or choose
Edit > Command History. If you
undo too many strokes, click the
Redo button or press
Ctrl + Alt + Z.



For all painting tools, to apply the foreground material, drag
with the left mouse button.



For all painting tools, to apply the background material, drag
with the right mouse button.



For all painting tools, to paint a straight line, click once at the
beginning point, then press Shift and click the end point. To
continue the straight line, move to the next point and press
Shift and click.



For the Airbrush, to build up color in one area click and hold
the mouse at one position.

Creating Brush Tips
Brush tips versus tool
Presets
When you create a brush tip, you
are saving all of the options
selected for the brush, including
the brush shape, step, density,
thickness, size, hardness, and
rotation settings. You can also
include the variance settings. The
brush tip settings that you save
can be applied to any tool that has
a brush tip control in the Tool
Options palette. When you create
a tool Preset, you are savings all
the settings that you specified for a
particular tool, including all of the
parameters and variance settings.
The tool Preset is available only
when you select that particular
tool.

You can create your own brush tips to use with painting tools. Select
a brush, modify the brush options and variance settings, and then
save the brush tip in the Brushes folder of the Paint Shop Pro
program folder. The next time you want to paint with that brush tip,
simply select it from the Brush Tip drop-down list.
You can also make a selection, and then turn that selection into a
custom brush with a width and height up to 500 by 500 pixels.
To create a brush tip:
1 On the Tools toolbar, choose a painting tool such as the Paint
Brush, Airbrush, or Color Replacer.
2 Modify the settings for the brush in the Tool Options and Brush
Variance palettes.
3 On the Tool Options palette, click the Brush Tip drop-down
window
. Current brush tips are displayed.
4 Click the Create Brush Tip button
, or choose File > Export >
Brush Tip to open the Create Brush Tip dialog.
Note: To save the new brush in a folder other than the default
Brushes folder, click the Edit Paths button
. For more
information on changing file locations, see “Setting File
Locations” on page 403.
5 In the Name field, type a name for the brush tip.
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6 Complete the Author, Copyright, and Description fields.
7 Mark the Save Variance check box to save the brush variance
settings with the brush tip.
8 Click OK. You can now use the brush tip with one of the painting
tools.
To create a brush tip from a selection:
1 Make a selection of the area you want to convert into a custom
brush. The selection must be on a raster layer. For more
information on selections, see “Using the Selection Tools” on
page 154.
2 On the Tools toolbar, choose a painting tool such as the Paint
Brush, Airbrush, or Color Replacer.
3 On the Tool Options palette, click the Brush Tip drop-down
window
. Current brush tips are displayed.
4 Click the Create Brush Tip from Selection button
, or choose
File > Export > Brush Tip. A preview of the new brush appears in
the Create Brush Tip dialog.
Note: To save the new brush in a folder other than the default
Brushes folder, click the Edit Paths button. For more information
on changing file locations, see “Setting File Locations” on
page 403.
5 To set a default step value, select a step value.
6 In the Name field, type a name for the brush tip.
7 Complete the Author, Copyright, and Description fields.
8 Mark the Save Variance check box to save the brush variance
settings with the brush tip.
9 Click OK. You can now use the brush tip with one of the painting
tools.
To delete a custom brush:
Importing Brush Tips
To import custom brush tips,
choose File > Import > Custom
Brush to open the Open dialog.
Select the location of the brush tip
and click OK to import the custom
brush tip.

1 On the Tools toolbar, choose a painting tool such as the Paint
Brush, Airbrush, or Color Replacer.
2 On the Tool Options palette, click the Brush Tip drop-down
window. Current brush tips are displayed.
3 In the list of brush tips, select the brush tip that you want to
delete, and then click Delete
.
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Setting Brush and Paint Options
The brush and paint options help you create hundreds of different
brush strokes. Play with the options until you get the effect you
want.

Basic Brush Options
Brush strokes with 75% and
25% densities

Brush strokes with 100% and
50% hardness

Brush strokes with
different thickness

Brush strokes with 0 and 45
degree rotation

Brush strokes with
different steps

The following options are available on the Tool Options palette for
painting tools.
Shape The shape of the brush tip. Round and Square are the standard
brush tips. Choose Round to create curved strokes that look more
smooth or choose Square to create brush strokes with corners.
Choose the other shapes to create interesting effects. For information
on creating your own brush tips, see “Creating Brush Tips” on
page 209.
Size The size of the brush, from 1 to 500 pixels. If the brush is
asymmetrical (such as when the Thickness is set to 50%), the size is
the brush height.
Hardness The sharpness of the brush edges. The harder the brush,
the more defined the edges of paint are. At 100%, the brush stroke
has sharply defined edges. As the hardness decreases, the brush edge
softens.
Step The spacing of paint impressions, or how frequently the brush
touches the image during a stroke. The step value is a percentage of
the brush size. At a step of 100%, a size 30 brush makes an
impression once every 30 pixels and the brush tip is clearly defined.
At a step of 50%, each impression touches the middle of the previous
impression. As the step decreases, the brush makes more
impressions, its shape becomes less noticeable, and its strokes
appear smoother and more dense.
Density The amount of paint applied with each stroke. At 100%,
paint covers the surface completely. As the density decreases, the
amount of paint applied with each stroke decreases. At 1%, only a
few pixels of paint appear.
Thickness The width of the brush in relation to the brush size (or
height). The value is a percentage. At 100% thickness, the brush
width is the same as the brush height. At 50% thickness, the brush
width is half the brush height.
Rotation The degrees of rotation of the brush tip, from 0 to 359.
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What is an impression?
A brush impression is one click of
the painting tool. For example, if
you click once with the Paint Brush
tool using a round brush, the
impression is a circle. The same
round paint brush makes many
impressions as you drag the
cursor, which results in a stroke of
color.

Opacity How well the paint covers the image surface. At 100%
opacity, the paint covers everything. At 1% opacity, the paint is
almost transparent.
Blend How painted pixels are blended with pixels on underlying
layers. The blend modes are the same as layer blend modes; for more
information, see “About Blend Modes” on page 275.

Using the Brush Variance Palette
Use the Brush Variance palette to customize the brush settings in the
Tool Options palette. The variance settings modify the Tool Option
settings by applying adjustments to the settings for a particular tool
option. Adjustments can be randomized by increasing the Jitter
percentage.

The Brush Variance palette

Note
To reset brush variance options to their default values, click the
Reset to Default button
on the Brush Variance palette.
To open the Brush Variance palette:
Choose View > Palettes > Brush Variance, or press F11.
To use the Brush Variance palette:

1 Choose a brush or eraser tool from the Tools toolbar.
2 Configure the brush options in the Tool Options palette.
3 On the Brush Variance palette, set the brush variance for each
available option:


Normal No variance applied.



Pressure The pressure applied from a tablet stylus.



Altitude The angle between the stylus and tablet.



Azimuth Determines the rotation angle of the tip.



Twist The rotation angle around the stylus (for 4D mouse
only).



Fingerwheel Applies to the wheel on an airbrush stylus.



Z-Wheel Used with a 4D mouse wheel with the wheel
configuration set to application defined behavior.



Direction The angle between consecutive mouse points on a
path.



Fade In Fades in the brush impression. For the Size option, the
brush size fades from small to large.
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Repeating Fade In Repeatedly fades in the brush impression.
For the Size option, the brush size fades from small to large.



Fade Out Fades out the brush impression. For the Size option,
the brush size fades from large to small.



Oscillating Fade Repeatedly fades the brush impression in and
out. For the Size option, the brush size fades from small to
large to small.
Note: Options in the Variance palette marked with an asterisk
* apply only to users with a pressure sensitive tablet. The
options available will depend on the type of tablet being used.

4 Set the Jitter% for each available option. The higher the value,
the more randomly the option is applied.
5 For the Fade rate (pixels) select the number of pixels over which
the fade in and fade out will occur. Lower values produce a faster
fade, while higher values produce a slower fade.
6 For the Position Jitter (%) select a percentage for randomly
adjusting the brush impression location. Mark the Scale check
box if you want the jitter to scale with the brush size.
7 For Impressions per step indicate how many brush impressions
are made per step of the brush stroke.

Using Brush Presets
Use the tool Presets to save creative brush effects. You can choose
from many artistic presets or create, save, and share your own.
Brush Presets work just like other tool Presets.
To reset brush options to their default values, on the Tool Options
palette click the Presets drop-down window and click the Reset to
Default button
.
For more information on presets, see “Using and Creating Presets”
on page 386.

Saving and Sharing Brush Presets
Once you create a Preset for a brush you can save it in the Brushes
folder in the Paint Shop Pro program folder. You can then share your
brush Presets with others by sending them the brush file. If the brush
uses a custom shape, you will have to share both the brush file and
the custom shape file for that brush.
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To save brush tip settings as a preset:
1 Click the down-arrow on the Presets button, and then click the
Save preset button
to open the Save Preset dialog.
2 Type a name for the Preset.
Brush tips versus tool
Presets
When you create a brush tip, you
are saving all of the options
selected for the brush, including
the brush shape, step, density,
thickness, size, hardness, and
rotation settings. You can also
include the variance settings. The
brush tip settings that you save
can be applied to any tool that has
a brush tip control in the Tool
Options palette. When you create
a tool Preset, you are savings all
the settings that you specified for a
particular tool, including all of the
parameters and variance settings.
The tool Preset is available only
when you select that particular
tool.

Note: You cannot use the names “Default” or “Last Used”.
3 To enter additional Preset information, click the Options button,
and then enter information in the Author, Copyright, and
Description fields.
The Preset includes group box shows the data saved with this
Preset. To omit any of these items from the Preset, click the Save
icon (a red X will appear over it) associated with the data.
4 Click OK.
To share brush tip Presets:
1 Navigate to the brushes folder in the Paint Shop Pro program
directory.
2 Provide the brush file or files (brush files have a .PspBrush
extension) to the person with whom you want to share the brush
Preset. They should place the brush files in the Brushes folder in
the Paint Shop Pro program folder.
Note: If you are sharing a Preset for a custom brush (brushes
created from selections) then you will need to select both the
.PspBrush file and the associated Jasc PSP Script file.
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Warping Images
Before and after applying the
Warp Brush tool

The warp brushes create strokes that produce a warping effect on
image pixels. You can twirl areas of images, contract or expand parts
of images, and create many interesting effects.
To use the Warp Brush:
1 On the Tools toolbar, choose the Warp Brush
under the Paint Brush or Airbrush.)

Default brush options
To reset brush options to their
default values, on the Tool Options
palette click the Presets drop-down
window and choose Default, or
click the Reset to Default button
.

What are time-dependent
warp types?
Time-dependent means that the
longer you hold the brush over an
area, the more the brush produces
the effect.

. (It may be hidden

2 Specify the brush options such as shape, size, and hardness. See
“Setting Brush and Paint Options” on page 211.
3 For the Strength value, enter a percentage (0 to 100) that
specifies how strong the warping effect is. Full strength is 100%;
minimum strength is 1%.
4 Under Warp Modes, choose the type of warp:
Push
pushes pixels in the direction of the stroke (similar to
smearing paint) in a time-independent way.
Expand
pushes pixels away from the center of the brush in a
time-dependent way.
Contract
pulls pixels into the center of the brush in a timedependent way.
Right Twirl
rotates pixels clockwise around the center of the
brush in a time-dependent way.
Left Twirl
rotates pixels counter-clockwise around the center
of the brush in a time-dependent way.
Noise
causes random movements of pixels under the brush in
a time-dependent way.

Another way to warp
images
You can also use the Mesh Warp
tool to warp images. See “Warping
Images” on page 146.

Iron Out

removes unapplied warps in a time-independent way.

Unwarp

removes unapplied warps in a time-dependent way.

5 Select an Edge mode, a Draft mode quality, and Final apply
mode quality. See “Warping Images” on page 146.
6 Do one or both of the following to warp the image:


Click and drag in the image.



For the time-dependent modes, place the cursor at one
position and hold down the mouse button to repeat the effect
at one area.
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7 To unwarp an area, choose the Iron Out or Unwarp option under
Warp Mode, and then click over the area you want to restore.
Continue clicking or holding the mouse button down until the
original pixel position is restored.

Erasing
Before and after applying the
Eraser tool

Use the Eraser tool to erase areas of a layer to transparency or to the
background color. Use the Background Eraser tool to selectively
erase to transparency—with options that determine which pixels are
erased.

Using the Eraser Tool
When you use the Eraser tool to erase on a raster layer, all pixels in
the tool’s path become transparent. When you erase on the
background (which does not support transparency), the Eraser tool
acts like a paintbrush; all pixels in the tool’s path become the current
foreground or background color or material.
To use the Eraser tool:
Undoing versus erasing
When should you undo paint
strokes and when should you
erase in the image?
Undo paint strokes when you made
a mistake with a stroke. Undoing a
paint stroke restores the image
detail under the stroke.
Erase paint when you want to
change certain pixels to
transparent (or a color if the
background is selected). Erase to
create an effect—such as one
layer showing through another
layer. Erasing does not restore the
image detail under the stroke.

1 On the Tools toolbar, choose the Eraser tool
under the Background Eraser tool.)

. (It may be hidden

2 On the Tool Options palette, choose the brush tip, size, opacity,
and other options. (See “Setting Brush and Paint Options” on
page 211.) For the opacity setting, 100% erases pixels to
complete transparency and a lower opacity erases pixels to
partial transparency.
3 Drag in the image to erase as follows:


To erase pixels, drag with the left mouse button.



To restore erased pixels, drag with the right mouse button.



To erase a straight line, click once at the beginning point, then
press Shift and click the end point. To continue the straight
line, move to the next point and press Shift and click.

Note: If you erase on the background, the eraser strokes change
to the background color when you use the left mouse button or to
the foreground color when you use the right mouse button. To
erase to transparency, promote the background to a full layer.
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Using the Background Eraser Tool
Use the Background Eraser tool to selectively erase pixels. For
example, in a photograph of a mountain range, you can erase the sky.
To use the Background Eraser tool:
1 On the Tools toolbar, choose the Background Eraser tool
may be hidden under the Eraser tool.)

. (It

2 On the Tool Options palette, choose the brush tip, size, opacity,
hardness and other options. (See “Setting Brush and Paint
Options” on page 211.) For the opacity setting, 100% erases
pixels to complete transparency and a lower opacity erases pixels
to partial transparency.
3 Choose from these additional options:
Before and after applying the
Background Eraser



Tolerance How closely the selected pixels must match the
sampled pixel. The range is 0 to 200. At lower settings, only
pixels with very similar colors are erased. At higher settings,
more pixels are erased. (This edit box is unavailable if the
Auto Tolerance check box is marked.)



Sampling How the tool determines what pixels to erase:
Once samples at the center of the brush where you first click
and erases all matching pixels for the duration of the stroke.
Continuous samples at the center of the brush at every step
and erases all matching pixels.
BackSwatch erases all pixels that match the current
background color on the Materials palette rather than
sampling from the image.
ForeSwatch erases all pixels that match the current
foreground color on the Materials palette rather than sampling
from the image.
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Sampling advice

Discontiguous erases all pixels in the tool’s path that match
the sampled pixels, even if they are discontiguous (nonadjacent). Use this mode on images that show the background
through holes in the image.

For the Sampling option, choose
the Once setting to erase similar
colors while avoiding erasing areas
you want to keep. You can keep
clicking and dragging (in other
words, keep restarting the eraser
strokes) to erase similar areas.
If the area you want to erase is
quite variable, try using the
Continuous setting and set the step
value very low (even down to 1) so
that the area is sampled frequently
as you erase.

Auto or manual tolerance?
Start with the Auto Tolerance
check box marked. Begin erasing.
If too much or too little is erased,
clear the Auto Tolerance check
box. The Tolerance edit box
displays the automatically
determined tolerance. If too much
was erased, lower the tolerance. If
too little was erased, raise the
tolerance.
In addition, you can reduce the
step and increase the brush size.
To determine the automatic
tolerance, the Background Eraser
samples a larger area more
frequently.

Limits Whether erased pixels must be adjacent to each other:

Contiguous erases only contiguous pixels that match sampled
pixels. Use this mode when the background pixels are close in
color to the edges of the object you want to isolate.
Find Edges restricts the brush erasing according to the edge
information.


Auto Tolerance Mark this check box to have the tool
determine the tolerance based on the pixels in the Background
Eraser tool’s path; the tolerance may change continuously as
the tool moves over different parts of the layer. Clear this
check box to have the tool use the Tolerance setting that you
choose.



Sample merged Mark this check box to sample data from all
layers merged together; only pixels in the current layer are
erased. Clear the check box to sample data from the current
layer only.



Ignore lightness Mark this check box when the colors in the
object that you want to isolate are strongly saturated and the
background is unsaturated, or vice versa.

4 If the image has more than one layer, on the Layer palette click
the layer that has an object that you want to isolate by erasing the
background.
Note: The Background Eraser cannot be applied on the
background, which does not support transparency. If you apply
the tool to the background, you are prompted to promote it to a
full layer.
5 Drag on the layer, around the edges of the subject to erase the
background area as follows:


To erase pixels, drag with the left mouse button.



To erase a straight line, click once at the beginning point, then
press Shift and click the end point. To continue the straight
line, move to the next point and press Shift and click.



To restore erased pixels, drag with the right mouse button.
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Cloning Parts of Images
Original image and image after
cloning

The Clone Brush tool is a fun and powerful way to edit your images
by using parts of an image as a paint source. You can remove
elements within your image by painting over them with another part
of the image. The paint source can be part of the same layer, another
layer in the image, a merged image, or a layer from another image.
To use the Clone Brush:
1 On the Tools toolbar, choose the Clone Brush tool

.

2 On the Tool Options palette, choose the brush tip, size, opacity,
and other options. See “Setting Brush and Paint Options” on
page 211.
Why does nothing happen
when I apply the Clone
Brush?
If nothing appears to be happening
when you apply the Clone Brush,
make sure you selected a source
area with data. If the selected layer
has no data at the source point, but
another layer does have data there,
it may appear that you selected a
source area.
On the Layer palette, click the
name of a raster layer before you
define the source area. Also, make
sure the layer doesn’t have a
selection or, if it does, make sure
you right-click within the selection.

3 Mark the Aligned mode check box to have the Clone Brush tool
paint from the point of the source area relative to the first point
you click on the target area each time you stop and start painting.
You can keep clicking and dragging over the target area to fill in
the source image.
Clear the check box to have every stroke copy the same data.
4 Mark the Sample merged check box to clone data from all layers
merged together. Clear the check box to clone data from the
current layer only.
5 On the source image, right-click or press Shift and click the
center point of the source area.
6 Click and drag on the image you want to change to paint the
cloned area.
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Retouching Images
Before and after applying the
Emboss brush

You can retouch images with Paint Shop Pro’s retouch brushes,
which apply changes with brush strokes. Some retouch brushes
mimic photographic effects while others change pixels based on
their lightness, saturation, hue, or color values. Some retouch
brushes create similar effects to Paint Shop Pro’s color correction
commands. The following table describes each of the retouch
brushes.

Before and after applying the
Dodge brush

Brush

Effect

Dodge

Lightens and brings out the details in areas that are
in shadow. This tool mimics the traditional
photographic darkroom technique of holding back
some of the light when printing photographs to
produce lighter areas. The Dodge tool is the opposite
of the Burn tool.

Before and after applying the
Smudge brush

Burn

Darkens areas of the image that are too light.

Smudge

Spreads color and image details from the starting
point and picks up new color and image details as it
moves; the effect is similar to smearing paint.

Push

Spreads color and image details from the starting
point but does not pick up any new color or image
details.

Soften

Smooths edges and reduces contrast.

Sharpen

Heightens edges and accentuates contrasts.

Emboss

Causes the foreground to appear raised from the
background by suppressing color and tracing edges
in black.

Lighten/Darken

Lightening increases brightness; darkening
decreases brightness. (Choose to affect the RGB or
Lightness value of pixels).

Before and after applying the
Soften brush

Saturation Up/Down Increases or decreases the saturation (affects the
HSL value of pixels).
Hue Up/Down

Increases or decreases the hue (affects the HSL
value of pixels).
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Brush

Effect

Change-to-Target

Changes pixels based on a characteristic of the
current foreground color (on the Materials palette):
color, hue, saturation, or lightness.
If you choose the color as the target, the tool applies
the foreground color without affecting the
luminance.
If you choose the hue, saturation, or lightness as the
target, it applies the foreground color’s hue,
saturation, or lightness value without changing the
other values.

To use a retouch brush:
Apply the brush only where
you want it
To limit the effects of this brush to
a specific area, first make a
selection in the image.

1 On the Tools toolbar, choose the retouch brush: Dodge , Burn
, Smudge , Push , Soften , Sharpen , Emboss ,
Lighten/Darken , Saturation , Hue , or Change to Target .
2 On the Tool Options palette, choose the brush tip, size, opacity,
and other options. See “Setting Brush and Paint Options” on
page 211.
3 Depending upon the tool, select from the following options:

Using the mouse buttons
When using the retouch tools you
can retouch an image by
left-clicking, and apply the
opposite of the retouch by rightclicking.

Swap mouse buttons Mark this check box to swap the functions
of the left (up) and right (down) mouse buttons.
Sample merged (Smudge, Push, Soften, Sharpen, Emboss) Mark
this check box to retouch data from all layers merged together.
Clear this check box to retouch data on the current layer only.
Mode (Lighten/Darken) Choose what is lightened or darkened:
RGB values or Lightness values.
Mode (Change to Target) Choose the characteristic of the
foreground color to target: Color (RGB value; luminance is not
changed), Hue, Lightness, or Saturation.
Limit Choose which option you want to limit for the Dodge and
Burn tools: None, Shadows, Midtones, or Highlights.
4 Drag in the image to apply the brush. If the brush has two
functions (such as Hue Up/Down), drag with the left mouse to
apply the first function and drag with the right mouse button to
apply the second function.
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Filling Areas with Colors, Gradients, Patterns, or
Textures
What are contiguous
pixels?
Contiguous means “near, next, or
adjacent.” Contiguous pixels are
like continuous chains of matching
pixels radiating from the initial pixel
you click. When the Flood Fill tool
finds a pixel that doesn’t match, it
breaks the chain. Even if a pixel is
just one pixel away from a
matching pixel, it is discontiguous.

Use the Flood Fill tool to fill a selection or a layer with the
foreground or background color and material. You can fill all pixels
or fill only those pixels that match options that you specify. When
you click in the image, the Flood Fill tool finds and fills all
contiguous (adjacent) pixels that match the pixel you select.
To use the Flood Fill tool:
1 On the Tools toolbar, choose the Flood Fill tool

.

2 Choose the foreground or background color and material to fill
the area with. See “Basics of Using the Materials palette” on
page 84.
3 On the Tool Options palette, specify the Match Mode options:

Flood Fill versus Color
Replacer
Because the Flood Fill tool can fill
pixels that match certain criteria
(such as RGB value), its effect is
similar to the Color Replacer tool.
Here are the differences:




The Flood Fill tool fills matching
pixels that are contiguous to the
initial pixel you click. The Color
Replacer changes pixels either
within its brush stroke or in the
entire layer.
The Color Replacer tool changes
colors based on their RGB value.
The Flood Fill tool changes
pixels based on RGB, hue,
brightness, or opacity values.

Match Mode How pixels that match the pixel you click are chosen
and filled:
None has no matching criteria and so fills all pixels.
RGB fills contiguous pixels that match the red, green, and blue
values.
Color fills contiguous pixels that match the hue and saturation
values.
Hue fills contiguous pixels that match the hue value.
Brightness fills contiguous pixels that match the brightness.
All Opaque fills all pixels that are opaque (not transparent).
Opacity fills contiguous pixels that match the opacity.
Tolerance How closely the selected pixels must match the initial
pixel you click. The range is 0 to 200. At lower settings, only
pixels with very similar colors are filled. At higher settings, more
pixels are filled.
Sample Merged Mark this check box to choose pixels to fill
based on matching pixels from all layers merged together. Clear
this check box to choose matching pixels to fill in from the
current layer only.
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4 Select the Blend Mode options:
Apply the tool only where
you want it

Blend Mode How filled pixels are blended with pixels of
underlying layers. The blend modes are the same as the Layer
blend modes; for more information, see “About Blend Modes” on
page 275.

To limit the effects of this tool to a
specific area, first make a selection
in the image.

Opacity The opacity for the fill. At 100% opacity, the paint
covers everything; at 1% opacity, the paint is almost transparent.
5 Position the cursor over the area of the selection or image that
you want to fill, and then do one of the following:


To fill with the foreground material, click the left mouse
button.



To fill with the background material, click the right mouse
button.

If the Match Mode is None, all pixels on the current layer are
filled. For all other Match Mode settings, the Flood Fill tool fills
matching pixels that are contiguous to the pixel you click.

Replacing Colors
Use the Color Replacer tool to replace one color in a selection or
layer with another color. You can use brush strokes to replace only
those pixels that the brush touches or you can replace all pixels of a
certain color in a selection or a layer. You can set a tolerance value
so that the Color Replacer changes similar, not just identical, colors.
To use the Color Replacer tool:
Apply the tool only where
you want it
To limit the effects of this tool to a
specific area, first make a selection
in the image.

1 On the Tools toolbar, choose the Color Replacer tool
may be hidden under the Eye Dropper tool.

. The tool

2 Choose the color to replace as the foreground or background
color. See “Basics of Using the Materials palette” on page 84 or
“Choosing Colors from an Image or the Desktop” on page 90.
3 Choose the color to substitute as the other color (foreground or
background).
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Nothing seems to happen
when you apply the Color
Replacer tool...

4 To replace colors using brush strokes (rather than all colors in the
layer), on the Tool Options palette choose the brush tip, size,
opacity, and other options. See “Setting Brush and Paint
Options” on page 211.

Make sure you have selected a
foreground or background color
that is in the image. If there are no
pixels that match, then no pixel
colors are replaced.

5 In the Tolerance edit box, specify a value that sets how closely
the selected pixels must match the initial pixel you click. The
range is 0 to 200. At lower settings, only pixels with very similar
colors are replaced. At higher settings, more pixels are replaced.

To pick a foreground or
background color directly from the
image, see “Choosing Colors from
an Image or the Desktop” on
page 90.

6 Position the cursor over the area of a selection or layer that
contains the color you want to replace, and then do one of the
following:


To replace all occurrences of a color, double-click.



To replace using brush strokes, drag in the image.

For both options, use the left mouse button to replace the
background color with the foreground color and use the right
mouse button to replace the foreground color with the
background color.

Painting with Picture Tubes
Two examples of picture tubes

Use the Picture Tube tool to paint with a collection of objects
without having to draw them. You can add butterflies and beetles to
a picnic setting, fill an aquarium with fish, or frame a picture with
holly. Use one of the picture tubes included with Paint Shop Pro or
create your own.
Picture tubes are .PspTube files. Each picture tube file is made up of
a series of images arranged in rows and columns that are called cells.
Picture tubes may have any number of cells. As you paint with the
Picture Tube tool, Paint Shop Pro paints one image of a picture tube
after another. Many picture tubes create discrete images (such as
traffic signs), while some create the effect of a continuous image
(such as crepe paper).

Raster only
The Picture Tube tool paints raster
objects on raster layers. You
cannot use the tool on vector
layers.
To make picture tube elements
easier to edit, it is helpful to paint
them on a separate layer.

Note
To use Paint Shop Pro version 8 picture tubes with Paint Shop Pro
version 7, copy the version 8 tubes with the .PspTube extension to
the picture tube directory in version 7, and then re-name the files
with the .TUB extension.
To paint with a picture tube:
1 On the Tools toolbar, choose the Picture Tube tool

.
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2 On the Tool Options palette, click the Picture Tube drop-down
window and select a picture tube.
Note: Most picture tube previews show one image rather than all
images in the picture tube. To view all images, paint with the
picture tube, or open the .PspTube file with the Browser.
3 If necessary, adjust the following options:
Changing default values for
picture tubes
To change default values for a
picture tube, including the
placement mode, step size, and
selection mode, click the Settings
icon on the Tool Options palette.
You can also change the number of
cells in the picture tube.
After you change values, mark the
Save as Default for this Picture
Tube check box and click OK.

Scale The percentage (10 to 250%) to reduce or enlarge each
image in the picture tube and scale the step.
Step The distance in pixels (1 to 500) between the centers of each
picture tube image that you paint.
Placement mode The way images are placed: Continuous evenly
spaced by step size or Random random spacing between 1 pixel
and the step size.
Selection mode How Paint Shop Pro selects images to paint from
the cells within the picture tube: Random selects images
randomly; Incremental selects images one by one from top left to
the bottom right; Angular selects images based on the direction
you drag the cursor as you paint; Pressure selects images based
on the pressure you apply on a pressure-sensitive tablet; Velocity
selects images based on the speed you drag the cursor as you
paint.
4 To paint one image of the picture tube, click once in the image.
To paint multiple images, drag in the image.

Creating Picture Tubes
Color depth and layers
This tool works only on raster
layers in greyscale and 16 million
color images. To convert a vector
layer to a raster layer, choose
Layers >
Convert to Raster Layer. To
increase the color depth of an
image, see page 109.

To create your own picture tubes, create a grid of cells and then fill
each cell with an image. The cells can be any size, but picture tubes
with larger cells require more memory to use.
To create a picture tube:
1 Choose View > Change Grid, Guide, and Snap Properties, click
the Grid tab, set the current horizontal and vertical grids, then click
OK.
The grid positions are the value in pixels that the width and
height of cells will be. Images can be no larger than this cell size.
2 Choose File > New to open the New Image dialog.
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3 Set the following options:
Painting with one image
To use an entire image as a paint
brush, export the image as a
picture tube. Use a cell
arrangement of one cell across by
one cell down. The image must
contain one raster layer that is not
the background; to promote the
background to a layer, choose
Layers > Promote to Layer.
Then choose the Picture Tube tool
and select the new picture tube
you created.

Filling the cells of a picture tube

Image Dimensions Choose a width and height (in pixels) that are
multiples of the horizontal and vertical grid spacing. The width
and height of the image determine the total number of cells in the
image. For example, if the grid spacing is 100 pixels, create an
image of 400 pixels wide by 300 pixels high to have 12 cells
(four across and three down).
Image Characteristics Choose Raster Background as the layer
type and mark the Transparent check box.
4 Click OK.
5 If the grid is not visible, choose View > Grid.
6 Create one image in each grid square. These squares are the
picture tube cells.
Note: To change the size of cells, change the grid size and then
use the Canvas Size command to change the canvas size.
7 Choose File > Export > Picture Tube to open the Export Picture
Tube dialog.
8 Set the following options:
Cell arrangement Enter the number of cells across and down.
Placement options Choose the default options for this picture
tube. You can change these options when you apply the picture
tube. For more information, see the descriptions on page 225.

I want more picture tubes!

Tube name Enter the file name of the tube. The extension
.PspTube is automatically added to the file name.

There are a variety of Web sites
that offer free picture tubes. Start
with Jasc.com and click Free
Downloads. Or search the Web for
“free picture tubes.”

Note: By default, picture tube files are stored in the Picture
Tubes folder of the Paint Shop Pro program folder. For
information on changing this location, see “Setting File
Locations” on page 403.
9 Click OK. The picture tube is saved.
10 Close the image file. To edit it later, save it as a .PspImage or
other format file.
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Drawing and Editing Objects
Use Paint Shop Pro drawing tools to create objects in a variety of
styles. Draw anything from simple lines and shapes to complex
illustrations.
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About Objects
An object is anything you create with the Pen or Preset Shape tool.
Use the Preset Shape tool to create standard shapes (circles, squares,
and stars). Or, create your own custom shapes using the Pen tool.
Both tools can create raster or vector objects.
Note
The Text tool can also create vector objects. For more information,
see “About Vector, Floating, and Selection Text” on page 305.

Raster Objects
For more about Raster vs.
Vector Objects
For overview information on vector
and raster data, see “About Raster
and Vector Graphics” on page 32.

When you use the Preset Shapes or Pen tool to draw raster objects,
you are really painting on a raster layer. Even though you create a
raster object in the same way as a vector object, your finished shape
is not a vector object. Once the shape is complete, it becomes pixels
on a layer. You can only edit the pixels with raster editing tools.
Note
You can only draw raster objects on raster layers. If you try to draw
a raster object on a vector layer, Paint Shop Pro will create a new
raster layer for your object.

Vector Objects
When you use the Preset Shapes or Pen tool to draw vector objects,
you are creating objects that can be edited later. A vector object’s
properties (outline color, fill color, size, location and more) can all
be easily changed over and over. You can also edit the paths,
contours, line segments, and nodes that make up vector objects.
Note
You can only draw vector objects on vector layers. If you try to draw
a vector object on a raster layer, Paint Shop Pro will create a new
vector layer for your object.
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The Anatomy of a Vector Object
Closed object selected with
Object Selection tool
Path

Bounding Box

Object An object is anything you create with the Pen or Preset Shape
tool. Each object is represented by its own bounding box. An object
has properties you can control such as line style and fill color. Each
object contains one path made up of contours and nodes.
Path An object contains one path. The path is all the contours in an
object. The properties of the path are controlled by the object’s
properties. A path’s direction flows from its start to end point. Some
paths are closed (their start and end points are the same).

Open object selected with
Pen tool
Contour
Path
Contour

Contour A path contains at least one contour. A contour contains at
least one line segment. A contour’s direction flows from its start to
end point. A contour can also be open or closed. The contours in a
path do not need to be connected. Some of a contour’s properties are
controlled by its object’s properties (e.g. line style, fill color, antialiasing). The shape of a contour is controlled by the type and
location of its nodes.
Node A contour contains at least two nodes. A node is a point on a
contour that define the contour’s shape at that point. For instructions
on editing nodes, see, “Editing Nodes” on page 251.
Line Segment The straight or curved line between two nodes is a line
segment.

Contour selected with
Pen tool
End

Start
Node

Line Segments

Drawing Objects
Use the drawing tool to draw single lines, freehand lines, Bezier
curves, and point to point lines, as raster objects on raster layers, or
vector objects on vector layers. When you use the Drawing too in
vector mode, the objects can be moved, deformed, and edited after
they are created, without affecting the rest of the image.
To select a drawing tool:
On the Tools toolbar, select the Pen tool
tool.

or the Preset Shapes
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Setting Line Options
Before you begin drawing an object, set the line options. The line
options control how the lines of your object will appear. You can
also adjust the line options of existing vector objects.
The following options appear on the Tool Options palette for the Pen
tool and Preset Shape tool.
Note
To see all of the options you may need to click the More button
at the end of the Tool Options palette.
Line Style Sets line style, such as solid or dashed. To create your
own line styles, see “Creating Custom Line Styles” on page 235.
Width Sets the line width, from 0.5 to 255 pixels.
Note: To draw shapes with no line, set the foreground color (in
the Materials palette) to transparent.
Join Sets the type of corners for the path:
Corner Join Types
Round Line

Miter



Miter Produces mitered (pointed) corners when the width of
the corner is within the Miter Limit value and produces
beveled corners when the corner width exceeds the limit.



Round Produces round corners.



Bevel Produces flattened corners.

Bevel

Miter limit This option is available only when you select Miter in the
Join group box. The value determines whether the corner is mitered
(pointed) or beveled (flattened). Higher miter limits will create more
pointed corners. Lower miter limits will create more beveled
corners.
Anti-alias Mark this check box to use anti-aliasing, which smooths
the jagged edges of lines by softening the color transition between
edge pixels and background pixels.
Curve Tracking (Pen tool only) The distance in pixels between the
nodes of a Freehand line. A higher value will create smoother,
less precise lines. A lower value will create more segmented, precise
lines.
Retain style (Preset Shape tool only) Mark this check box to use the
line and fill settings of the preset shape. Clear this check box to use
the current foreground and background material for the lines and fill.
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Drawing Preset Shapes
Sample Preset Shapes

Use the Preset Shape tool to draw objects (rectangles, ellipses, stars,
and more). To create your own custom preset shapes, see “Creating
New Preset Shapes” on page 234.
To draw a preset shape:
1 On the Layer palette, click the layer on which you want to draw.
2 On the Tools toolbar, choose the Preset Shape tool

.

Note: Choose the line (foreground) and fill (background) colors
and materials. To draw shapes with no line or no fill, set the
color to transparent. For instructions on setting colors, see
“Using the Materials Palette” on page 82.
Note: The color settings are ignored if you mark the Retain Style
check box on the Toolbar Options palette.
To view more preset shapes
at once:
From the View drop-down list,
choose Small Icons.

3 On the Tool Options palette, click the preset shapes drop-down
window and choose a shape.
4 Choose to draw a raster or vector object:
Create as vector Mark this check box to draw a vector object.
Clear the check box to draw a raster object.
5 Choose other line options. For more information, see “Drawing
Objects” on page 229.

Preset Shape Drawing Tips

6 Click and drag to draw the shape. When the shape outline is the
size you want, release the mouse button. The final shape appears
on the image.

To place the center of the shape
where you click, right-click and
drag.

Raster objects become part of the current raster layer.

To keep the height and width of the
shape proportional, hold the Shift
key while you click and drag.

A vector object will appear on the canvas and on the Layer palette as
an object within the current layer. Each vector preset shape you draw
is a separate vector object.
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Drawing Lines and Custom Shapes
Paint Shop Pro lets you draw lines and create custom shapes in three
different ways. You can draw straight lines, curved lines, and
freehand lines.
While each vector preset shape is drawn as a separate object, the Pen
tool can create multiple contours inside a single object.
If you draw three separate line segments without clicking the New
Shape button between each one, the three contours will be one
object.
To draw a line or shape:
1 On the Tools toolbar, choose the Pen tool

.

2 On the Tool Options palette, click Drawing Mode
3 On the Tool Options palette, click New Shape
Ctrl+N.

.
or press

4 Choose the line (foreground) and fill (background) colors and
materials. To draw shapes with no line or no fill, set the color to
transparent. For instructions on setting colors, see “Using the
Materials Palette” on page 82.
5 Choose the line options. For more information, see “Drawing
Objects” on page 229.
6 On the Tool Options palette, select a Segment Type to draw with.
For more information, see “To draw using the straight lines:” on
page 233.
7 Choose Pen tool settings:
Switch segment styles as
you draw:
In the Tool Options palette, click
the Line Segments, Point to
Point, or Freehand buttons to
choose how the next node will be
created.

Contiguous Mark this check box to connect each node you draw,
forming one contour. Clear this check box to draw unconnected
line segments (multiple contours).
Note: The contiguous setting only applies to the Freehand and
Line Segment styles.
Create as vector Mark this check box to create a vector object.
Clear the check box to create a raster object.
Simple Mode Clear this check box to show vector style controls
while drawing raster objects.
8 Click to draw nodes:


Once you have three nodes, Paint Shop Pro will fill the space
between them with the current background color.
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To close the path of a shape, click Close Path
. The Pen
tool automatically adds a line to connect the end point with
the starting point.

9 When you finish the object, do one of the following:
New Shape button tip:
If you clicked the New Shape
button by mistake, click it again to
resume drawing.



To add a new contour within the same object, click
New Contour
and continue drawing.



To draw another object, click New Shape
drawing.



Choose a new tool.

and begin

To draw using the straight lines:
Shape drawn with
Line Segment option

1 From the Pen tool Tool Options palette,
choose Line Segments
.
2 Click and drag from the line starting point to the location of the
next node. Release the mouse button.
3 To extend the line: click, drag, and release again.
Note: To draw lines at fixed angles (45 degree increments), press
and hold the Shift key as you drag.
To draw using curved and straight lines:

Shape drawn with
Point To Point option

1 From the Pen tool’s Tool Options palette,
choose Point to Point
.
2 Click and drag at the start point. When the direction of your line
is correct, release the mouse button.
3 For the next node:


To create a straight line, click where you want the next node.



To create a curved line, click and drag. When the curve is the
right shape, release the mouse button.

4 Add additional nodes, clicking for a straight segments or clicking
and dragging for curved segments.
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To draw using free-form lines:
Shape drawn with
Freehand option

1 From the Pen tool’s Tool Options palette,
choose Freehand
.
2 Click and drag the cursor along the path you want the line to take.
Release the mouse. Paint Shop Pro creates a contour that matches
the path. To adjust how precisely the line follows your cursor,
see “Drawing Objects” on page 229.

Creating New Preset Shapes
You can save any vector object (lines, shapes, or text) as a preset
shape used by the Preset Shape tool.
Preset shapes are stored in files called shape libraries, which contain
one or more vector objects. Paint Shop Pro’s default shape libraries
are located in the Preset Shapes folder of the Paint Shop Pro program
folder. By default, your custom preset shapes are saved in the Preset
Shapes folder of your My PSP8 Files folder in your My Documents
folder. To choose another folder for your preset shapes, see “Setting
File Locations” on page 403.
To create a new preset shape:
1 Create an image with the vector objects that you want to save as
preset objects.
2 Give each object a unique name that will help you identify it.You
cannot export multiple objects with the same name. To name
objects, see “Editing Vector Object Properties” on page 237.
3 Use the Object Selection tool
to select one or more objects to
save as preset shapes. To export all objects, make sure none are
selected.
4 To open the Export Shape Library dialog:


Choose File > Export > Shape.



Right-click and choose Export > Shape from the context
menu.

5 Type a name for the library file and click OK.
The library file (.PspShape extension) saves to the default Preset
Shapes folder. “Editing File Locations” on page 404.
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To modify a library:
1 Use File > Open to open the library file in Paint Shop Pro.
2 Modify, add, or delete objects in the file.
3 Save and close the library file.
Note: You will have to restart Paint Shop Pro to use the modified
preset objects.
To delete a entire library:


Delete the library file from the Preset Shapes folder.

Creating Custom Line Styles
You can edit the default line styles or design your own line styles.
Saved styles appear in the Line Style drop-down window on the Tool
Options palette for the Pen, Preset Shapes, and Text tools.
To create and save a customized line style:
1 Choose the Pen, Preset Shapes, or Text tool.
2 On the Tool Options palette, click the Line Style drop-down
window.
Note: If you want to copy an existing line style to create a new
style, or if you want to edit or delete an existing line style, select
that style in the Line Style drop-down window.
3 Click the Custom button to open the Styled Lines dialog.
4 In the Caps group box, choose end cap settings for the line
segments. For details, see “End Cap Styles” on page 236.
5 In the Style group box, choose dash and gap lengths. For details,
see “Dash Segment Style” on page 236.
6 When you are finished, do one of the following:


If you are creating a new line, click Save As New. Type a
unique name in the Styled Line Name field. Click OK.



If you are editing an existing line, click Save.



To close the dialog without saving changes, click Cancel.

Note
To reset the dialog back to the style you started with, click the Reset
button
.
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End Cap Styles
The Caps group box in the Styled Lines dialog controls the end cap
style of each segment in the line style. The settings are:
First Cap From the drop-down list, pick the style for the first
segment in the line.
Size Click this button to open the Cap Size dialog and adjust the size
of the end cap. To set and adjust height and width equally, select the
Link axes check box.
Last Cap From the drop-down list, pick the style for the last segment
in the line.
Different Segment Caps Mark this check box to create separate end
caps for all the middle segments (dashes) in the line. Clear the check
box to use the First Cap and Last Cap settings for each dash.
Segment Start From the drop-down list, pick the style for the
beginning of each dash.
Segment End From the drop-down list, pick the style for the end of
each dash.

Dash Segment Style
The Style group box in the Styled Lines dialog controls the length of
dashes and gaps in the line style.
Edit
Area
Slider
Preview
Area

First Cap

Segment Start

Segment End

Last Cap

The Preview Area at the bottom of the Styled Lines dialog displays
the changes you make to the line. The Edit Area has a ruler (in
pixels) to help you to size dashes and gaps. Each dash or gap can be
selected and adjusted with its Slider.
The Style settings are:
Add Adds dashes or gaps. Set the length of the dashes or gaps with
the numeric edit control or by clicking and dragging the sliders.
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Delete Deletes the selected dash or gap. Select a dash or gap by
clicking on its slider in the edit area.
Clear Removes all dashes and gaps.
Zoom Buttons
out.
Undo
box.

Click to zoom the view of the edit area in or

Click to undo previous changes made in the Style group

Editing Vector Object Properties
Selecting vector objects
Use the Object Selection tool to
select vector objects. Press Shift
and to select multiple vector
objects. For more information, see
“Selecting Vector Objects” on
page 161.

Drawing lines and shapes as vector objects gives you the flexibility
of editing them after they are drawn.
Note
All of the commands in the Objects menu appear in a context menu
that opens when you right-click on objects, contours, or nodes.
To delete a vector object:
1 Select the vector object to delete.
Note: To delete one object within a group, you must click its
name on the Layer palette.
2 Press the Delete key or choose Edit > Clear.
To edit the colors and materials of vector objects:
1 Select the vector object(s) you want to edit.
2 On the Materials palette, choose a new foreground or background
color or material. The background color controls an object’s fill
color. The foreground color controls an object’s line color. For
more information, see “Using the Materials Palette” on page 82.

Editing Vector Object Properties
Vector properties include the basics of vector objects such as line
width, line style, and anti-aliasing. You can also change the name of
the object (as it appears on the Layer palette) and change whether the
object is visible or not.
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To edit vector properties:
1 Select the vector object(s) you want to edit.
Object editing tip
You can also edit a vector object’s
properties, by selecting the object
and choosing the Pen tool.
Changing the settings in the Tool
Options palette will modify the
selected object.

2 Click Properties
on the Tool Options palette or choose
Objects > Properties to open the Property dialog.
Note: You can also open the dialog by double-clicking the
object’s name on the Layer palette.
3 Choose the line options (stroke width, join, miter, line style, and
anti-alias). For more information, see “Drawing Objects” on
page 229.
4 Choose stroke (line) and fill settings:
Stroke Clear the check box to choose no line. Mark the check
box and pick a color from the color box to choose line color.
Fill Clear the check box to choose no fill. Mark the check box and
pick a color from the color box to choose fill color.

Change object names from
the layer palette
On the Layer palette, right-click the
object name and choose Rename
from the context menu.

5 In the Name field, change the name of the object as it appears on
the Layer palette. If more than one object is selected, you must
change their names using the Layer palette.
6 To make the selected object(s) invisible or visible, clear or mark
the Visible check box. (You can also do this by clicking the
Visibility Toggle on the Layer palette.) Invisible objects are
often used as paths for text.
7 Click OK.
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Aligning and Arranging Vector Objects
Align and arrange vector objects in a variety of ways: align their
edges, distribute them evenly, center them on the image canvas, and
arrange their order (from top to bottom) on a layer.
Note
All of the commands in the Objects menu appear in a context menu
that opens when you right-click on objects, contours, or nodes.
To move a vector object:
Copying, and pasting vector
objects
Cut, copy, and paste vector objects
just like any other data. Select the
object and from the Edit menu,
select Cut or Copy.
To paste vector objects within the
same layer, choose Edit > Paste >
As New Vector Selection.
To paste vector objects as a new
layer, choose Edit > Paste >
As New Layer.
To paste vector objects as a new
image, choose Edit > Paste >
As New Image.

1 Select the object(s) you want to move.
2 Do any of the following:


Click inside a bounding box and drag the object or objects to a
new position.



To move one pixel at a time, press Shift or Ctrl and press the
Up, Down, Left, or Right arrow keys.



To move 10 pixels at a time, press Ctrl + Shift and press the
Up, Down, Left, or Right arrow keys.

Grouping and Ungrouping Vector Objects
To edit several objects in similar ways, group them together. When
objects are grouped, you can move, resize, reshape, and change their
lines and materials all at once. You can also group several groups of
vector objects.
When you group objects on different layers, Paint Shop Pro
automatically moves them all to the layer of the first object you
selected.
Each group has a label on the layer palette and all the objects in the
group are shown as components. Click the plus sign in front of the
group name to show the group’s components.
Note
Even if an object belongs to a group, you can still select it on the
Layer palette and edit it individually.
There are two ways to group objects: Use the Object Selection tool
or use the Layer palette.
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To group vector objects using the Object Selection tool:
How to edit one object
within a group
When you have a group of objects,
most Paint Shop Pro commands
apply to the entire group. However,
there are several ways to edit one
object within the group. First, click
the object name on the Layer
palette (the name becomes bold),
then you can:




Right-click the object name and
choose a command from the
context menu.
Move the object using the arrow
keys.

1 Use the Object Selection tool
the group.

to select each object you want in

2 On the Tool Options palette, click Group
Group.

or choose Objects >

To group objects using the Layer palette:
1 On the Layer palette, click the name of the first object you want to
group.
2 Press Shift and click each object you want to add to group.
3 Right-click one of the object names and choose Group from the
context menu.
Note: If you group objects from several layers, Paint Shop Pro
moves them all to the layer of the first object you selected.
To ungroup all objects in a group:
1 Select the group.
2 Do one of the following:


Choose Objects > Ungroup.



On the Object Selection tool’s Tool Options palette, click the
Ungroup button
.



On the Layer palette, right-click the group name and select
Ungroup from the context menu.

To remove a single object from a group:
On the Layer palette, drag the object from the group into another
group or layer.
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Aligning Vector Objects
You can align objects in relation to each other. For example, align
their top edges.

Align Tops

To align vector objects:
1 On the Tools toolbar, choose the Object Selection tool
Before

After

.

2 Select the first vector object. All other objects selected will align
to this object.
3 Press the Shift key and select each additional object you want to
align.
4 On the Tool Options palette, click one of the Object Alignment
buttons:
Top

, Bottom

, Left

Horizontal Center

, Right

, Vertical Center

, or

.

Note: You can also choose Objects > Align and select a
command.

Distributing Vector Objects
Distribute Vertical Tops

Before

After

You can evenly distribute vector objects in relation to each other.
For example, distribute three objects so that their top edges are
evenly spaced from each other. To distribute objects in relation to
the canvas, see “Positioning Vector Objects on the Canvas” on
page 242.
To evenly distribute objects:
1 On the Tools toolbar, choose the Object Selection tool

.

2 Select one object to select it. Press Shift and select the other
objects.
Note: You must have three or more objects selected to distribute
them in relation to each other.
3 Choose from the following:
Another way to distribute
With your objects selected, rightclick on an object. From the
context menu, select a distribution
method from Distribute Object.



To distribute objects in relation to each other:
On the Tool Options palette click one of the Object
Distribution buttons:
Vertical Top

, Vertical Center

Horizontal Right
Horizontal Left

, Vertical Bottom

, Horizontal Center
.

, or

,
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Positioning Vector Objects on the
Canvas
To align vector objects to the canvas:
Center on Canvas

1 On the Tools toolbar, choose the Object Selection tool

.

2 Click an object to select it.
3 On the Tool Options palette, click one of the Position on Canvas
buttons:
Before

After



Center in Canvas
, Horizontal Center in Canvas
Vertical Center in Canvas
.

, or

Note: All these commands are also available by choosing
Object > Align.
To distribute vector objects on the canvas:
1 On the Tools toolbar, choose the Object Selection tool

.

2 Click an object to select it.
3 On the Tool Options palette, click one of the Position on Canvas
buttons:
Space Evenly Horizontal

or Space Evenly Vertical

.

Note: All these commands are also available by choosing
Object > Distribute.

Arranging Vector Objects
Bringing the circle to the top

Each object you draw on a layer is stacked on top of the next (even if
they don’t overlap). If you draw 50 objects on a layer, the 50th is at
the top and the 1st in on the bottom. When you have overlapping
objects, you can move objects up or down the stack of objects.
To arrange vector objects:
1 On the Tools toolbar, choose the Object Selection tool
2 Click an object to select it.

.
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3 Do one of the following:
Using the Layer palette to
arrange vector objects
To change an object’s position on
a layer: select the object name in
the Layer palette, click and drag
the object up or down in the list of
objects.



To move an object to the top:
On the Tool Options palette, click Bring to Top

.



To move an object to the bottom: Click Send to Bottom



To move an object up or down one position:
Click Move Up

or Move Down

.

.

Note: All these commands are also available by choosing
Objects > Arrange.

Resizing and Reshaping Vector Objects
Quick steps for
proportional scaling
To resize a vector object and keep
the same proportions, select the
object with the Object Selection
tool and right-click and drag a
corner handle of the bounding box.

The Object Selection tool gives you the power to transform vector
objects and vector text interactively. Select an object and drag the
handles on the bounding box to resize, rotate, shear, distort, or apply
perspective. You can also resize and reshape a vector object by
editing its nodes and contours using the Pen tool. For instructions,
see “Editing Paths and Contours” on page 245.
Note
All of the commands in the Objects menu appear in a context menu
that opens when you right-click on objects, contours, or nodes.
To resize and reshape vector objects:
1 Use the Object Selection, Preset Shape, or Text tool to select an
object.

Reshaping Objects

2 Do one or more of the following:
Before

Shear

Symmetric
Perspective

Distort

Asymmetric
Perspective



To resize, click and drag one of the corner or edge handles.



To resize while keeping the current proportions, right-click
and drag a corner handle.



To change perspective symmetrically, press Ctrl and drag a
corner handle horizontally or vertically.



To change perspective asymmetrically, press Shift and drag a
corner handle.



To shear, press Shift while dragging a side handle.



To distort, press Ctrl and Shift while dragging a handle.
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To rotate vector objects:
1 Use the Object Selection tool
Rotation Controls

to select an object.

2 Click and drag the rotation handle.
Note: To change the center of rotation, press Ctrl while clicking
and dragging the rotation pivot point to a new location.

Rotation Pivot
Point

Making Vector Objects the Same Size
Rotation Handle

You can make all objects you select the same height, width, or both.
The dimensions of the first object selected are used for resizing.
To make vector objects the same size:

Same Size Both

1 On the Tools toolbar, choose the Object Selection tool

.

2 Click the first vector object. The first object controls how all the
other selections will be resized.
3 Press the Shift key and click the objects that you want to resize.
4 On the Tool Options palette, choose a Make Same Size option:
Before

After



Make Same Height



Make Same Width



Make Same Width and Height

Note: All these commands are also available by choosing
Objects > Make Same Size.
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Editing Paths and Contours
To fine-tune or completely transform vector objects, edit their nodes,
contours, and paths. For more detail on paths and contours see, “The
Anatomy of a Vector Object” on page 229. For more detail on types
of nodes, see “Editing Nodes” on page 251.
Note
All of the commands in the Objects menu appear in a context menu
that opens when you right-click on objects, contours, or nodes.
To edit a contour:
1 From the Tools toolbar, select the Pen tool

.

2 From the Tool Options palette, select Edit Mode

.

3 Click on a contour, then double-click one node to select all
nodes.
4 Choose Objects > Edit and select a command:
Cut Removes the selected contour to the Windows clipboard. If
the object has only one contour, the command removes the entire
object.
Copy Copies the selected contour to the Windows clipboard.
Paste Pastes a cut or copied contour into the current object.
Delete Deletes the selected contour.
Select All (Ctrl+A) Selects all nodes in the path.
Select None (Ctrl+Shift+A) Deselects any selected nodes.
Invert Selection (Ctrl+I) Selects all deselected nodes and
deselects all selected nodes.
To delete a contour:
1 From the Tools toolbar, select the Pen tool

.

2 From the Tool Options palette, select Edit Mode

.

3 Click on a contour, then double-click one node to select all
nodes.
4 Press Delete or choose Edit > Clear.
Note: You cannot delete a path. A path is deleted with its object
or when all its contours are deleted.

245

246

Chapter 10: Drawing and Editing Objects

To move a path:
1 From the Tools toolbar, select the Pen tool

.

2 From the Tool Options palette, select Edit Mode

.

3 To select the path, click on any contour in the path.
4 To move all the contours in the object (the path), click and drag
any contour.
To move a contour:
1 From the Tools toolbar, select the Pen tool

.

2 From the Tool Options palette, select Edit Mode

.

3 Do one of the following:


Hold down Shift and move the cursor over the contour. The
cursor will display “SUB.” Click and drag the contour.



Click on a contour or path, then double-click one node to
select all nodes. Click and drag one of the nodes.

Adding and Closing Contours
Adding a contour
to a preset shape

You can add new contours to any existing object, even objects you
created with the Preset Shapes tool. The new contour will have the
same properties (including color, material, line style, and so on) as
the selected object.
To add nodes to a contour, see “Adding or Removing Nodes on a
Contour” on page 254.
To add a contour to an object:
1 From the Tools toolbar, select the Pen tool

.

2 From the Tool Options palette, select Edit Mode

.

3 Click on an object to select it.
4 From the Tool Options palette, select Drawing Mode

.

5 Select a Segment Type and draw the new contour. For more
information, see “Drawing Lines and Custom Shapes” on
page 232.
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6 When you finish drawing the contour, do one of the following:
Another way to add
contours to an object:



You can paste a contour into a
selected contour.

To continue editing the contour, select Edit Mode from the
Tool Options palette.



To finish this object, choose another tool.

To close a contour:
1 From the Tools toolbar, select the Pen tool

.

2 From the Tool Options palette, select Edit Mode

.

3 Click on an contour to select it.
4 Do one of the following:


Choose Objects > Edit > Close (Ctrl+Shift+C).



Right-click on the contour and select Edit > Close from the
context menu



On the Tool Options palette, click
Close Selected open contours
.

Note: When you close a contour, Paint Shop Pro draws a segment
from the contour’s start to its end node.
To duplicate a contour:
Duplicating a contour

1 From the Tools toolbar, select the Pen tool

.

2 From the Tool Options palette, select Edit Mode

Before

.

3 Select one node on the contour.
4 From Objects > Edit choose:
Duplicate (Ctrl+D) Copies the selected contour and pastes it
directly on top of the original contour.
Duplicate
with
Offset

Note: The overlapping nodes will all show node-on-node
indicators.

Node on
Node
Duplicate
No
Offset

Duplicate & Offset (Ctrl+Shift+D) Copies the selected contour and
pastes it at an offset from the original contour. The default offset
is 10 pixels in the X and Y directions.
Note: To adjust the number of pixels contours are offset, type
new settings in the Duplication X and Duplication Y fields of the
Tool Options palette (for the Pen Tool).
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Reversing the Direction of Contours or Paths
Reversing a path with text

The direction of a contour flows from the start node to the end node.
When you place the cursor over the start node, “START” displays
next to the cursor. When you place the cursor over the end node,
“END” displays. If the object has an closed path, “CLOSE” displays.
For vector objects, you can reverse an entire path (all the contours in
the object) or reverse one contour within a path. The direction of a
contour or a path affects two important things:

Reversing a contour to create a
hollow shape



Text flow along a contour. Reverse direction to change how text
aligns on a contour.



Fill properties of overlapping contours. When contours with
different directions overlap, the resulting fill is transparent.
Reverse one contour overlapping another contour to create cutout
objects.

To reverse a path or contour:
1 From the Tools toolbar, select the Pen tool

.

2 From the Tool Options palette, select the Edit Mode

.

3 Click on a contour or path, then select on one node on the
contour.
Note: To reverse multiple contours, select one node from each
contour.
4 Right-click on the path or contour, choose Edit from the context
menu, and choose:
Reverse Path (Ctrl+Shit+R) or Reverse Contour (Ctrl+R).
Note: You can also access these commands by choosing
Objects > Edit.

Joining Contours
You can join two contours by connecting their end points.You can
manually drag nodes together to join them, or you can have Paint
Shop Pro automatically join two nodes.
To join two contours:
1 From the Tools toolbar, select the Pen tool

.

2 From the Tool Options palette, select the Edit Mode

.

3 Select one of the contours to show all nodes in the object.
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4 Select the start or end node of the first contour you want to join.
Note: You can only join contours in the same object.
5 Do one of the following:


To have Paint Shop Pro draw a contour between the points:
Press Shift and select the start or end node of the other
contour. Press Ctrl + J, or right-click and choose Edit > Join
from the context menu.



To join contours manually:
Click and drag the node over the other contour’s start or end
node. When the cursor displays “JOIN,” release the mouse
button.

To avoid joining contours
when moving nodes:
Hold down Ctrl while you drag.

Breaking Contours
Breaking a contour at a node

You can break a contour at any node. When you break a closed path
or contour, you open it. When you break an open path or contour,
you create two separate contours.
There are two ways to break contours: at a node or with the Pen tool.

Before

To break a contour at a node:
1 From the Tools toolbar, select the Pen tool

.

2 From the Tool Options palette, select the Edit Mode

.

3 Select the node you want to break the contour at.
4 Do one of the following:
After Break



Choose Objects > Edit > Break (Ctrl+K).



Right-click the node and choose Edit > Break from the context
menu.

The path or contour breaks and a new node is added on top of the
current node. The node square changes to a node-on-node
indicator. Drag one node away to separate them.
One node
dragged
away
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To break a contour with the Pen tool:
Breaking contours
with the Pen tool

1 From the Tools toolbar, select the Pen tool

.

2 From the Tool Options palette, select the Knife Mode

.

3 Select the contour you want to break.
Cutting in
Knife Mode

After

Breaking multiple contours
with the Pen tool

After
removing cut
sections

4 Click and drag across the contour where you want it to break.
Note
The Knife Mode of the Pen tool will cut through all selected
contours in an object.
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Editing Nodes
The Anatomy of a Node
Components of a Node
Selected Node
Control
arm

Control
Handle

Direction
Deselected
Node

Symmetrical Node

Asymmetrical Node

A node is a point on a contour that define the contour’s shape at that
point. The Nodes have zero, one, or two control arms extending from
them. The length and direction of the control arms determines the
shape of the contour at the node. Click on the control handles to
adjust control arms. The straight or curved line between two nodes is
a line segment.

Node Types
Symmetrical Choose this type to create a smooth flowing curve from
one side of the node to the other. Any adjustments to one control arm
are mirrored by the other.
Asymmetrical Choose this type to obtain a different amount of curve
on each side of the node, but still keep a smooth flow through the
node. You can independently adjust the length of each control arm,
but the not the direction.
Cusp Choose this type for nodes that have extreme changes in
direction. You can adjust the length and direction of each control
arm independently.
Smooth Choose this type of node to have create a smooth transition
between straight and curved line segments.

Cusp Node

Selecting Nodes
Smooth Node

To select one or more nodes:
1 From the Tools toolbar, select the Pen tool

.

2 From the Tool Options palette, select Edit Mode

.

3 Click a vector object. The object becomes an outline with nodes.
4 Do any of the following:


To select one node, click the node.



To deselect a node, press shift click the node.



To select multiple nodes, press Shift and click each node. Or,
click and drag a rectangle over the nodes.
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To select all nodes on a contour, double-click one node. If the
object has only one contour, this selects all nodes in the path.



To select all nodes in a path (all nodes in the object), press
Ctrl + A or right-click and choose Edit > Select All from the
context menu.



To select the next or previous node on a contour, press Shift
and press an arrow key.

Note: Start or end nodes are easy to find. The cursor will display
“START,” “END” when it is over the node. If the shape is
closed, the cursor will display “CLOSE.”

Moving Nodes
Node moving tips:
While you drag a node you can
constrain its line segments to 45
degree increments.
Hold down Shift to constrain the
previous segment. Hold down
Shif+Alt to constrain the next
segment.

Moving a node alters the shape of a vector object. If an object has
more than one contour, move a contour by moving all of its nodes.
Move the path to move the entire object.
To move a node:
1 From the Tools toolbar, select the Pen tool

.

2 From the Tool Options palette, select the Edit Mode

.

3 Click and drag a node to a new position or press the arrow keys.
Note: To move multiple nodes, select them and click and drag a
selected node.

Changing Curves and Lines
You can adjust the shape of the contour at a node by changing the
node type, adjusting the node’s control arms or changing the line
segments.
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Changing Node Types
For example, to soften a sharp corner, change a cusp node to a
symmetrical node.
To adjust a curve by changing the node type:
1 From the Tools toolbar, select the Pen tool
From Cusp to Symmetrical

.

2 From the Tool Options palette, select the Edit Mode

.

3 Select a node.
4 Do one of the following:


Choose Objects > Node Type and select a node type:
Asymmetrical (Ctrl+Shift+S)
Symmetrical (Ctrl+S)
Cusp (Ctrl+U)
Smooth



Right-click on the node, choose a Node Type from the context
menu.

Adjusting Nodes with Control Arms
Adjusting Control Arms

The length and direction of a nodes control arms determines the
shape of the contour at the node. The arrow control handle indicates
the direction of the contour.
To adjust a curve using control arms:
1 Select a node to display its control arms.
Note: Cusp nodes may have no control arms.
2 Move the cursor over a control handle until the cursor changes to
two rotating arrows, and then click and drag the handle.
Note: To constrain the control arms to fixed angles (45 degree
increments), press and hold Shift as you drag.

Changing Line Segments
Instead of changing node types, you can simply tell Paint Shop Pro
what type of line segment you want on each side of the node. You
can also convert line segments from curved to straight. The line
segment type and node type work together. For example, when you
add a straight line before or after a symmetrical curve, the node type
changes to asymmetrical.
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To change the line segment before or after a node:
1 Select a node.
Changing Line Segments

2 Do one of the following:


Choose Objects > Node Type and select an option:
To straighten the segment before and after a node, choose
Convert to Line. (Ctrl+L).
To straighten the segment before or after a node, choose Line
Before (Ctrl+B) or Line After (Ctrl+F).
To curve the segment before or after a node, choose Curve
Before (Ctrl+1) or Curve After (Ctrl+2).



Right-click the node and choose a Node Type from the context
menu.

Original

Line Before

3 Make a selection:
Line After

Note: You can also access these commands by choosing
Objects > Node Type.
To straighten a curve between two nodes:
1 Select two consecutive nodes.

Convert to Line

2 Right-click one node and choose Node Type >Convert to Line
from the context menu.

Adding or Removing Nodes on a
Contour
To create more options for editing the shape of a vector object, add,
delete, or merge nodes anywhere along the path of a vector object.

Adding Nodes
You can add nodes in all three modes of the Pen tool.
To add nodes on a contour (Drawing and Edit Modes):
1 From the Tools toolbar, select the Pen tool
Adding Nodes in
Drawing or Edit Modes

.

2 From the Tool Options palette, select Edit Mode

.

3 Click the contour you want modify.
4 Press and hold Ctrl as you move the cursor over the contour to
where you want to add a node. The cursor displays “+ADD.”
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5 While continuing to press Ctrl, click the line. A symmetric node
is added.
To add nodes on a contour (Knife Mode):
1 From the Tools toolbar, select the Pen tool
Adding nodes in Knife Mode

.

2 From the Tool Options palette, select Knife Mode

.

3 Click the contour you want modify.
4 Press and hold Ctrl. The cursor changes from “CUT” to “ADD.”
Click and
drag to add
nodes

5 Click and drag the cursor across the contour where you want to
add nodes.
To add a new start or end node:
1 From the Tools toolbar, select the Pen tool

.

2 From the Tool Options palette, select the Drawing Mode
the Segment Type you want to use.
After

and

3 Select the start or end node of the contour.
4 Click to draw another node, the contour automatically connects
to the new node.
5 Do one of the following:


Continue drawing new nodes.



To edit the nodes or contour, click the Edit Mode



To finish the changes, choose another tool.

.
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Deleting or Merging Nodes
Deleting vs. Merging
Node

Merging nodes on a contour removes the nodes from the contour, but
retains the line segments on each side. The line segments are
combined into one line segment between remaining nodes. If the
contour is curved at the node, Paint Shop Pro attempts to retain the
curve.
Deleting a node on a contour removes the node and line segments on
each side. If you delete a node in the middle of an open contour, the
vector object becomes two separate contours. If you delete a node in
a closed contour, the contour opens.

Deleted

Merged

To merge one or more nodes:.
1 Select the node you want to merge.
2 Merge the node in one of these ways:.


Choose Objects > Edit > Merge (Ctrl + M).



Right-click on the node and choose Edit > Merge from the
context menu.



Press Ctrl, move the cursor over the node until “MERGE”
displays, and then click the node.

To delete a node and its line segments:
1 Select the node you want to delete.
2 Do one of the following:


Press Delete.



Right-click and choose Edit > Delete from the context menu.



Choose Objects > Edit > Delete.

Note: To delete one line segment, break the path at one node of
the line segment, and then delete the new node that is created.
For information on breaking paths, see “Breaking Contours” on
page 249.
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Transforming Nodes
You can change the shape of a contour by manipulating its nodes in
a variety of ways, such as flipping, mirroring, and rotating.

Transforming Nodes

Transform nodes using the Object menu commands or the Tool
Options palette.
Flip

Using the Object Menu to Transform Nodes
The Objects menu will transform selected nodes using the current
settings for each transformation command.

Mirror

To transform nodes with the current settings:
1 Select the nodes you want to transform.
2 Choose Objects > Transform Selected Nodes and choose a
command:

Expand

Flip (Ctrl+Shift+F) Moves selected nodes along the vertical
axis—those on top go the bottom and vice versa. Applied to a
single node, the control arms (if any) will flip.
Mirror (Ctrl+Shift+M) Moves selected nodes along the horizontal
axis—those on the left go to the right and vice versa. Applied to a
single node, the control arms (if any) will mirror.

Contract

Rotate Rotates the selected nodes by the current rotation setting.
Applied to a single node, the control arms (if any) will rotate.
Skew X Moves selected nodes to the left or right (along the
horizontal axis) using the current skew setting.

Skew Y

Skew Y Moves selected nodes to the left or right (along the
vertical axis) using the current skew setting.
Contract (F8) Moves the selected nodes closer to each other by
the current contraction setting. Cannot be applied to a single
node.
Expand (F9) Moves the selected nodes away from each other by
the current expansion setting. Cannot be applied to a single node.
Note: To adjust the transform settings, see “Using the Tool
Options Palette to Transform Nodes” on page 258.
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Using the Tool Options Palette to Transform
Nodes
You can set and apply transformations to selected nodes from the
Pen tool’s Tool Options palette.
To adjust and apply transformation settings:
1 From the Tools toolbar, select the Pen tool

.

2 From the Tool Options palette, select the Edit Mode
Note: You may need to click the More button
options in the Tool Options palette.

.

to view all the

3 Select the node(s) to transform.
4 From the Tool Options palette select a transform function:
Expand
Contract

Sets the number of pixels to expand nodes.
Sets the number of pixels to contract nodes.

Skew X
Sets the number of pixels to skew nodes on the
horizontal axis.
Skew Y
Sets the number of pixels to skew nodes on the
vertical axis.
Rotate Sets the degrees nodes will rotate.
5 Type a value for the selected transformation setting.
6 Click Apply

.
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Working with Layers
Layers are fundamental to creating and editing images in
Paint Shop Pro. Use layers to add elements to your images, create
artistic effects and illustrations, and make editing images easier. You
can add or delete layers, rearrange their stacking order (the order
from top to bottom), and blend their pixels in a variety of ways.
Unless you merge the layers, each one remains independent; you can
edit it without affecting the others.
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About Layers
Ways to use layers
For descriptions of the many tasks
you can accomplish with layers,
check out these sections:



“Using Layers with Photographic
Images” on page 263
“Using Layers with Illustrations”
on page 264

When you create or import an image in Paint Shop Pro, the image
has a single layer. For simple retouches and corrections, you do not
have to add any layers. However, if you want to add new elements to
your image, use layers to make changes and artistic effects easier.
Each layer that you add begins as a transparent sheet over the
background. As you add brush strokes, objects, or text, you cover up
parts of the Background layer. Transparent parts allow you to see
through to underlying layers. Stack up multiple layers to create
whatever effect you’d like—such as artistic compositions, photo
collages, or complex illustrations.
In the following illustration, each image is on a separate layer. The
background layer is transparent.
Creating image compositions with layers

Chapter 11: Working with Layers

Types of Layers
Raster and vector data
For more information on raster and
vector data, see “About Raster and
Vector Graphics” on page 32.

There are five types of layers: background, raster, vector, mask, and
adjustment. The icon before the layer name on the Layer palette
shows the type of layer. In addition, you can create layer groups, and
promote selections to layers.

Raster Layers
How many layers?
Paint Shop Pro supports up to 500
layers. The actual number of layers
allowed in an image may be limited
by the amount of memory in your
computer.

Raster layers
are layers with raster data only. Raster data is
composed of individual elements, called pixels, arranged in a grid.
Each pixel has a specific location and color. Photographic images
are composed of raster data. If you magnify raster data, you can see
the individual pixels as squares of colors.
Use raster layers for displaying subtle changes in tones and colors.
Or, use raster layers for objects and raster text on which you want to
apply raster-only commands and tools. The effects commands, the
painting tools, and many other tools apply only to raster layers.
Raster data must be on raster layers (a regular raster layer or the
background layer). If you try to use a raster tool while a vector layer
is selected, Paint Shop Pro prompts you to convert the vector layer
into a raster layer.

Adjustment Layers
Adjustment layers are correction layers that adjust the color or tone
of underlying layers. Each adjustment layer makes the same
correction as an equivalent command on the Colors > Adjust menu,
but does not change image pixels like the command does.
Saving multi-layer images
When you create multi-layer
images, you must save them i
PspImage format (Paint Shop Pro’s
native format) to maintain all layer
information.
When you save to most other
formats, all layers are merged into
one background layer. When you
save to .PSD (PhotoShop) format,
the image maintains raster and
adjustment layers, but vector
layers are converted to raster
layers.

Adjustment layers cannot be the bottom layer. You will not be able
to delete other layers if deleting them causes an adjustment layer to
become the bottom layer. For more information, see “Using
Adjustment Layers” on page 283.

Mask Layers
Mask layers
show or hide portions of underlying layers. A mask
is basically an adjustment layer that modifies opacity. Use masks to
create sophisticated effects. For example, mask all details around the
main subject in a photograph, or use a mask to create a picture frame
that fades away at the center to reveal the subject.
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Mask layers cannot be the bottom layer. You will not be able to
delete other layers if deleting them causes a mask layer to become
the bottom layer. For more information, see Chapter 12, Working
with Masks.

Vector Layers
Color depth
Only greyscale and 16 million color
images can have multiple raster
layers. Images of any color depth
can include multiple vector layers.

Vector layers
are layers with only vector objects (lines and
shapes), vector text, or vector groups. Vector objects and text are
composed of geometric characteristics—lines, curves, and their
locations. When you edit vector objects and text, you edit these lines
and curves, rather than editing individual pixels. Vector graphics and
vector text maintain their clarity and detail when scaled to any size
or printed at any resolution.
Use vector layers to create objects or text that you can easily edit. To
display the names of vector objects on a vector layer, click the plus
sign in front of the layer name on the Layer palette.
Vector objects must be on vector layers. If you create a vector object
while a raster layer is selected, Paint Shop Pro creates a vector layer
just above the current layer. In addition, you cannot move a vector
layer to a non-vector layer.

Background Layer
Background layer or not?
Paint Shop Pro supports
transparency on layers other than
the background. To create an
image without transparent areas,
choose a solid colored background.
The image will contain a
background layer as the bottom
layer.
To create a new image with
transparent areas, choose a
transparent background. The
image will contain a raster layer as
the bottom layer.
For more information on creating
new images, see “Creating Images”
on page 32.

The background layer
is the bottom layer of an image. It is
named “Background” on the Layer palette and cannot be renamed.
When you import file formats such as JPEG, GIF, or PNG into
Paint Shop Pro, they are one layer—the background layer.
The background layer contains raster data but cannot display
transparency. You cannot change its order in the stack, its blend
mode, or its opacity.
To move a background layer higher in the stacking order, promote it
to a regular raster layer; see “Promoting a Background Layer to a
Regular Raster Layer” on page 268.
If you create a new image with a transparent background, it does not
have a background layer and its bottom layer is a raster layer named
“Raster Layer 1”. You may move this layer anywhere within the
stacking order, or change its opacity or blend mode.
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Using Layers with Photographic Images
Original photographs and the
resulting photo collage

When you open a digital photograph or scanned image in Paint Shop
Pro, the image is on the background layer. For most photographic
enhancements, such as cropping, correcting colors, or retouching,
you can work on this background layer without ever adding another
layer.
However, there are many ways to use layers with your photographic
images to make changes easier and create interesting effects:
Task

How to Do It with Layers

Preserve the original Make a duplicate copy of the background layer
image before
(choose Layers > Duplicate). Turn off the visibility
making changes.
of the background layer (click the layer’s Visibility
button ) and make all changes to the duplicate
layer.
Make color and
tonal corrections.

Use adjustment layers instead of changing the image
directly. For more information, see “Using
Adjustment Layers” on page 283.

Add text or
graphics.

Add them as vector objects to a new vector layer. (If
you add them to the raster layer with the image, you
must add them as raster data and they’ll be difficult
to edit.)

Create interesting
effects.

Duplicate the background layer, apply an effect to
the duplicate, and then change the opacity or blend
range of the modified layer to blend the two layers.

Create a photo
collage.

Place each photograph on a separate layer. (For each
image, choose Edit > Copy to copy the image, select
the collage image, and choose Edit >
Paste as New Layer. Position each layer with the
Move tool.
Use each layer’s opacity setting and blend mode to
control how much of each layer shows through. Use
a mask to hide parts of a layer or create soft edges
around a layer.
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Task

How to Do It with Layers

Create a panoramic
photograph.

Take a series of photographs with overlapping
subject matter, then stitch the photographs together
using layers.
Create an image with a canvas large enough to
display the panorama, then copy each photograph
onto a separate layer. Decrease the opacity of one
layer to see though it as you use the Move tool to
match up the edges of the other photograph. Do this
with each layer, then return the layers to 100 percent
opacity.

Using Layers with Illustrations
Individual layers and the final
illustration

Layers are invaluable for illustrations. Here are some of the many
ways to use layers:
Task

How to Do It with Layers

Make changes
easier.

Create individual components on separate layers to
make them easy to edit together. For example, if
you have an illustration of a car speeding down a
highway in the mountains, create the car, the driver,
the highway, and the mountains on separate layers.

Move multiple
layers together
on the image
canvas.

Link or group layers that need to move together.
For example, link the car and the driver in this
example so that when you move the car to the left,
the driver moves too.

Edit graphical
elements.

Create objects you need to fine-tune or edit as
vector objects on vector layers.

Apply rasteronly commands
and effects to
vector objects.

Create a new layer with raster copies of the vector
objects. To do this, duplicate the vector layer and
then convert it to a raster layer. Turn off the
visibility of the vector layer.

Experiment with
changes.

Make a copy of a layer and try out changes. Turn
the visibility of a layer off and on to see which
works best in the overall image.

Save work-inprogress.

Keep a copy of the intermediate steps of
transformations, then turn off the visibility of those
layers. If you need to go back a few steps at a later
date, you’ve got the data.
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Using the Layer palette
The Layer palette lists all layers in an image. The order of layers on
the palette is the order of layers in the image. The top layer is listed
first and the bottom layer is listed last. Change this stacking order by
dragging a layer to a new position on the Layer palette.
Note
 Adjustment and mask layers cannot be the bottom layer.


Vector objects cannot be moved from their layer group.

Create layer groups to organize the Layer palette. Link layers or
groups so they move together when you use the Move tool in the
image.
The left panel of the Layer palette displays the names of layers and
layer groups. The icon to the left of each name indicates the type of
layer (background, raster, vector, mask, adjustment, group, or
floating selection). When there are more layers than the palette can
display, use the scroll bars on the right side to move the list of layers
up or down.
The right panel of the Layer palette displays options for the layer,
including visibility, opacity, blend mode, link set, and lock
transparency.
The Layer palette toolbar includes buttons for command tasks, such
as adding a new raster or vector layer. To add and remove toolbar
buttons, see “Customizing Toolbars and Menus” on page 412.

Layer Palette
toolbar

Raster
layer

Vector
layer

Layer Link
button

Visibility
toggle

Lock Transparency
button

Group Link
button
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Displaying the Layer palette
Display or hide the Layer palette, or move it anywhere on the screen.
For information on moving, docking, and undocking the Layer
palette, see “Using Palettes” on page 16.
To display or hide the Layer palette:
Choose View > Layer palette or press F8.

Viewing the Contents of Layers
Seeing layer contents

The image window shows all visible layers in the image. To view a
thumbnail of a layer’s contents, use the Layer palette.
To turn off or on the visibility of layers in the image window, see
“Showing and Hiding Layers, Groups, and Vector Objects” on
page 270.
To view the contents of one layer:
On the Layer palette, move the cursor over a layer name to display a
thumbnail of the layer contents.

Selecting Layers
Selecting a layer

When an image has more than one layer, you must select the layer
you want to work on. Changes to the image affect only the selected
layer (also called the active layer). You can select only one layer at a
time.
To select a layer:
On the Layer palette, click the name of the layer to highlight the
selected layer.

Expanding and Contracting Layers and
Layer Groups
The Layer palette displays its components like the “tree” of folders
and directories in Windows Explorer. Items that have subcomponents have a minus sign in front of them when expanded or a
plus sign when contracted.
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Expand a vector layer or layer group to see the names of its subcomponents. Contract a vector layer or layer group to make the
Layer palette easier to navigate.
To expand a layer or layer group:
On the Layer palette, click the plus sign
or layer group name.

in front of the vector layer

To contract a layer or layer group:
On the Layer palette, click the minus sign
layer or layer group name.

in front of the vector

Adding New Layers to Images
Color depth
An image must be greyscale or 16
million color to create adjustment
layers or more than one raster
layer. If you have an image of
another color depth, Paint Shop
Pro prompts you to convert it to 16
million colors when you try to add a
new adjustment or raster layer.

Alternative ways to create
new layers
For all layer types, place the cursor
over a layer name on the Layer
palette, and then right-click and
select the new layer type from the
context menu.
To create a layer with default layer
properties, press Shift and click
one of the new layer buttons on the
Layer palette: New Raster Layer,
New Vector Layer, or
New Mask Layer.

There are many ways to add layers to images. Create a new layer,
promote the background to a regular layer, duplicate an existing
layer, or make a selection and turn it into a layer.

Creating New Layers
Create new layers to use for placing new elements in your images.
To create a new layer:
1 On the Layer palette, click the layer which you want to add a layer
above.
2 Do one of the following:


To create a new raster layer, click the New Raster Layer
button
or choose Layers > New Raster Layer.



To create a new vector layer, click the New Vector Layer
button
or choose Layers > New Vector Layer.



To create a new mask layer, click the New Mask Layer button
or choose Layers > New Mask Layer > Show or Hide. For
information on mask show or hide layers, see “Creating New
Mask Layers” on page 290.



To create a new adjustment layer, choose Layers >
New Adjustment Layer and choose a type of adjustment layer.
For information on adjustment layers, see “Using Adjustment
Layers” on page 283.
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3 Edit the layer properties as desired and click OK. For more
information, see “Editing Layer Properties” on page 270.
The new layer is added above the active layer. It is named with the
type of layer and a number, such as “Vector Layer 1.” To rename the
layer, see “Renaming Layers” on page 270.

Promoting a Background Layer to a
Regular Raster Layer
More about background
layers
For more information, see
“Background Layer” on page 262.

When you want the background layer to function like a regular raster
layer, promote it to a layer. Unlike the background layer, raster
layers support transparency and can be moved anywhere within the
stacking order.
To promote a background layer:
Choose Layers > Promote to Layer, or right-click on the layer and
select Promote to Layer.

Duplicating Layers
Copying all layers to
another image
Use the Browse window to copy all
layers of an image into another
image.
For more information, see “Copying
One Image into Another Using the
Browser” on page 125.

Duplicate a layer within an image to use as a starting point for a new
layer, or to try out edits and effects while keeping the original layer
intact. Or, copy a layer to another image.
To duplicate a layer within the same image:
Do one of the following:


Click its name on the Layer palette, then choose Layers >
Duplicate.



Right-click its name on the Layer palette, then choose Duplicate
from the context menu.



Click its name on the Layer palette, choose Edit > Copy to copy
the layer, and then choose Edit > Paste > As New Layer.

The duplicated layer is added just above the current layer.
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To copy a layer to another image:
Do either of the following:


On the Layer palette, click and drag the name of the layer or
layer group onto an open image, and then release the mouse
button. Paint Shop Pro adds the layer above the selected layer of
the second image.



On the Layer palette, click the name of the layer or layer group
that you want to copy, choose Edit > Copy, select the image to
copy to, and then choose Edit > Paste > As New Layer. The layer
is pasted to the center of the canvas.

Creating Raster Layers from Selections
How to start a new vector
layer with a vector selection
Use the Object Selection tool to
select one or more vector objects,
choose Edit > Copy to copy the
object(s), and then choose Edit >
Paste > As New Layer.

Cleaning up selection edges
When you promote a selection,
some of the pixels surrounding the
selection border may be included,
especially when the selection is
anti-aliased or feathered. Use the
Matting commands to clean up the
border by removing these pixels.
To clean up a selection before you
copy or promote it, see “Cleaning
Up the Edges of a Selection” on
page 171.
To clean up a layer created from a
selection, see “Cleaning up the
Edges of Layers Created from
Selections” on page 282.

Use the Selections > Promote to Layer command to promote a
selection to a layer. Use the Selection, Freehand Selection, or Magic
Wand tool to make a raster selection of raster or vector data. The
new layer is always a raster layer.
You can also copy a raster selection and paste it as a new layer.
To create a raster layer from a selection:
1 Use the Selection, Freehand Selection, or Magic Wand tool to
make a selection on the image.
2 Do one of the following:


Choose Selections > Promote to Layer. The new layer is
named Promoted Selection.



Choose Edit > Copy to copy the selection, and then choose
Edit > Paste > As New Layer. The new layer is named Raster
plus a number (Raster 1).

269

270

Chapter 11: Working with Layers

Editing Layer Properties
Layer properties are everything you see on the Layer palette: the
name, layer grouping and linking, layer opacity, blending,
transparency protection, and layer icon highlight colors. To change
properties, double-click a layer name to display the Layer Properties
dialog or make changes in the right panel of the Layer palette. For
information about editing an adjustment layer, see “Editing an
Adjustment Layer” on page 285.

Renaming Layers
As you add layers to an image, you may find it convenient to rename
the layers so they are easy to identify on the Layer palette.
To rename a layer:
Alternative way to rename
Double-click the layer name to
display the Layer Properties dialog
and enter a new name in the Name
edit box.

1 On the Layer palette, right-click the name of the layer and choose
Rename from the context menu.
2 Type the name and press Enter.

Showing and Hiding Layers, Groups,
and Vector Objects
Original image, and image with
all layers but one made invisible

Use the Visibility toggles on the Layer palette to make layers, layer
groups, or vector objects visible or invisible in the image. These
items remain in the image but are hidden. When a layer is visible, the
Visibility toggle displays
. When a layer is hidden, the Visibility
toggle displays .
To show or hide individual layers and layer groups:
Do one of the following on the Layer palette:


Click the Visibility toggle for each layer or Layer Group you
want to show or hide.
Note: Hiding a layer group hides all of the layers within that
group.



To show one layer only, right-click a layer name and choose
View > Current Only from the context menu.
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To show all layers:
Choose Layers > View > All, or right-click a layer name and choose
View > All from the context menu.
To invert which layers are shown or hidden:


Right-click a layer name and choose View > Invert from the
context menu. All previously visible items become invisible and
all invisible items become visible.



Right-click the layer name of a linked group and choose
View > Invert from the context menu.

To show or hide vector objects:
On the Layer palette, click the Visibility toggle for each vector object
you want to show or hide.

Grouping Layers
Modify that layer group
Here are some of the possible
ways to modify a layer group:







Edit its layer properties, such as
its opacity and blend mode. See
“Editing Layer Properties” on
page 270.
Drag it to a new position in the
image’s stacking order. All of its
layers move too.
Rename it. See “Renaming
Layers” on page 270.
Delete it—Paint Shop Pro
deletes all of its layers too. See
“Deleting Layers or their
Contents” on page 282.

Create layer groups to group multiple layers together. Layer groups
allow you to do the following:


Organize the Layer palette.



Set layer properties, such as opacity and blend mode, for the
whole group.



Limit the effect of adjustment layers to layers below them in a
group rather than in the entire image.



Move all grouped layers in the stacking order by clicking and
dragging the layer group name.



Move layers together on the image canvas—if the group is
linked. (Otherwise grouped layers move independently.) For
more information, see “Linking Layers and Layer Groups” on
page 272.

Layer groups can contain raster, vector, mask, and adjustment
layers, and must contain at least one layer. Layer groups can also
contain other layer groups (called nested groups). If you move all of
the layers out of a layer group, Paint Shop Pro deletes the layer
group.
Note
 Adjustment and mask layers cannot be the bottom layer.


Vector objects cannot be moved from their layer group.
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To create a layer group:
1 On the Layer palette, click the first layer to be in the layer group.
2 Do one of the following:
How to add a layer to the
bottom of a layer group
Drag the layer to the second-tobottom position. Then drag the
bottom layer up.



On the Layer palette, click the Layer Group button



Choose Layers > New Layer Group. The Layer Properties
dialog opens. Make changes as necessary and click OK.



Choose Layers > Arrange > Move Into Group.

.

The layer group is created, and the selected layer becomes part of
the layer group. By default, the layer group is named Group with
a number (for example, Group 1).
3 To add a layer to the layer group, click its name and drag it into
the layer group. A black line shows the position until you release
the mouse button.
Note: You can also add a layer group within a layer group (called
a nested group).
To remove a layer from the group:

Drag the layer to a new position outside the layer group, or choose
Layers > Arrange > Move Out of Group.
To ungroup layers:

Select the layer group that you want to ungroup, and then choose
Layers > Ungroup Layers.

Linking Layers and Layer Groups
Use layer linking to have layers move together on the image canvas
when you move one layer with the Move tool. To link individual
layers, use the Layer Link button on the Layer palette. By default,
this button says “None.” Change each layer that you want to link to
the same number, say “1” or “2.” Left-click to increase the number;
right-click to decrease it.
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An image with a linked group
and linked layers
Layer Link
button

Group Link
button

Use group linking to have all layers within a layer group move
together on the image canvas. The Group Link button on the Layer
palette displays a blue icon when the group is linked or a grey
icon when the group is not linked.
Layer links take precedence over group links. For example, Layer
Group 1 is linked and contains Layer1, Layer2, and Layer3. Layer1
is set to link number 1. Layer4 (outside of the layer group) is also set
to link number 1. If you move Layer4, Layer1 will move. If you
move Layer2, Layer1 will not move.
To link layers:
For each layer you want to link, change its link set number to the
same number. Do either of the following on the Layer palette:


Left-click the Layer Link button
to increase the number.
Right-click the Layer Link button to decrease the number.



Double-click each layer name to display the Layer Properties
dialog, change the Link Set number, and then click OK.

To unlink layers:
Does linking affect the
stacking order?
No. Linking affects only
movements within the image
canvas using the Move tool.
The only way to move layers
together in the stacking order is to
group them. When you move a
group layer in the stacking order,
all layers move (regardless of
whether the group is linked or not).

For each layer you want to remove from the link set, do either of the
following on the Layer palette:


Left-click or right-click the Layer Link button until it displays
None.



Double-click the layer name to display the Layer Properties
dialog, change the Link Set number to 0, and then click OK.

To link or unlink layer groups:
Do either of the following on the Layer palette:


Click the Group Link button
unlinked.



Double-click the layer name to display the Layer Properties
dialog, mark or clear the Group is Linked check box, and then
click OK.

. A grey button means the group is
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Changing Opacity of Layers
To create interesting effects, vary the opacity of a layer from the
default of 100 percent (fully opaque) down to 0 percent
(transparent). When a layer is partially transparent, layers below it
show through.
To change the opacity of all layers within a layer group, set the
opacity of the layer group.
The Opacity setting of the Layer palette displays the opacity of each
layer. The overall opacity of a layer and the opacity of individual
pixels are independent of each other. For example, if a pixel starts at
50% opacity and the layer is set to 50% opacity, the pixel will appear
25% opaque. If the layer is also in a layer group that is set to 50%
opacity, then the pixel opacity will be 12.5% opaque.
To set the opacity of a layer or layer group:
1 On the Layer palette, click the name of the layer.
2 Do one of the following:


Drag the Opacity slider



Double-click the layer name to display the Layer Properties
dialog, change the Opacity setting, and click OK.

to the desired percentage.

Blending Layers
Blend modes: Normal, Darken,
Luminance, and Dissolve

Create interesting effects by changing the way pixels of one layer
blend with pixels of underlying layers. Paint Shop Pro contains a
variety of blend modes that specify how it blends pixels. The image
displays the blended pixels, but layers are not actually combined.
By default, each layer has a blend mode of Normal, which blends
pixels based on the opacity of the selected layer. The pixels of the
selected layer are blended with the combination of all underlying
layers, not just the layer directly beneath it.
To limit the pixels that the blend mode affects, set the blend range.
See “Setting Blend Ranges” on page 277.
To set the blend mode of a layer:
On the Layer palette, click the Blend Mode drop-down list of the
layer you want to set and select the blend mode from the list. For
descriptions of the blend modes, see “About Blend Modes” below.
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About Blend Modes
Color depth and layers
The Hue, Saturation, Color, and
Luminance blend modes are
available only for 16 million color
images.
The Multiply, Screen, Difference,
and Exclusion blend modes
produce the same result no matter
how layers are ordered within the
Layer palette.

The table describes each of the blend modes. In the table, “selected
layer” refers to the layer for which you are setting the blend mode.
Note
Several of the blend modes have been enhanced, the transfer of color
channels has been improved. These blend modes may not be
compatible with other applications. Use the Legacy blend modes for
compatibility with other applications.
Blend Mode Result
Normal

Displays pixels of underlying layers based on the opacity
of pixels on the selected layer. If data is fully opaque, no
pixels show through. As the opacity decreases, more
pixels from underlying layers show through.

Darken

Displays pixels in the selected layer that are darker than
the underlying layers. Pixels lighter than the underlying
layers disappear.

Lighten

Displays pixels in the selected layer that are lighter than
the underlying layers. Pixels darker than the underlying
layers disappear.

Hue

Applies the hue of the selected layer to the underlying
layers (without changing the saturation or lightness).

Hue (Legacy)

Applies the hue of the selected layer to the underlying
layers (without changing the saturation or lightness).

Saturation

Applies the saturation of the selected layer to the
underlying layers (without affecting the hue or lightness).

Saturation
(Legacy)

Applies the saturation of the selected layer to the
underlying layers (without affecting the hue or lightness).

Color

Applies the hue and saturation of the selected layer to the
underlying layers (without affecting the lightness).

Color
(Legacy)

Applies the hue and saturation of the selected layer to the
underlying layers (without affecting the lightness).

Luminance

Applies the luminance (or lightness) of the selected layer
to the underlying layers (without affecting the hue or
saturation).

Luminance
(Legacy)

Applies the luminance (or lightness) of the selected layer
to the underlying layers (without affecting the hue or
saturation).
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Blend Mode Result
Multiply

Combines the colors of the selected layer with the
underlying layers to produce a darker color. Multiplying
any color with black produces black. Multiplying any
color with white leaves the color unchanged.

Screen

Lightens the colors of underlying layers by multiplying
the inverse of the selected and underlying layers. The
result is a color that is the same or a lightened version of
the selected layer.

Dissolve

Randomly replaces the colors of some pixels on the
selected layer with those of the underlying layers to create
a speckled effect. The selected layer’s opacity determines
the number of pixels replaced; the lower the opacity, the
more pixels that are replaced.

Overlay

Combines the Multiply and Screen blend modes. If the
color channel value of underlying layers is less than half
the maximum value, the Multiply blend mode is used. If
the color channel value is greater than or equal to half the
value, the Screen blend mode is used. The Overlay blend
mode shows patterns or colors of the selected layer while
preserving the shadows and highlights of underlying
layers.

Hard Light

Combines the Multiply and Screen blend modes. If the
color channel value of the selected layer is less than 128,
the Multiply blend mode is used. If the color channel
value is greater than or equal to 128, the Screen blend
mode is used. In general, use the Hard Light blend mode
to add highlights or shadows.

Soft Light

Combines the Burn and Dodge blend modes. If the color
channel value of the selected layer is less than 128, the
Burn blend mode is used. If the color channel value is
greater than or equal to 128, the Dodge blend mode is
used. In general, use the Soft Light blend mode to add soft
highlights or shadows.

Difference

Subtracts the selected layer’s color from the color of the
underlying layers.

Dodge

Lightens the image by having the lightness values of the
colors in the selected layer lighten the colors of
underlying layers. Light colors produce the most
lightening; black has no effect.

Burn

Darkens the image by having the lightness values of the
selected layer reduce the lightness of underlying layers.
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Blend Mode Result
Exclusion

Creates an effect similar to but softer than the Difference
blend mode.

Setting Blend Ranges
Blend ranges: normal, 50%,
60%, and 75%

In addition to setting the blend mode of a layer, you can set the blend
range. This range limits the pixels that the blend mode affects. By
default, the blend mode applies to all pixels. Blend ranges set the
opacity based on brightness or color channel to drop colors out of the
selected layer and make other colors show through.
To set the blend range:
1 On the Layer palette, select a layer and set its blend mode. (See
“Blending Layers” on page 274.)
2 Double-click the layer name to open the Layer Properties dialog.
3 Click the Blend Ranges tab.
4 In the Blend Channel drop-down list, select a channel to use
when blending layers. Select Grey Channel to have the lightness
values of layers determine opacity. Select Red Channel, Green
Channel, or Blue Channel to have the respective color values
determine opacity.
5 Set the opacity ramp for the channel as follows:


First, drag the upper arrows to indicate the values at which the
opacity is 100 percent.



Next, drag the lower arrows to indicate the values at which the
opacity is 0 percent.

Note that the values on the left side indicate the ramp up values,
while the values on the right side indicate the ramp down values.
Setting the blend ranges

For example, in the graphic in the left column, the selected
layer’s opacity is 100 percent between lightness values of 43 and
126, and falls off at the lightest and darkest areas.
6 Click OK.
Paint Shop Pro applies the blend only to the pixels that fall within
the range you selected. The right panel of the Layer palette displays
the Blend Range icon
to indicate that a blend range is being used.
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Protecting Transparent Areas
To apply tools and effects only to areas of a raster layer with data,
use the Lock Transparency feature on the Layer palette. Transparent
areas remain protected when you paint, apply effects, paste
selections, or perform other edits.
Note
This feature applies to raster layers only. You cannot lock the
transparency of vector, adjustment, mask, or group layers. Also,
background layers do not support transparency.
When transparency is locked, the Lock Transparency button displays
. When a transparency is not locked, the Lock Transparency
button is grey .
To lock or unlock the transparency:
Do one of the following:


On the Layer palette, click the Lock transparency button of the
appropriate raster layer.



Double-click the layer name to display the Layer Properties
dialog, mark or clear the Lock transparency check box, and click
OK.

Setting Icon Highlight Colors
To organize the Layer palette visually, specify the highlight colors
for layers and layer groups. The highlight color displays as the
background of the icon to the left of the layer or group name. It has
no effect on the image itself.
In a layer group, layers that have not been assigned individual
highlight colors inherit the color of the parent layer. As an example,
use the same highlight color for all layers in layer group and use a
different color to highlight other layers or layer groups.
To set the highlight color of an icon:
1 On the Layer palette, double-click the name of the layer to open the
Layer Properties dialog.
2 Mark the Highlight in Layer palette check box.
3 Do one of the following:


To select a new color, click the color box next to the check
box. Choose a color and click OK.
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To choose from recently used colors, right-click the color box
and click a color.

4 At the Layer Properties dialog, click OK. The icon now displays
the highlight color.

Modifying Layers
Modify layers to change the look of your image. Arrange the
stacking order, move layers within the image canvas, merge layers,
clean up edges of layers created from selections, or delete layers.

Arranging the Stacking Order of Layers
The arrangement of layers within your image is critical to what the
image looks like. If one layer is above another one, that layer’s data
can cover data below it.
To change the stacking order of layers—which changes the resulting
image—move layers on the Layer palette. If a layer or a layer group
has components, such as vector objects or grouped layers, all the
components move with it.
To move one layer, layer group, or vector object:
Moving the background
layer
The background layer is always the
bottom layer—it cannot be moved.
To change its position, promote it
to a raster layer first. See
“Promoting a Background Layer to
a Regular Raster Layer” on
page 268.

On the Layer palette, click the name of the layer, layer group, or
vector object and drag it to a new position. A black line shows the
position until you release the mouse button.
When you drag an item, the cursor changes into a hand
. If it
displays a null symbol , you cannot move the selected item to a
particular position. For example: The background layer cannot be
moved. There can never be a layer below the background layer. A
vector object cannot be moved into a raster layer. Mask and
Adjustment layers cannot be at the bottom of an image or a layer
group.
To move multiple vector objects:
1 On the Layer palette, click the first vector object.
2 Press Shift and click each additional vector object, or right-click
and choose Select all.
3 Drag the selected objects to a new position. A black line shows
the position until you release the mouse button.
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Moving Layers within the Image Canvas
Original image, and with one
layer moved to the right

Use the Move tool to move the contents of an entire layer anywhere
within the image canvas. If you move part of a layer off the canvas,
Paint Shop Pro does not crop it. You can move it back to the canvas,
or increase the canvas size to show the additional data.
Note
You cannot use the Move tool on the background layer. To move the
contents of the background layer, promote it to a regular raster layer
first. See “Promoting a Background Layer to a Regular Raster
Layer” on page 268.
To move a layer within the image canvas:
1 On the Layer palette, select the layer you want to move.

Where’s the layer?
If you move a layer off the image
canvas, you can no longer see it.
To get the data back, press the
Shift key while dragging it with the
Mover tool. Or, increase the canvas
size enough so that the layer
appears, move it to where you
want, then decrease the canvas
size again.

Saving flattened images
Many file formats, such as JPEG,
GIF, and TIF, do not support multilayered images. When you save to
these formats, Paint Shop Pro
merges all layers into a single
background layer.

2 On the Tools toolbar, click the Move tool

.

3 Click and drag in the image to move the layer to a new position.
4 To limit the Mover tool to the current layer, press and hold the
Shift key while you click the image and drag the layer.

Merging Layers
Merging layers is also called flattening. You can merge selected
layers, or all of the layers in an image. Merging layers decreases the
memory requirements for the image. Paint Shop Pro merges layers
based on the blend modes, converts vector data and vector text to
raster data, and replaces transparent areas of the background layer
with white.
Always make a backup copy of the original .PspImage image before
you merge layers. Once you merge layers, you cannot edit the layers
separately. Unless you are certain you have finished editing the
image, it’s best not to merge layers.
To merge two layers together:
1 Make sure one layer is located directly above the other on the Layer
palette.
2 Click the name of the layer above the one you want to merge it
with.
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3 Choose Layers > Merge > Merge Down to merge the two layers.
The following table describes how layer types are merged:
Any layer

Vector

Mask

Any Layer

Any Layer

Merged with

Raster

Vector

Mask

Background

Mask /
Adjustment

Creates

Raster

Vector

Mask

Background Not Permitted

Top Layer

To merge all layers:
Choose Layers > Merge > Merge All (Flatten) to merge the layers into
one background layer.
To merge all visible layers:
1 On the Layer palette, click the Visibility toggle for each layer that
you do not want to merge.
2 Choose Layers > Merge > Merge Visible to merge all visible
layers into a raster layer named Merged. Invisible layers are not
affected. The new raster layer, which maintains the transparency
information of the original layers, is the active layer.
Note: If a visible layer is in a layer group, only the visible layers
in that group will be merged. If the layer group is marked
invisible (making all layers within the group invisible), none of
the layers within the group will be merged.
To merge all layers in a layer group:
1 On the Layer palette, click the layer group, or a layer within the
group, that you want to merge.
2 Choose Layers > Merge > Merge Group to merge all layers in the
group into one raster layer.
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Cleaning up the Edges of Layers Created
from Selections
Color depth
These commands work on 16
million color and greyscale images
only. To increase the color depth
of an image, see page 109.

When you promote or paste a selection to create a layer, some of the
pixels surrounding the selection border are included, especially
when the selection is anti-aliased or feathered. The Layers > Matting
commands clean up the border by removing these pixels.
There are three Matting commands: Remove Black Matte, Remove
White Matte, and Defringe.
Use the Remove Black Matte or Remove White Matte command
when the selection came from an image with a black or white
background. These commands remove the black or white pixels at
the layer edges.
Use the Defringe command when the selection came from an image
with a colored background. Defringing bleeds non-feathered pixels
in the layer edges outward and over the “jaggies” in the feathered
part of the layer.
To use a Matting command:

Using matting on a
selection
To clean up the edges of a
selection before you promote or
copy it, use the Selections >
Matting commands. See “Cleaning
Up the Edges of a Selection” on
page 171.

1 On the Layer palette, click the name of the layer that was created
from a selection.
2 Do one of the following:


To remove the black matte, choose Layers > Matting >
Remove Black Matte.



To remove the white matte, choose Layers > Matting >
Remove White Matte.



To remove a colored matte, choose Layers > Matting >
Defringe to open the Defringe dialog. Enter the number of
pixels to defringe and press Enter.

Deleting Layers or their Contents
To remove a layer from an image, delete the entire layer. Or, delete
the contents of a layer to keep the layer within the image; raster and
vector layers become transparent and the background layer is filled
with the current background color and material.
To delete a layer:
1 On the Layer palette, click the name of the layer you want to delete.
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2 Click the Delete Layer button on the Layer palette toolbar, rightclick and choose Delete from the context menu, or drag the layer
to the Delete Layer button .
To delete the contents of a layer:
1 On the Layer palette, click the name of the layer.
2 Press the Delete key or choose Edit > Clear.

Using Adjustment Layers
Adjustment layers are correction layers that adjust the color or tone
of underlying layers, without modifying their pixels directly. Choose
from these types of adjustment layers: Brightness/Contrast, Channel
Mixer, Color Balance, Curves, Hue/Saturation/Lightness, Invert,
Levels, Posterize, and Threshold.
All adjustment levels have equivalent commands on the Colors >
Adjust menu. The advantage of an adjustment layer is that you do
not modify the image layers themselves, so it’s easier to make quick
changes to the color and tonal adjustments. Add adjustment layers to
test various color corrections or to see how several corrections look
when you combine them. Hide, delete, or edit adjustment layers.
How to create an
adjustment layer that
applies to one layer only
Create a layer group with the one
layer, and then add the adjustment
layer above the layer in the layer
group.

An adjustment layer applies to all layers below it that are at the same
level, as follows:


If the adjustment layer is at the main level (rather than in a layer
group), it applies to all layers below it in the stacking order.



If an adjustment layer is in a layer group, it applies only to layers
within the group that are lower in the stacking order.

To add an adjustment layer:
1 On the Layer palette, click the layer which you want to create an
adjustment layer above.
2 To apply the adjustment layer to a selection, make a selection.
3 Choose Layers > New Adjustment Layer and select the type of
adjustment layer.
A dialog with the name of the adjustment layer opens. The
preview windows show the image before and after changes. The
Adjustment tab shows the color and tonal correction settings to
change.
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Note: The General tab includes layer properties such as layer
name, blend mode, and opacity. Change these properties here or
on the Layer palette. For more information, see “Editing Layer
Properties” on page 270.
4 To reset values to default settings, in the Presets drop-down list
choose Default. Or, double-click the adjustment layer to open the
Properties dialog, and click the Reset to Default button .
5 Modify the settings on the Adjustment tab, and then click OK.
The adjustment layer is added just above the previously selected
layer.

About Adjustment Layer Types
Chapter 8, Making Color and Tonal Corrections describes in detail
each type of adjustment layer. The table shows specific sections to
refer to within that chapter.
Type of
Correction

Adjustment
Layer

Adjust color
balance

Color Balance

See “Changing the Color Balance of
Shadows, Midtones, and Highlights” on
page 185.

Hue/Saturation/
Lightness

See “Adjusting the Hue, Saturation, and
Lightness in Unison” on page 186.

Channel Mixer

See “Adjusting the Color Channels” on
page 189.

Brightness/
Contrast

See “Manually Adjusting Brightness
and Contrast” on page 191.

Curves

See “Adjusting Individual Brightness
Values” on page 192.

Levels

See “Adjusting the Lightness Levels” on
page 195.

Invert

See “Creating Negative Images” on
page 200.

Threshhold

See “Creating Black-and-White Images”
on page 198.

Posterize

See “Reducing the Number of Lightness
Levels” on page 199.

Adjust
brightness
and contrast

Reduce or
remove
colors

For More Information
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Editing an Adjustment Layer
How to delete an
adjustment layer
Delete an adjustment layer just as
you do any other type of layer.
Click the layer name and then click
the Delete Layer button on the
Layer palette toolbar.

Edit an adjustment layer to change the color or tonal correction. Or,
change the layer properties such as layer name and opacity.
To edit an adjustment layer:
1 On the Layer palette, double-click the name of the adjustment layer
that you want to edit. Or, select the layer and choose Layers >
Properties.

To undo a deletion, click the Undo
button or press Ctrl + Z.

The Layer Properties dialog opens.
2 On the Adjustment tab, modify the color or tonal correction
settings. For detailed information, refer to the appropriate section
as listed in “About Adjustment Layer Types” on page 284.
3 Click the General tab to modify the general layer properties such
as layer name, blend mode, and opacity. Change these properties
here or on the Layer palette. For more information, see “Editing
Layer Properties” on page 270.
4 Click OK.

Modifying Portions of Adjustment
Layers
Sometimes most of an adjustment layer correction works well, but
one part of an image doesn’t need all of the correction. One way to
solve this challenge is to make a selection in the image and create an
adjustment layer for that selection. However, if the image has
multiple areas that need different levels of correction, use a more
flexible approach of creating one adjustment layer and modifying
portions of it.
Adjustment layers are greyscale layers. Use the painting tools to
selectively change which parts of the image get the full correction
and which parts get partial or no correction.
Adjustment layers contain pixels that can display 256 shades of
grey. These grey levels indicate the amount of correction.


White pixels mean Paint Shop Pro applies the full correction that
you specify.



Black pixels mean Paint Shop Pro applies no correction.
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Grey pixels vary the correction. For lighter greys, Paint Shop Pro
applies close to the full correction. For darker greys, Paint Shop
Pro applies close to no correction. Middle grey means Paint Shop
Pro applies the correction at half strength.

Here are the basics of selectively modifying adjustment layers:


When you first create an adjustment layer, all pixels in the layer
are white (full strength correction).



If you create an adjustment layer when there is an active
selection, all pixels in the selection are white (full strength
correction) and all other pixels are black (no correction).



When you select an adjustment layer, the Material palette
displays black, white, and 254 shades of grey as available colors.
To modify portions of the adjustment layer, use the painting tools
to paint with shades of grey.



To see what the pixels of an adjustment layer look like, click the
Mask Overlay button . Or, position the cursor over the layer
name. The layer thumbnail displays the greyscale adjustment
layer.
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Working with Masks
A mask is a greyscale image that is applied to a layer. Use mask
layers hide and show parts of a layer, fade between layers, and create
other special effects. A mask can be created from a selection, from
an alpha channel, or an existing image. Masks can completely cover
a layer, or cover a layer with varying levels of opacity.
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About Masks
Original and masked images

A mask layer covers parts of another layer completely or with
varying levels of opacity. Use masks to fade between layers or to
create special effects with precision. For example, mask all details
around the main subject in a photograph, or use a mask to create a
Web page navigation bar that fades away.
You can create a new mask layer that you can paint on which hides
or shows underlying layers. You can also create a mask layer from
an image, a selection, or the luminance of an image. In addition, use
the sample masks (stored in the Masks folder of the Paint Shop Pro
program folder) and apply them as is, or customize them.
Mask layers function similar to other types of layers. Turn the
visibility of the mask layer on or off, change the overall opacity of
the mask layer, or link the mask layer to other layers. For more
information, see “Editing Layer Properties” on page 270.
Mask layers are automatically saved with the image in the .PspImage
format. You can also save a mask to an alpha channel or as a
separate image file on a disk. For more information, see “Saving
Masks” on page 297.

How Masks Affect Underlying Layers
A mask layer applies to all layers below it that are at the same level,
as follows:

Color depth
Masks work with greyscale with
transparency and 16 million color
images only. To increase the
color depth of an image, see
page 109.



If a mask layer is in a layer group, it applies only to layers within
the group that are lower in the stacking order.



If the mask layer is at the main level (rather than in a layer
group), it applies to all layers below it in the stacking order.

To change which underlying layers the mask applies to, on the Layer
palette drag the mask layer to a new position in the stacking order.
For more information, see “Arranging the Stacking Order of Layers”
on page 279.
Mask layers can never be the bottom layer in the image or in a layer
group.
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Mask Layers as Greyscale Raster Layers
See the contents of the
mask layer
To see what the mask layer looks
like, position the cursor over the
layer name on the Layer palette. A
thumbnail displays the greyscale
mask layer.

Masks are greyscale raster layers—they contain pixels that can
display 256 shades of grey. Rather than applying grey paint to the
image, however, the levels of grey correspond to levels of opacity,
or masking. White pixels show underlying layers, black pixels hide
underlying layers, and grey pixels show varying amounts of
underlying layers. The darker the grey, the more the underlying
pixels are masked.
Even though masks are raster layers, you can create masks that hide
or show portions of vector layers.
When you select a mask layer, the Materials palette displays black,
white, and 254 shades of grey as available colors. Paint on the mask
layer to change the visibility of underlying pixels. All tools and
commands that work on greyscale raster layers work on masks. For
the Pen, Preset Shapes, and Text tools (which can create raster or
vector objects), create raster objects on mask layers.

Creating Masks
There are several ways to add a mask to an image. You can create a
new mask layer completely showing or hiding the underlying layers.
You can also create a mask from an image or a selection.
Note
Because background layers do not support transparency, you cannot
apply a mask to them. When the background layer is selected when
you create a new mask, you are prompted to promote the background
to a full layer.
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Creating New Mask Layers
To show or hide the underlying layers completely with the new
mask, choose from the Show All or Hide All Layer menu commands.
To create a new mask layer:
Other ways to create a new
mask layer
On the Layer palette, right-click
the layer to which you want to add
a mask and choose New Mask
Layer > Show All to show all
underlying pixels or Hide All to
hide all underlying pixels. Or, click
the Show All button on the Layer
palette.

1 On the Layer palette, click the layer you want to mask.
2 Choose Layers > New Mask Layer and then choose the type of
mask:
Show All Shows all underlying pixels. All pixels of the mask are
white. The underlying layer will appear unchanged. Paint the
mask with greys or black to hide portions of the underlying
layers.
Hide All Hides all underlying pixels. All pixels of the mask are
black. The underlying layer will be completely hidden. Paint the
mask with white or greys to show portions of underlying layers.
The mask layer and the selected layer are added to a new layer
group. The mask layer applies to the selected layer only. To apply it
to all underlying layers, drag it from the layer group to the main
level.

Hint for editing masks
Display the Overview palette
(choose View > Palettes >
Overview) while editing a mask so
that you can see the image as it
will print or display (without the
transparency grid or the mask
overlay).

To view the mask on the image, on the Layer palette click the Mask
Overlay toggle .
For more information on editing the mask, see “Editing Masks” on
page 294.
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Creating Masks from Images
Using an image as a mask

Use any image as a mask for another image. Paint Shop Pro converts
the image into greyscale raster data and uses it for the mask. The
original, or source, image is not altered.
Note
Another way to create a mask from an image is to load the image file
from disk; see “Loading Masks from Disk” on page 298.
To create a mask from an image:
1 Open the image that you want to use for the mask.
2 Select the image in which you want to create the mask layer.
3 On the Layer palette, click the layer you want to mask.
4 Choose Layers > New Mask Layer > From Image to open the Add
Mask From Image dialog.
5 In the Source window drop-down list, select the image to use for
the mask.
6 In the Create mask from group box, select an option:
Source luminance The luminance value of the pixel color
determines the degree of masking. Lighter colors produce less
masking; darker colors produce more masking. Transparent areas
completely mask the layer.
Any non-zero value Transparent areas completely mask the layer.
There is no gradation to the masking. Pixels with data (opacity of
1-255) become white pixels in the mask; transparent pixels
become black in the mask.
Source opacity The opacity of the image determines the degree
of masking. Fully opaque pixels produce no masking; partially
transparent pixels create more masking; transparent pixels
produce full masking.
7 To reverse the transparency of the mask data, mark the Invert
mask data check box. Black pixels become white, white pixels
become black, and greys are assigned their mirror value.
8 Click OK.
The mask layer and the selected layer are added to a new layer
group. The mask layer applies to the selected layer only. To apply it
to all underlying layers, drag it from the layer group to the main
level.
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For information on editing the mask, see “Editing Masks” on
page 294.
To view the mask on the image, on the Layer palette click the Mask
Overlay toggle .

Creating Masks from Selections
Using a selection as a mask

Use a raster selection to create a mask that shows or hides the
selection.
To create masks from selections on vector layers, use the Selection,
Freehand Selection, and Magic Wand tools. You cannot use the
Object Selection tool.
To create a mask from a selection:
1 Use the Selection, Freehand Selection, or Magic Wand tool to
make a selection on a raster or vector layer in the image.
2 Do either of the following:


To mask the selection, choose Layers > New Mask
Layer > Hide Selection.



To mask everything except the selection, choose
Layers > New Mask Layer > Show Selection.

The mask layer and the selected layer are added to a new layer
group. The mask layer applies to the selected layer only. To apply it
to all underlying layers, drag it from the layer group to the main
level.
For information on editing the mask, see “Editing Masks” on
page 294.
To view the mask on the image, on the Layer palette click the Mask
Overlay toggle .
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Creating Masks from Channels
Using the greyscale channel as
a mask

When you split an image into its RGB, HSL, or CMYK channels,
Paint Shop Pro creates a greyscale image for each channel. Use one
of these channel images to create a mask for the original image or
another image.
To create a mask from a channel:
1 Split the image into channels using one of the Image > Split
Channel commands, and leave the resulting greyscale images open
in the workspace. For more information, see “Working with Color
Channels” on page 107.
2 Select the image where you want to create the mask layer.
3 Choose Layers > New Mask Layer > From Image to open the Add
Mask From Image dialog.
4 In the Source window drop-down list, select which channel
image to use for the mask.
5 In the Create mask from group box, select the Source opacity
option.
6 To reverse the transparency of the mask data, mark the Invert
mask data check box.
7 Click OK.
The mask layer and the selected layer are added to a new layer
group. The mask layer applies to the selected layer only. To apply it
to all underlying layers, drag it from the layer group to the main
level.
For information on editing the mask, see “Editing Masks” on
page 294.
To view the mask on the image, on the Layer palette click the Mask
Overlay toggle .
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Displaying the Mask Overlay
Masked image with and without
overlay

When you create a mask, the image window shows the effect of the
mask, but does not display the mask automatically. Use the Mask
Overlay toggle
on the Layer palette to display the mask overlay.
By default, the overlay is a 50 percent opacity red color for
completely masked pixels and lower opacity red for partially masked
pixels. When you paint or modify the mask, this overlay shows what
is painted or changed. To change the color and opacity of the mask
overlay, see “Changing the Mask Overlay Color” on page 295.
When the mask overlay is displayed, the Mask Overlay toggle
displays
. When the overlay is hidden, the Mask Overlay toggle
displays .
To display or hide the mask overlay:
Click the Mask Overlay toggle

, or choose Layers > View Overlay.

Editing Masks
Ways to modify masks
Use the painting tools. See
Chapter 9, Painting.
Paint with gradients, textures, or
patterns. See “Creating Gradient,
Pattern or Texture Masks” on
page 296.
Apply effects commands. See
Chapter 14, Applying Effects.
Create a shape in one image, then
use it as a mask in another image.
See “Saving Masks” on page 297.
Use the Move tool to move the
mask layer within the image
canvas.

Edit a mask the same way you edit any greyscale raster layer. Select
a mask layer on the Layer palette, and then use the painting tools or
the effects commands to modify the mask. When you edit a mask,
you change either the areas or the degree of masking. For example,
painting over an object to mask it changes the area, while applying a
gradient fill edits the degree of masking.
Remember that a mask layer is a greyscale layer with 256 levels of
grey that correspond to levels of masking. When you select a mask
layer, the Materials palette displays the greyscale palette. Apply
black or white to mask or erase the mask at 100 percent. Apply greys
to vary the level of masking.
Edit the layer properties of a mask, such as the name, visibility, or
opacity, in the same way you do any type of layer. For more
information, see “Editing Layer Properties” on page 270.
To create a gradient or textured mask, invert the mask, or change the
overlay color, refer to the following sections.
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Changing the Mask Overlay Color
By default, the mask overlay displays red semi-transparent pixels to
show the mask on the image. Change the color or opacity for the
mask layer to make it easier to see on your image.
To change the mask overlay color and opacity:
Displaying the Mask
Overlay
For more information on the mask
overlay, see “Creating Masks” on
page 289.

1 Do one of the following to open the Layer Properties dialog:


On the Layer palette, double-click the mask layer button or
right-click the mask layer button and choose Properties.



Choose Layers > Properties.

2 Click the Overlay tab and change the following:
Overlay Color The default overlay color is pure red
(RGB 255, 0, 0). Click the color box and choose a new color.
Opacity The opacity of the overlay. The default is 50 percent.
3 Click OK.

Inverting Masks
To reverse the transparency of a mask, invert it. Black pixels become
white and white pixels become black. Greys become their mirror
value—the maximum value (255) minus the current value.
To invert a mask:
1 On the Layer palette, select the name of the mask layer.
2 Choose Layers > Invert Mask/Adjustment.
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Creating Gradient, Pattern or Texture
Masks
Using a gradient mask

Use a gradient, pattern, or texture mask to create interesting effects.
A gradient mask varies the opacity of an image from fully hidden to
fully shown. Use a gradient mask to fade an image in or out. A
pattern or texture mask varies the image opacity in a repeated pattern
throughout the image.
To create any of these masks, on the Materials palette select the
material (gradient, pattern, or texture) and then fill the mask layer
with it. When you choose a colored material, Paint Shop Pro
converts it to greyscale before applying it.
To create a gradient, pattern, or texture mask:
1 Create a new mask. See “Creating Masks” on page 289.

Using a pattern mask

2 Click the Mask Overlay toggle
the mask overlay.

on the Layer palette to display

3 On the Tools toolbar, click the Flood Fill tool

.

Note: To fill all pixels in the mask, on the Tool Options palette
set the Match Mode to None.


On the Materials palette, select a gradient, texture, or pattern. See
“Choosing Gradients” on page 91, “Choosing Patterns” on
page 93, or “Choosing Textures” on page 94.

4 Left-click the mask to apply the foreground material; right-click
the mask to apply the background material.
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Saving Masks
Paint Shop Pro automatically saves mask layers in the .PspImage
format. When you want to share a mask with others, or use a mask in
another image, save the mask to your hard drive or to an alpha
channel.

Saving Masks to Disk
When you save a mask to a hard disk or a removable disk,
Paint Shop Pro saves the mask as a separate file with a .PspMask
extension. You can then load this mask into other images without
opening the original image.
To save a mask to disk:
1 On the Layer palette, click the name of the mask layer.
2 Choose Layers > Load/Save Mask > Save Mask to Disk to open
the Save Mask To Disk dialog.
The Mask files group box displays the current masks in the
default Masks directory. The New mask group box displays the
current mask.
3 To change the folder where the mask file is saved, click the Edit
Paths button. By default, mask files are stored in the Masks
folder of the Paint Shop Pro program folder. For more
information, see “Setting File Locations” on page 403.
4 In the File name edit box, type a name for the mask file.
5 Click Save.

Saving Masks to Alpha Channels
Save a mask to an alpha channel within the current image or within
another image. An alpha channel is a data storage area in an image
which stores masks and selections. Alpha channels are like secret
compartments within a suitcase—use them to store things you may
need later. Masks and selections stored in alpha channels have no
effect on the look of an image. To use the stored masks or selections,
load them into the same image or another image.
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Selections in alpha
channels

When you save the image to a file format other than .PspImage
format, the alpha channels are not saved. Always keep a master copy
of your image in .PspImage format.

For information on saving or
loading selections in alpha
channels, see “Saving Selections
to Alpha Channels” on page 177.

To save a mask to an alpha channel:
1 On the Layer palette, click the name of the mask layer.
2 Choose Layers > Load/Save Mask > Save Mask To Alpha Channel
to open the Save Mask to Alpha dialog.
The Add to document drop-down list displays all open
documents and below it are the alpha channels in the image (if
any).
3 To save a mask to an image’s alpha channel, select the image
name in the Add to document drop-down list. The image must be
open in Paint Shop Pro.
4 To edit the default name for the new alpha channel, type a new
name in the Name field.
5 Click Save.

Loading Masks
Paint Shop Pro masks

Once you have saved a mask to a hard disk or a removable disk, you
can load the mask into images without opening the original image.

The Masks folder of the Paint Shop
Pro program folder contains
sample masks, such as gradients
and several types of circles and
squares that frame images.

Loading Masks from Disk
Load a mask file that you have saved or load one of the sample
masks that come with Paint Shop Pro. Mask files have a .PspMask
extension. Use the Layers > Load Mask > From Disk command to
load mask files or load image files as masks.
To load a mask from disk:
1 On the Layer palette, click the layer you want to mask.
2 Choose Layers > Load/Save Masks > Load Mask From Disk to
open the Load Mask From Disk dialog.
The Mask group box shows all masks in all directories listed in
your file locations for masks. To change the default directory,
click the Edit Paths button. For more information, see “Setting
File Locations” on page 403.
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3 In the Mask group box, click the drop-down list to choose from
mask and image files.
The Preview group box displays the selected mask on the image
canvas.
4 In the Orientation group box, select from the following options:
Fit to canvas Adjusts the mask to fit the current image canvas
(stretching or contracting as needed).
Fit to layer Adjusts the mask to fit the current layer’s data
(stretching or contracting as needed). If the layer has not been
shifted beyond the edges of the canvas, this option is identical to
the Fit to Canvas option.
As is Places the mask starting in the top left corner of the current
layer; this option does not change the mask proportions. If the
mask image is smaller than the current layer, Paint Shop Pro by
default masks all pixels outside of the mask image boundaries.
5 In the Options group box, choose whether Paint Shop Pro shows
or hides pixels surrounding the loaded mask data (if there are
any). These options affect the mask only if the Orientation option
is As Is and the loaded mask is smaller than the current image
canvas.
Invert transparency To invert the transparency of the mask
image.
Hide all mask Makes surrounding pixels black to hide underlying
pixels.
Show all mask Makes surrounding pixels white to show
underlying pixels.
Use image value Makes surrounding pixels white or black
depending upon whether the original mask was a show all mask
or a hide all mask.
6 Click Load.
Paint Shop Pro adds the mask layer and the selected layer to a new
layer group. The mask layer applies to the selected layer only. To
apply it to all underlying layers, drag it from the layer group to the
top of the main level.
To view the mask on the image, on the Layer palette click the Mask
Overlay toggle .
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Loading Masks from Alpha Channels
When you save a mask to an alpha channel within a .PspImage
image, you can load that mask from the alpha channel into the same
image or into any other image.
To load a mask from an alpha channel:
1 On the Layer palette, click the layer you want to mask.
2 Choose Layers > Load/Save Mask > Load Mask From Alpha
Channel to open the Load Mask from Alpha dialog.
3 In the Document drop-down list, select the image which contains
the alpha channel you want to load. (Choose from open images
with existing alpha channels only.)
4 In the drop-down list below the document name, choose the alpha
channel which contains the mask you want to load.
5 In the Orientation group box, select from the following options:
Fit to canvas, Fit to layer, or As is. For descriptions, see
page 299.
6 In the Options group box, select whether Paint Shop Pro hides or
shows pixels surrounding a loaded mask that is smaller than the
current image canvas. Choose a Hide all or Show all mask. To
invert the transparency of the mask image, mark the Invert
transparency check box. For detailed descriptions, see page 299.
7 Click Load.
Paint Shop Pro adds the mask layer and the selected layer to a new
layer group. The mask layer applies to the selected layer only. To
apply it to all underlying layers, drag it from the layer group to the
main level.
To view the mask on the image, on the Layer palette click the Mask
Overlay toggle .
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Deleting Masks
Hiding masks
To turn off the visibility of a mask,
but keep it in the image, click the
Visibility toggle on the Layer
palette.

Delete a mask entirely from an image, or merge the mask with the
underlying layer and then delete the mask layer. If you merge the
mask, you can no longer edit it independently.
A mask saved to an alpha channel is not deleted when you delete the
mask layer.
To delete a mask:
1 Delete the mask in either of these ways:


On the Layer palette, right-click the name of the mask layer
and choose Delete.



On the Layer palette, click the name of the mask layer, and
then choose Layers > Delete, or click the Delete button .

Paint Shop Pro displays a message asking if you want to merge
the mask with the underlying layer.
2 Do either of the following:


To merge the mask with the layer, click Yes. Paint Shop Pro
merges the layers and deletes the mask layer.



To remove the mask from the image without affecting the
underlying layer, click No. Paint Shop Pro deletes the mask
layer.

Deleting Masks from Alpha Channels
How do I view the
alpha channels?
To see what masks and selections
are saved to alpha channels in an
image, choose Selections >
Delete Alpha Channel. Click the
Alpha Channel drop-down list to
list all alpha channels in the
current image. When you finish,
click Cancel.

If you saved selections to alpha channels that you no longer need,
you can delete them. Delete alpha channels from the current image
only.
To delete an alpha channel:
1 Choose Image > Delete Alpha Channel to open the Delete Alpha
Channel dialog.
2 Select the alpha channel that you want to delete, or mark the
Delete all alpha channels check box.
3 Click Delete.
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C H A P T E R 13
Working with Text
Create both raster and vector text, and edit vector text using the Text
tool. Choose the font, style, size, and color of the text. Apply any of
Paint Shop Pro’s effects making text in your images stand out.
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Creating Text
Text in images

Use the Text tool to create text on an image. Choose text colors on
the Materials palette and text options on the Tool Options palette,
then click in the image and enter text in the Text Entry dialog.
To create text:
1 On the Tools toolbar, choose the Text tool

.

2 On the Materials palette, choose the foreground material as the
text outline and the background material as the text fill (the area
within characters). See “Basics of Using the Materials palette”
on page 84.
For standard text with no outline, set the Stroke width on the
Tool Options palette to 0 or click the Foreground Material box’s
Transparent button. For hollow text, click the Background
Material box’s Transparent button .
3 On the Tool Options palette, in the Create as drop-down list
choose the type of text: Vector, Selection, or Floating. For more
information, see “About Vector, Floating, and Selection Text” on
page 305.
4 Choose the text formatting options, such as font, point size,
stroke width, and alignment. See “Formatting Text” on page 306.
5 Click in the image where you want to place the text. The Text
Entry dialog opens.
6 Type the text. As you type in the dialog, the text displays on the
image. To add a line break, press Enter.
7 To change any of the text formatting options, in the Text Entry
dialog, highlight the words or characters that you want to change,
and then make changes on the Tool Options palette. For more
information about editing, see “Editing Text” on page 308.
8 Mark the Remember Text check box to display the entered text
the next time you open the Text Entry dialog.
9 Click Apply.
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About Vector, Floating, and Selection
Text
The Text tool creates vector text, a text selection, or floating (raster)
text. Choose an option from the Create As drop-down list:
Vector Creates vector text, which is the only type of text you can edit
by changing the words, font type, style, and alignment. Use this
setting in most cases. When you want to apply raster-only tools
(such as the Paint Brush) or commands (such as applying a
3D effect), merge the vector layer to a raster layer.
If you create vector text while a raster layer is active, Paint Shop Pro
adds a new vector layer with the text.
Selection Creates a selection marquee in the shape of text, rather
than creating text as a painted object. Move, copy, fill, or otherwise
edit it just like any other selection. For example, use the Paint Brush
to paint the selection with a texture. You can also use a text selection
to create special effects. Delete the text selection to create words that
are cut out of the image. Or, create a text selection on a photographic
image, and then copy and paste the selection to a new image; the
result is text filled with the image.
Floating (Raster) Creates raster text that is a floating selection. You
cannot exit raster text, so use this type when you know that the
words and formatting will not change. Use raster text when you want
to apply raster-only tools (such as the Paint Brush) or commands
(such as applying a 3D effect).
It’s best to create raster text on a new raster layer. That way, you can
easily select the text and make changes such as stretching it with the
Deform tool.
When Paint Shop Pro defloats the raster text selection (such as when
you click another tool), the raster text is merged with the underlying
raster layer. If a vector layer is active, Paint Shop Pro creates a new
raster layer.
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Formatting Text
Text with several formatting
options

When you enter or edit text with the Text tool, select from the
following formatting options on the Tool Options palette:
Font A set of characters (letters, numbers, and symbols) that share a
common look. Click the Font drop-down list to see the font family
name (such as Arial or Times New Roman) displayed in the font
itself.
Size The point size of the text. How small or large a font looks in the
image depends upon the image’s resolution. 72-point text is
approximately 1 inch high in a 72-dpi image, but will be smaller in
images with higher resolution.
Stroke Width The text outline pixel width. Choose 0 pixels to have
no outline.
Anti-alias Anti-aliasing smooths the jagged edges of text by
softening the color transition between edge pixels and background
pixels. Anti-aliasing greatly increases the number of colors in the
image. This makes it challenging to reduce the number of colors and
thus reduce file size. Anti-aliasing may cause stray colors to appear
along the edges of text.
Alignment How text is aligned in relation to the initial cursor
position—where you clicked in the image to insert the text.


Aligns the left edge of each text line to the initial cursor
position.



Aligns the center of each text line to the initial cursor
position.



Aligns the right edge of each text line to the initial cursor
position.

Type Style The style of text; choose

bold,

italic, or both.

Underline or Strikethrough Click
to underline text. Click
place a horizontal line through text.

to

Line Options Define the look of the text outline (stroke). Options
include Line Style (such as solid or dashed), Join, and Miter Limit.
For details, see “Drawing Objects” on page 229. For information on
Custom line styles, see “Creating Custom Line Styles” on page 235.
Auto Kern Mark this check box to have Paint Shop Pro use the
kerning of the font as the spacing between characters.
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About em’s
Em’s are a unit of measurement
used in typesetting.
1000 em’s equals 72 points.

Kerning The horizontal space between characters, measured in em’s.
A value of 0 uses the font’s automatic kerning. Use a positive value
to increase the spacing or a negative value to decrease the spacing.
Paint Shop Pro uses the Kerning value only when you clear the Auto
Kern check box.
Leading The vertical space between lines of text, measured in em’s.
Use a positive value to increase the spacing or a negative value to
decrease the spacing.
Note: When creating text on a path or a shape, use positive
values to position the text below the path and negative values to
position the text above the path.

Moving Text
How to move text to
another layer
To move text to another layer,
select the text, then cut and paste
it to another layer.

To move or position vector text on a layer, use the Object Selection
tool. To move raster text, use a selection tool like the Magic Wand
tool to select and move it.
To move vector text:
1 On the Tools toolbar, click the Object Selection tool

.

2 Select the text you want to move. A bounding box surrounds the
text.
3 Move the cursor inside the bounding box, the cursor changes
to
.
4 Click and drag the text anywhere within the image.
To move raster text:
1 On the Tools toolbar, select one of the Selection tools. For details,
see “Using the Selection Tools” on page 154.
2 Select the text you want to move.
3 Move the cursor inside the selection marquee, the cursor changes
to
.
4 Click and drag the text anywhere within the image.
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Editing Text
Use the Text tool to edit vector text. Edit the characters and their
appearance.
Note
You cannot edit the characters or formatting of raster text. To
modify Raster text, use the Deform tool.
To edit vector text:
1 To open the Text Entry dialog, do one of the following:


On the Tools toolbar, click the Text tool
, position the
cursor over the text in the image until the cursor turns to
then click.

,



Right-click the text and select Edit Text.



On the Layer palette, double-click the text object



On the Layer palette, right-click on the text object and select
Edit Text from the context menu.

The Text Entry dialog opens with the text highlighted.
In this dialog, Paint Shop Pro changes only highlighted text. If no
text is highlighted when you choose options, the options affect
new text you type at the cursor position.
2 Edit the text in any of these ways:


To format all text, keep it all highlighted and choose options
on the Tool Options palette or choose new colors or materials
on the Materials palette.



To format one or more characters, click and drag to highlight
the text you want to change, and choose options on the Tool
Options or Materials palette.



To add new text, click where you want to insert it and begin
typing.



To delete text, highlight the text and press Delete.
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Scaling and Transforming Text
To scale (resize) and transform text:


For vector text, use the Object Selection tool to scale, rotate,
shear, distort, or apply perspective to text. For more information,
see “Resizing and Reshaping Vector Objects” on page 243.



For raster text, use the Deform tool to scale, rotate, shear, distort,
or apply perspective to a raster selection or a layer. For more
information, see “Scaling and Transforming Images” on
page 143.

Applying Effects to Text
Text with buttonize effect and
drop shadow effect

Apply any of Paint Shop Pro’s effects to raster text to create an
endless variety of looks. Apply a drop shadow or a beveled edge,
turn text into brush strokes or colored chalk. For vector text, convert
it into a raster selection, and then apply effects.
Type of Text

How to Apply Effects

Raster

Create the raster text on a transparent layer, separate
from other raster data in the image. Select the text on
the layer using the Magic Wand tool, and then apply
any of the commands on the Effects menu.

Vector

Use the Object Selection tool to select the text.
Choose Selections > From Vector Object to create a
raster selection of the text, then choose Paste > As
New Layer. Follow the steps above for raster text.
Turn off the visibility of the vector text, but keep the
vector text in case you want to edit it.
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Creating Text with Image Patterns
There are several ways to create text that is filled with an image:
Text filled with a pattern

Effect

How to do it

Fill text with a
repeated image

Open the image you want to use to fill the text, click
the Background Material box on the Materials
palette, click the Pattern tab, and select the image
from the drop-down list. Use this background
material to create new vector or raster text, or to edit
existing vector text.
For existing raster text, paint or fill the text with the
background material.

Fill text with one
image

Open a copy of the image. Create new text as a
selection on the image (on the Text tool’s Tool
Options palette, in the Create As drop-down list
choose Selection). Then copy the selection to a new
image.

Creating Text on Object Paths
Create text that fits any vector object—line or shape. Every vector
object in Paint Shop Pro has a path (or outline) that defines its shape.
Use this object path to create text with interesting variations.
Note
You cannot create deformed text on a path, Paint Shop Pro will
remove the deformation when placing the text on the path.
There are two ways to create text on a path:


Create the path (a line or shape), then create new text on the path.



Create the path and the text as separate objects, then fit the text to
the path.
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To create new text on a path:
1 Use the Pen or Preset Shapes tool to create a vector line or vector
shape.
2 Click the Text tool
Put some distance between
text and path
To change the distance between
the text and the object path,
change the text leading; see
“Formatting Text” on page 306.

.

3 On the Tool Options palette, in the Create as drop-down list
choose Vector.
4 Select other options (font, size, alignment, and so on) as desired.
5 Move the cursor over the line or shape until the cursor changes to
, and then click. The Text Entry dialog displays.
6 Enter the text and click OK.
To fit existing text to a path:

Make the object disappear
After you align text to a vector
object, you can make the object
invisible. On the Layer palette,
click the Visibility toggle of the
object.

1 Choose the Object Selection tool

.

2 Click the text to select it.
3 Press Shift and click the vector object to select it also.
4 Choose Objects > Fit Text to Path.
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Aligning and Spacing Text on Object
Paths
Aligning Text on a path
Text is aligned based on
the insertion point

When you create text along a path, the text placement depends upon
features of the text and the path.
Feature

How it affects text on a path

Text alignment
(left, center, or
right).

For new text on a path:
Paint Shop Pro aligns the text using the position
where you clicked to insert the text. Left-aligned text
begins at that position. Center-aligned text is centered
on that position. Right-aligned text ends at that
position.
For existing text fit to a path:
Paint Shop Pro aligns the text using the start and end
nodes of the path. Left-aligned text begins at the start
node. Center-aligned text is placed midway between
the start and end nodes. Right-aligned text ends at the
end node.

Direction of path

The text goes in the direction from the start node to
the end node. The direction determines whether the
text aligns right-side-up above the path or upsidedown below the path.
Reverse the path to change the direction. See
“Reversing the Direction of Contours or Paths” on
page 248.

Spacing between
text and path

The leading of the text determines the spacing
between the text and the path. Set the leading on the
Text tool’s Tool Options palette. Use positive values
to position the text above the path and negative values
to position the text below the path.

Open or closed
path

On open paths, text that is longer than the path hangs
from the end. The angle of the last line segment
determines the direction it hangs.
On closed paths, text that is longer than the path wraps
around itself.
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Converting Text to Curves
Regular text, and text converted
to curves and modified with the
Pen tool

To edit vector text as a vector object, convert it to curves. You can
then move or add nodes, change the angles of line segments, and
perform other edits using the Pen tool.
Convert each letter into its own object, or convert the entire text into
one object with each letter as a separate contour with the object path.
After you convert text to curves, it is no longer text—so you cannot
change the characters, their font or leading, or do any other text
edits.
To convert text to curves:
1 Use the Object Selection tool

to select the text.

2 Do one of the following:


To convert the entire text object into one vector object, choose
Objects > Convert Text to Curves > As Single Shape. This
produces one path containing a contour for each letter.



To convert each letter into a separate vector object with its
own path, choose Objects > Convert Text to Curves > As
Character Shapes. To edit the nodes of the text, you must
select the letters individually.

To edit the nodes, use the Pen tool. For more information, see
“Editing Paths and Contours” on page 245.
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C H A P T E R 14
Applying Effects
Paint Shop Pro has many special effects you can apply to your
images including: 3D, artistic, geometric, illumination, reflection,
and texture effects. Distort images to create subtle or dramatic
effects.
Note
To blur images, see “Blurring Images” on page 78.
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Choosing Effects
Choose Paint Shop Pro’s effects in one of two ways: through a menu
command or through the Effect Browser. Use the Effect Browser
when you want to try out multiple effects before applying them to
your image. The Effect Browser displays presets, both the defaults
and any that you create.
To choose an effect through a menu:
From the main menu, choose Effects, choose a sub-menu, and then
choose an effect. For example, choose Effects > Distortion Effects >
Twirl.
For most effects, a dialog with preview windows opens. Modify the
settings and click OK.
To choose an effect using the Effect Browser:
About effects presets
To display the thumbnail previews
that you see in the Effect Browser,
Paint Shop Pro applies an effect’s
default preset and any presets you
have saved to the image. This
preset is a script file (.PspScript).

1 Choose Effects > Effect Browser to open the Effect Browser.
The left panel shows the Effects Presets folders, which are
located in the Presets folder of the Paint Shop Pro program
folder. Paint Shop Pro scans the folders and creates thumbnails
of your image with each effect applied to it.
2 To preview all effects on the image, click the Presets folder.
3 To preview types of effects, click one of the Effect folders (such
as 3D Effects, Artistic Effects, or Blur).
4 To select an effect preset, click the thumbnail image in the right
panel.
5 Do either of the following:


To apply the selected preset effect, click the Apply button.



To display a dialog where you can modify the selected preset
effect, click the Modify button. (If this button is greyed out,
the effect does not have adjustable settings.)

Paint Shop Pro applies the effect to your image.
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Using Effects Dialogs
Most effects open a dialog in which you adjust settings to customize
the effect. These dialogs contain several common features:


Use the preview windows to view the original image and the
image with the effect applied to it. For more information on
using these preview windows, see “Using Preview Windows” on
page 26.



To reset settings to default values, in the Presets drop-down list
select Default.



When you first open a dialog, Paint Shop Pro displays the lastused settings. (The Presets drop-down list is set to Last Used.)
Use this preset to apply the same effect to multiple images
without having to adjust the settings each time.



To save and load your own preset effects, see “Using and
Creating Presets” on page 386.

For general information on dialogs, see “Working with Dialogs” on
page 25.

Applying 3D Effects
Example of a 3D effect

The 3D effects create images or selections that appear to have three
dimensions. These effects are particularly useful for creating images
for Web pages. To see the appropriate effect for the Buttonize,
Chisel, Cutout, Drop Shadow, Inner Bevel, and Outer Bevel effects,
first make a selection in the image.
To apply an effect, choose it from the Effects Browser or choose
Effects > 3D Effects and select an effect.
To apply these effects to an entire layer, increase the canvas size to
add pixels around the edges.
Note
 These effects work on greyscale and 16 million color (24-bit)
images only. To increase the color depth of an image, see
page 109.


For descriptions and visual examples of each effect, refer to the
Help system.
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Applying Art Media Effects
Example of an Art Media effect

Apply art media effects to make an image look like it was painted or
drawn using pencil, charcoal, or chalk. To limit an effect to a
specific area, make a selection before applying the effect.
To apply an effect, choose it from the Effects Browser or choose
Effects > Art Media Effects and select an effect.
Note
 These effects work on greyscale and 16 million color (24-bit)
images only. To increase the color depth of an image, see
page 109.


For descriptions and visual examples of each effect, refer to the
Help system.

Applying Artistic Effects
Example of an Artistic effect

Apply artistic effects to age a photograph or to create a variety of
artistic results. To limit an effect to a specific area, make a selection
before applying the effect.
To apply an effect, choose it from the Effects Browser or choose
Effects > Artistic Effects and select an effect.
Note
 These effects work on greyscale and 16 million color (24-bit)
images only. To increase the color depth of an image, see
page 109.


For descriptions and visual examples of each effect, refer to the
Help system.

Applying Edge Effects
Use Edge effects to clarify your image and to accentuate the edges
and contrast areas in your image.
To apply an effect, choose it from the Effects Browser or choose
Effects > Edge Effects and select an effect.
Note
 These effects work on greyscale and 16 million color (24-bit)
images only. To increase the color depth of an image, see
page 109.


For descriptions and visual examples of each effect, refer to the
Help system.

Chapter 14: Applying Effects

Applying Distortion Effects
Example of an Distortion effect

Apply distortion effects to distort an image. To limit an effect to a
specific area, make a selection before applying the effect.
To apply an effect, choose it from the Effects Browser or choose
Effects > Distortion Effects and select an effect.
Note
 These effects work on greyscale and 16 million color (24-bit)
images only. To increase the color depth of an image, see
page 109.


For descriptions and visual examples of each effect, refer to the
Help system.

Applying Geometric Effects
Example of a Geometric effect

The geometric effects include such effects as turning an image into a
sphere or cylinder, and altering an image’s perspective. To limit an
effect to a specific area, make a selection before applying the effect.
To apply an effect, choose it from the Effects Browser, or choose
Effects > Geometric Effects and select an effect.
Note
 These effects work on greyscale and 16 million color (24-bit)
images only. To increase the color depth of an image, see
page 109.


For descriptions and visual examples of each effect, refer to the
Help system.

Applying Illumination Effects
Example of an Illumination
effect

The illumination effects apply a sunburst or spotlights to images. To
limit an effect to a specific area, make a selection before applying
the effect.
To apply an effect, choose it from the Effects Browser, or choose
Effects > Illumination Effects and select an effect.
Note
 These effects work on greyscale and 16 million color (24-bit)
images only. To increase the color depth of an image, see
page 109.


For descriptions and visual examples of each effect, refer to the
Help system.
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Applying Image Effects
Example of an Image effect

The Image effects are Offset, Page Curl, and Seamless Tiling. To
limit an effect to a specific area, make a selection before applying
the effect.
To apply an effect, choose it from the Effects Browser, or choose
Effects > Image Effects and select an effect.
Note
 These effects work on greyscale and 16 million color (24-bit)
images only. To increase the color depth of an image, see
page 109.


For descriptions and visual examples of each effect, refer to the
Help system.

Applying Reflection Effects
Example of a Reflection effect

The reflection effects include such effects as creating a kaleidoscope
or an intricate pattern. To limit an effect to a specific area, make a
selection before applying the effect.
To apply an effect, choose it from the Effects Browser, or choose
Effects > Reflection Effects and select an effect.
Note
 These effects work on greyscale and 16 million color (24-bit)
images only. To increase the color depth of an image, see
page 109.


For descriptions and visual examples of each effect, refer to the
Help system.
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Applying Texture Effects
Example of a Texture effect

The texture effects turn images into a variety of textures, such as
leather, mosaic tiles, and polished stone. To limit an effect to a
specific area, make a selection before applying the effect.
To apply an effect, choose it from the Effects Browser, or choose
Effects > Texture Effects and select an effect.
Note
 These effects work on greyscale and 16 million color (24-bit)
images only. To increase the color depth of an image, see
page 109.


For descriptions and visual examples of each effect, refer to the
Help system.

Adding Noise
Adding noise to an image

Use the Add Noise effect to reduce the detail in an image and add a
grainy texture. This effect can also be used for image correction. By
adding a small percentage of noise to an image, you can reduce the
appearance of small imperfections and scratches.
To use the Add Noise effect:
1 Choose Adjust > Add/ Remove Noise > Add Noise to open the Add
Noise dialog.
2 Choose the pattern of the noise: Random, Uniform, or Gaussian.
With Uniform noise, the color of the noise resembles the original
pixels. With Gaussian noise, the majority of the noise values are
even closer to the original.
3 In the Add Noise edit box, select the percentage of noise to add.
4 To use black and white noise pixels, mark the Monochrome
check box. To use colored pixels, clear the check box.
5 Click OK.

321

322

Chapter 14: Applying Effects

Adding Picture Frames
Add any of Paint Shop Pro’s many picture frames as a separate layer
on your image. Choose from square or oval frames, modern or
classic styles, stained glass or metal, or a variety of other styles.
Note
 This effect works on greyscale and 16 million color (24-bit)
images only. To increase the color depth of an image, see
page 109.
To add a picture frame:
Adding a picture frame

1 Choose Image > Picture Frame to open the Picture Frame dialog.
2 Select a frame from the drop-down list.
3 If the frame has transparent areas (for example, round or oval
frames), in the Transparency color group box choose your
options:

Picture frames with
transparency
If you apply a picture frame with
transparent areas to a background
layer and place the frame outside
the image, the transparent areas
are the current background color
rather than transparent. (The
background layer does not support
transparency.)

Loading picture frames
To change the folder to load
picture frames from, click the Edit
paths button. By default, picture
frames are stored in the Frames
folder of the Paint Shop Pro
program folder. For more
information, see “Setting File
Locations” on page 403.



To have the transparent areas remain transparent, mark the
Keep Transparent check box.



To use a color for transparency areas, clear the Keep
Transparent check box and click the color box to select a
color.

4 In the Orientation group box, select the frame placement: Frame
inside of the image or Frame outside of the image.
If you select an inside frame, Paint Shop Pro resizes the frame to
fit within the image canvas.
If you select an outside frame, Paint Shop Pro increases the
canvas size to accommodate the frame. The added canvas uses
the current background color. However, the area will be
transparent if it is a layer and you mark the Keep Transparent
check box.
5 Choose an orientation option: Flip frame (reverse the frame along
its horizontal axis), Mirror frame (reverse the frame along its
vertical axis), or Rotate frame 90 CW (rotate clockwise).
6 Click OK. Paint Shop Pro adds the frame to the image as a new
layer named Picture Frame.
Note: If the width and height differ by a considerable amount, the
frame appears thicker along the shorter sides.
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Mathematically Combining Two Images
Paint Shop Pro can create a variety of effects using the Arithmetic
effect, which combines two images to produce a third one based on
settings you select.
To combine images using the Arithmetic command:
1 Open the two images you want to combine.
2 Choose Image > Arithmetic to open the Image Arithmetic dialog.
3 In the Image #1 and Image #2 drop-down lists, select the images
to combine. The size of Image #1 determines the size of the new
image.
4 In the Function group box, select a method for combining the
images. The color data from the two images is combined on a
pixel-by-pixel basis according to the function.
Function

New Color Value Equals

Add

Image 1 Value + Image 2 Value

Subtract

Image 1 Value - Image 2 Value

Multiply

Image 1 Value x Image 2 Value

Difference

Absolute Value of (Image 1 Value - Image 2
Value)

Lightest

Maximum of (Image 1 Value, Image 2 Value)

Darkest

Minimum of (Image 1 Value, Image 2
Value)

Average

(Image 1 value + Image 2 Value) / 2

Or

Binary Or

And

Binary And

5 From the Channel group box, select the color channels to
combine:


Mark the All channels check box to use all the color channels
in both images. This will produce a 24-bit image.



Select a specific color channel for each image to produce a
greyscale image.
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6 Set the Modifiers. The modifiers are applied to the color values
produced by the Formula and the Channel selections.


The Divisor number is used to divide the color values. It can
reduce the effects of the other selections.



The Bias number shifts each color value by a fixed amount.
The number is added to the color value produced by the
Formula, Channel, and Divisor selections.

7 Mark or clear the Clip color values check box to determine how
Paint Shop Pro handles final color values greater than 255 and
less than 0.
Check box
Setting

If value is less
than 0

If Value is more
than 0

Selected

value = 0

value = 255

Cleared

value = 256 + value

value = value - 256

8 Click OK.
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Creating Your Own Effects
To create your own effects (also called filters), use the User Defined
command.
To create your own effects:
An easy way to create your
own effects
On the User Defined Filter dialog,
click the Randomize button
to
automatically adjust the
coefficients and create unusual
effects. Just keep clicking the
Randomize button until you find an
effect that you like.

1 Choose Effects > User Defined to open the User Defined Filter
dialog.
The edit boxes in the Filter matrix group box show coefficients
that process pixels to create the effect.
2 In the Presets drop-down list, select a filter to use as a starting
point. Choose Default for default settings or select one of the
other filters.
3 Set the Matrix modifiers:


The Divisor number is used to divide the Filter matrix values.
It can reduce the effects of the filter matrix. Use the Compute
button to calculate a Divisor that will adjust the brightness of
the image back to no change.



The Bias number shifts each color value by a fixed amount.
The number is added to the color value produced by the filter
matrix.

4 In the Apply to group box, pick the which color values the effect
applies to.Choose Color Channels and mark the channels, or
choose Grey Values.
5 After you make changes, click OK. Paint Shop Pro applies the
effect to the image.
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C H A P T E R 15
Using the Web Tools
Use the Web tools to create backgrounds for your Web pages, map
and slice images to create hotspots or rollovers. Optimize images for
the Web to reduce the image file size and make images load more
quickly. Share your images by sending them via e-mail. Protect your
images by adding a watermark with creator and copyright
information.
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Sending Images via E-Mail
Use Paint Shop Pro to e-mail any open image to friends, family, or
colleague using an e-mail program. The image is in its current file
format whenever possible.
Note
In order to send images via e-mail your computer must have a
default e-mail application that supports the MAPI standard such as
Microsoft Outlook, or Outlook Express
To send the image via e-mail:
Choose File > Send or click the Send Mail button on the toolbar.
Your current mail program opens with the file attached. Enter the
recipient, type a message, and then send it.

Uploading Images to a Photo Sharing Service
Use Paint Shop Pro to easily upload your images to a photo sharing
service. Photo sharing services allow you to upload and store your
images online, order high-quality prints and greeting cards, and
share your images online.
Using other photo sharing
services
As Paint Shop Pro is updated,
support for additional photo
sharing services may be included.
To find out if support for additional
photo sharing services is available,
be sure your computer is
connected to the Internet, and then
choose Help > Jasc Software
Online > Check for Updates. To
change your service choose File >
Preferences > General Program
Preferences, click the
PhotoSharing tab, and then
choose the photo sharing service
from the list of available services.

Before you can add, share, and print pictures at a photo sharing
service, you must enroll. Signing up is free and gives you space to
store, print, and share your images. Visit the Web site for the photo
sharing to obtain your user name and password.

Uploading Images a Photo Sharing
Service
You can use Paint Shop Pro to upload images to a photo sharing
service.
To upload images to a photo sharing service:
1 Choose File > Browse or click the Browse button
to open the Paint Shop Pro Browser.

on the toolbar

2 Select the images that you want to upload to a photo sharing
service.
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3 To open the PhotoSharing dialog:


Click the PhotoSharing button



Choose File > Export > PhotoSharing.



Right-click to display a context menu and select
PhotoSharing.

on the Browser toolbar.

4 The Upload Album field displays the name of the album where the
images will be stored on the PhotoSharing site. By default the
album is named with the current date, but you can enter a
different name for the album.
5 In the Connection Info group box, enter the user name (e-mail
address) and password for the photo sharing service.
Note: Mark the Remember Password check box if you want the
system to remember the login information.
6 Click the Upload button to upload the images to the photo sharing
site.
7 Once the images are uploaded, you will be prompted to visit the
photo sharing site, click Yes to automatically access the web site
for the photo sharing service.

Notes about Uploading
If you are unable to log-in to a photo sharing service, first make sure
that your computer is connected to the Internet, and that you have
entered the correct e-mail address and password on the login screen.
If you are unable to log-in and are using Paint Shop Pro in a
corporate environment, you may need to modify the Proxy Server
settings. Check with your Network Administrator to get the Proxy
Server information for your corporate network.
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Previewing Images in a Web Browser
If you have a Web browser installed on your computer, you can use
the Web Browser feature to see how your active image will look on
the Web. Paint Shop Pro creates an HTML page that displays your
image in Windows Bitmap, GIF, JPEG, or PNG format.
To preview image files in Web browsers:
1 Choose View > Preview in Web Browser to open the Preview in
Web Browser dialog.
2 To change or add Web browsers, click the Edit Web Browsers
button. For more information, see “Setting File Locations” on
page 403. You can select up to three browsers.
3 In the Select image formats list, click each format in which you
want to preview your image.
4 To select a background color for the Web page, left-click the
Background color box to choose from the Color dialog or rightclick it to choose a recently used color.
5 In the Image size group box:


Mark the Use default check box to keep the original image
dimension. Clear the check box to enter new image
dimensions (in pixels) in the Width and Height edit boxes.
The resizing is done using HTML and not by Paint Shop Pro.



Mark the Lock Aspect Ratio check box to keep the image’s
current height to width ratio when it is resized.

6 Click the Preview button.


If you selected to preview only the Bitmap format, the
program launches the Web Browser and displays the image.



If you selected any other format, the program opens the
appropriate Optimization dialog (see “Saving Images for the
Web” on page 341). Select your choices for optimizing the
image and click OK.

The Web browser or browsers display your image in the selected
formats. You may need to scroll to see them. For each format, the
browser displays the file size, color depth, and approximate
download times at different modem speeds.
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Mapping Images
Use the Image Mapper dialog to create image maps for your Web
pages. An image map is a graphic that contains a mapped areas
(called cells), that link to URLs. Cells can be circles, rectangles, or
irregular shapes. When user moves the mouse over a cell, the cursor
changes to a hand indicating that you can click that area to jump to
another Web page.
To map an image, first create the map areas (cells), then assign the
URLs, set cell properties, and then save the map file as GIF, JPEG,
or PNG file. When you save the file, a HTML page is automatically
generated and copied to the clipboard, so all you have to do is paste
it into the source files for the Web page.

Creating Map Areas
On the Image Mapper dialog, use the tools in the Tools group box to
create and edit the mapped areas.
To create a map area:
Tips:






Use the Pan tool drag the image
in the preview to view hidden
areas of the image.
Increase the size of the dialog to
view more of the image in the
preview area.
Use the Zoom buttons to
magnify a specific area of the
image.

1 Choose File > Export > Image Mapper to open the Image Mapper
dialog.
2 Choose the shape of a mapped area.
The Rectangle tool creates square or rectangular map areas, the
Circle tool creates circular map areas, and the Polygon tool
creates map areas enclosed with multiple straight line segments.
3 Do either of the following:


With the Rectangle or Circle tool, click the image in the
preview window (not the original image) and drag the cursor
until the area you want map is enclosed.



With the Polygon tool, click the image in the preview window
to set the starting point, move the cursor to where you want
the line to change directions, and click the image. Continue
clicking new positions in the image to change the direction of
the line. To complete the polygon, left-click on or near the
starting point, or right-click the image.
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To change the shape of a map area:
Select the Pan tool

, and then:



Click and drag any point on a rectangle or a polygon.



Click and drag a circle by the dot at its upper left or lower right.

To move the entire map area:
Select the Move tool
to a new position.

, click inside the map area, and then drag it

To remove a map area from the image:
Select the Eraser tool

, and then click inside the map area.

To remove all of the map areas:
Click the Clear button.

Assigning Map Area Properties
After you have created the map areas (or cells), use the settings in
the Cell Properties group box to assign URLs, alternate text, and
targets.
To assign map area properties:
Viewing a Preview
Click the Preview button
to
view your work in a Web browser
window.

1 Make a map area active by clicking inside it with the Pan or Move
tool. Its boundaries are displayed in the lower portion of the Cell
Properties group box.
2 In the URL field, type the address of the Web page that you want
to link to (example: http//www.jasc.com), or select an recently
used address from the drop-down list. If you do not want to link
to a Web page, type #.

URL and Alt text tip
The recent information typed in the
URL and Alt text fields is
remembered by the program. To
adjust how much information is
remembered, see “Setting Map
Preferences” on page 333.

3 In the Alt text field, type the text that displays if image doesn't
load or if the user has images disabled in their Web browser. This
text also appears as a ToolTip in some versions of Internet
Explorer. You can also select recently typed text from the
drop-down list.
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4 In the Target box, select the target frame in which to open the
linked page:
_blank Loads the linked page in a new browser window.
_parent Loads the linked page in the parent frameset of the link.
If the link is not in a nested frame, the image loads in the full
browser window.
_self Loads the linked page in the same frame as the link.
_top Loads the linked page in the full browser window and
removes all frames.
5 To assign a rollover to a map area, click the Rollover Creator
button, see “Creating Image Rollovers” on page 336.

Setting Map Preferences
Using the Map Preferences dialog to select new colors for the border
lines of the active and inactive map areas and enter the number of
entries that the URL and Alt text drop-down lists display.
1 In the Image Mapper dialog, click the Preferences button to open
the Map Preferences dialog.
2 For the Active map border color, click the color box and choose a
color.
3 For the Inactive map border color, click the color box and choose
a color.
4 For the Maximum history list, enter the number of entries stored
in the URL and Alt text drop-down lists.
5 Click OK.
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Saving and Loading the Map Settings
When you save the map settings, you save the map area arrangement
and the information you entered in the Image Mapper dialog. You
can then re-load the settings into the same image, or use the settings
with a different image.
To save the map settings:
1 In the Image Mapper dialog, click the Save Settings As button to
open the Save Map Settings dialog.
2 Navigate to the folder in which you want to save the settings file.
The file is saved in the .JMD format.
3 Type a name for the file and click Save.
To load the map settings:
1 Open the image in which you want to load map settings.
2 Choose File > Export > Image Mapper to open the Image Mapper
dialog.
3 Click the Load Settings button to open the Load Map Settings
dialog.
4 Navigate to and select the .JMD file you want to load.
5 Click Open.
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Saving an Image Map to the Clipboard
Save map settings to the clipboard so you can paste them into the
HTML code.
To save an image map to the clipboard:
1 In the Image Mapper dialog, click the Save to Clipboard button to
open the HTML Destination Folder dialog.
2 Navigate to the folder where the HTML file is saved, and click
OK to open the Image Map Save as dialog.
3 Navigate to the folder where the image file is saved, and click
Save.
4 Open the HTML file, place the cursor where you want to insert
the HTML map code, and press Ctrl + P.

Saving Image Maps
Save image maps to a directory on your hard drive so you can use or
edit them.
To save image maps:
1 In the Image Mapper dialog, click the Save or Save as button to
open the HTML Save As dialog.
2 Navigate to the folder where you want to save the HTML code
and click OK.
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Creating Image Rollovers
A rollover is an image or section of an image that changes
appearance when the user activates it. Web designers frequently
create rollovers for the buttons of a navigation bar. When a user
clicks a button, the browser displays the linked Web page (or file),
and the rollover area displays a different button.
You can assign a rollover to both sliced and mapped images by
choosing a file for the slice or area to display when the user performs
a specific mouse action.
To create image rollovers:
1 Choose File > Export > Image Mapper or Image Slicer to open the
Image Mapper or Image Slicer dialog.
2 Select the Pan tool
add a rollover.

, and then click the cell where you want to

3 Click the Rollover Creator button to open the Rollover Creator
dialog.
Viewing a Preview
Click the Preview button
to
view your work in a Web browser
window.

4 Select the check box of the action you want used to activate the
rollover: Mouse over, Mouse out, Mouse click, Mouse
double-click, Mouse up, Mouse down, and then click the Open
button
to open the Select Rollover dialog.
5 Navigate to and select the graphics file you want to use as the
rollover image.
6 Click Open. On the Rollover Creator dialog, the File box displays
the file path.
7 For each action you want associated with a rollover, mark the
check box and choose a rollover file.
Note: If you do not select a file, then the original file is used.
8 Click Close to return to the Image Mapper or Image Slicer
dialog.
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Slicing Images
When you slice an image, you divide it into several smaller images
that you can save in different formats or at different levels of
optimization. Because these optimized images can take less time to
download than one large image, your Web pages may load more
quickly.
Slicing an image also can reduce the number of graphics you need to
save. If your Web site displays the same logo or other graphic in
more than one image, you only need to save that section once if you
slice the images; you reload the same logo or graphic section into all
the images.
The Imager Slicer works by creating a table from the image, saving
the location of each sliced section as a region in the table, and
generating the HTML code for the column and cells. Copy this code
into your source files so that the image can be reassembled when the
user downloads the Web page.
The Image Slicer can also create rollovers, which are areas that
display secondary images when the user clicks or moves a mouse
over them.

Creating and Editing Cells
In the Image Slicer dialog, use the tools in the Tools group box to
divide the image into cells and to edit the cell boundaries. The Grid
tool creates a grid of evenly spaced cells, either over the entire image
or within another cell. The Line tool creates a horizontal or vertical
line.
To create the cells:
1 Choose File > Export > Image Slicer to open the Image Slicer
dialog.
2 Do either of the following:


To create evenly spaced and sized cells, click the Grid
tool
. Click in the image. The Grid Size dialog opens. Set
the number of Rows and Columns.
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Tips:






Use the Pan tool drag the image
in the preview to view hidden
areas of the image.
Increase the size of the dialog to
view more of the image in the
preview area.
Use the Zoom buttons to
magnify a specific area of the
image.

To isolate a specific area, such as a logo, click the Slice tool
. Click and drag in the image where you want a line to
appear. To create a vertical line, click and drag vertically; to
create a horizontal line, click and drag horizontally.

To move a line or grid border:
1 Choose either the Pan tool

or Slice tool

.

2 Move the cursor over a line.
3 When the cursor changes to the double-sided arrow , click and
drag the line to a new position. To move only the segment within
the current cell, press the Shift key before clicking the line.
Note: You can move lines up, but not across adjacent parallel
lines. You can move individual lines and lines that are part of a
grid. As you drag a line, Paint Shop Pro moves the longest
segment that can be repositioned without creating a
non-rectangular cell.
To delete a line or grid border:
1 Select the Eraser tool

and move the cursor over the line.

2 When the cursor changes to the Eraser, click to delete the line. If
deleting the line would create an invalid area, Paint Shop Pro
displays an icon
to indicate that you cannot erase the line.

Assigning Slice Cell Properties
After you have created sliced cells, use the settings in the Cell
Properties group box to assign URLs, alternate text, and targets to
each cell. You also set whether the cell should appear in the
downloaded image. By omitting cells, you can add cells from other
images (such as logos or text) and create images in non-rectangular
shapes.
To assign cell properties:
1 Choose the Pan tool
, then click inside the cell to make it active.
The cell boundary information displays in the lower portion of the
Cell Properties group box.
2 In the URL drop-down list, type the address of the Web page
where you want the cell to appear. Click the arrow in the box to
display and select recently used addresses.
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3 In the Alt text box, type alternate text that the browser can
display while the cell is downloading, if the cell doesn't
download, or if the user has images disabled in the Web browser.
This text also appears as a ToolTip in some versions of Internet
Explorer.
4 In the Target box, select the target frame or window in which you
want the image to open:
_blank Loads the linked page in a new browser window.
_parent Loads the linked page in the parent window or frameset
of the link. If the link is not in a nested frame, the image loads in
the full browser window.
_self Loads the linked page in the same window or frame as the
link.
_top Loads the linked page in the full browser window and
removes all frames.
5 To omit the cell from the downloaded image, clear the Include
cell in table check box. No image will be saved for that cell.
By default, this check box is marked and the cell appears in the
image.
6 To assign a rollover to a map area, click the Rollover Creator
button. For more information, see “Creating Image Rollovers” on
page 336.

Setting Slice Preferences
In the Slice Preferences dialog, select new colors for the border lines
of the active and inactive areas and enter the number of entries URL
and Alt text drop-down lists display.
1 In the Image Mapper dialog, click the Preferences button to open
the Slice Preferences dialog.
2 For the Active tile border color, click the color box and choose a
color.
3 For the Inactive tile border color, click the color box and choose
a color.
4 For the Maximum history list, enter the number of entries stored
in the URL and Alt text drop-down lists.
5 Mark the Prompt for image folder on Save or Save As check box
to indicate that you want to be prompted for a file location and
name for your slices when you save the HTML code.

339

340

Chapter 15: Using the Web Tools

6 Click OK.

Saving and Loading Slice Settings
When you save the slice settings, you save the cell arrangement and
the information you entered in the Image Slicer dialog. You can then
re-load the settings into the same image or use them with a different
image.
To save the slice settings:
1 In the Image Mapper dialog, click the Save Settings button to open
the Save Slice Settings dialog.
2 Navigate to the folder in which you want to save the settings file.
The file is saved in the .JSD format.
3 Type a name for the file and click Save.
To load the slice settings:
1 In the Image Mapper dialog, click the Load Settings button to open
the Load Slice Settings dialog.
2 Select the JSD file you want to load and click Open.
If you are loading a grid to a different image, Paint Shop Pro
automatically adjusts the grid size if the dimensions of the image are
not the same.

Saving Image Slices to the Clipboard
Save slice settings to the clipboard so you can paste them into your
HTML code.
To save Image Slices to the clipboard:
1 In the Image Slicer dialog, click the Save to Clipboard button to
open the HTML Destination Folder dialog.
2 Navigate to the folder where the HTML file is saved, and click
OK save the slice settings.
3 Open the HTML file, place the cursor where you want to insert
the HTML slice code, and press Ctrl + P.
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Saving Slices
Save slices to a directory on your hard drive so you can use or edit
them.
To save slices:
1 In the Image Slicer dialog, click the Save or Save as button to
open the HTML Save As dialog.
2 Navigate to the folder where you want to save the HTML code
and click OK.

Saving Images for the Web
Because the majority of Web browsers recognize GIF and JPEG
images, these two formats are used most often for saving Web
images. Newer versions of the Web browsers can also recognize the
more recent PNG format, and many Web browsers also support
Windows Wireless Bitmap (WBMP) and iMode formats, which are
popular to display when using wireless devices.
When you save images for the Web, there are three major issues to
consider: layers, color depth, and file size.

Layers
Because none of the current Web browsers can display layered
images, you need to flatten an image before saving it for the Web.
Flatten it by choosing Layers > Merge > Merge All (Flatten).

Color Depth
Some computers are only capable of displaying up to 256 colors. If
an image on a Web page contains more colors, the Web browser uses
its own dithering method to display the image. This can produce
color distortion. If you reduce the color depth of the image to 8 bits
(256 colors) before placing it on your Web page, its appearance will
be more consistent.
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File Size
Lossy vs. Lossless
compression
Lossy compression is a
compression method that
eliminates data to reduce the file
size, while lossless compression
retains all of the original image
data and reduces the file size by
storing patterns of pixels in the
image.

File size affects the majority of users accessing a Web page. As the
size of an image file increases, it takes more time to download, so
viewers have a longer wait. Use a file format that reduces the image
size most efficiently while keeping the quality as high as possible.

Web File Formats
Choose from the following file formats when saving image for use
on the Web:


GIF Use this format to compress line art and images with areas of
similar colors. It supports 8-bit (256) color. There are two
versions of GIF: 89a, which can save transparency and animation
information, and 87a, which cannot. Both are recognized by most
browsers and use lossless compression.



JPEG Use this format to compress photographic images. It
supports 24-bit (16 million) color, uses lossy compression, and is
recognized by most browsers.



PNG This format compresses most images efficiently. It supports
up to 24-bit (16 million) color and uses lossless compression. It
is recognized by most browsers, however many features of this
format are not available.



Wireless Bitmap (WBMP) This format is used with many wireless
devices. The images are black and white and have lossless
compression.

Optimizing GIF Files
Use the Paint Shop Pro GIF Optimizer feature to save GIF files that
maximize quality while minimizing file size. You can save images
with or without transparency, depending on how you want to display
them on your Web pages.
Paletted images (those with 256 or fewer colors, such as GIF or PNG
files) do not support transparent backgrounds, but you often need to
make part of your image transparent when displayed on a Web page.
For example, you may have a round logo and you want the
background of the Web page to display around the logo.
Most Web browsers can choose not to display one color, effectively
making that color transparent. Use the GIF optimizer to choose the
color to make transparent.
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To optimize and save a GIF file:
1 Choose File > Export > GIF Optimizer to open the GIF Optimizer
dialog. The preview windows show the current image on the left
and the resulting GIF file on the right.
2 Do one of the following:


Configure the settings on the Transparency, Partial
Transparency, Colors, and Format tabs. For more information,
see “Choosing GIF Optimizer Settings” below.



Click the Use Wizard button to let Paint Shop Pro guide you
through the process.

Choosing GIF Optimizer Settings
The GIF Optimizer dialog contains four tabs where you configure
the transparency, color, and format options for the file. The fifth tab
displays estimated download times of the image at various modem
speeds.

GIF Optimizer Transparency Tab
The option you choose in this tab determines which area of the
image becomes transparent:
None Produces a GIF file that does not contain one color set to
transparency.
Existing Image or Layer Transparency Uses the current transparency
information from the image.
Inside the Current Selection For images with a selection, this option
makes everything within the selection transparent.
Outside the Current Selection For images with a selection, this
option makes everything outside the selection transparent.
Areas that Match this Color Click the color box to select any color.
Or, to choose a color from the image, move the cursor over the
image, and click the color. In the Tolerance edit box, set a tolerance
factor that indicates how closely colors must match the selected
color before they become transparent.
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GIF Optimizer Partial Transparency Tab
A GIF file cannot contain partially transparent pixels. All pixels
must be either transparent or opaque (visible). Original images may
contain partially transparent pixels if the image does not have a
background layer, and you have reduced the opacity of a layer,
added a mask, feathered a selection, or used a brush at a reduced
opacity setting. Use the options in the Partial Transparency tab to
determine whether the partially transparent pixels become
transparent or opaque, and whether they are blended with another
color. If you chose the None option in the Transparency tab, the
options in this tab are unavailable.


To determine how Paint Shop Pro represents partially transparent
pixels, choose from these options:
Use Full Transparency for Pixels Below x% Opacity Pixels below
the opacity value you enter become transparent. Pixels above the
opacity value become opaque. As you lower the value, you
reduce the number of transparent pixels.
Use a 50% Dither Pattern Paint Shop Pro makes partially
transparent pixels opaque using either the color chosen for
blending or the image color (depending on the blending option),
then applies a 50% dither pattern to make colors look more
natural.
Use Error Diffusion Dither Paint Shop Pro makes partially
transparent pixels opaque using either the color chosen for
blending or the image color (depending on the blending option),
then applies an error diffusion dither to make colors look more
natural.



To determine how partially transparent pixels are blended,
choose one of these options:
Yes Blends the partially transparent pixels with the color in the
Blend color box. To choose a new color, click in the color box to
choose from the Color dialog. Partially transparent pixels below
the value you entered above are blended with this color.
No Uses the existing image color at 100% opacity.

GIF Optimizer Colors Tab
GIF images have an 8-bit color depth, which means they can display
up to 256 colors. Because these colors are stored in a palette, an
image containing 256 or fewer colors is called a paletted image. To
reduce file size, you can have fewer than 256 colors. Use the options
in this tab to select the colors and type of palette used.
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1 Choose how many colors you want the saved image to contain. As
you remove colors, the size of the file decreases, but so does the
quality of the image. Use the preview windows to help you
determine the best balance between file size and image quality.
2 Choose the amount of dithering, which refers to the way Paint
Shop Pro arranges pixels in an image to compensate for missing
colors in the adjacent pixels.
3 Choose a method of color selection for the palette that will be
used for the image:


Choose the Existing Palette option if your image is already
paletted and you want to use its palette.



Choose the Standard/Web-safe option if your image will be
used on the Web.



Choose the Optimized Median Cut option if you need to
reduce the image to only a few colors.



Choose the Optimized Octree option if your original image
contains only a few colors.
Note: Depending on your needs, you may want to try both
“Optimized” options and choose the one that gives you the
best looking result or the smallest file size.

4 In the Options group box:


Mark Boost selected colors to give selected colors more
weight by a factor of the value you enter. Use this if you have
made a selection in the image and you want its colors stand
out from the rest of the image. After marking the check box,
and set the value to determine the amount of color boosting.



Mark the Include Windows’ colors check box to include the
16 standard Windows colors in the palette. If the image will
be used on the Web, mark this check box.

GIF Optimizer Format Tab
1 Choose a type of file, to determine how the image is displayed as it
downloads:


Non-interlaced The image downloads one line at a time,
starting from the top.



Interlaced The image is displayed incrementally in several
passes, and detail is added each time. Use this option with
larger images so that the viewer can get an idea of how the
image looks while waiting for it to download.
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2 Choose a version for the file. Choose Version 89a to save
transparency information. It is selected automatically if the
image contains transparent pixels. Version 87a is available only
if the image does not contain a transparency.

GIF Optimizer Download Times Tab
This tab displays the size of the compressed file and an estimate of
the download time at four Internet speeds. If the file size is too large,
decrease it by clicking the Colors tab and reducing the number of
colors.

Saving the GIF File
After you have selected the options, click OK to open the Save As
dialog. Navigate to the folder in which you want to save the new
image and type a name for the file. When you click Save, Paint Shop
Pro saves a copy of the image as a GIF file.

Optimizing JPEG Files
Paint Shop Pro provides a JPEG Optimizer feature to assist you in
saving JPEG files that maximize quality while minimizing file size.
To optimize and save a JPEG file:
1 Choose File > Export > JPEG Optimizer to open the JPEG
Optimizer dialog. The preview windows show the current image on
the left and the resulting JPEG file on the right.
2 Do one of the following:


Configure the settings on the Quality and Format tabs, and
view estimated download times on the Download Times tab.



Click the Use Wizard button to let Paint Shop Pro guide you
through the process.

Choosing JPEG Optimizer Settings
Don’t lose more data
Each time you open and save a
JPEG, image data is discarded. It
is a good idea to keep a copy of
the original image.

The JPEG Optimizer dialog contains two tabs where you configure
the settings and a third that displays estimated download times of the
image at various Internet speeds.
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JPEG Optimizer Quality Tab
Lossy vs. Lossless
compression
Lossy Compression is a
compression method that
eliminates data to reduce the file
size, while lossless compression
retains all of the original image
data and reduces the file size by
storing patterns of pixels in the
image.

Use this tab to set a compression value and chroma subsampling for
the file.


The compression value reduces the file size by deleting image
information. This means that as you increase the compression,
you lower the quality of the image. Use the image preview
window to help you find the best balance between the two.



With Chroma subsampling the file size of the JPEG is reduced
by averaging the color information for every 2 x 2 square of
pixels. You can change this setting to have a larger area of color
information averaged.

JPEG Optimizer Format Tab
The options on this tab determine how an image appears as it is
being loaded:
Standard The image downloads one line a time, starting from the
top.
Progressive The image is displayed incrementally in several passes,
and detail is added each time. Use this option with larger images so
that the viewer can get an idea of how the image looks while waiting
for it to download.

JPEG Optimizer Download Times Tab
This tab displays the size of the compressed file and an estimate of
the download time at four modem speeds. To change the file size,
click the Quality tab and increase or reduce the compression value.

Saving the JPEG File
After you have selected the options, click OK to open the Save As
dialog. Navigate to the folder in which you want to save the new
image, and type a name for the file. When you click Save, Paint
Shop Pro saves the image in the JPEG format.
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Optimizing PNG Files
Paint Shop Pro provides a PNG Optimizer feature to assist you in
saving PNG files that maximize quality while minimizing file size.
To optimize and save a PNG file:
1 Choose File > Export > PNG Optimizer to open the PNG Optimizer
dialog. The preview windows show the current image on the left
and the resulting PNG file on the right.
2 Do one of the following:


Configure the settings on the Colors, Transparency, and
Format tabs, and view estimated download times on the
Download Times tab. For more information, see “Choosing
PNG Optimizer Settings” below.



Click the Use Wizard button to let Paint Shop Pro guide you
through the process.

Choosing PNG Optimizer Settings
The PNG Optimizer dialog contains three tabs where you configure
the color, transparency, and format options of the file. The fourth
page displays estimated download times of the image at various
modem speeds.

PNG Optimizer Colors Tab
Use this tab to select a color depth for your PNG image and, for
paletted images, the method of color reduction, number of colors,
and amount of dithering.
1 Select the image type to determine whether the saved image is
Palette-Based (256 colors or less), Greyscale (8-bit), or 16 million
color (24-bit). Remember that a 24-bit image is larger and takes
more time to download than an 8-bit image. If you want to use the
Alpha Transparency option (on the Transparency tab) with your
image, you must choose either the Greyscale or 24-bit color option.
Paletted images cannot display alpha transparency.
Note: When you choose to create a Palette-Based image, the
other options on this tab become available.
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2 Choose how many colors you want the image to contain. As
mentioned, a paletted image contains 256 or fewer colors. As you
remove colors, the size of the file decreases, but so does the
quality of the image. Use the preview windows to help you
determine how small you can make the image without
compromising quality.
3 Choose how much dithering you want in the image. This refers to
the way the program arranges pixels to compensate for missing
colors in the adjacent pixels. Use the preview windows to help
you determine the best setting.
4 Select a method of color selection to determine how Paint Shop
Pro reduces the number of colors in the image:


Select Existing Palette if your image is paletted and you want
to use its palette.



Select Standard/Web-safe if your image will be used on the
Web.



Select Optimized Median Cut if you need to reduce the image
to only a few colors.



Select Optimized Octree if your original image contains only a
few colors.

Note: Depending on your needs, try both “Optimized” options
and select the one that produces the better-looking image or the
smaller file size.
5 In the Options group box:


Mark Boost selected colors to give selected colors more
weight by a factor of the value you enter. Use this if you have
made a selection in the image and you want its colors stand
out from the rest of the image. After marking the check box,
and set the value to determine the amount of color boosting.



Mark the Include Windows’ colors check box to include the
16 standard Windows colors in the palette. If the image will
be used on the Web, mark this check box.
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PNG Optimizer Transparency Tab
The option you choose in this tab determines which area of the
image becomes transparent. To create a transparency from a
selection, make the selection before opening the PNG Optimizer
dialog.
1 For the type of transparency, choose from these options:


No transparency Saves the image without transparency.



Single color transparency Makes one color transparent. If the
image contains transparency, then you can then select the
Existing Image or Layer Transparency option (described
below). If the image does not contain a transparency, then
select the Areas that Match this Color option. The Single
Color Transparency option usually creates a smaller file than
the Alpha Channel Transparency option, but selecting it
causes the image to lose existing alpha channel transparency.



Alpha channel transparency Uses the image’s alpha channel
transparency. Because paletted images cannot contain alpha
channels, this option is available only when you select
Greyscale or 16 million color option on the Colors tab.

2 For the areas of the image to be transparent, choose from these
options:


Existing image or layer transparency Uses the current
transparency information. For paletted transparency and alpha
transparency images, the alpha channel is used to create
transparency



Inside the current selection For images with a selection, this
option makes transparent everything within the selection.



Outside the current selection For images with a selection, this
option makes transparent everything outside the selection.



Areas that match this color Click the color box to select any
color. Or, to choose a color from the image, move the cursor
over the image, and click the color. In the Tolerance edit box,
set a tolerance factor that indicates how closely colors must
match the selected color before they become transparent.
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PNG Optimizer Format Tab
Use this tab to determine how an image appears as it is downloaded:
Non-interlaced The image downloads one line at a time, starting
from the top.
Interlaced The image is displayed incrementally in several passes,
and detail is added each time. Use this option with larger images so
that the viewer can get an idea of how the image looks while waiting
for it to download.

PNG Optimizer Download Times Tab
This tab displays the size of the compressed file and an estimate of
the download time at four modem speeds. If the file size is too large,
decrease it by clicking the Colors tab and reducing the number of
colors.

Saving the PNG File
After you have selected the options, click OK to open the Save As
dialog. Navigate to the folder in which you want to save the new
image, and type a name for the file. When you click Save, Paint
Shop Pro saves a copy of the image and leaves the original image
unchanged.

Using Digital Watermarks
A digital watermark is a permanent proof of authenticity for an
image. While a computer can detect it, it is invisible to the viewer. A
watermark contains information about the creator, the copyright, and
the image. When a viewer chooses to see this information, the
program opens a dialog that contains a link to the Digimarc® Web
page, which displays contact information for the artist.
Note
A layer can contain only one watermark. You cannot embed a new
watermark in a layer that already contains one.
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Embedding a Digital Watermark
A digital watermark can only be embedded on a layer once. Because
its quality may be degraded by further changes to the layer. If you
try to embed a watermark in a layered image, Paint Shop Pro
displays a message recommending that you flatten the image before
proceeding.
When you embed a watermark, you can select the following options:
creator ID, image copyright dates, image attributes and restrictions
on use, and watermark durability. You can change the copyright
date, image attributes, and durability each time you embed a
watermark. You only need to configure the creator ID the first time
you embed a watermark.
To embed a watermark:
1 Choose Image > Watermarking > Embed Watermark to open the
Embed Watermark dialog.
2 Choose the information you want the watermark to contain:
Creator ID The identification of the creator of the image. Initially
set to “Jasc Watermark Demo.” To receive your own Creator ID,
register with Digimarc; click the Personalize button. See
“Personalizing the Creator ID” on page 353.
Copyright year(s) Type either one or two years in the copyright
boxes. Digimarc accepts years from 1922 to the present.
Image Attributes The Image Attributes are the restrictions shown
when the program displays the watermark information. Mark the
check boxes of the attributes you want to apply to the image:
Restricted Use, Do Not Copy, or Adult Content.
Watermark Durability The durability indicates how visible
watermarks are on the image. For more information, see “Setting
the Watermark Durability” below.
3 Click OK.
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Setting the Watermark Durability
The watermark durability indicates how visible watermarks are on
the image. For images to be printed, use stronger watermarks. For
images to be displayed on a monitor, use weaker watermarks
because they are not as visible. While stronger watermarks are easier
to detect, and harder to remove, they are also more visible in the
image. You can make two copies of the image and apply a stronger
watermark to the copy you are printing and a weaker one to the copy
you are displaying electronically.
To set the watermark durability:
1 From the Target Output drop-down list, choose how the image will
be displayed: Monitor or Print. If you select the Print option for an
image with a resolution under 300 dpi, Paint Shop Pro displays a
message recommending that you increase the image resolution
before embedding the watermark.
2 To set the watermark strength, in the Watermark Durability field
type a number from 1 to 16, drag the slider below it, or use the
default values. The default Monitor option is 8; the default Print
option is 12.
3 To verify that the watermark information is embedded correctly,
mark the Verify check box. The program checks that the
watermark has been applied and displays its attributes and
durability.

Personalizing the Creator ID
Initially, Paint Shop Pro’s watermark Creator ID is set to “Jasc
Watermark Demo.” Customizing the watermark with your own
identification number is a two-step process:


First, register with Digimarc to obtain your own ID number.



Second, enter the information in the Personalize Creator ID
dialog.

To personalize the Creator ID:
1 Display the Embed Watermark dialog. See “Embedding a Digital
Watermark” on page 352.
2 Click the Personalize button to open the Personalize Creator ID
dialog.
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3 To register with Digimarc, do one of the following:


If your computer has Web access, click Register. Your Web
browser opens and navigates to the Digimarc Web page.
Follow the on-screen instructions to receive a Creator ID
number, a PIN number, and a password. You should write
them down for later use. Close the browser to return to the
Personalize Creator ID dialog.



If your computer does not have Web access, phone Digimarc
using the toll-free number to register and receive your Creator
ID number, a PIN number, and a password.

4 Type the PIN and Creator ID numbers in the appropriate fields.
5 Click OK. The Embed Watermark dialog opens.
6 Click OK.
If the “Verify” check box is selected, the Embed Watermark:
Verify dialog opens. It lets you know that the watermark has
been embedded and displays the creator, copyright, image
attribute, and durability information from the Embed Watermark
dialog.

Reading a Digital Watermark
Whenever Paint Shop Pro opens an image, it automatically checks
for a digital watermark. If one is detected, the program displays a
copyright symbol in front of the filename on the title bar. View the
watermark information by choosing Image > Image Information, and
then clicking the Watermark Information tab.
While most watermarks are detected, some may be too weak to read.
To do a more thorough search, use the Read Watermark command
by choosing Image > Watermarking > Read Watermark. If Paint Shop
Pro does not detect a watermark, it displays a message stating that no
watermark was found. If it detects a watermark, it opens the
Watermark Information dialog.
If your computer is connected to the Web, click the Web Lookup
button to open your browser and view the Digimarc Web page that
displays information about the creator.
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C H A P T E R 16
Printing Images
With Paint Shop Pro you can print one image on a page, print several
images on a page, or print selected images within a folder. You can
also create templates that save the size and placement of images.
There are several ways to ways to print in Paint Shop Pro:


Print a single image. For more information, see “Printing a
Single Image” on page 359.



Print multiple images on one page. Arrange and size images in
any way you like. For more information, see “Printing Multiple
Images on a Page” on page 360.

Print images from the Browser as thumbnails or in any arrangement.
For more information, see “Printing Images from the Browser” on
page 369.
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Chapter 16: Printing Images

Before Printing
Before you print, you should understand how image resolution, color
and lightness, paper quality, and the file type of the image effect the
quality of the printed image.

Image Resolution
Laser and ink-jet printers work by applying dots of black or colored
ink to paper. While the image resolution is measured in pixels per
inch (ppi), the printer resolution is measured in dots per inch (dpi).
To determine the printed image size in inches, the printer divides the
image size in pixels by the pixels per inch. An image with a high
resolution appears smaller when printed at its original size than an
image with a low resolution.
You can scale images when you use Print Layout to print multiple
images. However, this can lower the quality of the print, as it
enlarges each pixel. You will get better results if you create the
image using a resolution that is appropriate for the printer. Use the
following guidelines to determine the image size for printing:


For a 300 dpi printer, use a 72 to 120 ppi image.



For a 600 dpi printer, use a 125 to 170 ppi image.



For a 1200 dpi printer, use a 150 to 200 ppi image.

Image Color and Lightness
Computer monitors display color by combining red, green, and blue
light on the screen. Color printers, however, use a combination of
cyan, magenta, yellow, and black inks. The difference in these two
color modes can cause images to appear darker on paper than on the
screen. As you become familiar with how your printer handles color,
adjust your images to compensate. If the printed image appears too
dark, use the Brightness/Contrast command to adjust it.

Paper Quality
The texture and color of the paper affects the quality of the printed
image. Porous paper can cause colors to bleed into each other;
colored paper can alter the image colors; off-white paper can reduce
the contrast and vibrancy of colors. For the best results, refer to your
printer’s owner manual for paper recommendations.
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Saving Images for Printing
If you are printing your image on a personal printer, save it in the
.PspImage format. This gives you the most flexibility. Paint Shop
Pro prints all the layers in an image, so you don’t need to flatten it
(merge all layers). If you are using a black-and-white printer, choose
the Greyscale option in the Print dialog.
If you are sending the image to a printing service, flatten the image
before saving it. When you save an image in most formats other than
.PspImage, Paint Shop Pro automatically flattens the image. Ask
your printer about the requirements for file format, resolution, and
color depth. If you need CMYK color separations, choose that
option in the Print dialog.

Choosing Printing Setup Options
To open the Print Setup dialog, from the main Paint Shop Pro
workspace, choose File > Print, or press Ctrl + P. From the Print
Layout window, choose File > Print Setup, or click the Print Setup
button.
How to access Print options
From the main Paint Shop Pro
workspace, choose File > Print, or
press Ctrl + P.
From the Print Layout window,
choose File > Print Setup, or click
the Print Setup button.

Note: Note: You can script most print options. However, all
printer settings may not be scriptable due to variations in printer
drivers.
The following printing options are available when printing a single
image. Most of the options are also available when printing multiple
images from the Print Layout window.
Choosing print setup options:
1 In the Printer group box, choose the printer to send the image to.
Click the Printer button to select a different printer. Click the
Properties button to view or change printer properties. For more
information, refer to your printer documentation.
2 Print to File Mark this check box to save the image to a file
instead of sending it to a printer. When you click the Print button
to print the image, Paint Shop Pro prompts you for a file name.
3 Enter the number of copies to print in the Number of Copies field.
4 In the Orientation group box choose either the portrait or
landscape orientation.
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Scripting print options
You can script most print options.
However, all printer settings may
not be scriptable due to variations
in printer drivers.

5 In the Print Output group box, choose the type of output: Color,
Greyscale, or CMYK Separations. For more information on
printing CMYK color separations, see “Printing with CMYK
Color Separations” on page 371.
6 In the Color options group box, choose an option:


Negative Mark this check box to print a negative of the image.



Background Mark this check box to print a color background
around the image, and then click the color box to choose the
background color.

7 In the Print Marks group box, choose from the following options:


Corner Crop Marks Mark this check box to print crop marks at
the corners of the image.



Center Crop Marks Mark this check box to print crop marks at
the center of the image edges.



Registration Marks Mark this check box to print registration
marks at the corners of the image.



CMYK Plate Labels Mark this check box to print labels (Cyan,
Magenta, Yellow, or Black) on each color plate (or page). This
check box is available only when you select the CMYK
Separations option.



Image Name Mark this check box to print the image file name
below the image.

8 Mark the Header check box to include header text at the top of
the page, and then type the text in the edit box.
9 Mark the Footer check box to include footer text at the bottom of
the page, and then type the text in the edit box.
10 Click Close to apply the settings and close the Print Setup dialog.
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How to change the
paper size
The paper size (such as letter or
legal) is a printer property. At the
Print window or the Page Setup
window, click the Properties
button, then the Paper tab.

Template printing is now
scriptable.
The Print command and the
Template tab settings can be
recorded in a script.

Select Template (Print dialog only) Click this button to open the
Templates dialog and choose a template. For more information on
choosing templates, see “Printing Images Using a Template” on
page 366.
Fill the template with the current image (Print dialog only) Choose
this option to fill the selected template with the current image.
Print the selected template with saved images (Print dialog only) If
you select a template that contains links to images, the current image
will be ignored and the template and all its images will be printed.
Header (Print Layout window only) Mark the check box to include
header text at the top of the page, and then type the text in the edit
box.
Footer (Print Layout window only) Mark the check box to include
footer text at the bottom of the page, and then type the text in the edit
box.

Printing a Single Image
To print the active image:
Quick steps for printing
Press Ctrl + P to open the Print
dialog, then press Enter.

1 Choose File > Print, click Print
Print dialog.

, or press Ctrl + P to open the

2 Do any or all of the following:


In the Printer group box, select the printer and whether to
print to file.



On the Placement tab, choose the number of copies, the page
orientation, and the size and position of the image.



On the Options tab, choose the print output, color options, and
print marks.



On the Template tab, choose to print a template with images
or fill a template with the current image.

Selected options display on the image preview. For more
information on the options, see “Printing Multiple Images on a
Page” on page 360.
3 Click the Print button to print the image. Or, click the Close
button to save the print options without printing the image.
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Printing Multiple Images on a Page
Use Paint Shop Pro’s Print Layout window to print multiple images
in a variety of ways. For example, print nine wallet-size copies of
the same image, print two different images on the same page, or
arrange an image to print on labels.
Note
After you arrange a layout, save the layout as a template that you can
use later. For more information, see “Saving a Page Layout” on
page 365. Paint Shop Pro includes many templates to use or modify.
For more information, see “Printing Images Using a Template” on
page 366.

About the Print Layout Window
Print Layout Window
Thumbnails

Layout

To print images using the Print Layout Window:
1 Open the Print Layout window:


From the Paint Shop Pro workspace, open each of the images
you want to print, and then choose File > Print Layout.



From the Paint Shop Pro Browser, select the thumbnail of
each image you want to print, and then choose File > Print
Layout.
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Where did the image go?
The print layout workspace
extends under the thumbnail list.
Zoom out or use the scroll bars to
see if your image is hidden under
the thumbnail list.

Using the Zoom tools:
 To zoom in on a specific area,
click the Zoom to Rectangle
button
. Then click and drag
within the page layout to choose
an area to zoom in on (make
sure you click on a blank part of
the page to begin).
 To zoom in, click Zoom In 10% .
 To zoom out, click Zoom Out
10%.
 To make the page layout fill the
workspace, click
Zoom to Page .
You can also choose any of these
commands from the Zoom menu.

Thumbnails of all open images display on the left side. The page
layout to be printed displays in the center of a gray area (the print
layout workspace).
Note: To select more images from the Print Layout window,
choose File > Open Image or click the Open an Image button

.

2 Drag the thumbnails of the images you want to print into the print
layout. If an image is larger than the page, Paint Shop Pro asks
whether you want to scale the image. Click Yes to scale the
image to fit, or click No to place the image at its current size.
Note: To locate an image that is out of view in the Print Layout
window, use the scrollbars to scroll through the workspace and
locate the image, or choose Preferences > Auto Arrange. Paint
Shop Pro arranges all images in the workspace onto the page. If
the image is still out of view, choose Zoom > Zoom to Page.
3 Choose File > Print, or press Ctrl + P to open the Print dialog, or
click Print
to print the page with the current print settings.
Note: To adjust print settings, choose File > Print Setup or click
the Print Setup
. For more details, see “Choosing Printing
Setup Options” on page 357.
4 To close the Print Layout window, choose File > Close or click
the Close button
.
Note
To remove an image from a print layout, click the image to select it,
and then press Delete, or choose Image > Remove.

Arranging and Sizing Images in a Layout
Save layouts
You can save layouts as templates
to make page layout easier. Paint
Shop Pro also includes many
templates with common layouts.
For more information, see “Saving
a Page Layout” on page 365 and
“Printing Images Using a Template”
on page 366.

Once you have images open in the Print Layout window, you can
automatically or manually arrange images in a layout.

Automatically Arranging Images in a Layout
Use the Auto Arrange command to automatically size and position
images on the page of the Print Layout window. Paint Shop Pro
divides the page into sections of equal size and places each image in
a section. Only images on the page or in the workspace are used.
Before automatically arranging images, specify these preferences:
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To include borders between arranged images, choose
Preferences > Options to set the border width (the default is 0.5
inches or 1.27 centimeters). Then choose Preferences > Use
Borders or click the Use Borders button
. If you do not use
borders, Paint Shop Pro may arrange images with touching
edges.



To have Paint Shop Pro enlarge (stretch) images to fit their
sections of the page layout, choose Preferences > Stretch to Fit
or click the Stretch to fit button . If you do not choose this
option, when Paint Shop Pro automatically arranges photos, it
keeps them the same size or, if necessary, makes them smaller to
fit.

Manually Arranging and sizing Images in a Layout
Use rotate, resize, position, or zoom the images. Display the grid if
you want to precisely position image in the window.
To automatically arrange images:
1 Drag each image that you want to arrange onto the page or the
workspace.
2 Choose Preferences > Auto Arrange, or click the Auto Arrange
button .
To rotate an image:
1 Click the image to select it. To select multiple images, press Shift
and click each additional image.
2 On the toolbar, click Rotate 90+
or Rotate 90the same commands from the Image menu.

. Or, select

To resize an image:
Notes on resizing
Resizing an image for printing can
result in poor image quality. When
you enlarge an image, the image
loses detail and sharpness. As a
general rule, don’t enlarge or
reduce an image more that about
25 percent. If you need more than
a 25 percent change, scan or
create the image at a different
resolution.

1 Click the image to select it.
2 Drag a corner handle until the image is the size you want it. The
image maintains its aspect ratio.
To position an image:
Click and drag the image to a new position on the page. You can also
temporarily place images in the workspace around the page.
You can also position an image by clicking one of the command
buttons. These buttons align the selected image to the layout page.
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Place lower left

Place upper left

Center image

Place lower right

Position image at X,Y

Place upper right

Position image at X,Y Click this button to open the Place Image
dialog. Enter values to set the position of the image’s top left corner.

Using the Grid in a Layout
Use the grid to align images evenly on the page.
To display or hide the grid:
Choose Preferences > Show Grid, or click the Show Grid button

.

To snap images to the grid:
1 Display the grid.
2 Choose Preferences > Snap to Grid, or click the Snap to Grid
button
.
When you click and drag an image to position it, Paint Shop Pro
snaps it to the nearest grid line when you release the mouse.
To change the grid settings:
1 Choose Preferences > Options to open the Print Layout dialog.
2 Set the grid options. For more information see “In the Grid
settings group box, set the following options:” on page 364.
3 Click OK.
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Changing Print Layout Window Options
Use the options in the Print Layout dialog to set auto arrange
options, units of measurement, grid settings and template options.
To change Print Layout window settings:
1 In the Print Layout window, choose Preferences > Options to open
the Print Layout dialog.
2 Choose the Units, either inches or centimeters from the drop
down list. The dialog’s measurements will change to match.
3 Mar the Center to full page check box to have Paint Shop Pro
calculate the page center based on the actual size of the page.
Clear this check box to have the page center calculated based on
the printer’s margins.
4 In the Auto Arrange group box, choose from the following:


Use borders Mark this box to have the Auto Arrange function
leave a specified border around all images. Enter values for
the horizontal and vertical border sizes.



Stretch to fit Mark this box to have the auto arrange function
enlarge images as much as possible (while keeping their
aspect ratios).

5 In the Template options group box:


Choose the Default Placement to determine how images will
be placed in template cells by default.



Mark the Apply to current template check box to apply the
new default placement option to all the cells of the open
template.

6 In the Grid settings group box, set the following options:


Show Grid Mark the check box to show the grid, or clear it to
hide the grid.



Dot Grid Mark the check box to use a dotted-line grid, or clear
it to use a solid line grid.



Grid Color Click the color box to choose another color for grid
lines.



Horizontal Spacing Sets spacing between horizontal grid
lines.



Vertical Spacing Sets spacing between vertical grid lines.
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Snap-to-Grid Mark the check box to snap images to grid lines
when you position them. Clear the check box to position
images freely on the page.

Saving a Page Layout
After you set up a page layout, you can save it to print later. You can
also save just the formatting of your layout to use with other images.
Paint Shop Pro saves the layout as a template.
By default, templates you save are stored in the Print Templates
folder of the My PSP8 Files folder in your My Documents folder.
You can save your layouts in two ways: as a template or as a
template with images.

Templates
By default, Paint Shop Pro saves your layout as a template. When
you save your layout, Paint Shop Pro uses the size and position of
the images in your layout to create blank cells for new images to be
placed in. When you open the template later, you must place new
images into the blank cells.

Templates with Images
For a layout with certain images that you want to print repeatedly,
save the layout as a template with links to the images. Every time
you open the template, it will open and display the images you
placed in your layout. If you modify images linked to a template, the
modified images will appear the next time you open the template.
To save a layout:
1 Choose File > Save Template or click the Save Template button
to open the Save dialog.
2 Enter a name for the new template in the Name field.
3 Choose a save option:


Mark the Save with Images check box to save image links
with the template. When you open the template the images
currently on the page will appear. Clear this check box to
create a blank template.
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4 Click OK.
Note
To delete a print layout, navigate to the Print Templates folder in the
Paint Shop Pro program directory, and delete the layout from the
folder.

Printing Images Using a Template
To open the Print Layout
window
At the Paint Shop Pro main menu,
choose File > Print Layout.
This command is only available
when at least one image is open in
Paint Shop Pro.

Use templates to simplify image placement and sizing. Templates,
by default, do not contain any specific images. However, Paint Shop
Pro can save templates with links to images.
Save your own templates (created from page layouts) or use any of
Paint Shop Pro’s many templates.
By default, sample templates are stored in the Print Templates folder
of Paint Shop Pro program folder. To change where Paint Shop Pro
stores and searches for templates, click the Edit template file
locations button
or choose File > Template locations. For more
information, see Chapter 18, Setting File Locations.
To print images using a template:
1 Open the Print Layout window:

A quick way to print with
templates from the
main workspace
The Template tab of the
File > Print command allows you
to fill templates with the current
image and print templates with
saved images. These actions are
also scriptable. For more
information on the Print to
Template option, see “Printing
Multiple Images on a Page” on
page 360.



From the Paint Shop Pro workspace, open each of the images
you want to print, and then choose File > Print Layout.



From the Paint Shop Pro Browser, select the thumbnail of
each image you want to print, and then choose File > Print
Layout.

Each open file is displayed in the thumbnail list on the left side.
A blank layout is displayed.
2 In the Print Layout window, choose File > Open Template or
click Open Template
to open the Templates dialog.
3 Choose a category from the Select a category list. Thumbnails of
the templates in each category are shown in the window to the
left. Templates that have images saved with them will show
colored template cells.
Note: When you save custom templates, they will appear under
the User Defined category.
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4 Select the thumbnail of the template you want to open.
Template Hint
You can also open a template by
double clicking its thumbnail.

5 Click OK. Paint Shop Pro displays the template in the Print
Layout window.
Note: If you saved images with the template, the images will
appear in the template cells and in the thumbnail list. Templates
that have images missing will display a greyed out cell in the
template thumbnail.
6 In the Print Layout window, choose File > Open Template or
click Open Template
to open the Templates dialog.
7 Choose a category from the Select a category list.
8 Select the thumbnail of the template you want to delete. Click
Delete.
9 Place images into the cells in the template:


Place multiple images by dragging each thumbnail into a
template cell.



Fill the template with copies of the same image, by dragging
one image thumbnail onto any cell and then choosing
Templates > Fill Template with Image or clicking the Fill
template with image button
.
Paint Shop Pro fills all cells with the image.

Note: By default, Paint Shop Pro centers the image within the
cell and scales the image to fit the cell. To change the default
placement method, see “In the Template options group box:” on
page 364.
Quick steps to printing
multiple copies of the
same image
Open a template, drag one image
into any cell of the template, then
choose Templates > Fill
Template with Image. Paint Shop
Pro places the same image in
every cell. Now choose File >
Print.

10 Choose a cell placement method from the Print Layout window
toolbar or from Image > Placement.
Note: You can select the image placement method of a cell before
or after you place an image.
Free format
Allows you to freely resize and position the
image in the cell.
Size and Center
The image size is not changed to match the
cell. You can resize the image and the image will always stay
centered in the cell.
Fill Cell with the image
Centers the image in the cell and
scales the image to fill the cell. The image aspect ratio is
maintained, but parts of the image may not be visible.
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Fit and center
Scales the image to fit entirely inside the cell
and centers the image in the cell. The image aspect ratio is
maintained.
Fit and adjust left
Scales the image to fit entirely inside the
cell and aligns the image to the left side of the cell. The image
aspect ratio is maintained.
Fit and adjust right
Scales the image to fit entirely inside the
cell and aligns the image to the right side of the cell. The image
aspect ratio is maintained.
Fit and adjust top
Scales the image to fit entirely inside the
cell and aligns the image to the top of the cell. The image aspect
ratio is maintained.
Fit and adjust bottom
Scales the image to fit entirely inside
the cell and aligns the image to the bottom of the cell. The image
aspect ratio is maintained.
To move, rotate, and resize images in cells:
Placing images from the
thumbnail list
To control how Paint Shop Pro
places an image when you drag it
from the thumbnail list, change the
template options. For more
information see, “In the Template
options group box:” on page 364.

Follow the instructions in “Choose Preferences > Auto Arrange, or
click the Auto Arrange button .” on page 362.
To delete a template:
1 Do one of the following:


From the Paint Shop Pro workspace, choose File > Print
Layout.



From the Paint Shop Pro Browser, choose File > Print Layout.

To remove an image from a template:
1 Click the image to select it.
2 Press Delete, or choose Image > Remove.
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Editing Template Cells
You cannot move or resize cells in a template. A cell’s position and
size is locked when a layout is saved as a template.
However, if you saved images with a template, you can revert the
template back to a layout.
To revert a template (with images) to a layout:
1 Open the template you want to edit. For more information, see
“Printing Images Using a Template” on page 366.
2 Choose File > New Template or click the New Template button
. A dialog will open asking, “Do you want to keep the current
images in the new template?”
3 Click Yes.
The Print Layout window will display a new layout that contains
all the images that were in the template.

Printing Images from the Browser
Use the Paint Shop Pro Browser to print all images within a folder,
or only selected images. Print the images as thumbnails, or print
them any size using a template.
When you print from the Browser, Paint Shop Pro automatically
includes the file name under each image, as well as the folder name
at the top of the page, and a page number at the bottom.
To print images from the Browser:
1 Choose File > Browse or press Ctrl + B.
The Browse window opens and the main menu updates with
Browse commands.
2 Navigate to the folder that contains the files you want to print.
3 Select files using one of these methods:


Click the file’s thumbnail.



To select more than one file, press Ctrl and click each file.



To select sequential files, click the first file, then press Shift
and click the last file.

Note: To deselect a file, press Ctrl and click its thumbnail.
4 Choose File > Print to open the Browser Print dialog.
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5 Choose options from the Printer and Copies group boxes.
For more information, see “Printing Multiple Images on a Page”
on page 360.
6 Choose a thumbnail option:
Use Thumbnails Mark the check box to use thumbnail images,
which print faster but are lower resolution and fuzzy. Clear the
check box to print the images at normal resolution.
7 Choose template options:
Use the standard template


Mark this box to print all the images at thumbnail size.



Clear this box to choose a template from the drop down list.
The Browser will use the template to format your images for
printing. To change the folder where Paint Shop Pro loads
templates from, click the Edit Paths button. For more
information, see Chapter 18, Setting File Locations.

8 Choose a Print Range option:
All Prints all the pages the Browser has created for printing.
Pages Prints only the page range you enter in the from and to
fields.
Selection Prints only the images you selected in the Browser
window instead of all the images in the current folder.
9 Click the Print button to print. Or, click the Close button to save
the print options without printing the images.
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Printing with CMYK Color Separations
When you print using CMYK separations, Paint Shop Pro prints four
pages representing the levels of Cyan, Magenta, Yellow, and Black
in the image.
Note
Printing CMYK separations is the opposite of the Colors > Split
Channels > Split to CMYK command. When you split channels
Paint Shop Pro treats white as full color and black as no color
(brighter equals more color). When you print CMYK separations,
Paint Shop Pro treats black as full color and white as no color
(darker equals more color).
To modify the default CMYK conversion preferences, see “Defining
CMYK Profiles” on page 371
To print CMYK color separations:
1 Choose File > Print to open the Print dialog.
2 Click the Options tab.
3 In the Print Output group box, choose CMYK Separations.
4 Choose other print options as desired. For more information, see
“Printing Multiple Images on a Page” on page 360.
5 Click the Print button.

Defining CMYK Profiles
In a CMYK (Cyan, Magenta, Yellow, and Black) conversion, Paint
Shop Pro replaces the RGB (Red, Green, and Blue) colors you see on
the monitor with the CMYK colors used in printing. You can then
print a separate page for each CMYK color by selecting the CMYK
Separations option in the Page Setup dialog box. This is useful if you
are using a pre press shop and doing high-end printing.
Before printing the separations, configure the CMYK preferences to
determine how Paint Shop Pro handles the conversion from RGB to
CMYK. Save these preferences in a file called a profile.
To set the current profile:
1 Choose File > Preferences CMYK Conversion Preferences to
open the CMYK Conversion Preferences dialog.

371

372

Chapter 16: Printing Images

2 Choose the name of the profile from the Current Profile drop
down list.
3 Click OK.
To create a new profile:
Note
Paint Shop Pro uses the program’s default settings until you create a
profile.
1 Choose File > Preferences > CMYK Conversion Preferences to
open the CMYK Conversion Preferences dialog.
2 Do one of the following:


Choose the name of a profile from the Current Profile drop
down list and click New. This will base the new profile on the
settings of the selected profile.



Click New. This will base the new profile on the program’s
defaults.

The New CMYK Profile dialog will open.
3 Type a name for the new profile in the Enter profile name field.
4 Choose the initial setting:
Reset to defaults Base the new profile on the program’s defaults.
Use current settings Base the new profile on the settings in the
current profile.
5 Click OK.
To remove a profile:
1 Choose File > Preferences > CMYK Conversion Preferences to
open the CMYK Conversion Preferences dialog.
2 Choose the name of the profile from the Current Profile drop
down list.
3 Click OK.
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Modifying a CMYK Profile
Use the tabs on the CMYK Profile dialog to configure the CMYK
black generation, transfer and components, and to adjust the for
color shifts.
To open the CMYK Profile dialog:
1 Choose File > Preferences > CMYK Conversion Preferences to
open the CMYK Conversion Preferences dialog.
2 Choose the name of the profile from the Current Profile drop
down list.
3 Click Modify to open the CMYK Profile dialog
Note
Clicking Default in any of the profile tabs will reset the tab to the
program’s default settings.
To configure the Black Generation tab:
1 In the CMYK Profile dialog click the Black Generation tab.

2 In the Method group box, choose from the following options:
UCR - Undercolor Removal Replaces some of the cyan, magenta,
and yellow components of neutral grey and shadow areas with
black. This helps compensate for some of the trapping problems
that occur in multi-color printing.
GCR - Grey Component Replacement Replaces grey components
in colored areas with black. The least prominent color is reduced
or removed completely, along with proportional amounts of the
other two colors, to define a grey component, which is then
replaced with black ink.
3 In the Parameters group box, configure the following settings:
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Total coverage limit This can range from 200 to 400%
Blank ink coverage limit This can range from 0 to 200%
Black starts at This can range from 0 to 100%
GCR Black Gamma This can range from 1 to 4. This option is
inactive unless the GCR option is selected.
Note: The black line in the graph represents the black value and
updates as you change the settings.
To configure the Transfer and Components tab:
1 In the CMYK Profile dialog click the Transfer and Components
tab.

The left panel of the Transfer and Components tab displays a graph
of the transfer curves for cyan, magenta, yellow, and black. The
right panels display parameters for grey and color components.
2 In the Transfer Curves group box, adjust the transfer curves by
highlighting the name of a curve in the Transfer Curves dropdown list, and then dragging the points of the curve up or down.
Each transfer curve contains five adjustable points that define the
curve based on its zero-tone, quarter-tone, mid-tone, threequarter-tone, and full-tone percentages. The default curve is a
straight line from 0 to 100%. A curve that slopes above this 45°
line produces darker tones.
3 In the Grey Component group box, set the percentages by typing
values into the corresponding fields. Values can range from 0 to
100%.
4 In the Color Component group box, set the percentages by typing
values into the corresponding fields. Values can range from 0 to
100%.
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To configure the Ink Calibration tab:
1 In the CMYK Profile dialog click the Ink Calibration tab.

2 In the Hue and Greyness group box, click in the color box of the
color you want to change to open the Color dialog. Adjust the
color settings and click OK.
3 In the Grey Balance group box , type values in the text fields to
adjust the individual CMY percentages.
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C H A P T E R 17
Automating Tasks
Automating a lengthy task or set of tasks is one of the many exciting
benefits of Paint Shop Pro 8. This chapter describes four important
time-saving features:

Contents



Automated Productivity Scripts let you automate an action or set
of actions that you apply to images.



Presets allow you to save dialog or tool settings for later use.



The Batch Process feature lets you, among other things, convert
multiple files from one file format to another.



The Batch Rename feature lets you rename multiple files at once.
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Scripting Basics
What is Scripting?
One of the more powerful new features in Paint Shop Pro 8 is
Scripting. Paint Shop Pro 8 has a full-featured scripting engine based
on the Python programming language (see http://www.python.org/
for more information on this language). Although you can write your
own scripts using Python syntax, Paint Shop Pro’s built-in script
recorder can do this work for you, allowing you to script almost any
action within the application.
If, however, you choose to write a script in the Python language,
note that Python uses indentation to determine scoping, thus you
must be very careful about mixing spaces and tabs. We recommend
that you use a Python-aware editor such as PythonWin or Idle if you
choose to write your own scripts.

Displaying the Script Toolbar
You will find it much easier and faster working with scripts via the
Script toolbar. If it is not already displayed, choose
View > Toolbars > Script. The Script toolbar looks like this:

About the Script Toolbar Buttons
Note
Most of the Script toolbar buttons have equivalent menu commands
accessed by choosing File > Script.
The items in the Script toolbar are:
Select Script
By default, this drop-down list
shows the scripts saved in Paint Shop Pro 8’s Scripts-Trusted and
Scripts-Restricted folders. Using the File Locations dialog, you
can set this drop-down list to display any folder’s scripts.
Run Selected Script
Click this button to run the script
displayed in the Select Script drop-down list.
Edit Selected Script
Click this button to edit the script
displayed in the Select Script drop-down list.
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Interactive Script Playback Toggle
Click this button to switch
between Silent and Interactive mode when running scripts. When
the button shows a border, it is set to Interactive mode.
Run Script

Click this button to open and run a script.

Stop Script

Click this button to stop the running script.

Note: This button will only be active while the script is
running.
Start Script Recording
Click this button to begin recording
actions that will comprise a script.
Pause Script Recording
recording of a script.
Cancel Script Recording
recording.
Save Script Recording
you have recorded.

Click this button to pause the
Click this button to cancel script
Click this button to save the actions

Note: This button is only active if you have completed a
“scriptable” action.

About the Script Output Window
Script Output tip
Text in the Script Output window
can be selected and copied to the
clipboard. This can be helpful if
you need to report error
information.

To display this window, choose View > Palettes > Script Output.
This window may automatically appear to display information such
as:


Commands that are executed when running a script.



Script error information such as Python syntax errors or runtime
errors.



Statements output from hand-written scripts containing a Print
command.

To clear the Script Output window:
Choose File > Script > Clear Output Window or right-click the
window and choose Clear from the context menu.
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Recording and Saving a Script
Before you begin recording a script, be aware of these general rules
as to which actions can be recorded within Paint Shop Pro 8:


You cannot script user interface customizations, CMYK profile
creation/editing, operations inside the Browser, operations inside
of Print Layout, gradient creation, or the floating/docking/
arranging of toolbars, palettes and windows.



Materials palette operations and Tool Palette selections can be
scripted but are not recorded — these actions need to be written
via a text editor application.



Plug-ins are scriptable, but plug-ins that do not support scripting
cannot be scripted.



Outside of the above restrictions, anything you do in Paint Shop
Pro 8 should be scriptable.

Scripting rules of thumb:
The longer a task takes to
complete, the more desirable it is
to have a script for it. However, if a
task only takes two or three mouse
clicks to complete, creating and
running a script for those few
actions may not save you any time.

To record and save a script:
Want to author your own
Python language scripts?
On the Paint Shop Pro 8 CD,
browse for a directory labeled
“Script Authoring.” Inside are
documents detailing sample
scripts, instructions for writing
scripts, and an API document.

1 Make a note of or write down the specific actions you wish to
record. Ideally, your actions should be as efficient as possible.
2 To begin recording, click Start Script Recording

.

3 Perform the actions that comprise the script.
4 Click Save Script Recording . In the Save As dialog, navigate
(if necessary) to where the script will reside, enter a name for the
script, and then click Save.

Running a Saved Script
To run a script listed in the Select Script drop-down list:
1 Select the script that you want to run from the drop-down list.
To run a script on all open
images:
Using one of the methods on the
right, run the script on the first
image. Make another image active,
and then press Ctrl + Y. Repeat
this for each open image.

2 Click Run Selected Script

.

To run a script not listed in the Select Script drop-down list:
1 Click Run Script

to display the Run Script dialog.

2 Navigate to the folder containing the script that you want to run.
3 Select the script and click Open to execute the script.

Chapter 17: Automating Tasks

Stopping or Undoing a Script
To stop a running script:
Click Stop Script

.

Note: The Stop Script button is only active while the script is
running. Depending on the script, this may only be a few
seconds.
To undo an applied script:
Like any other action applied to an image, you can always undo an
applied script by clicking Undo
on the Standard toolbar.

About BoundScripts
Paint Shop Pro allows you to create up to nine special scripts called
BoundScripts. Because these scripts are essentially commands, you
can drag them into a toolbar, a menu, or assign them a keyboard
shortcut.

Creating a BoundScript
A BoundScript is created just like any other type of script. However,
you must name it “BoundScriptn”, where n is a number ranging from
1 to 9. Before creating a BoundScript, you may want to delete the
supplied sample BoundScript of the same name to ensure you are
using your new script.
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Adding a BoundScript to a Toolbar
Add a BoundScript to a toolbar or menu just like any other command
button. (Refer to Chapter 18 for more information on user interface
customization.) Shown below is a section of the Customize dialog’s
Commands tab. When you select BoundScripts in the Categories
list, the buttons for the nine BoundScripts appear in the Commands
list. Simply drag the desired button into a toolbar or menu.

About Protected Script Mode
The scripts in Paint Shop Pro 8 are created in the Python
programming language, which can unfortunately be used to create
and execute malicious scripts. Because of this potential danger, Paint
Shop Pro includes two explicit directory sets:
Scripts - Restricted Scripts residing here are restricted (see
Restriction information below).
Scripts - Trusted Script residing here are trusted.

What is Restricted?
Some general notes about Restricted scripts:


If a Restricted script calls a Trusted script, the Trusted script runs
as Restricted. If a Trusted script calls a Restricted script, the
Restricted script remains Restricted. Following the return of the
Restricted script, the Trusted script is trusted again.



When the application searches for scripts, Restricted scripts are
searched before Trusted scripts. In the Script toolbar’s Select
Script drop-down list, the two sets of scripts are intermingled and
listed alphabetically.



When saving a script, the path defaults to the Restricted directory
for the first time this is done with the application. After that, it
defaults to the most recently used directory.
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If a script is run from an unconfigured path, it is treated as
Restricted.



If a path appears in both the Restricted and Trusted lists, it is
treated as Restricted.



Presets, Material palette Swatches, and Print Layout Templates
(which are essentially scripts) are treated as Restricted.



Additionally, the following commands are not allowed when run
from a Restricted script:
File: Save, Save As, Save Copy As, Close, Close All, Send, Exit
File > Export: GIF Optimizer, PNG Optimizer, JPEG Optimizer,
Image Mapper, Image Slicer
File > Preferences: File Locations
File > Batch: Process, Rename

Toggling Interactive Script Playback
Mode
To toggle between Interactive and Silent script playback mode,
simply click the Interactive Script Playback Toggle button
on the
Script toolbar. When the button has a border around it, it is in
Interactive mode.
Note
If part or all of a script has been set to run in either Silent or
Interactive mode, this button will not override that setting. If all or
part of a script is set to Default mode, the state of this button will
override the Default setting.

383

384

Chapter 17: Automating Tasks

Editing Scripts
Scripts can be edited via the Paint Shop Pro user interface, or by
editing the script’s Python code with a text editor application.

Editing Scripts Using Paint Shop Pro
To edit the currently selected script:

1 Click the Edit Selected Script button . The Script Editor dialog
will appear, listing the actions that comprise the script, as well as
some basic information. Shown below is a portion of the dialog.

Mark to use
command

Select a Mode for
the command actions

Click the command or feature
to modify its settings

Note: If the script you wish to edit is not in the Select Script
drop-down, choose File > Script > Edit to display the Open
dialog. Navigate to where the script resides. When you open the
script, its information will appear in the Script Editor dialog.
Note: If the Script Editor cannot open the script (e.g. the format
is unreadable, or perhaps the script was created or edited
manually in a text editor), the script will open in the default text
editor application set in the File Locations dialog. Refer to the
section “Editing Via a Text Editor” below.
2 In the Scripts Commands section, you can do the following:


Mark the check box to use that portion of the script.



Use the Mode drop-down list to set a mode for the script’s
actions:
Silent Skip all dialogs. The command in the script is executed
without showing any of the user interface.
Interactive Allows for user interaction with dialogs and other
settings.
Default Executes the command based on what the execution
environment has set for its preference.
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To display and/or modify a command’s settings, select the
command and then click Edit, or double-click the command.
Be aware that command names show in italics with the words
“NOT editable” cannot be selected for editing.
Note: There are a small number of commands that can only be
edited when an image is open in the workspace.



To remove commands from the script, select the command
and click Delete. To select multiple commands, use the
standard Shift-click or Ctrl-click methods.

3 To view and/or edit the Python code associated with the script,
click the Text Editor button. The default text editor will open the
script. Until you specify another application, the default editor is
Notepad. To change the default text editor, see “Editing Scripts
with a Text Editor” below.
4 To save your edits, click Save, and then click Close.

Editing Scripts with a Text Editor
With the Script Editor dialog displayed, you can edit the Python
code for your script by clicking the Text Editor button. (If you have
already modified the script in the Script Editor dialog, you will be
prompted to save or discard changes prior to switching to the text
editor application.) The editor application designated for script
editing will open.
To change the script editing application:
1 Choose File > Preferences > File Locations to open the File
Locations dialog.
2 In the File Types list, choose Python Source Editor.
3 On the right side of the dialog, enter the path for the editor
application you wish to use. Click Browse if you need to navigate
for the correct path.
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Using and Creating Presets
Presets are essentially scripts that define the behavior, properties, or
settings of a dialog or tool. Many dialogs and tools come with
predefined, ready to use Presets. You can also design and save your
own Presets.

Examples of Presets
Shown below are two examples of Presets, one from the Crop tool,
and one from the New Image dialog.

Crop tool Presets in the Tool Options palette

New Image dialog Presets
Most Paint Shop Pro dialogs and the Tool Options palette have the
following default presets:


Last Used These are the settings last used in this dialog. Each
time the dialog opens, Paint Shop Pro displays the Last Used
preset settings.
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Default These are the default program settings for this dialog or
tool. The default settings can provide a good starting point for
your work.

To choose a preset:
In the Presets drop-down list, select the desired Preset from the list.
To reset values to default settings:
In the Presets drop-down list, choose Default, or click the Reset
button
. To reset the dialog to the settings that displayed when
you opened the dialog, hold down Shift and then click the Reset
button.
To save settings as a preset:
How do I edit a preset?
To edit a Preset, select it, modify
the dialog or tool settings, click the
Save Preset button, and type the
same preset name. When you are
prompted to replace the current
Preset, choose Yes.

1 Modify the dialog or tool settings.
2 Click the Save preset button

. to open the Save Preset dialog.

3 Type a name for the Preset.
Note: You cannot use the names “Default” or “Last Used”.
4 To enter additional Preset information, click the Options button,
and then enter information in the Author, Copyright, and
Description fields.
The Preset includes group box shows the data saved with this
Preset. To omit any of these items from the Preset, click the Save
button associated with the item (a red X will appear over it).
5 Click OK.
To delete a preset:
1 In the Presets drop-down list, select the preset you want to delete.
Note: You cannot delete the Last Used or Default presets.
2 Click the Delete preset button

.
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Processing Multiple Files
To process multiple files use the Batch Process feature. Depending
on your settings in the Batch Process dialog, Paint Shop Pro can
make copies of original files, convert and then save the copies in the
output folder you select.
To use the Batch Process feature:
1 Open the Batch Process dialog by choosing
File > Batch > Process.
2 Navigate to the folder containing the source (original) files.
3 In the Save Mode group box, choose one of the following
options:
New Type This is the most basic option, requiring only that a new
output type be set in the Type field of the Save Options group
box. You can also choose to run a script with this Save Mode.
This option will: a) read in the file, b) run the script (if defined)
against the file, c) save the file to its new location and/or name,
and d) convert it to the new file format.
Copy This option requires that a script is defined in the Script
group box. This option will: a) read in the file, b) run the script
against the file, and c) save the file to a new location and/or
name. With this option selected, the Type field and Options
button of the Save Options group box will be disabled.
Overwrite This option requires that a script is defined in the
Script group box. This option will: a) read in the file, b) run the
script against the file, and c) save the file to its original location
(the original file is overwritten). With this option selected, all
Save Options group box settings are inactive.
Obey Script This option requires that a script is defined in the
Script group box. This option will: a) read in the file, and b) run
the script against the file. With this option selected, all Save
Options group box settings are inactive.
Note: Since no save is performed, you should only use this
option when you know the script performs a save. If not, this
option will not have any effect.
4 In the Save Options group box, set the following (the Save Mode
settings affects what is available in this group box):
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Click the Type drop-down list to select a new file format. If a
format has save options, the Options button is accessible.
Click it to open the Save Options dialog. Select the format
options and click OK to return to the Batch Process dialog.



Designate another output (destination) folder for the new files
by typing a path in the Folder field, or by clicking the Browse
button next to this field and navigating to another folder.
Unless you specify another output folder, Paint Shop Pro
saves the converted files in the same folder as the source files.



You also have the option of renaming the converted files. To
do so, click Modify to open the Modify Filename Format
dialog. The Rename Options list displays the choices for
renaming your files. Select an option and click Add to move it
into the Included list. Choose from the following options:


Custom Text When you choose this option, the program
displays a Custom text field below the Included list. Type
the name you want applied to the converted files.



Date The current date is added to the name.



Document Name Includes the original name in the new
name, but also allows for case changes (upper, lower).



Sequence The position of a file in the renaming process is
added to each file.



Time The current time is added to the name.

A preview of the new file naming scheme appears at the bottom
of the dialog. Click OK to go back to the Batch Process dialog.
5 To stop the conversion process if Paint Shop Pro encounters an
error, mark the Stop on error check box. If you do not mark it,
the program processes all the images without stopping. The error
messages appear in a Batch Conversion Status dialog.
Note: If you are overwriting files during processing, particularly
many files, you may want to leave this box unchecked to avoid
having to confirm the overwriting of each file.
6 Use the Script group box to run a script on all the files before
converting them. In the text entry box, enter the path for the
script, or click Browse and then navigate to where the script
resides. Mark the Run script in silent mode check box to ensure
the script runs in this mode.
7 If you have already selected files to process, click Start. If you
have not already selected the files to process, do one of the
following:
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To process specific files, press Shift while selecting
contiguous files or Ctrl while selecting non-contiguous files,
and then click Start.



To process all files displayed, click Select All.

The Batch Progress dialog opens, and the batch conversion starts.
The Current Step pane displays each filename and whether it is
converted, while the Job Progress bar indicates the conversion
progress. To stop the conversion, click Abort.
During the conversion, Paint Shop Pro might open other dialogs
requesting more information if you have selected Meta, PostScript,
Photo-CD, or RAW files.
8 After the files have been converted, either click OK to close the
dialog, or click Save Log to save the progress messages to a text
file. Clicking Save Log opens the Save As dialog. Type a name
for the file and click Save. Paint Shop Pro saves the information
with a .log file extension.
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Renaming Multiple Files
To use the Batch Rename feature:
1 Open the Batch Rename dialog by choosing
File > Batch > Rename.
2 Navigate to the folder containing the source (original) files.
If necessary, use the Files of type field to display particular file
formats. Choose All Files to display the folder’s entire contents.
3 To define a new name for the files, click Modify to open the
Modify Filename Format dialog. The Rename Options list
displays the choices for renaming your files. Select an option and
click Add to move it into the Included list. Choose from the
following options:


Custom Text When you choose this option, the program
displays a Custom text field below the Included list. Type the
name you want applied to the converted files.



Date The current date is added to the name.



Document Name Includes the original name in the new name,
but also allows for case changes (upper, lower).



Sequence The position of a file in the renaming process is
added to each file.



Time The current time is added to the name.

A preview of the new file naming scheme appears at the bottom
of the dialog. Click OK to go back to the Batch Rename dialog.
4 To stop the rename process if Paint Shop Pro encounters an error,
mark the Stop on error check box. If you do not mark it, the
program processes all the images without stopping.
5 If you have already selected files to rename, click Start. If you
have not already selected the files to rename, do one of the
following:


To rename specific files, press Shift while selecting
contiguous files or Ctrl while selecting non-contiguous files,
and then click Start.



To rename all files displayed, click Select All.
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C H A P T E R 18
Customizing Paint Shop Pro
By setting up Paint Shop Pro to appear and respond in ways that
best suit your work, you’ll not only create a better user experience,
but you’ll likely find yourself working faster and more efficiently.
This chapter describes the various ways you can customize Paint
Shop Pro.
Note
CMYK Conversion Preferences are covered in Chapter 16, Printing
Images.
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Setting General Program Preferences
General Program Preferences define the behavior of various
features.
To set General Program Preferences:
1 Choose File > Preferences > General Program Preferences to
open the Paint Shop Pro Preferences dialog.
2 Click the tab containing the preference information you want to
change.
3 Modify the desired settings, and then click OK.

Undo/Redo Preferences
The Undo tab controls some settings of the Undo and Redo
commands.
Enable the undo system Mark this check box to activate the
Undo command. Clear the check box to deactivate the Undo and
Redo commands.
When the undo system is active, choose from these options:
Limit undo/redo disk usage per open image Sets the maximum
amount of disk space each images undo/redo steps can use.
Limit undo/redo steps per open image Sets the number of times
you can undo or redo in each open image.
Compress undo/redo information Saves disk space, but slows
down undo and redo operations.
Enable the redo system Activates the Redo command.

View Preferences
The View tab controls some image window behaviors.

Zooming
These options determine if Paint Shop Pro automatically resizes an
image window when you zoom in or zoom out. A window is resized
to include as much of the image as will fit.
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New Images
Auto size With this check box marked, Paint Shop Pro automatically
zooms out to fit the entire image in the window if you open an image
that is too large to fit in its image window.

After Changing Size
Fit window to image check box is selected, Paint Shop Pro
automatically resizes the image window whenever you resize an
image.
Auto Size With this check box marked, if you increase an image’s
size to more than can fit in its window, Paint Shop Pro reduces the
image’s magnification accordingly.

Display and Caching Preferences
The Display and Caching tab controls presentation and caching.
About color pickers
In previous versions of Paint Shop
Pro, you could use the Jasc Color
Picker or the Windows Color
Picker. In Paint Shop Pro 8, the
Windows Color Picker is not
available.

Presentation Options
Re-use last type in save-as dialog When you mark this check
box, the last file format used to save an image automatically
appears in the Save as type field.
Display all color dropper ToolTips Clear this box to hide the
color information that appears next to the dropper tool when it is
positioned over a color.
Use precise cursors Mark this check box to use a cross hair for
tool cursors instead of the tool’s icon.
Show brush outlines Clear this check box to hide the outline
(shape, size) of the current brush as the cursor moves over an
image.
Thumbnail/Preview Enter a size for the thumbnails in the Effects
Browser and the preview images that display in the Layer palette.
Zoom/Rescaling Quality Adjust the slider between Faster and
Better. Faster will zoom images faster, but will display less fine
detail. Better will zoom images more slowly, but display more
fine detail.
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Caching Options
These options allow for faster image redraws after you make
changes. By default, they are all marked. Turning these options off
will likely slow image redraws.
In the Image group box:
Merged Image Clear this check box to stop saving an image cache
of your entire merged image.
Merged Below Active Layer Clear this check box to stop saving
an image cache of all the layers below the active one.

Group Layers Options
Merged Group Clear this check box to stop saving an image
cache of the merged image for each group.
Merged Below Active Layer Clear this check box to stop saving
an image cache of all the group layers below the active one.

Palettes Preferences
The Palettes tab controls behaviors of the materials palette as well as
how palettes dock.

Materials Palette Options
Display colors in RGB format or Display colors in HSL format
This option controls the color information that appears in the
materials palette and with the dropper tool.
Why use hexadecimal?
Web browsers use the
hexadecimal format to specify
colors.

Decimal display or Hexadecimal display
This option controls how color values will display throughout the
program.
Show rainbow picker or Show document palette
For images with limited palettes (8-bit, 256 color), the document
palette shows only colors that are actually in the image.

Docking Options
Clear the check box beside each palette to prevent the palette
from docking. This will allow you to drag the palette anywhere in
the workspace.

Chapter 18: Customizing Paint Shop Pro

Browser Preferences
The Browser tab controls the appearance and operation of the
Browser.

Thumbnail Size
Enter values (in pixels) for the thumbnail size the Browser
displays. The size range is from 50 to 150 pixels. Clear the
Symmetric check box to adjust thumbnail width and height
independently.

Appearance
Color choice tip:
Right-click the Selection color
box to pick from the Recent
Colors dialog.

Choose Use Windows colors to highlight thumbnails with the
current Windows selection color. Or, choose Use classic colors
and choose a thumbnail highlight color form the Selection color
box.
Clear the Display flat style thumbnails check box to display
thumbnails that look like raised button bars.

Other Options
Display tooltips over thumbnails Clear this check box to hide the
image information that appears when the cursor is over
thumbnails.
Save browser files to disk Clear this check box to stop the
Browser from creating a cache file in folders you browse. By
default, when you view a folder using the Browser, Paint Shop
Pro saves a file called pspbrwse.jbf in that folder. This cache file
allows you to view the thumbnails more quickly the next time
you browse the folder.
Automatically update the thumbnails Mark this check box to
automatically update a folder’s cache file every time the folder is
browsed. When you view a folder with the Browser, the Browser
displays the contents of the folder’s cache file. If you make
changes to the images in the folder, the thumbnails will not show
the results unless the cache file is updated.
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Units Preferences
Grid Preferences
To set grid preferences, see
Chapter 6, Editing Images.

The Units tab controls ruler options and the default resolutions for
new images.

Rulers
Choose a measurement system for the rulers from the Display
units drop-down list.
Choose Toolbar colors to have the ruler color match
Paint Shop Pro’s toolbars or choose Black on White rulers.

Default Resolution
Choose a measurement system from the drop-down list and enter
the default resolution for new images. You can override this
resolution on an image-by-image basis by modifying the settings
in the New Image dialog.

Vector Coordinates
When this check box is marked, objects will snap to the center of
pixels while they’re moving. You will have to zoom in very far
to see this.

Transparency Preferences
The Transparency tab controls the grid representing transparent
backgrounds and transparent areas of layers.
Grid size Chose a grid size from the drop-down list.
Grid Colors Choose a color scheme from the Scheme drop down
list. To customize the grid colors, click inside the Color 1 or
Color 2 boxes and select new colors.

Color choice tip:
Right-click the Selection color
box to pick from the Recent
Colors dialog.

Preview displays your proposed changes to the transparency grid.

Warnings Preferences
The Warnings tab controls how warning dialogs will display.
By default, Paint Shop Pro displays a warning dialog whenever you
are about to perform an operation that will result in lost information
or one that can not be applied to the image in its current state.


To prevent a warning from appearing, clear the check box in
front of its description.
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Click the Enable All button to mark all the check boxes in the list.



Click the Disable All button to clear all the check boxes in the
list.

Photo Sharing Preferences
The current photo sharing service provider is shown in the Select a
photo sharing service list. When you choose File > Export >
PhotoSharing, that provider’s site will be accessed via your Web
browser.

Auto Action Preferences
Common actions that need to be performed in order to further edit an
image can be automated.
For example, you can only apply effects to 24-bit images. However,
most of the Effects menu items are active even if the active image is
8-bit. When you select an effect in an 8-bit image, the Auto Actions
dialog opens telling you Paint Shop Pro must convert the image to
24-bit to proceed with the effect.
To set the preferences for an Auto Action:
1 Select an Auto Action from the Auto Action Prompt list.
2 Choose one of these options for each action:
Never Prevents the action from happening. Choosing Never will
make certain menu commands inactive if an Auto Action is
required to complete the command. Note that some items in the
list do not have this option available.
Always Performs the action silently (without prompting you).
Prompt Asks if you want perform the action.
Set all the actions in the list to a certain option by clicking
Always All, Never All, or Prompt All.
Reset all the actions in the list to the program’s default settings by
clicking Reset.
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Miscellaneous Preferences
The Miscellaneous tab controls a variety of preferences.
Recently used file list Set the maximum number of files that will
appear when you choose File > Recent Files. For example, if the
value is set to four, only the last four saved files will appear on
the list.
Note: You must restart Paint Shop Pro before the new settings
will take effect.
Tolerance to background color when pasting a transparent
selection When you paste data as a transparent selection, Paint
Shop Pro adds it to the current image, defines it as a selection,
and then deselects all the pixels that match the current
background color. The tolerance value you enter determines how
closely the background color must match the transparent color
for it to become transparent. The tolerance scale is 0% to 200%.


Zero percent indicates that only image pixels with a perfect
match to the current background color are made transparent.



200 percent indicates that all image pixels are made
transparent.

Clipboard Data on Exit Choose how Paint Shop Pro will handle
any clipboard data when you exit the program.


Ask Whenever you exit, Paint Shop Pro will ask you what to
do with the clipboard data.



Delete Clipboard data will be deleted on exit.



Leave Data will remain in the clipboard on exit.

Force full window redraw when positioning image elements
Mark this check box to redraw the information in the active
window whenever you move objects in the image.
Show splash screen when application starts Clear this option to
hide the Jasc Software, Inc. splash screen which appears at
program startup.
Disable pressure support for puck-type pointing devices Mark
this check box to turn off the pressure sensitive features of pucktype pointing devices included with graphics tablets.
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Resetting Application Preferences
Various program preferences can be reverted back to their defaults.
To reset application preferences:
1 Choose File > Preferences > Reset Preferences to open the Reset
the Application dialog.
2 Select from these choices:
Reset file locations Mark this check box to reset all file location
settings to the program defaults.
Reset workspace to default configuration Mark this check box to
reset the current workspace to the program defaults.
Reset dialog positions and last used settings When you mark
this check box, any dialogs that open will appear in their default
locations. Also, Paint Shop Pro will forget the last settings you
used in all dialogs.
Delete all cache files Mark this check box to delete (reset) all
existing cache files. Paint Shop Pro saves cache files on your
computer to improve program performance. Cache files can
become corrupted by computer errors.
Make all toolbars/palettes visible and on screen Mark this check
box to view all toolbars and palettes.
3 Click OK.

Using Custom Workspaces
The Paint Shop Pro workspace is made up of all the program’s
palettes, toolbars, and open images. You may find that the way you
arrange the workspace while editing photos may differ from your
arrangement for using the Web tools. Fortunately, Paint Shop Pro
allows you to save any number of workspace arrangements, allowing
you to load the specific workspace that best suits the work you
intend to do.
Paint Shop Pro also contains sample workspaces, such as one that
duplicates the Paint Shop Pro 7 workspace.
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Saving Workspaces
When you save a workspace, Paint Shop Pro saves the information
in a .PspWorkspace file. The following information is stored:


Ruler, grid, and guide information



Menu, palette, and toolbar settings, locations, and docking status



Browser window position (if open)



Full screen edit mode status



Open images, including the images zoom levels and scroll bar
locations
Note: Workspace files do not include an actual copy of any open
images. Workspace files only reference the name and location of
an image. If you delete an image from your computer, it will not
display in a workspace.

To save the current workspace:
1 Choose File > Workspace > Save or press Shift + Alt + S to open
the Save Workspace dialog.
2 To save the workspace in a folder other than the program default
folder, click Edit Paths. For information on editing paths, refer to
“Setting File Locations” on page 403.
3 In the New Workspace Name field, type a name for the new
workspace.
4 Click Save.
If your workspace contains any modified images that you have not
saved, you will be prompted to save the changes to your image.
Choose from these options:
Yes Saves the image changes and saves the workspace.
No Saves the workspace, but does not save the changes to your
image.
Cancel The workspace is not saved.
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Loading Workspaces
To load a workspace:
Quick Access to
Workspaces
Load a recently used workspace by
choosing it from the list of recent
workspaces located at the bottom
of the File > Workspace menu.

1 Choose File > Workspace > Load or press Shift + Alt + L to open
the Load Workspace dialog.
2 Select the workspace file you want to load.
Note: To load a workspace not displayed in the dialog, click Edit
Paths. For information on editing paths, please see “Setting File
Locations” on page 403.
3 Click Open.
Workspace files do not include an actual copy of any open images.
Workspace files only reference the name and location of an image. If
you delete an image from your computer, it will not display in a
workspace.
If you had two windows open for the same image when you saved
the workspace, they both open again.
If an image from the workspace is already open, Paint Shop Pro
applies the workspace settings to the open image.

Deleting Saved Workspaces
To delete a saved workspace:
1 Choose File > Workspace > Delete or press Shift + Alt + D to open
the Workspace dialog.
2 Select the workspace file you want to delete.
3 Click Delete.

Setting File Locations
Paint Shop Pro saves and searches for items in several default
folders on your computer. By changing File Locations preferences,
you can change where Paint Shop Pro looks for and saves important
items. You can also control how plug-ins are used and which Web
browsers are used to preview your images.

403

404

Chapter 18: Customizing Paint Shop Pro

Note
By default, all new files you create are saved in the appropriate
folder of the My Paint Shop Pro 8 Files folder in your My
Documents folder. Most default program files are stored in the
appropriate folder in the Paint Shop Pro 8 program folder.

Editing File Locations
Edit Paths: another way to
view file locations
You can open the File Locations
dialog by clicking the Edit Paths
button which appears in many
Paint Shop Pro dialogs.

The File Locations dialog controls where Paint Shop Pro looks for
and saves important files.

Changing File Locations
You can change where Paint Shop Pro to stores and retrieves
specific items.
To change file locations:
1 Choose File > Preferences > File Locations to open the File
Locations dialog.
2 From the File types list, select the file type that you want to
change file locations for.
3 Set the options and settings for listed folders:
Save To Folder
Choose one of the listed folders to be the
place Paint Shop Pro saves any new files of this type.
Scan Subfolders
Mark this check box to have Paint Shop Pro
search the folders inside the folder. Subfolders will not be
scanned unless the Enable Directory check box is marked.
Enable Directory
Mark this check box to have Paint Shop Pro
search for files in this folder.
4 Set the loading order of the folders in the list.


Use the arrows
to move a folder up or down the list
of folders. The folder at the top of the list will be searched and
loaded first. For example, the brushes in the first folder on the
Brushes list will display first in the Tool Options palette brush
tip drop-down window.
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Adding or Deleting File Locations
You can add or delete folders for Paint Shop Pro to store/retrieve
specific items. Deleting a folder means that Paint Shop Pro will no
longer look in the folder for any items (the folder is not deleted from
your computer).
Note
Some of the file types (Cache, CMYK Profiles) can have only one
location. You can only change the file location from one folder to
another. For more information on changing file locations, see
“Changing File Locations” on page 404.
To add file locations:
1 Choose File > Preferences > File Locations to open the File
Locations dialog.
2 From the File types list, select the file type for which you want to
add locations.
3 Click the Add button. A new blank item will appear in the folder
list.
4 Type the full path name of the folder you want to add, or click the
Browse button and navigate to the folder.
5 Click OK.
To delete file locations:
1 Choose File > Preferences > File Locations to open the File
Locations dialog.
2 From the File types list, select the file type that you want to
delete a folder from.
3 In the list of folders, select the folder you want to delete.
4 Click the Delete button.
5 Click OK.
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Setting Plug-in Locations
Paint Shop Pro allows you to use Adobe compatible plug-ins. Use
the File Locations dialog to choose folders containing plug-ins and
control how plug-ins are used.
To control plug-in functions:
1 Choose File > Preferences > File Locations to open the File
Locations dialog.
2 From the File types list, select Plug-ins.
3 Set these options:
Enable plug-ins Mark this box to allow Paint Shop Pro to use
plug-ins.
Limit Loaded plug-in files to those with an .8B* extension
The .8B* extension is the most common plug-in extension. Clear
this check box to load plug-ins with other extensions.
Allow file format plug-ins to request pre-filtering of support file
types Some plug-ins can open files that Paint Shop Pro also
supports. Mark this check box to allow a plug-in to try to open
(pre-filter) the file before it opens in Paint Shop Pro.
To add plug-in locations:
1 Choose File > Preferences > File Locations to open the File
Locations dialog.
2 From the File types list, select Plug-ins.
3 Click the Add button. A new blank item will appear in the folder
list.
4 Type the full path name of the folder you want to add or click the
Browse button to find and select the folder.
5 Set the options and settings for listed folders:
Enable Directory
Mark this check box to have Paint Shop Pro
search for plug-ins in this folder.
Scan Subfolders
Mark this check box to have Paint Shop Pro
search the folders inside the folder. Subfolders will not be
scanned unless the Enable Directory check box is marked.
6 Click OK.
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Selecting a Web Browser
Paint Shop Pro allows you to preview your images with Web
browsers. Use the File Locations dialog to select which browser(s)
to use.
To delete or edit Web browsers:
Another way to select Web
browsers:
Select View > Preview in Web
Browser to open the Preview in
Web Browser dialog. Click the Edit
Web Browser button.

1 Choose File > Preferences > File Locations to open the File
Locations dialog.
2 From the File types list, select Web Browsers.
3 Select a browser from the list.
4 Click Edit to change the browsers location or Delete to remove
the browser from the list.
5 Click OK.
To add Web browsers:
1 Choose File > Preferences > File Locations to open the File
Locations dialog.
2 From the File types list, select Web Browsers.
3 Click Add to open the Browser Information dialog.
4 Type the full path name of the Web browser you want to add or
click the Browse button to find and select the program.
Type a different name in the Web Browser Name field if desired
and Click OK.
5 Click OK.

Setting File Format Associations
File format associations control how Paint Shop Pro will interact
with many types of file formats.
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Adding and Removing Associations
What if I want to open a file
in another program?
When you associate a file format
with Paint Shop Pro, you can still
open that format in other
programs. Just use the other
program’s Open command.

You can have certain file formats automatically open in Paint Shop
Pro. For example, when you associate the JPEG file format with
Paint Shop Pro, all JPEG files will open in Paint Shop Pro when you
double-click them from the Windows desktop. The associated JPEG
files will also display Paint Shop Pro icons.
To associate a file with Paint Shop Pro:
1 Choose File > Preferences > File Format Associations to open the
File Format Associations dialog. Do any of the following:


To associate a specific file format, mark the format’s check
box.



To associate all listed formats, click the Select All button.



To associate all listed formats that are not already associated
with other applications, click the Select Unused button.



To associate no file formats with Paint Shop Pro, click the
Remove All button.

2 Click OK.
Note
To add or remove file extensions you want associated with the
selected format, see “Changing File Format Extensions” below.

Changing File Format Extensions
Note
File format extension changes will not take effect until the next time
you start Paint Shop Pro.
To set file extensions:
1 Choose File > Preferences > File Format Associations to open the
File Format Associations dialog.
2 Select the file format that contains the extensions you want to
set.
3 Click the Extensions button to open the Extensions dialog. The
preferred extension (the extension that Paint Shop Pro will use to
save files) is at the top of the list.
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4 Do one of the following:


To add a file extension, click the Add button. Type in the new
extension and click OK.
Note: File extensions that have been associated with Paint
Shop Pro will have an asterisk (*) after the name.



To delete a file extension, select the extension from the list
and click Delete.



To reset a format to its default extension(s), select the
extension from the list and click Reset.



To make an extension the preferred choice, select the
extension and click Preferred. The extension will move to the
top of the list.

5 Click OK.

Setting Autosave Preferences
Paint Shop Pro can automatically save all open images on a set
schedule. These autosaved files can help you recover your work if
your computer crashes. When Paint Shop Pro starts after a crash, it
will open any autosaved files it finds.
Note
To find where Paint Shop Pro saves the autosaved files, select
File > Preferences > File Locations and select the
Undo/Temporary Files folder from the File Type list.
To set the autosave preferences:
1 Choose File > Preferences > Autosave Settings to open the
Autosave dialog.
2 Set the options:


Enable autosave Mark this check box to activate the autosave
feature.



Minutes Set the number of minutes between each autosave.
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Setting File Format Preferences
You can specify how PSP handles images in the following formats:
Kodak PhotoCD, PostScript, RAW, and Windows Meta File.

Setting Kodak PhotoCD Preferences
The Kodak PhotoCD format (PCD) is used by many photo
developers. This format can provide multiple image resolutions in
one file.
To set PCD file format preferences:
1 Choose File > Preferences > File Format Preferences to open the
File Format Preferences dialog.
2 Click the PCD tab.
3 Choose:


A default resolution setting. For example, 1536 x 1204 pixels.



Ask when loading each file PSP will ask you to pick a default
resolution each time you open a PCD file.

4 Click OK.

Setting Postscript File Preferences
Paint Shop Pro can read PostScript files (including multi-page files)
through level 2 and open them as raster images. When converting,
Paint Shop Pro can anti-alias objects and retain transparency
information.
To set PostScript file import preferences:
1 Choose File > Preferences > File Format Preferences to open the
File Format Preferences dialog.
2 Click the PostScript tab.
3 Choose a prompt setting:
Prompt for size and options each time a PostScript file is opened
When you mark this check box, Paint Shop Pro will ask you to
choose settings for each PostScript file you open. Clear this
check box to use the Size and Options when not prompting
settings for all opened PostScript files.
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4 If necessary, choose non-prompting options:
Resolution Set the resolution for the converted raster image
Image mode Select a mode from the drop-down list.
Page Size Select a page size from the drop-down list.
By default, if a PostScript file has a bounding box, the program
will match the canvas size to the bounding box.
Landscape Mark this check box to switch the page orientation to
landscape. The default is portrait. This option does not rotate
your images; only use this option for landscape PostScript files.
Anti-aliasing Mark this box to anti-alias PostScript objects as
they are converted to raster images.
Render transparency Clear this check box to use a white
background instead of the default transparent background.

Setting RAW File Preferences
Paint Shop Pro can read and save RAW image formats.
To set RAW file preferences:
1 Choose File > Preferences > File Format Preferences to open the
File Format Preferences dialog.
2 Click the RAW tab.
3 Set the Save options:
Header size Sets header size of the file.
Flip top and bottom Mark this box to flip the image upside down.
4 Set the 24 bit options:
RGB order or BGR order Choose the color order.
Planar mode Clear this box to turn off planar mode.

Setting Metafile Preferences
Windows Meta File (WMF) is the Microsoft Windows native vector
format.
To set WMF image preferences:
1 Choose File > Preferences > File Format Preferences to open the
File Format Preferences dialog.
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2 Click the Metafile / Import tab.
3 Choose from the two Load options:
Prompt for size and options each time a file is opened When you
choose this option, Paint Shop Pro will ask you to choose settings
for each WMF image you open.
Use file header information when available Some WMF files
have a file header containing default size information. Choose
this option to use the file header default size (if available). If you
open a file without a header, the size defaults to the values you
type in the Default size when file header is not available group
box.
4 Choose the following options:
Import vector data Mark this check box to import WMF vector
data as objects you can edit with vector tools. Clear this check
box to convert all vector objects to raster images.
Apply smoothing Mark this check box to smooth curved
polylines (vector data only).

Customizing Toolbars and Menus
Paint Shop Pro 8 gives you almost total control over the program’s
toolbars, allowing you to:


Move commands from toolbar to toolbar.



Add almost any command to any toolbar.



Add your own custom scripts to toolbars (Refer to Chapter 17).



Create your own custom toolbar.

Customizing Toolbars
When you display the Customize dialog, the entire Paint Shop Pro
workspace transforms into customize mode. You can click and drag
almost any menu command or tool to any other menu or toolbar.
You can add or delete commands from the menus on the Menu Bar.
All this can be done with the Commands and Toolbars tabs of the
Customize dialog.
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To access the toolbar customize mode:
Right-click access to
Customize dialog
Another way to access the
Customize dialog is to right-click in
the Menu bar, Tool palette, or Tool
Options palette, and then choose
Customize from the context menu.

1 To open the Customize dialog, choose View > Customize. You can
click back and forth between tabs to access the controls you need.
2 After making your changes, click Close.
To select which toolbars are displayed:
1 Click the Toolbars tab.
2 Mark the check box next to the name of the toolbar you want to
display.
Note: The Menu Bar and Layer Palette Toolbar cannot be hidden.
To select which Menu Bar is displayed:
1 Click the Menu tab.
2 In the Application Frame Menus group box, select an option from
the Show Menus for drop down list:
Default This set of commands displays when no images are open.
Image This set of commands displays when images are open.
Browser This set of commands displays when the Browser is the
active window.
To reset a Menu Bar:
1 Click the Menu tab.
2 In the Application Frame Menus group box, select the menu you
want to reset from the Show Menus for drop-down list.
3 Click the Reset button.
To move a command button or tool:
Click and drag the item to another palette or toolbar.
To add commands or tools to a toolbar:
1 Click the Commands tab of the Customize dialog.
2 From the Categories list, select a category. Paint Shop Pro groups
related commands into categories. For example, click the File
category to display all File menu commands. To list all Paint
Shop Pro commands at once, choose All Commands.
3 From the Commands list, click and drag a command to a toolbar.
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To remove commands or tools from a toolbar


Click and drag the item to an empty workspace area or an empty
area outside a toolbar. Release the mouse button when you see
the cursor change to this shape:



Right-click on the item and choose Delete from the context
menu.

To reset all toolbars:
1 Click the Toolbars tab.
2 Click the Reset All button. All toolbars will revert to the
program’s default settings.
To reset a specific toolbar:
1 Click the Toolbars tab.
2 In the Toolbars list, select the name of the toolbar to reset.
3 Click the Reset button. The selected toolbar will revert to the
program’s default settings.
To add a separator to a toolbar:

1 Choose View > Customize to display the Customize dialog.
2 Right-click a button in the toolbar to which you’ll be adding the
separator, and then choose Start Group from the context menu
that appears. This adds a separator to the left of the button you
clicked.
Note: To rearrange a button relation to the separator, hold down
Alt and drag the button to the desired location.
To delete a separator from a toolbar:
1 Choose View > Customize to display the Customize dialog.
2 Right-click the toolbar button directly to the right of the
separator. This displays the context menu. Notice the check mark
next to the Start Group item.
3 Select the Start Group item to remove the check mark and the
separator.
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Creating a New Toolbar
You can create a custom tool bar with your favorite commands and
tools.
To create a new toolbar:
1 Choose View > Customize to open the Customize dialog.
2 Click the Toolbars tab.
3 Click New to open the Toolbar name dialog.
4 Type a name for the new toolbar and click OK.
A small, empty toolbar will open in the middle of the workspace.
To add commands to it, choose the Commands tab, and then drag
command icons into the new toolbar. For more information, see
“Customizing Toolbars” on page 412.
5 When you’re done adding commands, click Close.
To delete a custom toolbar:
1 Choose View > Customize to open the Customize dialog.
2 Click the Toolbars tab.
3 In the Toolbars list, select the name of the custom toolbar you
want to delete.
4 Click Delete.
5 Click Close.

Customizing Context Menus
Context menus open when you right-click with a certain tool or
right-click over a certain area of the workspace.
To customize a context menu
1 Choose View > Customize to open the Customize dialog.
2 Click the Menu tab.
3 From the Select context menu drop-down list, choose a context
menu. The context menu will display in the workspace. Edit the
menu just like any other toolbar. For instructions see,
“Customizing Toolbars” on page 412.
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Setting Other View Options
Assigning Shortcut Keys
You can assign a keyboard shortcut to menu commands, tools, and
even scripts.
To assign shortcut keys to commands and tools:
1 Choose View > Customize to open the Customize dialog.
2 Click the Keyboard tab.
3 In the Set Accelerator for drop-down list, pick which
application’s shortcuts you want to assign. Choose Browser or
Default (Paint Shop Pro’s main workspace).
4 In the Category drop-down list, select a category. Paint Shop Pro
groups related commands into categories. For example, if you
pick the File category, all the commands in the file menu are
displayed. To list all commands at once, choose All Commands.
5 In the Command list, select a command name.
The description of the command and any assigned shortcut keys
are displayed.
6 Click in the Press New Shortcut Key field.
7 Press the new keyboard shortcut you want to assign to the
command. The shortcut will appear in the Press New Shortcut
Key field. If the shortcut is already assigned to another
command, this will display below the field.
8 Click Assign to assign the new shortcut to the selected command.
9 Assign more shortcut keys or click Close.
To assign a shortcut key to a script:
1 Choose View > Customize to open the Customize dialog.
2 Click the Keyboard tab.
3 In the Set Accelerator for drop-down list, pick which
application’s shortcuts you want to assign. Choose Browser or
Default (Paint Shop Pro’s main workspace).
4 In the Category drop-down list, select Bound Script. For more
information on bound scripts, refer to Chapter 17.
5 In the Command list, select a bound script.
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6 Click in the Press New Shortcut Key field.
7 Press the new keyboard shortcut you want to assign to the bound
script. The shortcut will appear in the Press New Shortcut Key
field. If the shortcut is already assigned to another command, this
will display below the field.
8 Click Assign to assign the new shortcut to the selected bound
script.
9 Assign more shortcut keys or click Close.
To view all shortcut keys:
1 Choose Help > Keyboard Map to open the Help Keyboard dialog.
2 In the Show Accelerator for drop-down list, pick which
application’s shortcuts you want to view. Choose Browser or
Default (Paint Shop Pro’s main workspace).
3 In the Category drop-down list, select a category. Paint Shop Pro
groups related commands into categories. For example, if you
pick the File category, all the commands in the file menu are
displayed. To list all commands at once, choose All Commands.
The commands and their shortcut keys are displayed in the list,
sorted by command name. Click any column heading (Command,
Keys, or Description) to sort alphabetically by that column.
Note: To print the list of the current category of shortcut keys,
click Print
in the dialog’s toolbar.
To select commands and copy their information to the clipboard,
click Copy
.
4 When you are finished viewing keys, click the Close Window
button in the upper right corner.

Adjusting General View Options
The Menu and Options tabs of the Customize dialog control a
variety of general menu and toolbar features.

Menu Tab
Menu animations Choose an animation style for menu opening
and closing from the drop-down list.
Menu icons Clear this check box to hide the Menu Bar icons.
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Options Tab
Toolbar
Show Screen Tips on toolbars Clear this check box to hide the
ToolTips that appear over tools and buttons.
Show shortcut keys in Screen Tips Clear this check box to hide
the shortcut key (if available) that appear in ToolTips.
Large icons Mark this check box to display larger toolbar icons.

Personalized Menus and Toolbars
Menus show recently used commands first Mark this check box
to have Paint Shop Pro simplify its menus to show only recently
used commands. You can expand the menus by clicking the
expansion button.
Show full menus after a short delay If menus are only showing
the most recent items, all items will appear in a moment.
Reset my usage data Click this button to erase the memory of
your recently used menu commands.

Palettes
Show captions on docked palettes Mark this check box to give
layout captions a different appearance.

Adjusting Monitor Display Options
Calibrating Your Monitor
To get the best results when working with Paint Shop Pro, you need
to properly calibrate your monitor. Calibrating the monitor improves
image quality and allows others to view your images as you intend.
How often should I calibrate
my monitor?
Monitor performance can change
over time, so it’s best to calibrate
your monitor every few months.

To calibrate your monitor, you need an on-screen aid that helps you
adjust the monitor’s brightness and contrast. The Jasc Web site
provides an on-screen aid as well as detailed instructions for
calibration. Go to the Product Support section of www.jasc.com
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Adjusting the Monitor Gamma Setting
Note about Color
Management
If you enable Windows Color
Management, Paint Shop Pro
ignores the monitor gamma
preference setting.

Paint Shop Pro’s monitor gamma setting adjusts how colors display
in Paint Shop Pro. This setting does not affect how your monitor
displays colors in other applications.
Most users should not adjust the monitor gamma setting. If you
make color corrections after you change the monitor gamma, the
colors may look distorted on other monitors or in applications other
than Paint Shop Pro.
To adjust the monitor gamma:
1 Choose File > Preferences > Monitor Gamma to open the Monitor
Gamma Adjustment dialog.
2 Lean away from your monitor and look at the red, green, blue,
and grey rectangles. Each color contains an inner, solid color
rectangle and outer, patterned rectangles. On a correctly adjusted
monitor, the inner rectangles are difficult to distinguish from the
outer rectangles.
3 Do one of the following:


To adjust the red, green, and blue values in unison, mark the
Link channels check box.



To adjust the values individually, clear the Link channels
check box.

4 For each color (or for all colors if they are linked), drag the slider
until the inner rectangle seems to blend into the outer rectangle.
Note: If you have difficulty getting the inner rectangle to blend
into the outer rectangle, your monitor may be too old and faded.
5 Click OK.
Note: Click Reset to return no gamma adjustment (1.00).
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Using Windows Color Management
Color Management is a feature in Windows 98 or later that improves
color consistency and accuracy between images displayed on
monitors and printed on paper. Color Management also allows you
to preview how images will look when printed on a specific color
printer. Color Management is generally not used for Web images
because most Web browsers don’t use Color Management.
When to use Color
Management
You need to use Color
Management if any of the following
are true:






Your pre-press provider requires
specific color values for a known
set of printing conditions.
You are using the same color
graphics for printing on a printer
and displaying on a monitor.
You plan to use international and
domestic printing presses.

In order for Windows Color Management to work effectively, you
must have proper color profiles for all the devices you are using.
To create proper monitor and printer profiles, you must use thirdparty color profiling tools that include software or hardware for
determining how your monitor and printer produce color. If you do
not have custom monitor and printer profiles, using Color
Management is not recommend. For more information on Color
Management, please refer to your Windows documentation.
To use Color Management:
1 Choose File > Preferences > Color Management.
2 Mark the Enable Color Management check box.
3 Choose an option:
Basic color management Adjusts how the monitor displays
colors and how the printer produces colors. Most users should
choose this option.
Proofing Previews on the monitor how colors will appear on a
particular device. This option is best at representing the
limitations of a particular output device, such as a printer.
4 Select the printer and monitor profiles for your devices in the
drop-down lists.
5 For Rendering Intent, select the approach used to map image
colors to the color gamut of your monitor or printer. The
available options depend upon your Windows system. For
detailed descriptions, see your Windows documentation.
6 If you selected the Proofing option, select the Emulated device
profile (the profile of the output device) and the Rendering
Intent.
7 Click OK.
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Brightness and Contrast
Automatic Contrast Enhancement, 60
Brightness/Contrast, 191
Channel Mixer, 189
Clarify, 79
Curves, 192
Equalize, 191
Gamma Correction, 193
Highlights/Midtones/Shadows, 194
Histogram Adjustment, 205
Levels, 195
Stretch, 191
Threshold, 198
Color Balance
Automatic Color Balance, 54
Black and White Points, 188
Color Balance, 185
Fade Correction, 59
Manual Color Correction, 55, 57
Red/Green/Blue, 184
Grey World Color Balance, 58
Hue and Saturation
Automatic Saturation Enhancement, 61
Colorize, 197
Hue Map, 196
Hue/Saturation/Lightness, 186
Lens Correction
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Barrel Distortion Correction, 70
Fisheye Distortion Correction, 70
Pincushion Distortion Correction, 71
Negative Image, 200
Red-Eye Removal, 72
Sharpness
Sharpen, 80
Sharpen More, 80
Unsharp Mask, 80
Softness
Soft Focus, 68
Soften, 68
Soften More, 68
Adjustment layers
about, 283
adding, 283
editing, 285
modification basics, 285
types of, 284
Airbrush, 208
align vector objects, 241
alpha channels, deleting masks from, 301
anti-aliasing
lines, 230
text, 306
Art Media effects, 318
Artistic effects, 318
asterisk in title bar, 20
Auto Kern, 306
Automated Productivity Scripts, see Scripting
Automatic Color Balance, 54
Automatic Color Balance command, 54
Automatic Contrast Enhancement command, 60
Automatic Saturation Enhancement command, 61
Automating tasks, 377
Autosave
settings, 409
using, 47
Available Colors panel, 85
Average blur, 78

B
background color, 83
Background eraser, 217
Barrel Distortion Correction command, 70
Batch Process command, 388
black & white printers, 357
black and white images, 198
Black and White Points command, 188
blend
modes, 275
ranges, 277
Blur command, 78
Blur more, 78
borders
adding to an image, 150
modifying in selection, 174
BoundScripts
about, 381
adding to a toolbar or menu, 382
creating, 381
breaking contours, 249
brightness and contrast
adjusting, 190
adjusting gamma, 193
adjusting individual values, 192
adjusting manually, 191
Browser
Edit menu
Invert Selection, 44
Select None, 43
File menu
Select, 44
Sort, 44
Update Thumbnails, 46
Image File menu
Open, 30
preferences, 397
printing, 369
printing with templates, 370
using to copy images, 125
brush Preset
sharing with others, 214

Index

brush tip
creating, 209
deleting, 210
resetting defaults, 213
saving, 214
Brush Variance palette
opening, 212
using, 212
brushes
Clone, 219
erasers, 216
options, 211
Paint Brush or Airbrush, 208
Retouch, 220
Warp, 215
brushes, painting, 208
Burn brush, 220

C
cells
in image maps
in sliced images, 337
Change-to-Target brush, 221
changing canvas size, 139
changing curves and lines, 252
Channel Mixer command, 189
choosing colors, 86
for the Web, 88
from an image, 88
from the desktop, 90
from the image palette, 89
using the dropper, 90
choosing gradients, 91
choosing patterns, from an image, 94
Clear Output Window command, 379
Clipboard, emptying, 126
Clone brush, 219
closing contours, 247
CMYK, 107
color separations, 371
profiles
defining, 371

modifying, 373
Color Balance
Grey World, 58
color balance, 184
black and white points, 188
highlights/midtones/shadows, 185
hue/saturation/lightness, 186
manual correction, 55
overall balance, 184
color box, 27
color cast, removing, 54
color categories in manual color correction, 56
color channels, working with, 107
color correction
automatic, 54
Grey World, 58
manual, 55, 57
color depth
about, 108
Color Management
about, 420
using, 420
color model
CMYK, 105
HSL, 104
RGB, 104
color palette, 82
color palette, making transparent, 120
Color Picker, Windows, 395
color reduction, 115
Color Replacer tool, 223
color values, 87
colorizing images, 197
colors
correcting by setting black and white points, 188
GIF files, 344
how to approach adjustments, 53
improving in photographs, 59
in print, 106
manually correcting, 55
overview of correction options, 54
PNG files, 349
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viewing on a monitor, 106

hollow shapes, 248
images, 32
new image, 35
raster images, 32
vector graphics, 32

Colors menu
Combine Channel, 107
Increase Color Depth, 109
Split Channel, 107
Colors tab, 82

creator IDs, registering, 353

combining images, 323
Command History, 128

cropping, 134
a selection, 136
to opaque areas, 136

commands, moving, 413

Curves command, 192

compressing images, 47

curves, adjusting, 253

context menus, 19
customizing, 415

custom line styles, 235
dash segment style, 236
end cap styles, in vector objects, 236

contiguous pixels, definition of, 222
contours
adding, 246
break with Pen tool, 250
breaking, 249
closing, 247
definition of, 229
editing, 245
joining, 248
reversing, 248

custom shapes, drawing, 232

contrast
enhancing automatically, 60
how to approach adjustments, 53
improving in photographs, 60
overview of correction options, 60

Cut command, 124

control arms, 253
convert to line, 254
Copy command, 124
Copy Merged command, 124
copying images
into other applications, 126
parts of an image, 219
using the Browser, 125
correcting eyes, 73
correcting image angle, 142
correcting perspective, 145
create as vector, 231
creating
brush tip from selection, 210
brush tips, 209

Customizing
menu and toolbar appearance, 417
Paint Shop Pro, 393
toolbars, 412
customizing
context menus, 415
the workspace, 413

D
dash segment style, 236
defects
removing noise in images, 65, 68
removing source, 62, 64
Deform tool, 141, 143, 145
options, 144
deformation maps, 148
deinterlace command, 62
deleting
a selection, 163
brush tips, 210
images, 127
masks, 301
nodes, 256
vector objects, 237
Despeckle command, 65
dialogs

Index

about, 25
color box, 27
editing values, 27
presets, 27
preview windows, 26
proofing, 26
Digimarc
registering, 353
digital camera
importing images, 38
digital watermark
using, 351
distort, 243
Distortion effects, 319
distortions
correcting in photographs, 69, 71
overview of correction options, 69
Dodge brush, 220
downloading images
mounted drive, 39
Windows XP, 39
drawing
curved and straight lines, 233
custom line styles, 235
custom shapes, 232
free-form lines, 234
lines, 232
preset shapes, 231
segment types, 233
straight lines, 233
drawing mode, 232
duotone images, 197
Dynamic adjustment method, 194

E
Edge Preserving Smooth command, 66
Edge Seeker, 157
Edit menu
Command History, 128
Copy, 36, 124
Copy Merged, 37, 124
Empty Clipboard, 126
Paste

As New Image, 37
As New Selection, 165
Paste As New Image, 124
Paste As New Layer, 124
Paste As New Selection, 125
Paste As Transparent Selection, 125
Paste Into Selection, 125
Repeat, 129
Select All, 43
edit mode, 245
Edit Selection command, 164
editing
contours, 245
gradients, 98
masks, 294
nodes, 251
paths, 245
scripts, 384
template cells, 369
text, 308
vector objects, 237
Effect Browser, 316
effects
adding to text, 309
choosing, 316
creating your own, 325
Effect Browser, 316
using dialogs, 317
Effects menu
3D Effects, 317
Artistic Effects
Posterize, 199
Solarize, 201
Distortion Effects, 319
Edge Effects, 318
Geometric Effects, 319
Illumination Effects, 319
Image Effects, 320
Seamless Tiling, 175
Reflection Effects, 320
Texture Effects, 321
User Defined, 325
Em, definition of, 307
embedding watermarks, 352
Emboss brush, 220
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end cap styles, 236

Save As, 40, 48
Script, 378

Equalize command, 191
Eraser tool, 216

fill color for vector objects, 238

erasing
image background, 217
parts of images, 216

filter, soft focus, 68

EXIF, 24

floating selections, 166

exporting
GIF files, 342
JPEG files, 346
PNG files, 348

floating text, 305

F
feathering selections, 170
File Format Associations
about, 407
adding or removing, 408
changing, 408
File Format Preferences
PCD tab, 410
PostScript tab, 410
RAW tab, 411
WMF tab, 411
File Locations
about, 403
adding, 405
deleting, 405
editing, 404
Web browsers, 407
File menu
Browse, 30
Export
Shape, 234
Import
From Scanner or Camera, 39
Screen Capture, 41
TWAIN, 40
New, 35
Open, 30
Print, 359
Print Layout
print layout window, 360
Recent Files, 31
Revert, 127
Save, 48

Fisheye distortion, 70
Flip command, 151

Flood Fill tool, 222
font style, text, 306
footer, 359
foreground color, 83
frames, see picture frames
Free Rotate, 140
Freehand, 157
Freehand Selection too
using, 157
Freehand Selection tool
about, 154
full screen
editing in, 23
preview, 23
function keys, 28

G
Gamma Correction command, 193
Gaussian blur, 78
General Program Preferences
accessing, 394
Auto Action tab, 399
Browser tab, 397
Display and Caching tab, 395
Miscellaneous tab, 400
Palettes tab, 396
Photo Sharing tab, 399
Transparency tab, 398
Undo tab, 394
Units tab, 398
View tab, 394
Warnings tab, 398
Geometric effects, 319

Index

GIF files
exporting, 342
optimizing, 342
saving, 342
using the Wizard, 346
GIF optimizer settings, 343
Gradient Editor, 99
gradients, 91
changing color, 100
changing markers, 99
changing midpoints, 99
deleting marker, 100
editing, 98
exporting, 102
importing, 102
marker color, 100
marker transparency, 100
new marker, 100
new types, 101
renaming and deleting, 103
saving, 101
selecting options, 92
graininess, reducing, 78
Grey World correction, 58
greyscale images, 198, 199
grid
snapping to, 133
using, 130
grouping, vector objects, 240
guides
changing color, 131
deleting, 132
modifying settings, 132
moving, 131
placing, 131
snapping to, 133
using, 131

H
halos in JPEG images, 63
help
Help system, 8
Technical Support, 9
viewing the Product Tour, 7

highlights/midtones/shadows, adjusting, 194
Histogram, 190
correcting images, using, 204
displaying, 201
guidelines for analyzing, 203
understanding values, 203
using to analyze images, 201
holes and specks, removing from a selection, 172
hollow shapes, creating, 248
HSL, 107
hue and saturation
adjusting using Hue Map, 196
colorizing, 197
Hue Map command, 196
Hue Up/Down brush, 220

I
Illumination effects, 319
image
adding borders, 150
adding effects, 315
changing resolution, 138
color and lightness, 356
color palette, 117
correcting faded, 59
correcting perspective, 145
cropping, 134
decreasing color depth, 111
deforming, 143
deleting, 127
effects, 320
embedding a digital watermark, 352
increasing color depth, 109
information, 24
previewing in Web browsers, 330
resizing, 137
rotating, 140
saving, 48
saving a copy, 50
saving for printing, 357
saving with new format, 49
warping, 146
Image menu
Add Borders, 150
Arithmetic, 151, 323
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Count Colors Used, 108
Count Image Colors, 109
Delete Alpha Channel, 179
Flip, 151
Greyscale, 199
Image Information, 108
Palette
Edit Palette, 117
Load Palette, 118
Save Palette, 118
Set Palette Transparency, 120
Picture Frame, 322
Resize, 137
image negatives, 200
image perspective, correcting, 145
image problems, JPEG images, 63
images
automatically arranging in layouts, 361
combining, 151, 323
mapping, 331
positioning in layouts, 362
slicing, 337
importing images
from a digital camera or scanner, 38
using TWAIN, 40
installing, 6
Invert command, 200
inverting
masks, 295
selections, 167

J
Jasc Color Picker, 86
Basic Colors panel, 87
color wheel, 87
displaying the, 87
joining contours, 248
joining types of corners for vector objects, 230
JPEG images, removing artifacts in, 63
JPEG optimizer settings, 346

K
Kerning, 307

Keyboard Map command, 417

L
Layer palette
displaying, 266
highlighting icons, 278
using, 265
viewing layer content, 266
Layers
about, 260
adding new, 267
Adjustment layers, 261, 283
Background layers, 262
Blend modes, 274
Blend ranges, 277
changing opacity, 274
copying to another image, 269
creating from selections, 269
deleting, 282
duplicating, 268
editing properties, 270
grouping, 271
highlight colors, 278
layer groups, 266
Layer palette, using, 265
linking layers and groups, 272
Load/Save Mask
Load Mask From Alpha Channel, 300
Lock Transparency setting, 278
Mask layers, 261
Matting commands, 282
merging, 280
modifying, 279
moving vector objects, 279
promoting Background layers, 268
Raster layers, 261
renaming, 270
selecting, 266
stacking order, 279
unlinking layers and groups, 273
using Move tool, 280
using with illustrations, 264
using with photos, 263
Vector layers, 262
visibility options, 270
Layers menu
Invert Mask/Adjustment, 295

Index

Load Mask
From Disk, 298
Load/Save Mask
Save Mask To Alpha Channel, 298
Save Mask to Disk, 297
Matting
Defringe, 171
Remove Black Matte, 171
Remove White Matte, 171
New Adjustment Layer
Brightness/Contrast, 191
Channel Mixer, 189
Curves, 192
Hue/Saturation/Lightness, 186
Invert, 200
Levels, 195
Threshold, 198
New Mask Layer
From Image, 291
Hide All, 290
Hide Selection, 292
Show All, 290
Show Selection, 292
View Overlay, 294
layouts
automatically arranging images, 361
grids, 363
positioning images, 362
resizing images, 362
rotating images, 362
saving, 365
Leading, 307
learning tools, 7
Help system, 8
Learning Center, 8
news groups, 8
Product Tour, 7
Quick Guides, 7
Web resources, 10
lens correction
barrel distortions, 70
fisheye distortion, 70
pincushion distortion, 71
Levels command
brightness and contrast
adjusting using levels, 195
Lighten/Darken brush, 220

Lightness, 104
line options, 230
anti-alias, 230
bevel, 230
curve tracking, 230
join, 230
line style, 230
miter limit, 230
retain style, 230
round, 230
width, 230
line segments, 233
changing, 253
line, drawing a, 232
Linear adjustment method, 194
Link Colors check box, 88
loading
deformation map, 148
masks, 298

M
Magic Wand tool, 154
Magnifier tool, 23
magnifying an image, 23
making selections, 153
Manual Color Correction, 55
Mapping images, 331
marquee
applying effects to, 164
definition of, 153
hiding, 166
moving, 166
masks
about, 288
as greyscale layers, 289
changing overlay color, 295
creating from channels, 293
creating from images, 291
creating from selections, 292
creating new, 290
deleting, 301
deleting from alpha channels, 301
displaying overlay, 294
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editing, 294
gradient, 296
inverting, 295
layers, 288
loading from alpha channels, 300
loading from disk, 298
pattern, 296
saving to alpha channel, 297
saving to disk, 297
see contents, 289
texture, 296
Match mode, 159
Materials palette, 82
choosing colors, 84
choosing texture, 84
using, 84
Median Filter command, 67
Menu bars
displaying, 413
resetting, 413
merging images, 151
merging nodes, 256
Mesh Warp tool, 147
Mirror command, 151
miter limit, 230
moiré patterns, removing, 64
monitor
interaction with Windows Color Management, 419
Monitor adjustments, 418
Monitor Gamma command, 419
Motion blur, 78
Mounted Drive, 38
moving
commands, 413
multiple image printing, see print layout

characteristics, 35
dimensions, 35
duplicating existing image, 36
from clipboard, 37
from layer, 36, 37
node-on-node indicator, 249
nodes
adding, 254
adding with knife mode, 255
adjusting control arms, 253
anatomy of, 251
changing types, 253
definition of, 229
deleting, 256
editing, 251
merging, 256
moving, 252
new start or end, 255
selecting, 251
transform with Objects menu, 257
transform with tool options, 258
types, 251
asymmetrical, 251
cusp, 251
smooth, 251
symmetrical, 251
types of, 251
noise
adding, 321
overview of removal options, 65
removing, 65, 68
removing specks, 65
removing while keeping texture, 68
removing while perserving edges, 66
removing with Blur commands, 78

O
object distribution, 241
Object Selection tool, 154

new features, 2

objects
about, 228
alignment, 241
definition, 229
raster, 228
vector, 228

new image, 35, 36

Objects menu

N
Negative Image command, 200
negative, creating positive image from, 200

Index

Align, 241
Arrange, 242
Distribute, 242
Edit
Break, 249
Close, 247
Join, 248
Merge, 256
Reverse Contour, 248
Reverse Path, 248
Edit commands, 245
copy, 245
cut, 245
delete, 245
invert selection, 245
Paste, 245
select all, 245
select none, 245
Group, 240
Node Type, 251
Convert to Line, 254
Curve After, 254
Curve Before, 254
Line After, 254
Line Before, 254
Transform Selected Nodes
Contract, 257
Expand, 257
Flip, 257
Mirror, 257
Rotate, 257
Skew, 257
Ungroup, 240
opening images
existing images, 30
recently used, 31
using the Browser, 30
Optimized Median Cut, 116
Optimized Octree, 116
Options, 157
options, for printing, 357
Overview palette, 19

P
Paint Brush, 208
Paint Shop Pro

customizing, 393
exiting, 12
installing Paint Shop Pro, 6
Product Tour, 7
starting, 12
user interface, 12
painting
brush options, 211
with brushes, 208
with Picture Tubes, 224
palette
docking, 17
hiding and displaying, 17
Materials, 82
options, 116
resizing, 17
roll up, 17
using, 16
weighted, 111
paper quality, and printing, 356
Paste command, 124
paths
definition of, 229
editing, 245
reversing, 248
patterns
choosing, 93
creating new, 94
making from selections, 175
undesirable in images, 64
PCD file format preferences, 410
Pen tool
contiguous, 232
create as vector, 232
curve tracking, 230
drawing mode, 232
edit mode, 245
freehand, 234
knife mode, 250, 255
line segments, 233
point to point, 233
segment types, 233
simple mode, 232
Perspective Correction tool, 146
Photo Sharing command, 399
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photo sharing service
uploading images, 328
photographs
basic steps in improving, 52
correcting distortions, 69, 71
correcting faded, 59
improving, 51
improving colors, 54, 59, 60, 61
retouching, 72
picking colors, 27
picture frames, 322
Picture Tubes, 224
creating, 225
downloading more, 226
Plug-ins
about, 406
adding, 406
in File Locations, 406
PNG files
exporting, 348
number of colors, 349
PNG optimizer settings, 348
Point to Point selection tool, 157
position on canvas, 242
Posterize command
reducing lightness levels, 199
PostScript file format preferences, 410
Preferences
Autosave Settings, 409
CMYK conversion, 372
File Format preferences, 410
File Locations, 404
resetting, 401
setting, 394

brushes, 213
choosing, 387
deleting, 387
editing, 387
examples of, 386
resetting Default, 387
saving, 387
previewing images in Web browsers, 330
print layout
printing, 360
selecting images, 360
window options, 364
print template
placing cells, 365
printing
CMYK color separations, 371
from the Browser, 369
greyscale, 357
header text, 359
image resolution, 356
multiple images on a page
options, 357
page size, 359
paper quality, 356
paper size, 359
print layout, 360
saving images for, 357
single image, 359
using templates, 366
Product Tour, 7
Pure Colors category, 57
Push brush, 220
Python programming language, 378

Q

Preset Shape tool
retain style, 230

Quick Guides, 7

preset shapes
create as vector, 231
creating new, 234
drawing, 231
shape libraries, 234

R

Presets
about, 386

reading Watermarks, 354

randomizing parameters, 28
raster text, moving, 307
RAW file format preferences, 411
recently used materials, 85

Index

red-eye correction, 72
fine tuning, 74
Redo command, 127
reducing colors to black and white, 198
Reflection effects, 320
regions, see cells
registering with Digimarc, 353
Remember Text, 304
removing
scratches, 75, 77
specks, 65
repeating commands, 129
replacing colors, 196, 223
using the Hue Map, 196

S
Salt and Pepper Filter, 65
saturation, 104
enhancing automatically, 61
how to approach adjustments, 53
improving in photographs, 61
overview of correction options, 61
Saturation Up/Down brush, 220
Save As
dialog box, 48
Save Copy As command, 50
Saving, 48, 49
images for printing, 357

resolution, changing, 138

saving
an image, 48
an image in a different file format, 49
brush tip, 214
copy of image, 50
deformation map, 148
gradients, 101
layouts, 365
masks, 297
PNG files, 348
using Autosave, 47

retouch brushes, 220

scan line problems, 62

reversing contours, 248

scanned photographs with undesirable patterns, 64

reversing paths, 248

scanning images, 38

Revert command, 127

Scratch Removal tool, 75

RGB, 104, 107
adjusting, 184
adjusting color channels, 189

scratches, removing automatically, 77

resampling, 137
Reset Preferences command, 401
Resetting settings, 387
reshaping vector objects, 243
resizing images, 137
resizing vector objects, 243

rotating images, 140
Deform tool, 141
Free Rotate, 140
Straighten tool, 142
rotating vector objects, 244
rotation handle, 244
rotation pivot point, 244
rulers
displaying, 129
using, 129

screen capture, 41
area, 43
capturing a screen, 42
object, 43
setting options, 41
Scripting
basics, 378
changing Python Source editors, 385
displaying Script toolbar, 378
editing, 384
Protected Script Mode, 382
Python programming language, 378
recording, 380
running a script, 380
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saving, 380
Script Output Window, 379
Scripts-Restricted folder, 382
Scripts-Trusted folder, 382
undoing an applied script, 381
Scripts, assigning a shortcut key to, 416
seamless tiling, 175
segment types, 233
selecting
layers, 266
non-masked areas, 163
pixels, 163
text, 162
vector objects, 161
selecting nodes, 251
selecting vector objects
from the Layer palette, 161
on all visible layers, 161
selection
creating brush tip, 210
cropping to, 136
expanding
based on color value, 168
Selection tool, 154
custom selection, 156
using, 155
selection tools
about, 154
Freehand Selection, 154
Magic Wand, 154
Object (Vector) Selection, 154
Selection, 154
Text, 154
selection types, 157
Edge Seeker, 157
Selections
Modify
Select Color Range, 170
selections
adding to, 167
adding/removing color, 170
anti-alias based on shape, 173
applying effects to marquee, 164
create selection from, 156

expanding by pixels, 168
feathering, 169
fixing edges, 171
floating, 166
inverting, 167
loading, 177
loading from alpha channel, 178
modifying borders, 174
modifying the feathering, 170
moving in images, 174
promoting to layer, 175
recovering anti-alias, 173
removing, 163
removing specks and holes, 172
saving to alpha channel, 177
saving to disk, 176
smoothing the boundary, 172
subtracting from, 169
subtracting from in pixels, 169
unfeathering, 170
using Edit Selection, 164
Selections menu
Defloat, 166
Edit Selections, 164
Float, 166
From Mask, 163
From Vector Object, 164
Hide Marquee, 166
Invert, 167
Load/Save Selection
Load Selection from Alpha Channel, 178
Save Selection to Disk, 176
Load/Save Selections
Load Selection from Disk, 177
Save Selection to Alpha Channel, 177
Modify
Contract, 169
Expand, 168
Feather, 169
Inside/Outside Feather, 170
Remove Specks and Holes, 172
Select Selection Borders, 174
Select Similar, 168
Shape-Based Anti-alias, 173
Smooth, 172
Unfeather, 170
Promote to Layer, 175
Recover Anti-alias, 173
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Select All, 163
Select None, 163

Straighten tool, 142

sepia tone images, 199

Stroke Width, 306

shape libraries, 234

style buttons, 83

shape-based anti-alias, 173

swatches, 96
changing display of, 97
creating new, 96
deleting, 97
editing, 97
renaming, 97
selecting, 97

sharing
brush Presets, 214
images using a photo sharing service, 328
images via e-mail, 328
Sharpen brush, 220
Sharpen command, 80
Sharpen More command, 80
shear, 243
Shortcut keys, 28
assigning, 416
customizing, 28
viewing all, 417

Stretch command, 191

Swatches tab, 82
symmetric perspective, 243
system requirements, 6

T
target colors, 55

simple mode, 232

Technical Support, 9

slicing an image, 337

template
delete, 368

Smart Edge, 157
Smudge brush, 220
snapping, to grids and guides, 133
Soft Focus command, 68
Soften brush, 220
Soften command, 68
Soften More command, 68
Solarize command, 201
source colors, 55
source defects
removing, 64
source defects, removing, 62
specks and holes, 172
spray can, 208
Stacking order, 259, 265
standard colors
using for manual color correction, 57
Standard Colors category, 57
Standard palette, 116

template cells
editing, 369
templates
fill template with image, 367
new template, 369
opening, 366
printing, 366
remove image, 368
revert to layout, 369
saving with images, 365
text
adding to images, 304
align on path, 312
alignment, 306
anti-alias, 306
applying effects, 309
auto kern, 306
convert to curves, 313
creating, 304
editing, 308
floating (raster), 305
formatting, 306
kerning, 307
leading, 307
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make path invisible, 311
moving, 307
on a path, 310
remember text, 304
scale, 309
selection, 305
size, 306
stroke width, 306
transform, 309
type style, 306
types of, 305
vector, 305
with patterns, 310
Text tool, 154, 162, 304
texture button, 83

TWAIN, 38

U
Undo command, 127
unfeathering selections, 170
ungroup, 240
Unsharp Mask command, 80
user colors, defining, 56
user defined effects, 325
using
Autosave, 47
Help, 8
Web resources, 10

Texture effects, 321
Texture Perserving Smooth command, 68
textures
choosing, 94
creating new, 95
Threshold command, 198
to, 345
Toolbars
adding a separator to, 414
adding BoundScripts to, 382
adding commands or tools, 413
creating custom, 415
customizing, 412
deleting custom, 415
displaying, 413
executing commands, 15
hiding and displaying, 15
removing a separator from, 414
removing commands or tools from, 414
resetting all, 414
resetting specific, 414
using, 15
Tools
setting options, 18
using, 18

V
vector objects
align, 241
anatomy, 229
arrange, 242
converting to raster, 164
deleting, 237
distort, 243
distribute, 241
distribute on canvas, 242
editing, 237
grouping, 240
make same size, 244
perspective, 243
position on canvas, 242
properties
fill, 238
name, 238
stroke, 238
visibility, 238
resize and reshape, 243
rotate, 244
selecting, 161
shear, 243
ungroup, 240

transparency button, 83

vector text, 305
moving, 307

transparent
GIF files, 342
PNG files, 350

video images
fixing line problems, 62
viewing

Index

creator information, 24
EXIF information, 24
image information, 24
viewing images, 20
arranging multiple, 20
closing image, 21
fit to window, 21
moving an image window, 20
multiple images, 20
panning, 21
resizing an image window, 20
zooming, 22

W
Warning messages, 398
Warp brush, 215
warp modes, 215
warping images, 147
Watermarks
embedding, 352
reading, 354
Web
Learning Center, 8
news groups, 8
resources, 10
Web browser
adding a browser, 407
deleting or editing a browser, 407
previewing an image in, 330
Web image
Mapping, 331
previewing in browsers, 330
slicing, 337
Web safe color palette, 119
Web safe colors, 88
WIA, 38
Window menu
Duplicate, 36
Windows Color Management
Interaction with monitor gamma, 419
Windows Color Picker, 395
Windows palette, 116

WMF file format preferences, 411
Workspaces
about, 401
deleting, 403
loading, 403
saving, 402

Z
Zoom tool, 22
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